<!DOCTYPE html>
<html lang="en-US"
 xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />

<meta property="og:image" content="https://i1.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Pro-Mod-Win-Don-Walsh-Jr.jpg?resize=400%2C242&ssl=1" />


<link rel="shortcut icon" href="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2014/06/DI_16x16_favicon.png" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://dragillustrated.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://dragillustrated.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://dragillustrated.com/feed/atom/" />
<link rel="pingback" href="https://dragillustrated.com/xmlrpc.php" />


<title>Two Times the Talent at Nitto NMRA/NMCA Super Bowl of Street Legal Drag Racing &#8211; Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</title>
<script>window._wca = window._wca || [];</script>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Feed" href="https://dragillustrated.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Comments Feed" href="https://dragillustrated.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; iCal Feed" href="https://dragillustrated.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Two Times the Talent at Nitto NMRA/NMCA Super Bowl of Street Legal Drag Racing Comments Feed" href="https://dragillustrated.com/two-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing/feed/" />
<link rel='stylesheet' id='front-css-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/facebook-comment-by-vivacity/css/fb-comments-hidewpcomments.css?ver=1464982304' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.0.4/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wc-block-style-css'  href='https://c0.wp.com/p/woocommerce/3.6.5/assets/css/blocks/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=1558371468' type='text/css' media='all' />
<link rel='stylesheet' id='digg-digg-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/digg-digg/css/diggdigg-style.css?ver=1421190495' type='text/css' media='screen' />
<link rel='stylesheet' id='woocommerce-layout-css'  href='https://c0.wp.com/p/woocommerce/3.6.5/assets/css/woocommerce-layout.css' type='text/css' media='all' />
<style id='woocommerce-layout-inline-css' type='text/css'>

	.infinite-scroll .woocommerce-pagination {
		display: none;
	}
</style>
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://c0.wp.com/p/woocommerce/3.6.5/assets/css/woocommerce-smallscreen.css' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='https://c0.wp.com/p/woocommerce/3.6.5/assets/css/woocommerce.css' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='mvp-style-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/Braxton-Child/style.css?ver=1548773882' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='mvp-iecss-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/Braxton-Child/css/iecss.css?ver=46c8ab1b8b48c1759514c5f5863aaeaa' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='reset-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/css/reset.css?ver=1510873624' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.css?ver=46c8ab1b8b48c1759514c5f5863aaeaa' type='text/css' media='all' />
<link rel='stylesheet' id='media-queries-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/css/media-queries.css?ver=1510873624' type='text/css' media='all' />
<link rel='stylesheet' id='studio-fonts-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A400%7CQuicksand%3A300%2C400%7CVidaloka%7CPlayfair+Display%3A400%2C700%2C900%7COpen+Sans+Condensed%3A300%2C700%7COpen+Sans%3A400%2C800%7COswald%3A300%2C400%2C700%7CRaleway%3A200%2C300%2C400%2C500%2C600%2C700%2C800%26subset%3Dlatin%2Clatin-ext&#038;ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='fw-ext-builder-frontend-grid-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/unyson/framework/extensions/builder/static/css/frontend-grid.css?ver=1550785709' type='text/css' media='all' />
<link rel='stylesheet' id='fw-ext-forms-default-styles-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/unyson/framework/extensions/forms/static/css/frontend.css?ver=1550785709' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/tablepress-combined.min.css?ver=1551219115' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/7.1.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.0.4/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.0.4/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.1.1/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.0.4/wp-includes/js/comment-reply.min.js'></script>
<link rel='https://api.w.org/' href='https://dragillustrated.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dragillustrated.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dragillustrated.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Winters Returning To Bandimere Speedway With One Goal: Win The WSOPM' href='https://dragillustrated.com/winters-returning-to-bandimere-speedway-with-one-goal-win-the-wsopm/' />
<link rel='next' title='Sonnax Ramps Up Powerglide Durability With New Ratio Options For Big Shaft System' href='https://dragillustrated.com/sonnax-ramps-up-powerglide-durability-with-new-ratio-options-for-big-shaft-system/' />

<link rel='shortlink' href='https://dragillustrated.com/?p=35817' />
<link rel="alternate" type="application/json+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Ftwo-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Ftwo-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing%2F&#038;format=xml" />
<script type="text/javascript" src="https://paywall.subscriptiongenius.com/load.js"></script>

<!-- This site is using AdRotate v5.3 Professional to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.gformba { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.gformba img { height:auto; }
	.gformba-col { position:relative; float:left; }
	.gformba-col:first-child { margin-left: 0; }
	.gformba-col:last-child { margin-right: 0; }
	.gformba-1 {  margin: 0 auto; }
	.gformba-2 { margin:1px 1px 1px 1px; }
	.gformba-3 { margin:1px 1px 1px 1px; }
	.gformba-4 { margin:1px 1px 1px 1px; }
	.gformba-5 { margin:1px 1px 1px 1px; }
	.gformba-6 { margin:1px 1px 1px 1px; }
	.gformba-7 { margin:1px 1px 1px 1px; }
	.gformba-8 { min-width:3px; max-width:618px; }
	.bformba-8 { margin:1px 3px 1px 3px; }
	.gformba-9 { margin:1px 1px 1px 1px; }
	.gformba-10 { margin:1px 1px 1px 1px; }
	.gformba-16 { min-width:5px; max-width:150px; margin: 0 auto; }
	.bformba-16 { margin:0px 5px 0px 5px; }
	@media only screen and (max-width: 480px) {
		.gformba-col, .gformba-dyn, .gformba-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<link rel="image_src" href="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/07/NA-10.5-Win-Leonard-Long-800x532.jpg" /><meta property="fb:app_id" content="297668800418060"/>
<meta property="fb:admins" content=""/>
<meta property="og:locale" content="en_US" />
<meta property="og:locale:alternate" content="en_US" />
<style type="text/css">
			.wpsdc-drop-cap {
				float : left;				
				padding : 0.25em 0.05em 0.25em 0;				
				font-size : 5em;
				line-height : 0.4em;color : #0a0a0a;}
		</style><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//dragillustrated.com/?wordfence_lh=1&hid=6BC752514CE8677B418F258A0BD8C838');
</script><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://dragillustrated.com"><link rel="https://theeventscalendar.com/" href="https://dragillustrated.com/wp-json/tribe/events/v1/" />
<link rel='dns-prefetch' href='//c0.wp.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>
<style type='text/css'>

@import url(//fonts.googleapis.com/css?family=Vidaloka:100,200,300,400,500,600,700,800,900|Raleway:100,200,300,400,500,600,700,800,900|Playfair+Display:100,200,300,400,500,600,700,800,900|Oswald:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese);

#nav-wrapper,
#nav-top-wrap {
	background: #ff0000;
	}

.fly-but-wrap span {
	background: #555555;
	}

#main-nav .menu li a:hover,
#main-nav .menu li.current-menu-item a,
#search-button:hover,
.home-widget h3.widget-cat,
span.post-tags-header,
.post-tags a:hover,
.tag-cloud a:hover,
.woocommerce .widget_price_filter .ui-slider .ui-slider-range {
	background: #ff0000;
	}

.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce span.onsale,
.woocommerce #respond input#submit.alt,
.woocommerce a.button.alt,
.woocommerce button.button.alt,
.woocommerce input.button.alt,
.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt:hover {
	background-color: #ff0000;
	}

.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt:hover {
	opacity: 0.8;
	}

#main-nav .menu-item-home a:hover {
	background: #ff0000 !important;
	}

#top-story-left h3,
#top-story-right h3 {
	border-bottom: 3px solid #ff0000;
	}

a, a:visited,
ul.top-stories li:hover h2,
ul.top-stories li:hover h2,
#top-story-middle:hover h2,
#top-story-wrapper:hover #feat2-main-text h2,
#feat1-left-wrapper:hover .feat1-left-text h2,
#feat1-right-wrapper:hover .feat1-right-text h2,
ul.split-columns li:hover h2,
.home-widget ul.wide-widget li:hover h2,
.home-widget ul.home-list li:hover h2,
h3.story-cat,
h3.story-cat a,
.sidebar-widget ul.home-list li:hover h2,
.sidebar-widget ul.wide-widget li:hover h2,
.sidebar-widget ul.split-columns li:hover h2,
#footer-nav .menu li a:hover,
.footer-widget ul.home-list li:hover h2,
.footer-widget ul.wide-widget li:hover h2,
.footer-widget ul.split-columns li:hover h2,
.prev,
.next {
	color: #ff0000;
	}

#wallpaper {
	background: url() no-repeat 50% 0;
	}

.featured-text h2,
.featured-text h2 a,
.feat1-main-text h2,
.feat1-main-text h2 a {
	font-family: 'Vidaloka', serif;
	}

#main-nav .menu li a,
#main-nav .menu li:hover ul li a {
	font-family: 'Raleway', sans-serif;
	}

#top-story-left h2,
#top-story-right h2,
.feat1-left-text h2,
.feat1-right-text h2,
#feat2-main-text h2,
#middle-text h2,
ul.split-columns li h2,
.home-widget .wide-text h2,
.home-widget .home-list-content h2,
h1.story-title,
.sidebar-widget .wide-text h2,
.sidebar-widget ul.split-columns li h2,
.footer-widget .wide-text h2,
.footer-widget ul.split-columns li h2,
#post-404 h1 {
	font-family: 'Playfair Display', serif;
	}

#top-story-left h3,
#top-story-right h3,
#middle-text h3,
h1.home-widget-header,
#woo-content h1.page-title,
h3.home-widget-header,
h1.archive-header,
h3.story-cat,
h3.story-cat a,
#content-area h1,
#content-area h2,
#content-area h3,
#content-area h4,
#content-area h5,
#content-area h6,
h4.post-header,
h3.sidebar-widget-header,
h3.footer-widget-header {
	font-family: 'Oswald', sans-serif;
	}

@media screen and (max-width: 767px) and (min-width: 480px) {

	.sidebar-widget .home-list-content h2 {
		font-family: 'Playfair Display', serif;
		}

	}

#menufication-outer-wrap.menufication-transition-in #menufication-scroll-container {
	overflow-y: auto !important;
	}

</style>
	
<style type="text/css">



</style>

<style type="text/css">
#wallpaper {
	background-size: 100%;
}</style>

	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e7e7e7; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Two Times the Talent at Nitto NMRA/NMCA Super Bowl of Street Legal Drag Racing" />
<meta property="og:url" content="https://dragillustrated.com/two-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing/" />
<meta property="og:description" content="NMCA and NMRA drivers teamed up to put down twice as much power in the Prairie State for the 14th Annual Nitto NMRA/NMCA Super Bowl of Street Legal Drag Racing presented by FST Carburetors, July 25…" />
<meta property="article:published_time" content="2019-07-30T00:57:05+00:00" />
<meta property="article:modified_time" content="2019-07-30T00:57:24+00:00" />
<meta property="og:site_name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
<meta property="og:image" content="https://i1.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Pro-Mod-Win-Don-Walsh-Jr.jpg?fit=1080%2C719&amp;ssl=1" />
<meta property="og:image:width" content="1080" />
<meta property="og:image:height" content="719" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Two Times the Talent at Nitto NMRA/NMCA Super Bowl of Street Legal Drag Racing" />
<meta name="twitter:image" content="https://i1.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Pro-Mod-Win-Don-Walsh-Jr.jpg?fit=1080%2C719&#038;ssl=1&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->

<!-- BEGIN ExactMetrics v5.3.8 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-21052018-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END ExactMetrics Universal Analytics -->
<script async src='https://stats.wp.com/s-201931.js'></script>

</head>

<body data-rsssl=1 class="post-template-default single single-post postid-35817 single-format-standard custom-background woocommerce-no-js tribe-no-js">
<div id="site">
	<div id="fly-wrap">
	<div class="fly-wrap-out">
		<div class="fly-side-wrap">
			<ul class="fly-bottom-soc left relative">
									<li class="fb-soc">
						<a href="https://www.facebook.com/DragIllustrated/" target="_blank">
						<i class="fa fa-facebook-square fa-2"></i>
						</a>
					</li>
													<li class="twit-soc">
						<a href="https://twitter.com/DragIllustrated" target="_blank">
						<i class="fa fa-twitter fa-2"></i>
						</a>
					</li>
																	<li class="inst-soc">
						<a href="https://www.instagram.com/dragillustrated/" target="_blank">
						<i class="fa fa-instagram fa-2"></i>
						</a>
					</li>
																													<li class="rss-soc">
						<a href="https://dragillustrated.com/feed/rss/" target="_blank">
						<i class="fa fa-rss fa-2"></i>
						</a>
					</li>
							</ul>
		</div><!--fly-side-wrap-->
		<div class="fly-wrap-in">
			<div id="fly-menu-wrap">
				<nav class="fly-nav-menu left relative">
					<div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-15084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15084"><a href="https://dragillustrated.com/category/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-20226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20226"><a href="https://dragillustrated.com/category/blogs/driver-blogs/">Blogs</a></li>
	<li id="menu-item-15087" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15087"><a href="https://dragillustrated.com/category/tech/">Tech</a></li>
	<li id="menu-item-15100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15100"><a href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a></li>
</ul>
</li>
<li id="menu-item-15104" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15104"><a href="https://dragillustrated.com/shop/">Store</a></li>
<li id="menu-item-34161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34161"><a href="https://dragillustrated.com/category/thewesbuckshow/">The Wes Buck Show</a></li>
<li id="menu-item-15094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li id="menu-item-15102" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
</ul></div>				</nav>
			</div><!--fly-menu-wrap-->
		</div><!--fly-wrap-in-->
	</div><!--fly-wrap-out-->
</div><!--fly-wrap-->	<div id="nav-top-wrap" class="left relative">
		<div id="nav-top-mid" class="relative">
			<div id="nav-top-cont" class="left relative">
																</div><!--nav-top-cont-->
		</div><!--nav-top-mid-->
	</div><!--nav-top-wrap-->
	<div id="nav-wrapper">
		<div class="nav-wrap-out">
		<div class="nav-wrap-in">
			<div id="nav-inner">
			<div class="fly-but-wrap left relative">
				<span></span>
				<span></span>
				<span></span>
				<span></span>
			</div><!--fly-but-wrap-->
							<div id="logo-small" itemscope itemtype="http://schema.org/Organization">
											<a itemprop="url" href="https://dragillustrated.com"><img itemprop="logo" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2015/01/DI_141x54_white_shadow.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" /></a>
									</div><!--logo-small-->
						<div id="main-nav">
				<div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15084"><a href="https://dragillustrated.com/category/features/">Features</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20226"><a href="https://dragillustrated.com/category/blogs/driver-blogs/">Blogs</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15087"><a href="https://dragillustrated.com/category/tech/">Tech</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15100"><a href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15104"><a href="https://dragillustrated.com/shop/">Store</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34161"><a href="https://dragillustrated.com/category/thewesbuckshow/">The Wes Buck Show</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
</ul></div>			</div><!--main-nav-->
			<div id="search-button">
				<img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/images/search-icon.png" />
			</div><!--search-button-->
			<div id="search-bar">
				<form method="get" id="searchform" action="https://dragillustrated.com/">
	<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>			</div><!--search-bar-->
			</div><!--nav-inner-->
		</div><!--nav-wrap-in-->
		</div><!--nav-wrap-out-->
	</div><!--nav-wrapper-->
		<div id="body-wrapper">
				<div id="main-wrapper">
										
    <div id="ad-area-wrap"><div class="ad-rotate-widget"><div class="ad-rotate-widget-widget">			<div class="textwidget"><div class="gformba gformba-7"><div class="gformba-single aformba-554"><a class="gofollow" data-track="NTU0LDcsMSw2MA==" href="https://www.ididitinc.com/" target="_blank"><img src="https://i0.wp.com/dragillustrated.com/wp-content/uploads/2019/05/IDIDIT_DRILL_May_728x90.jpg?ssl=1" /></a></div></div>
</div>
		</div></div><!-- end .ad-rotate-widget --><div class="subscribe-now"><div class="subscribe-now">			<div class="textwidget"><p><a href="http://www.dragracingmastermind.com/"><img src="https://i0.wp.com/dragillustrated.com/wp-content/uploads/2018/03/MasterMind_160x90.png?resize=160%2C90&#038;ssl=1" alt="Drag Racing Master Mind" width="160" height="90" data-recalc-dims="1" /></a></p>
</div>
		</div></div><!-- end .subscribe-now --></div><!-- end #ad-area-wrap -->	
	<div id="content-wrapper">
						<div id="content-main">
																										<div id="featured-image" itemscope itemtype="http://schema.org/Article">
																													<img itemprop="image" src="https://i1.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Pro-Mod-Win-Don-Walsh-Jr.jpg?resize=660%2C400&ssl=1" />
													</div><!--featured-image-->
																					<div id="home-main">
				<div id="post-area" itemscope itemtype="http://schema.org/Article" class="post-35817 post type-post status-publish format-standard has-post-thumbnail hentry category-news">
					<h3 class="story-cat">News</h3>
					<h1 class="story-title" itemprop="name">Two Times the Talent at Nitto NMRA/NMCA Super Bowl of Street Legal Drag Racing</h1>
					<div id="post-info">
						By&nbsp;<span class="author" itemprop="author"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span>&nbsp;|&nbsp;<time class="post-date" itemprop="datePublished" datetime="2019-07-29" pubdate>July 29, 2019</time>
					</div><!--post-info-->
											<div class="social-sharing-top">
							<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://dragillustrated.com/two-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing/&t=Two Times the Talent at Nitto NMRA/NMCA Super Bowl of Street Legal Drag Racing', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"></span><p>Share</p></div></a>
							<a href="#" onclick="window.open('http://twitter.com/share?text=Two Times the Talent at Nitto NMRA/NMCA Super Bowl of Street Legal Drag Racing -&url=https://dragillustrated.com/two-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"></span><p>Tweet</p></div></a>
							<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://dragillustrated.com/two-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing/&media=https://i1.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Pro-Mod-Win-Don-Walsh-Jr.jpg?resize=660%2C400&ssl=1&description=Two Times the Talent at Nitto NMRA/NMCA Super Bowl of Street Legal Drag Racing', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"></span><p>Share</p></div></a>
							<a href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https://dragillustrated.com/two-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"><div class="google-share"><span class="google-but1"></span><p>Share</p></div></a>
							<a href="https://dragillustrated.com/two-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing/#respond"><div class="social-comments"><p>0 comments</p></div></a>
						</div><!--social-sharing-top-->
										<div id="content-area">
							
		<p>NMCA and NMRA drivers teamed up to put down twice as much power in the Prairie State for the <strong>14th Annual Nitto NMRA/NMCA Super Bowl of Street Legal Drag Racing presented by FST Carburetors</strong>, July 25-28 at Route 66 Raceway in Joliet, Illinois.</p>
<p>With their sights set on the <strong>Aerospace Components Winner’s Circle</strong> and season championship points at this fourth of six events on this year’s tour, drivers in the potent <strong>VP Racing Fuels Xtreme Pro Mod</strong> category pulled to the lanes. In qualifying, they were led by Don Walsh Jr., who wheeled to a 3.74 in his Corvette, and several rounds later, Walsh Jr. pulled off another win with a 3.72 over Randy Adler, who was not far behind with a 3.77 in his Bel Air.</p>
<p><strong>NMCA Mickey Thompson Street Outlaw </strong>and<strong> NMRA VP Racing Fuels Street Outlaw </strong>merged to make even more muscle at this event, and Dom DiDonato drove to a 4.46 to lead qualifying in his Mustang. The final round, however, belonged to Shane Fisher and Shawn Pevlor and their Mustangs. When the tree came down, both drivers recorded comparable reaction times, and Fisher flew to the win with a 4.45 over Pevlor’s 7.91.</p>
<p><strong>Holley EFI Factory Super Cars </strong>saw Bill Skillman secure a 7.90 in his Mustang Cobra Jet to lead qualifying, and later, he sailed to a 7.98 to win over Terry Munroe, who turned in an 8.06 in his COPO Camaro.</p>
<p>There was a full supply of nitrous purges in <strong>ARP Nitrous Pro Street</strong>, except from Tony Gillig, who runs a naturally aspirated combination, and he still grabbed a 4.37 in his Cutlass to lead qualifying. Several rounds later, he faced reigning category champion Jordan Ensslin and his Trans Am, and Gillig, who had a slightly better reaction time, took the win on a holeshot after both drivers put identical 4.41 runs on the board.</p>
<p><strong>NMCA Edelbrock Xtreme Street </strong>and <strong>NMRA Edelbrock Renegade </strong>drivers dueled each other at this event, and Joel Greathouse drove to a 4.70 in his Mustang to set the pace in qualifying. But making it to the final were NMCA newcomer Mike Thompson and Paul Smith and their Camaros. Thompson took it all the way to the Aerospace Components Winner&#8217;s Circle with a 4.72 to Smith’s 4.83.</p>
<p><img class="size-medium wp-image-35818 aligncenter" src="https://i2.wp.com/dragillustrated.com/wp-content/uploads/2019/07/NA-10.5-Win-Leonard-Long.jpg?resize=620%2C412&#038;ssl=1" alt="" width="620" height="412" srcset="https://i2.wp.com/dragillustrated.com/wp-content/uploads/2019/07/NA-10.5-Win-Leonard-Long.jpg?resize=800%2C532&amp;ssl=1 800w, https://i2.wp.com/dragillustrated.com/wp-content/uploads/2019/07/NA-10.5-Win-Leonard-Long.jpg?resize=150%2C100&amp;ssl=1 150w, https://i2.wp.com/dragillustrated.com/wp-content/uploads/2019/07/NA-10.5-Win-Leonard-Long.jpg?resize=768%2C511&amp;ssl=1 768w, https://i2.wp.com/dragillustrated.com/wp-content/uploads/2019/07/NA-10.5-Win-Leonard-Long.jpg?resize=600%2C399&amp;ssl=1 600w, https://i2.wp.com/dragillustrated.com/wp-content/uploads/2019/07/NA-10.5-Win-Leonard-Long.jpg?w=1080&amp;ssl=1 1080w" sizes="(max-width: 620px) 100vw, 620px" data-recalc-dims="1" /></p>
<p>In the high-winding world of <strong>FST Carburetors NA 10.5,</strong> Leonard Long shifted his way to a 7.85 to lead qualifying in his Mustang. He made it all the way to the final round of eliminations where, in the heat of the day, he recorded a 7.95 to win over Dwight Ausmus, who wheeled his wheel-standing Firebird to an 8.10.</p>
<p>In <strong>Chevrolet Performance Stock presented by Scoggin-Dickey Parts Center</strong>, Jesse Wilson wrapped up a 10.191 to lead qualifying in his Camaro, but Haley Burkhammer was right there with a 10.197 in her Camaro to qualify in the second spot. She remained right there through the final round, where she won with a 10.23 to Wilson’s 10.32. Burkhammer&#8217;s victory snapped a season and a half-long winning streak by Wilson, resulting in an even bigger celebration in the <strong>Aerospace Components Winner&#8217;s Circle</strong>.</p>
<p>Wayne Larsen ran to an 13.42 on a 14.95 index in his Comet to lead qualifying in <strong>Coan Engineering Stock/Super Stock Combo</strong>, but the final round featured Jeffrey Frees and his Drag Pak Challenger and Terry Knott and a Dart. In the double break out race, Frees picked up the win with a 9.84 on a 9.86 dial, while Knott was 11.17 on an 11.20 dial.</p>
<p>In <strong>Quick Fuel Technology Nostalgia Super Stock</strong>, reigning category champion Kevin Gass gunned to a 9.75 on a 9.75 index in his Chevelle to lead qualifying. He stayed strong through the final to take the win with a 9.77 on a 9.75 index over Tim Frees, who drove to a 10.56 on a 10.50 index in his Savoy.</p>
<p><img class="size-medium wp-image-35819 aligncenter" src="https://i1.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Nostalgia-Muscle-Car-Win-Andy-Warren.jpg?resize=620%2C413&#038;ssl=1" alt="" width="620" height="413" srcset="https://i1.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Nostalgia-Muscle-Car-Win-Andy-Warren.jpg?resize=800%2C533&amp;ssl=1 800w, https://i1.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Nostalgia-Muscle-Car-Win-Andy-Warren.jpg?resize=150%2C100&amp;ssl=1 150w, https://i1.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Nostalgia-Muscle-Car-Win-Andy-Warren.jpg?resize=768%2C511&amp;ssl=1 768w, https://i1.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Nostalgia-Muscle-Car-Win-Andy-Warren.jpg?resize=600%2C400&amp;ssl=1 600w, https://i1.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Nostalgia-Muscle-Car-Win-Andy-Warren.jpg?w=1080&amp;ssl=1 1080w" sizes="(max-width: 620px) 100vw, 620px" data-recalc-dims="1" /></p>
<p>Multi-time <strong>Detroit Truetrac</strong> <strong>Nostalgia Muscle Car </strong>champion Andy Warren wheeled to a 10.25 on a 10.25 index in his Caprice to lead qualifying, and as the NMCA’s winningest driver, he made it to another final round. There, he broke out with a 10.23 on a 10.25 index, but still earned the win as Audrey Baize also broke out with an 11.72 on an 11.75 index.</p>
<p>Nicholas Massengale recorded a .002 to lead qualifying in <strong>MagnaFuel Open Comp</strong>, but in the sixth and final round, Kurt Anderson, who spends just as much time going skyward as he does going forward in his Camaro, won with a 9.98 on a 10.01 dial over Scott Williams, who was 8.48 on an 8.53 in his Chevelle in the double-breakout bout.</p>
<p><img class="size-medium wp-image-35820 aligncenter" src="https://i0.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Open-Comp-Win-Kurt-Anderson.jpg?resize=620%2C413&#038;ssl=1" alt="" width="620" height="413" srcset="https://i0.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Open-Comp-Win-Kurt-Anderson.jpg?resize=800%2C533&amp;ssl=1 800w, https://i0.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Open-Comp-Win-Kurt-Anderson.jpg?resize=150%2C100&amp;ssl=1 150w, https://i0.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Open-Comp-Win-Kurt-Anderson.jpg?resize=768%2C511&amp;ssl=1 768w, https://i0.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Open-Comp-Win-Kurt-Anderson.jpg?resize=600%2C400&amp;ssl=1 600w, https://i0.wp.com/dragillustrated.com/wp-content/uploads/2019/07/Open-Comp-Win-Kurt-Anderson.jpg?w=1080&amp;ssl=1 1080w" sizes="(max-width: 620px) 100vw, 620px" data-recalc-dims="1" /></p>
<p><strong>NMCA Gear Vendors True Street </strong>drivers joined<strong> NMRA QA1 True Street </strong>drivers for this event, and as a special feature, their cruise included laps on the Chicagoland Speedway NASCAR tri-oval. When it was all said and done, Eric Olson stood out as the overall winner with an unexpected 8.54 average in a Ranger, and Randy Thomas was the runner-up with an 8.72 average in a Mustang Shelby GT500. Bill Unkel ran to the 9-second win in a Mustang, Heinz Stock picked up the 10-second win in a Mustang, Robert Ball drove to the 11-second win in a Mustang and Mike Baker picked up the 12-second win in a Mustang. Rounding out the category were Jeff Buck, who was the 13-second winner, Wayne Haley, who was the 14-second winner and Belinda Moore, who was the 15-second winner.</p>
<p>Drivers with 2005 and newer Gen III-powered Challengers, Demons, Hellcats, Chargers, 300s and Jeeps have been duking it out in the <strong>Dodge // Mopar HEMI Shootout </strong>at NMCA events this year, with Dodge // Mopar covering the cost of the entry for the first 75 drivers registering who take part. At this event, Victor Cervantes was the overall winner with a 10.11 average, while Derrick Roderweiss was the runner-up with an 10.16 average. John Ridings was the 11-second winner, Pat Baldezier was the 12-second winner, Ken Mason was the 13-second winner and Dana Baker was the 14-second winner. Brandon Alley wrapped things up as the 15-second winner. Then, after the eight quickest drivers in the category came together for the <strong>Arrington Performance HEMI Quick 8 presented by Red Line Oil,</strong> Wade Atchison arrived at the win with a holeshot and a 10.41 in his Demon over Derrick Roderweiss, who was 10.22 in his Demon.</p>
<p>In the <strong>Chevrolet Performance Street Car Challenge</strong>, Louis Truffa was the overall winner with a 9.22 average in his Monte Carlo, while Kevin Rowand was the runner-up with an 11.03 average in his Corvette. Robert Peter picked up the 12-second win in his Camaro, Greg Jessup pushed to the 13-second win in his Camaro, Jeremy Billecki was the 14-second winner in his Camaro and Steve Weigl was the 15-second winner in his Caprice.</p>
<p>NMCA <strong>Gear Vendors True Street</strong>, NMRA <strong>QA1 True Street</strong>, Chevrolet Performance Street Car Challenge and Dodge // Mopar HEMI Shootout drivers who wanted even more track-time were able to take part in the <strong>True Street Bracket</strong>. Six rounds later, Rodney Ward wrapped up the win with a 15.12 on a 15.10 dial, while Keith Saymore was the runner-up with a break out time of 10.65 on a 10.69.</p>
<p>To begin the newly named <strong>Bob Curran Memorial Super Bowl Shootouts</strong> featuring NMCA and NMRA drivers who won in their categories, Bob Curran&#8217;s son, Jeremy Curran, slowly drove his late father&#8217;s Xtreme Street Corvette down track, as his mother, Sue Curran, and fellow racers watched. Then, drivers faced off as flocks of fans rooted for their favorite series. After the last pair of cars had trampled the track, Team NMRA earned the title for the tenth time. As a righteous reward, each NMRA team member will be given a Nitto Diamond Tree ring, and Bob Curran’s family will generously give $500 to each round winner.</p>
<p>Next up on this year’s NMCA tour is the highly anticipated 18th Annual NMCA All-American Nationals, Aug. 22-25 at Summit Motorsports Park in Norwalk, Ohio. For more information and advance tickets, visit <a href="http://www.NMCAdigital.com/OH">www.NMCAdigital.com/OH </a></p>
<div class='dd_post_share'><div class='dd_buttons'><div class='dd_button'><a name='fb_share' type='button_count' share_url='https://dragillustrated.com/two-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing/' href='http://www.facebook.com/sharer.php'></a><script src='https://static.ak.fbcdn.net/connect.php/js/FB.Share' type='text/javascript'></script></div><div class='dd_button'><a href="http://twitter.com/share" class="twitter-share-button" data-url="https://dragillustrated.com/two-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing/" data-count="horizontal" data-text="Two Times the Talent at Nitto NMRA/NMCA Super Bowl of Street Legal Drag Racing" data-via="dragillustrated" ></a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script></div><div class='dd_button'><iframe src='https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fdragillustrated.com%2Ftwo-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing%2F&amp;locale=en_US&amp;layout=standard&amp;action=like&amp;width=350&amp;height=24&amp;colorscheme=light' scrolling='no' frameborder='0' style='border:none; overflow:hidden; width:500px; height:24px;' allowTransparency='true'></iframe></div></div><div style='clear:both'></div></div><!-- Social Buttons Generated by Digg Digg plugin v5.3.6,
    Author : Buffer, Inc
    Website : http://bufferapp.com/diggdigg --><!-- FB Comments For Wp: http://www.vivacityinfotech.com --><h3 class='coments-title'>Comments</h3><p class='commentcount'><fb:comments-count href="https://dragillustrated.com/two-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing/"></fb:comments-count> comments</p><div class="fb-comments" data-href="https://dragillustrated.com/two-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing/" data-numposts="6" data-width="100%" data-colorscheme="light"></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-423"><a class="gofollow" data-track="NDIzLDE2LDEsNjA=" href="https://kinsler.com/Shop/shop/" target="_blank"><img src="https://i1.wp.com/dragillustrated.com/wp-content/uploads/2018/01/Kinsler_F_I_Web_Ad18.jpg?ssl=1" /></a></div></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-550"><a class="gofollow" data-track="NTUwLDE2LDEsNjA=" href="https://www.epartrade.com/" target="_blank"><img src="https://i0.wp.com/dragillustrated.com/wp-content/uploads/2019/07/drag.jpg?ssl=1" /></a></div></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-484"><a class="gofollow" data-track="NDg0LDE2LDEsNjA=" href="http://www.us.mahle.com/en/motorsports/elite-sportsman-drag-pistons/?utm_source=drag-illustrated&utm_medium=banner&utm_campaign=elitesportsman-drag-illustrated" target="_blank"><img src="https://i1.wp.com/dragillustrated.com/wp-content/uploads/2019/03/MAH-1396-Drag-Illustrated-300x250.jpg?ssl=1" /></a></div></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-563"><a class="gofollow" data-track="NTYzLDE2LDEsNjA=" href="https://www.racecraft.com/" target="_blank"><img src="https://i2.wp.com/dragillustrated.com/wp-content/uploads/2019/06/rcj.jpg?ssl=1" /></a></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>																		<div class="post-tags">
							<span class="post-tags-header">Related Items</span>						</div><!--post-tags-->
					</div><!--content-area-->
				</div><!--post-area-->
										<div id="author-wrapper">
						<div id="author-info">
							<img alt='' src='https://secure.gravatar.com/avatar/19114ff647afcd14a1c84568b6be9a46?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/19114ff647afcd14a1c84568b6be9a46?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' />							<div id="author-text">
								<span class="author-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span>
								<p></p>
								<ul>
																																																														</ul>
							</div><!--author-text-->
						</div><!--author-info-->
					</div><!--author-wrapper-->
													<div class="prev-next-wrapper">
					<div class="prev-post">
						&larr; Previous Story <a href="https://dragillustrated.com/hines-wins-pro-bike-battle-millican-hight-laughlin-and-smith-earn-no-1-qualifiers-in-sonoma/" rel="prev">Hines Wins Pro Bike Battle; Millican, Hight, Laughlin And Smith Earn No. 1 Qualifiers In Sonoma</a>					</div><!--prev-post-->
					<div class="next-post">
											</div><!--next-post-->
				</div><!--prev-next-wrapper-->
												<div id="comments">
				
	
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><h4 class="post-header"><span class="post-header">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/two-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://dragillustrated.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='35817' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>
<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf1N='051f01bae3fec2c0f983f90a2728eb93';
hf1V='48f4c8712399e827e2c63563c22496c5';
document.write("<input type='hidden' name='r3f5x9JS' value='"+r3f5x9JS+"' /><input type='hidden' name='"+hf1N+"' value='"+hf1V+"' />");
/* ]]> */
</script>
<noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript>
<noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript>
			</form>
			</div><!-- #respond -->
	
</div><!--comments-->			</div><!--home-main-->
				</div><!--content-main-->
		<div id="sidebar-wrapper">
	<div id="text-26" class="sidebar-widget widget_text">			<div class="textwidget"><div id="adblock" align="center"><div class="gformba gformba-1"><div class="gformba-single aformba-473"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="NDczLDEsMSw2MA==" href="https://www.jerrybickel.com/" target="_blank"><img src="https://i2.wp.com/dragillustrated.com/wp-content/uploads/2018/04/imgad-8-18.jpg?ssl=1" /></a></div></div></div>
</div>
		</div><div id="text-45" class="sidebar-widget widget_text">			<div class="textwidget"><div id="adblock" align="center"><div class="gformba gformba-1"><div class="gformba-single aformba-568"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="NTY4LDEsMSw2MA==" href="https://www.aeromotiveinc.com/current-promotion/" target="_blank"><img src="https://i2.wp.com/dragillustrated.com/wp-content/uploads/2019/06/Aeromotive_SummerRebate_2019_300x300.jpg?ssl=1" /></a></div></div></div>
</div>
		</div><div id="text-27" class="sidebar-widget widget_text">			<div class="textwidget"><div align="center" id="adblock"><div class="gformba gformba-2"><div class="gformba-single aformba-563"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="NTYzLDIsMSw2MA==" href="https://www.racecraft.com/" target="_blank"><img src="https://i2.wp.com/dragillustrated.com/wp-content/uploads/2019/06/rcj.jpg?ssl=1" /></a></div></div></div>
</div>
		</div> 		</div><!--sidebar-wrapper-->					</div><!--content-wrapper-->
</div><!--main-wrapper-->
		<div id="footer-wrapper">
			<div id="footer-top">
			   <div class="ad-rotate-widget-footer"><div class="ad-rotate-widget-widget">			<div class="textwidget"><div class="gformba gformba-7"><div class="gformba-single aformba-531"><a class="gofollow" data-track="NTMxLDcsMSw2MA==" href="https://www.maximausa.com/performance-auto/" target="_blank"><img src="https://i0.wp.com/dragillustrated.com/wp-content/uploads/2019/03/DRAG-ILL-APR2019-728x90.gif?ssl=1" /></a></div></div>
</div>
		</div></div><!-- end .ad-rotate-widget --><div id="ad-rotate-footer-bottom"></div>				<div id="footer-nav">
					<div class="menu-about-di-container"><ul id="menu-about-di" class="menu"><li id="menu-item-21282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21282"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/">Subscribe</a></li>
<li id="menu-item-15093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15093"><a href="https://dragillustrated.com/about/">About</a></li>
<li id="menu-item-15089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15089"><a href="https://dragillustrated.com/our-team/">Our Team</a></li>
<li id="menu-item-15091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15091"><a href="https://dragillustrated.com/advertise/">Advertise</a></li>
<li id="menu-item-15090" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15090"><a href="https://dragillustrated.com/contact/">Contact</a></li>
</ul></div>				</div><!--footer-nav-->
								<div id="footer-widget-wrapper">
										<div class="footer-widget">
												<div id="logo-footer">
							<img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2014/05/DragIllustratedMediablackRGBSMALL.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
						</div><!--logo-footer-->
												<p>Drag Illustrated is not affiliated with, nor is it bound by any sanctioning body or association. From groundbreaking stories on underground grudge and outlaw racing to in-depth interviews with world-renowned racers and exclusive event coverage, Drag Illustrated shines the spotlight on the hottest stories in drag racing. When drivers, builders, and hardcore fans want the unbiased truth, Drag Illustrated is where they turn.</p>						<div id="footer-social">
							<ul>
																<li class="fb-item">
									<a href="https://www.facebook.com/DragIllustrated/" alt="Facebook" class="fb-but2" target="_blank"></a>
								</li>
																								<li class="twitter-item">
									<a href="https://twitter.com/DragIllustrated" alt="Twitter" class="twitter-but2" target="_blank"></a>
								</li>
																																								<li class="instagram-item">
									<a href="https://www.instagram.com/dragillustrated/" alt="Instagram" class="instagram-but2" target="_blank"></a>
								</li>
																																								<li><a href="https://dragillustrated.com/feed/rss/" alt="RSS Feed" class="rss-but2"></a></li>
															</ul>
						</div><!--footer-social-->
						<div id="copyright">
							<p>Copyright © 2019 Drag Illustrated Media, LLC.</p>
						</div><!--copyright-->
					</div><!--footer-widget-->
															<div class="footer-widget">
						<h3 class="footer-widget-header">Latest News</h3>
						<ul class="home-list">
														<li>
								<a href="https://dragillustrated.com/sonnax-ramps-up-powerglide-durability-with-new-ratio-options-for-big-shaft-system/" rel="bookmark">
								<div class="home-list-content">
									<h2>Sonnax Ramps Up Powerglide Durability With New Ratio Options For Big Shaft System</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/two-times-the-talent-at-nitto-nmra-nmca-super-bowl-of-street-legal-drag-racing/" rel="bookmark">
								<div class="home-list-content">
									<h2>Two Times the Talent at Nitto NMRA/NMCA Super Bowl of Street Legal Drag Racing</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/winters-returning-to-bandimere-speedway-with-one-goal-win-the-wsopm/" rel="bookmark">
								<div class="home-list-content">
									<h2>Winters Returning To Bandimere Speedway With One Goal: Win The WSOPM</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/hight-b-torrence-anderson-and-hines-all-win-at-nhra-sonoma-nationals/" rel="bookmark">
								<div class="home-list-content">
									<h2>Hight, B. Torrence, Anderson And Hines All Win At NHRA Sonoma Nationals</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/hines-wins-pro-bike-battle-millican-hight-laughlin-and-smith-earn-no-1-qualifiers-in-sonoma/" rel="bookmark">
								<div class="home-list-content">
									<h2>Hines Wins Pro Bike Battle; Millican, Hight, Laughlin And Smith Earn No. 1 Qualifiers In Sonoma</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/pre-entries-open-for-additional-classes-at-world-series-of-pro-mod/" rel="bookmark">
								<div class="home-list-content">
									<h2>Pre-Entries Open for Additional Classes at World Series of Pro Mod</h2>
								</div><!--home-list-content-->
								</a>
							</li>
													</ul>
					</div><!--footer-widget-->
					<div class="footer-widget">
						<h3 class="footer-widget-header">Tags</h3>
						<div class="tag-cloud">
						<a href="https://dragillustrated.com/tag/drag-illustrated/" class="tag-cloud-link tag-link-377 tag-link-position-1" style="font-size: 12px;">drag illustrated</a>
<a href="https://dragillustrated.com/tag/wes-buck/" class="tag-cloud-link tag-link-1284 tag-link-position-2" style="font-size: 12px;">wes buck</a>
<a href="https://dragillustrated.com/tag/yahoo/" class="tag-cloud-link tag-link-1321 tag-link-position-3" style="font-size: 12px;">yahoo</a>
<a href="https://dragillustrated.com/tag/ian-tocher/" class="tag-cloud-link tag-link-553 tag-link-position-4" style="font-size: 12px;">ian tocher</a>
<a href="https://dragillustrated.com/tag/drag-illistrated/" class="tag-cloud-link tag-link-376 tag-link-position-5" style="font-size: 12px;">drag illistrated</a>
<a href="https://dragillustrated.com/tag/dragillistrated/" class="tag-cloud-link tag-link-382 tag-link-position-6" style="font-size: 12px;">dragillistrated</a>
<a href="https://dragillustrated.com/tag/dragillustrated/" class="tag-cloud-link tag-link-383 tag-link-position-7" style="font-size: 12px;">dragillustrated</a>
<a href="https://dragillustrated.com/tag/google/" class="tag-cloud-link tag-link-501 tag-link-position-8" style="font-size: 12px;">google</a>
<a href="https://dragillustrated.com/tag/drag-racing/" class="tag-cloud-link tag-link-378 tag-link-position-9" style="font-size: 12px;">drag racing</a>
<a href="https://dragillustrated.com/tag/bing/" class="tag-cloud-link tag-link-163 tag-link-position-10" style="font-size: 12px;">bing</a>
<a href="https://dragillustrated.com/tag/nhra/" class="tag-cloud-link tag-link-840 tag-link-position-11" style="font-size: 12px;">nhra</a>
<a href="https://dragillustrated.com/tag/nhra-photos/" class="tag-cloud-link tag-link-879 tag-link-position-12" style="font-size: 12px;">nhra photos</a>
<a href="https://dragillustrated.com/tag/pro-stock/" class="tag-cloud-link tag-link-973 tag-link-position-13" style="font-size: 12px;">pro stock</a>
<a href="https://dragillustrated.com/tag/funny-car/" class="tag-cloud-link tag-link-462 tag-link-position-14" style="font-size: 12px;">funny car</a>
<a href="https://dragillustrated.com/tag/top-fuel/" class="tag-cloud-link tag-link-1222 tag-link-position-15" style="font-size: 12px;">top fuel</a>
<a href="https://dragillustrated.com/tag/pro-mod/" class="tag-cloud-link tag-link-968 tag-link-position-16" style="font-size: 12px;">pro mod</a>
<a href="https://dragillustrated.com/tag/pro-modified/" class="tag-cloud-link tag-link-970 tag-link-position-17" style="font-size: 12px;">pro modified</a>
<a href="https://dragillustrated.com/tag/adrl/" class="tag-cloud-link tag-link-55 tag-link-position-18" style="font-size: 12px;">ADRL</a>
<a href="https://dragillustrated.com/tag/john-force/" class="tag-cloud-link tag-link-639 tag-link-position-19" style="font-size: 12px;">john force</a>
<a href="https://dragillustrated.com/tag/jeg-coughlin-jr/" class="tag-cloud-link tag-link-597 tag-link-position-20" style="font-size: 12px;">jeg coughlin jr</a>
<a href="https://dragillustrated.com/tag/courtney-force/" class="tag-cloud-link tag-link-298 tag-link-position-21" style="font-size: 12px;">courtney force</a>
<a href="https://dragillustrated.com/tag/don-schumacher/" class="tag-cloud-link tag-link-361 tag-link-position-22" style="font-size: 12px;">don schumacher</a>
<a href="https://dragillustrated.com/tag/antron-brown/" class="tag-cloud-link tag-link-107 tag-link-position-23" style="font-size: 12px;">antron brown</a>
<a href="https://dragillustrated.com/tag/jack-beckman/" class="tag-cloud-link tag-link-576 tag-link-position-24" style="font-size: 12px;">jack beckman</a>
<a href="https://dragillustrated.com/tag/tony-schumacher/" class="tag-cloud-link tag-link-1217 tag-link-position-25" style="font-size: 12px;">tony schumacher</a>
<a href="https://dragillustrated.com/tag/american-drag-racing-league/" class="tag-cloud-link tag-link-95 tag-link-position-26" style="font-size: 12px;">american drag racing league</a>
<a href="https://dragillustrated.com/tag/erica-enders/" class="tag-cloud-link tag-link-419 tag-link-position-27" style="font-size: 12px;">erica enders</a>
<a href="https://dragillustrated.com/tag/allen-johnson/" class="tag-cloud-link tag-link-88 tag-link-position-28" style="font-size: 12px;">allen johnson</a>
<a href="https://dragillustrated.com/tag/greg-anderson/" class="tag-cloud-link tag-link-505 tag-link-position-29" style="font-size: 12px;">greg anderson</a>
<a href="https://dragillustrated.com/tag/spencer-massey/" class="tag-cloud-link tag-link-1119 tag-link-position-30" style="font-size: 12px;">spencer massey</a>						</div>
					</div><!--footer-widget-->
					 									</div><!--footer-widget-wrapper-->
			</div><!--footer-top-->
		</div><!--footer-wrapper-->
	</div><!--body-wrapper-->
</div><!--site-->


<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=297668800418060&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='051f01bae3fec2c0f983f90a2728eb93';
hf4V='48f4c8712399e827e2c63563c22496c5';
cm4S="form[action='https://dragillustrated.com/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form, .wpcf7-form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);return true;});var h="form[method='post']";$(h).submit(function(){$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(h);return true;});});
/* ]]> */
</script> 
		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		
<script type="text/javascript">
jQuery(document).ready(function($) {

	// Main Menu Dropdown Toggle
	$('.menu-item-has-children a').click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$('.menu-item-has-children').click(function(){
    	  $(this).addClass('toggled');
    	  if($('.menu-item-has-children').hasClass('toggled'))
    	  {
    	  $(this).children('ul').toggle();
	  $('.fly-nav-menu').getNiceScroll().resize();
	  }
	  $(this).toggleClass('tog-minus');
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});

});
</script>


<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script>	<script type="text/javascript">
		var c = document.body.className;
		c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
		document.body.className = c;
	</script>
	<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.1.1/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js?ver=1563472768'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/dragillustrated.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=1558371468'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201931'></script>
<script type='text/javascript' src='https://c0.wp.com/p/woocommerce/3.6.5/assets/js/jquery-blockui/jquery.blockUI.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/dragillustrated.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/woocommerce/3.6.5/assets/js/frontend/add-to-cart.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/woocommerce/3.6.5/assets/js/js-cookie/js.cookie.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/woocommerce/3.6.5/assets/js/frontend/woocommerce.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_f0c91d7f4e3f0644a3ce523654f9cc4c","fragment_name":"wc_fragments_f0c91d7f4e3f0644a3ce523654f9cc4c","request_timeout":"5000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/woocommerce/3.6.5/assets/js/frontend/cart-fragments.min.js'></script>
<script type='text/javascript'>
		jQuery( 'body' ).bind( 'wc_fragments_refreshed', function() {
			jQuery( 'body' ).trigger( 'jetpack-lazy-images-load' );
		} );
	
</script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/js/jquery.iosslider.js?ver=1510873624'></script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/js/scripts.js?ver=1510873624'></script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/js/respond.min.js?ver=1510873624'></script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/js/retina.js?ver=1510873624'></script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/wp-spamshield/js/jscripts-ftr2-min.js?ver=1509165004'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.0.4/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201931.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.1.1',blog:'37035244',post:'35817',tz:'-5',srv:'dragillustrated.com'} ]);
	_stq.push([ 'clickTrackerInit', '37035244', '35817' ]);
</script>

</body>
</html>