<!DOCTYPE html>
<html lang="en-US"
 xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />

<meta property="og:image" content="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/NHRA_E6Ignition_640-400x242.jpg" />


<link rel="shortcut icon" href="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2014/06/DI_16x16_favicon.png" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://dragillustrated.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://dragillustrated.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://dragillustrated.com/feed/atom/" />
<link rel="pingback" href="https://dragillustrated.com/xmlrpc.php" />


<title>FAST E6 Digital CD Ignition Box Approved by NHRA | Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</title>

<!-- All in One SEO Pack 2.3.11.4 by Michael Torbert of Semper Fi Web Designob_start_detected [-1,-1] -->
<meta name="description"  content="Thanks to approval from the NHRA technical department, the FAST E6 Digital CD Ignition Box is now available for use in NHRA Championship Drag Racing. The new" />

<link rel="canonical" href="https://dragillustrated.com/fast-e6-digital-cd-ignition-box-approved-by-nhra/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Feed" href="https://dragillustrated.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Comments Feed" href="https://dragillustrated.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; iCal Feed" href="https://dragillustrated.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; FAST E6 Digital CD Ignition Box Approved by NHRA Comments Feed" href="https://dragillustrated.com/fast-e6-digital-cd-ignition-box-approved-by-nhra/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/dragillustrated.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='front-css-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/facebook-comment-by-vivacity/css/fb-comments-hidewpcomments.css' type='text/css' media='all' />
<link rel='stylesheet' id='inoplugs_backgrounds_css-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/wp-backgrounds-lite/includes/wp-backgrounds.css' type='text/css' media='all' />
<link rel='stylesheet' id='cardpay-authnet-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/authnet-cim-for-woo/assets/css/cardpay-authnet.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='digg-digg-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/digg-digg/css/diggdigg-style.css' type='text/css' media='screen' />
<link rel='stylesheet' id='theiaPostSlider-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/theia-post-slider/css/buttons-red.css' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-layout-css'  href='//dragillustrated.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='//dragillustrated.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='//dragillustrated.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-style-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/Braxton-Child/style.css' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='mvp-iecss-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/Braxton-Child/css/iecss.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='reset-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/css/reset.css' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.css' type='text/css' media='all' />
<link rel='stylesheet' id='media-queries-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/css/media-queries.css' type='text/css' media='all' />
<link rel='stylesheet' id='studio-fonts-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A400%7CQuicksand%3A300%2C400%7CVidaloka%7CPlayfair+Display%3A400%2C700%2C900%7COpen+Sans+Condensed%3A300%2C700%7COpen+Sans%3A400%2C800%7COswald%3A300%2C400%2C700%7CRaleway%3A200%2C300%2C400%2C500%2C600%2C700%2C800%26subset%3Dlatin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='fw-ext-builder-frontend-grid-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/unyson/framework/extensions/builder/static/css/frontend-grid.css' type='text/css' media='all' />
<link rel='stylesheet' id='fw-ext-forms-default-styles-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/unyson/framework/extensions/forms/static/css/frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/tablepress-combined.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js'></script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/theia-post-slider/js/balupton-history.js/history.js'></script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/theia-post-slider/js/balupton-history.js/history.adapter.jquery.js'></script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/theia-post-slider/js/async.min.js'></script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/theia-post-slider/js/tps-transition-slide.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var photocrati_ajax = {"url":"https:\/\/dragillustrated.com\/?photocrati_ajax=1","wp_home_url":"https:\/\/dragillustrated.com","wp_site_url":"https:\/\/dragillustrated.com","wp_root_url":"https:\/\/dragillustrated.com","wp_plugins_url":"https:\/\/dragillustrated.com\/wp-content\/plugins","wp_content_url":"https:\/\/dragillustrated.com\/wp-content","wp_includes_url":"https:\/\/dragillustrated.com\/wp-includes\/","ngg_param_slug":"nggallery"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/ajax/static/ajax.min.js'></script>
<link rel='https://api.w.org/' href='https://dragillustrated.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dragillustrated.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dragillustrated.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='DI 30 UNDER 30 2016: Ty Tutterow' href='https://dragillustrated.com/di-30-under-30-2016-ty-tutterow/' />
<link rel='shortlink' href='https://dragillustrated.com/?p=25459' />
<link rel="alternate" type="application/json+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Ffast-e6-digital-cd-ignition-box-approved-by-nhra%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Ffast-e6-digital-cd-ignition-box-approved-by-nhra%2F&#038;format=xml" />
<script type="text/javascript" src="https://paywall.subscriptiongenius.com/load.js"></script>

<!-- This site is using AdRotate v4.1.5 Professional to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 {  margin: 0 auto; }
	.g-2 { margin:1px 1px 1px 1px; }
	.g-3 { margin:1px 1px 1px 1px; }
	.g-4 { margin:1px 1px 1px 1px; }
	.g-5 { margin:1px 1px 1px 1px; }
	.g-6 { margin:1px 1px 1px 1px; }
	.g-7 { margin:1px 1px 1px 1px; }
	.g-8 { min-width:3px; max-width:618px; }
	.b-8 { margin:1px 3px 1px 3px; }
	.g-9 { margin:1px 1px 1px 1px; }
	.g-10 { margin:1px 1px 1px 1px; }
	.g-16 { min-width:5px; max-width:150px; margin: 0 auto; }
	.b-16 { margin:0px 5px 0px 5px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<link rel="image_src" href="" /><meta property="fb:app_id" content="297668800418060"/>
<meta property="fb:admins" content=""/>
<meta property="og:locale" content="en_US" />
<meta property="og:locale:alternate" content="en_US" />
<style type="text/css">
			.wpsdc-drop-cap {
				float : left;				
				padding : 0.25em 0.05em 0.25em 0;				
				font-size : 5em;
				line-height : 0.4em;color : #0a0a0a;}
		</style><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//dragillustrated.com/?wordfence_logHuman=1&hid=24B044C65EBC55C9466DF59911907915');
</script><!-- <meta name="NextGEN" version="2.1.77" /> -->
<style type='text/css'>img#wpstats{display:none}</style>
<style type='text/css'>

@import url(//fonts.googleapis.com/css?family=Vidaloka:100,200,300,400,500,600,700,800,900|Raleway:100,200,300,400,500,600,700,800,900|Playfair+Display:100,200,300,400,500,600,700,800,900|Oswald:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese);

#nav-wrapper,
#nav-top-wrap {
	background: #ff0000;
	}

.fly-but-wrap span {
	background: #555555;
	}

#main-nav .menu li a:hover,
#main-nav .menu li.current-menu-item a,
#search-button:hover,
.home-widget h3.widget-cat,
span.post-tags-header,
.post-tags a:hover,
.tag-cloud a:hover,
.woocommerce .widget_price_filter .ui-slider .ui-slider-range {
	background: #ff0000;
	}

.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce span.onsale,
.woocommerce #respond input#submit.alt,
.woocommerce a.button.alt,
.woocommerce button.button.alt,
.woocommerce input.button.alt,
.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt:hover {
	background-color: #ff0000;
	}

.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt:hover {
	opacity: 0.8;
	}

#main-nav .menu-item-home a:hover {
	background: #ff0000 !important;
	}

#top-story-left h3,
#top-story-right h3 {
	border-bottom: 3px solid #ff0000;
	}

a, a:visited,
ul.top-stories li:hover h2,
ul.top-stories li:hover h2,
#top-story-middle:hover h2,
#top-story-wrapper:hover #feat2-main-text h2,
#feat1-left-wrapper:hover .feat1-left-text h2,
#feat1-right-wrapper:hover .feat1-right-text h2,
ul.split-columns li:hover h2,
.home-widget ul.wide-widget li:hover h2,
.home-widget ul.home-list li:hover h2,
h3.story-cat,
h3.story-cat a,
.sidebar-widget ul.home-list li:hover h2,
.sidebar-widget ul.wide-widget li:hover h2,
.sidebar-widget ul.split-columns li:hover h2,
#footer-nav .menu li a:hover,
.footer-widget ul.home-list li:hover h2,
.footer-widget ul.wide-widget li:hover h2,
.footer-widget ul.split-columns li:hover h2,
.prev,
.next {
	color: #ff0000;
	}

#wallpaper {
	background: url() no-repeat 50% 0;
	}

.featured-text h2,
.featured-text h2 a,
.feat1-main-text h2,
.feat1-main-text h2 a {
	font-family: 'Vidaloka', serif;
	}

#main-nav .menu li a,
#main-nav .menu li:hover ul li a {
	font-family: 'Raleway', sans-serif;
	}

#top-story-left h2,
#top-story-right h2,
.feat1-left-text h2,
.feat1-right-text h2,
#feat2-main-text h2,
#middle-text h2,
ul.split-columns li h2,
.home-widget .wide-text h2,
.home-widget .home-list-content h2,
h1.story-title,
.sidebar-widget .wide-text h2,
.sidebar-widget ul.split-columns li h2,
.footer-widget .wide-text h2,
.footer-widget ul.split-columns li h2,
#post-404 h1 {
	font-family: 'Playfair Display', serif;
	}

#top-story-left h3,
#top-story-right h3,
#middle-text h3,
h1.home-widget-header,
#woo-content h1.page-title,
h3.home-widget-header,
h1.archive-header,
h3.story-cat,
h3.story-cat a,
#content-area h1,
#content-area h2,
#content-area h3,
#content-area h4,
#content-area h5,
#content-area h6,
h4.post-header,
h3.sidebar-widget-header,
h3.footer-widget-header {
	font-family: 'Oswald', sans-serif;
	}

@media screen and (max-width: 767px) and (min-width: 480px) {

	.sidebar-widget .home-list-content h2 {
		font-family: 'Playfair Display', serif;
		}

	}

#menufication-outer-wrap.menufication-transition-in #menufication-scroll-container {
	overflow-y: auto !important;
	}

</style>
	
<style type="text/css">



</style>

<style type="text/css">
#wallpaper {
	background-size: 100%;
}</style>

<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e7e7e7; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="FAST E6 Digital CD Ignition Box Approved by NHRA" />
<meta property="og:url" content="https://dragillustrated.com/fast-e6-digital-cd-ignition-box-approved-by-nhra/" />
<meta property="og:description" content="Thanks to approval from the NHRA technical department, the FAST E6 Digital CD Ignition Box is now available for use in NHRA Championship Drag Racing. The new FAST E6 Digital CD Ignition Box (part n…" />
<meta property="article:published_time" content="2017-02-08T18:00:23+00:00" />
<meta property="article:modified_time" content="2017-02-08T18:00:23+00:00" />
<meta property="og:site_name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
<meta property="og:image" content="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/NHRA_E6Ignition_640.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="431" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/NHRA_E6Ignition_640.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- BEGIN GADWP v4.9.6.1 Universal Tracking - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-21052018-1', 'auto');
  ga('send', 'pageview');
</script>

<!-- END GADWP Universal Tracking -->


<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/wp-spamshield/js/jscripts.php'></script> 

</head>

<body data-rsssl=1 class="post-template-default single single-post postid-25459 single-format-standard custom-background tribe-no-js">
<div id="site">
	<div id="fly-wrap">
	<div class="fly-wrap-out">
		<div class="fly-side-wrap">
			<ul class="fly-bottom-soc left relative">
									<li class="fb-soc">
						<a href="https://www.facebook.com/DragIllustrated/" target="_blank">
						<i class="fa fa-facebook-square fa-2"></i>
						</a>
					</li>
													<li class="twit-soc">
						<a href="https://twitter.com/DragIllustrated" target="_blank">
						<i class="fa fa-twitter fa-2"></i>
						</a>
					</li>
																	<li class="inst-soc">
						<a href="https://www.instagram.com/dragillustrated/" target="_blank">
						<i class="fa fa-instagram fa-2"></i>
						</a>
					</li>
																													<li class="rss-soc">
						<a href="https://dragillustrated.com/feed/rss/" target="_blank">
						<i class="fa fa-rss fa-2"></i>
						</a>
					</li>
							</ul>
		</div><!--fly-side-wrap-->
		<div class="fly-wrap-in">
			<div id="fly-menu-wrap">
				<nav class="fly-nav-menu left relative">
					<div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-15084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15084"><a href="https://dragillustrated.com/category/features/">Features</a></li>
<li id="menu-item-17722" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17722"><a>Blogs</a>
<ul class="sub-menu">
	<li id="menu-item-17723" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17723"><a href="https://dragillustrated.com/category/blogs/ian-tocher/">Ian Tocher</a></li>
	<li id="menu-item-17724" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17724"><a href="https://dragillustrated.com/category/blogs/wes-buck/">Wes Buck</a></li>
	<li id="menu-item-17725" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17725"><a href="https://dragillustrated.com/category/blogs/ontheroad/">On The Road</a></li>
	<li id="menu-item-17726" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17726"><a href="https://dragillustrated.com/category/blogs/lucky-hudson/">Lucky Hudson</a></li>
	<li id="menu-item-17727" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17727"><a href="https://dragillustrated.com/category/blogs/tommy-d/">Tommy D</a></li>
	<li id="menu-item-20226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20226"><a href="https://dragillustrated.com/category/blogs/driver-blogs/">Driver Blogs</a></li>
</ul>
</li>
<li id="menu-item-15087" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15087"><a href="https://dragillustrated.com/category/tech/">Tech</a></li>
<li id="menu-item-15086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15086"><a href="https://dragillustrated.com/category/race-coverage/">Coverage</a>
<ul class="sub-menu">
	<li id="menu-item-15096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15096"><a href="https://dragillustrated.com/category/race-coverage/nhra-race-coverage/">NHRA</a></li>
	<li id="menu-item-15100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15100"><a href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a></li>
	<li id="menu-item-15098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15098"><a href="https://dragillustrated.com/category/race-coverage/ihra-race-coverage/">IHRA</a></li>
	<li id="menu-item-15099" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15099"><a href="https://dragillustrated.com/category/race-coverage/outlaw/">Outlaw</a></li>
	<li id="menu-item-21234" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21234"><a href="https://dragillustrated.com/category/lightsout7/">Lights Out 7</a></li>
	<li id="menu-item-15101" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15101"><a href="https://dragillustrated.com/category/race-coverage/sportsman-race-coverage/">Sportsman</a></li>
</ul>
</li>
<li id="menu-item-15104" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15104"><a href="https://dragillustrated.com/shop/">Store</a></li>
<li id="menu-item-15094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li id="menu-item-15102" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
</ul></div>				</nav>
			</div><!--fly-menu-wrap-->
		</div><!--fly-wrap-in-->
	</div><!--fly-wrap-out-->
</div><!--fly-wrap-->	<div id="nav-top-wrap" class="left relative">
		<div id="nav-top-mid" class="relative">
			<div id="nav-top-cont" class="left relative">
																</div><!--nav-top-cont-->
		</div><!--nav-top-mid-->
	</div><!--nav-top-wrap-->
	<div id="nav-wrapper">
		<div class="nav-wrap-out">
		<div class="nav-wrap-in">
			<div id="nav-inner">
			<div class="fly-but-wrap left relative">
				<span></span>
				<span></span>
				<span></span>
				<span></span>
			</div><!--fly-but-wrap-->
							<div id="logo-small" itemscope itemtype="http://schema.org/Organization">
											<a itemprop="url" href="https://dragillustrated.com"><img itemprop="logo" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2015/01/DI_141x54_white_shadow.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" /></a>
									</div><!--logo-small-->
						<div id="main-nav">
				<div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15084"><a href="https://dragillustrated.com/category/features/">Features</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17722"><a>Blogs</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17723"><a href="https://dragillustrated.com/category/blogs/ian-tocher/">Ian Tocher</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17724"><a href="https://dragillustrated.com/category/blogs/wes-buck/">Wes Buck</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17725"><a href="https://dragillustrated.com/category/blogs/ontheroad/">On The Road</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17726"><a href="https://dragillustrated.com/category/blogs/lucky-hudson/">Lucky Hudson</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17727"><a href="https://dragillustrated.com/category/blogs/tommy-d/">Tommy D</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20226"><a href="https://dragillustrated.com/category/blogs/driver-blogs/">Driver Blogs</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15087"><a href="https://dragillustrated.com/category/tech/">Tech</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15086"><a href="https://dragillustrated.com/category/race-coverage/">Coverage</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15096"><a href="https://dragillustrated.com/category/race-coverage/nhra-race-coverage/">NHRA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15100"><a href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15098"><a href="https://dragillustrated.com/category/race-coverage/ihra-race-coverage/">IHRA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15099"><a href="https://dragillustrated.com/category/race-coverage/outlaw/">Outlaw</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21234"><a href="https://dragillustrated.com/category/lightsout7/">Lights Out 7</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15101"><a href="https://dragillustrated.com/category/race-coverage/sportsman-race-coverage/">Sportsman</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15104"><a href="https://dragillustrated.com/shop/">Store</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
</ul></div>			</div><!--main-nav-->
			<div id="search-button">
				<img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/images/search-icon.png" />
			</div><!--search-button-->
			<div id="search-bar">
				<form method="get" id="searchform" action="https://dragillustrated.com/">
	<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>			</div><!--search-bar-->
			</div><!--nav-inner-->
		</div><!--nav-wrap-in-->
		</div><!--nav-wrap-out-->
	</div><!--nav-wrapper-->
		<div id="body-wrapper">
		
				
		<div id="main-wrapper">
										
    <div id="ad-area-wrap"><div class="ad-rotate-widget"><div class="ad-rotate-widget-widget"><ul><li><div class="g g-7"><div class="g-single a-338"><a class="gofollow" data-track="MzM4LDcsMSw2MA==" href="http://www.mahlemotorsports.com?utm_source=dragillustrated&utm_campaign=elitesportsman&utm_medium=banner" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/MAH-01-1195-Drag-Ill-2017-728x90.jpg" /></a></div></div></li></ul></div></div><!-- end .ad-rotate-widget --><div class="subscribe-now"><div class="subscribe-now">			<div class="textwidget"><a href="https://dragillustrated.com/product/make-drag-racing-great-again-hat/"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2016/02/MDRGA_Hats.png" alt="Make Drag Racing Great Again" height="90" width="180"></a></div>
		</div></div><!-- end .subscribe-now --></div><!-- end #ad-area-wrap -->
	<div id="content-wrapper">
						<div id="content-main">
																										<div id="featured-image" itemscope itemtype="http://schema.org/Article">
																													<img itemprop="image" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/NHRA_E6Ignition_640-640x400.jpg" />
													</div><!--featured-image-->
																					<div id="home-main">
				<div id="post-area" itemscope itemtype="http://schema.org/Article" class="post-25459 post type-post status-publish format-standard has-post-thumbnail hentry category-tech">
					<h3 class="story-cat">Tech</h3>
					<h1 class="story-title" itemprop="name">FAST E6 Digital CD Ignition Box Approved by NHRA</h1>
					<div id="post-info">
						By&nbsp;<span class="author" itemprop="author"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span>&nbsp;|&nbsp;<time class="post-date" itemprop="datePublished" datetime="2017-02-08" pubdate>February 8, 2017</time>
					</div><!--post-info-->
											<div class="social-sharing-top">
							
	<div class="share-count">
		</div><!--share-count-->

							<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://dragillustrated.com/fast-e6-digital-cd-ignition-box-approved-by-nhra/&t=FAST E6 Digital CD Ignition Box Approved by NHRA', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"></span><p>Share</p></div></a>
							<a href="#" onclick="window.open('http://twitter.com/share?text=FAST E6 Digital CD Ignition Box Approved by NHRA -&url=https://dragillustrated.com/fast-e6-digital-cd-ignition-box-approved-by-nhra/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"></span><p>Tweet</p></div></a>
							<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://dragillustrated.com/fast-e6-digital-cd-ignition-box-approved-by-nhra/&media=https://dragillustrated.com/wp-content/uploads/2017/02/NHRA_E6Ignition_640-640x400.jpg&description=FAST E6 Digital CD Ignition Box Approved by NHRA', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"></span><p>Share</p></div></a>
							<a href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https://dragillustrated.com/fast-e6-digital-cd-ignition-box-approved-by-nhra/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"><div class="google-share"><span class="google-but1"></span><p>Share</p></div></a>
							<a href="https://dragillustrated.com/fast-e6-digital-cd-ignition-box-approved-by-nhra/#respond"><div class="social-comments"><p>0 comments</p></div></a>
						</div><!--social-sharing-top-->
										<div id="content-area">
							
		<div class="g g-16"><div class="g-col b-16 a-336"><a class="gofollow" data-track="MzM2LDE2LDEsNjA=" href="http://www.mahlemotorsports.com?utm_source=dragillustrated&utm_campaign=elitesportsman&utm_medium=banner" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/MAH-01-1195-Drag-Ill-2017-300x300.jpg" /></a></div></div><div class="g g-16"><div class="g-col b-16 a-301"><a class="gofollow" data-track="MzAxLDE2LDEsNjA=" href="http://www.fuelairspark.com/" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2016/05/xfi_sportsman-400x400.png" /></a></div></div><div class="g g-16"><div class="g-col b-16 a-340"><a class="gofollow" data-track="MzQwLDE2LDEsNjA=" href="http://www.fuelairspark.com/fas/ignition-systems-componentshtml" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/FASTE6_400x400_vs2.jpg" /></a></div></div><div class="g g-16"><div class="g-col b-16 a-305"><a class="gofollow" data-track="MzA1LDE2LDEsNjA=" href="http://www.rosspistons.com/" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2016/12/Ross-Ad-DI-Online-300px-Dec-Animated.gif" /></a></div></div><p>Thanks to approval from the NHRA technical department, the <a href="http://www.fuelairspark.com/" target="_blank">FAST</a> E6 Digital CD Ignition Box is now available for use in NHRA Championship Drag Racing.</p>
<p>The new <a href="http://www.fuelairspark.com/" target="_blank">FAST</a> E6 Digital CD Ignition Box (part no. 306425) has been added to NHRA’s Accepted Product List per Glen Gray, NHRA Vice President of Technical Operations. It is legal in any sportsman class that does mandate the use of a specific box.&nbsp;This approval further entrenches <a href="http://www.fuelairspark.com/" target="_blank">FAST</a> as a major player in the ignition market since the brand’s entrance into the arena over the past year. The E6 Digital CD Ignition Box features multiple-spark functionality, meaning the engine will fire multiple sparks per cylinder while the engine is below 3000 RPM. The multiple-spark feature provides a more complete burning of the fuel in the combustion chamber, resulting in a smoother running engine and better fuel economy. The box is EFI-friendly and is specifically designed to work with the revolutionary &nbsp;<a href="http://www.fuelairspark.com/" target="_blank">FAST</a> EFI systems including XFI, XFI Sportsman, EZ-EFI&nbsp;Fuel and EZ-EFI 2.0&nbsp;Fuel + Ignition – all of which are commonly found in sportsman drag racing classes. However, the box is also fully compatible with carbureted applications.</p>
<div class='dd_post_share'><div class='dd_buttons'><div class='dd_button'><a name='fb_share' type='button_count' share_url='https://dragillustrated.com/fast-e6-digital-cd-ignition-box-approved-by-nhra/' href='http://www.facebook.com/sharer.php'></a><script src='https://static.ak.fbcdn.net/connect.php/js/FB.Share' type='text/javascript'></script></div><div class='dd_button'><a href="http://twitter.com/share" class="twitter-share-button" data-url="https://dragillustrated.com/fast-e6-digital-cd-ignition-box-approved-by-nhra/" data-count="horizontal" data-text="FAST E6 Digital CD Ignition Box Approved by NHRA" data-via="dragillustrated" ></a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script></div><div class='dd_button'><iframe src='https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fdragillustrated.com%2Ffast-e6-digital-cd-ignition-box-approved-by-nhra%2F&amp;locale=en_US&amp;layout=standard&amp;action=like&amp;width=350&amp;height=24&amp;colorscheme=light' scrolling='no' frameborder='0' style='border:none; overflow:hidden; width:500px; height:24px;' allowTransparency='true'></iframe></div></div><div style='clear:both'></div></div><!-- Social Buttons Generated by Digg Digg plugin v5.3.6,
    Author : Buffer, Inc
    Website : http://bufferapp.com/diggdigg --><!-- FB Comments For Wp: http://www.vivacityinfotech.com --><h3 class='coments-title'>Comments</h3><p class='commentcount'><fb:comments-count href="https://dragillustrated.com/fast-e6-digital-cd-ignition-box-approved-by-nhra/"></fb:comments-count> comments</p><div class="fb-comments" data-href="https://dragillustrated.com/fast-e6-digital-cd-ignition-box-approved-by-nhra/" data-numposts="6" data-width="100%" data-colorscheme="light"></div><div class="g g-16"><div class="g-col b-16 a-336"><a class="gofollow" data-track="MzM2LDE2LDEsNjA=" href="http://www.mahlemotorsports.com?utm_source=dragillustrated&utm_campaign=elitesportsman&utm_medium=banner" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/MAH-01-1195-Drag-Ill-2017-300x300.jpg" /></a></div></div><div class="g g-16"><div class="g-col b-16 a-305"><a class="gofollow" data-track="MzA1LDE2LDEsNjA=" href="http://www.rosspistons.com/" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2016/12/Ross-Ad-DI-Online-300px-Dec-Animated.gif" /></a></div></div><div class="g g-16"><div class="g-col b-16 a-340"><a class="gofollow" data-track="MzQwLDE2LDEsNjA=" href="http://www.fuelairspark.com/fas/ignition-systems-componentshtml" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/FASTE6_400x400_vs2.jpg" /></a></div></div><div class="g g-16"><div class="g-col b-16 a-301"><a class="gofollow" data-track="MzAxLDE2LDEsNjA=" href="http://www.fuelairspark.com/" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2016/05/xfi_sportsman-400x400.png" /></a></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>																		<div class="post-tags">
							<span class="post-tags-header">Related Items</span>						</div><!--post-tags-->
					</div><!--content-area-->
				</div><!--post-area-->
										<div id="author-wrapper">
						<div id="author-info">
							<img alt='' src='https://secure.gravatar.com/avatar/19114ff647afcd14a1c84568b6be9a46?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/19114ff647afcd14a1c84568b6be9a46?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' />							<div id="author-text">
								<span class="author-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span>
								<p></p>
								<ul>
																																																														</ul>
							</div><!--author-text-->
						</div><!--author-info-->
					</div><!--author-wrapper-->
													<div class="prev-next-wrapper">
					<div class="prev-post">
						&larr; Previous Story <a href="https://dragillustrated.com/frank-hawleys-drag-racing-school-featured-on-local-cbs-news-broadcast/" rel="prev">Frank Hawley&#8217;s Drag Racing School Featured on Local CBS News Broadcast</a>					</div><!--prev-post-->
					<div class="next-post">
											</div><!--next-post-->
				</div><!--prev-next-wrapper-->
												<div id="comments">
				
	
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><h4 class="post-header"><span class="post-header">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/fast-e6-digital-cd-ignition-box-approved-by-nhra/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://dragillustrated.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='25459' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>
<noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript>
<noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript>
			</form>
			</div><!-- #respond -->
	
</div><!--comments-->			</div><!--home-main-->
				</div><!--content-main-->
		<div id="sidebar-wrapper">
	<div id="text-26" class="sidebar-widget widget_text">			<div class="textwidget"><div align="center" id="adblock"><div class="g g-1"><div class="g-single a-340"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="MzQwLDEsMSw2MA==" href="http://www.fuelairspark.com/fas/ignition-systems-componentshtml" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/FASTE6_400x400_vs2.jpg" /></a></div></div></div></div>
		</div><div id="ajdg_grpwidgets-3" class="sidebar-widget ajdg_grpwidgets"><ul><li><div class="g g-1"><div class="g-single a-340"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="MzQwLDEsMSw2MA==" href="http://www.fuelairspark.com/fas/ignition-systems-componentshtml" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/FASTE6_400x400_vs2.jpg" /></a></div></div></li></ul></div><div id="mvp_list_widget-7" class="sidebar-widget mvp_list_widget"><span class="sidebar-widget-header"><h3 class="sidebar-widget-header">Exclusives</h3></span>

					<ul class="home-list">
												<li>
							<a href="https://dragillustrated.com/di-30-under-30-2016-ty-tutterow/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/Ty-Tutterow-3_Web-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/Ty-Tutterow-3_Web-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/Ty-Tutterow-3_Web-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/Ty-Tutterow-3_Web-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Lisa Collier</span> | February 8, 2017</span>
								<h2>DI 30 UNDER 30 2016: Ty Tutterow</h2>
								<p>	
		Ty Tutterow has been around racing his entire life. It’s a sport he’s been fed turned into a...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/exclusive-stevie-fast-reveals-the-shadow-2-0/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/Shadow-2.0_1-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/Shadow-2.0_1-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/Shadow-2.0_1-150x92.jpg 150w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/Shadow-2.0_1-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/Shadow-2.0_1-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Wes Buck</span> | February 3, 2017</span>
								<h2>EXCLUSIVE: &#8216;Stevie Fast&#8217; Reveals the &#8216;Shadow 2.0&#8217; Camaro</h2>
								<p>	
		On the heels of his blockbuster announcement earlier this week that he would make his J&amp;A Services NHRA...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/is-drag-racing-facing-a-nitrous-shortage/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2016/02/purge-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2016/02/purge-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2016/02/purge-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2016/02/purge-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Brandon Mudd</span> | February 3, 2017</span>
								<h2>Is Drag Racing Facing a Nitrous Shortage?</h2>
								<p>	
		Last August, an explosion at the Airgas plant in Cantonment, Fla., killed an employee, Jesse Graham Folmer, and...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/stevie-fast-fired-up-for-nhra-pro-mod-debut-in-march/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/PDR_4740_web-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/PDR_4740_web-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/PDR_4740_web-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/PDR_4740_web-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Nate Van Wagnen</span> | February 1, 2017</span>
								<h2>&#8216;Stevie Fast&#8217; Fired up for NHRA Pro Mod Debut in March</h2>
								<p>	
		One of outlaw racing’s most beloved characters, yet feared competitors, is about to jump into the high-profile world...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/di-driver-blog-troy-coughlin-jr/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/IMG_6251-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/IMG_6251-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/IMG_6251-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/IMG_6251-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Drag Illustrated</span> | January 26, 2017</span>
								<h2>DI DRIVER BLOG: Troy Coughlin Jr.</h2>
								<p>	
		First of all, it is a huge honor and privilege to be writing a blog for Drag Illustrated!&nbsp;...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/barry-mitchell-fires-off-3-79-second-blast-at-bradenton-test-session/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/Mitchell1-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/Mitchell1-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/Mitchell1-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/Mitchell1-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Josh Hachat</span> | January 25, 2017</span>
								<h2>Barry Mitchell Fires off 3.79-Second Blast at Bradenton Test Session</h2>
								<p>	
		Barry Mitchell will have a difficult time topping his incredible double-up weekend from Lights Out 7 a year...</p>
							</div><!--home-list-content-->
							</a>
						</li>
											</ul>


		</div><div id="text-27" class="sidebar-widget widget_text">			<div class="textwidget"><div align="center" id="adblock"><div class="g g-2"><div class="g-single a-318"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="MzE4LDIsMSw2MA==" href="http://www.golddustclassics.com/" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2016/07/GDC-3.75x3.png" /></a></div></div></div></div>
		</div><div id="mvp_list_widget-8" class="sidebar-widget mvp_list_widget"><span class="sidebar-widget-header"><h3 class="sidebar-widget-header">TECH</h3></span>

					<ul class="home-list">
												<li>
							<a href="https://dragillustrated.com/fast-e6-digital-cd-ignition-box-approved-by-nhra/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/NHRA_E6Ignition_640-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/NHRA_E6Ignition_640-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/NHRA_E6Ignition_640-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Drag Illustrated</span> | February 8, 2017</span>
								<h2>FAST E6 Digital CD Ignition Box Approved by NHRA</h2>
								<p>	
		Thanks to approval from the NHRA technical department, the FAST E6 Digital CD Ignition Box is now available...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/frank-hawleys-drag-racing-school-featured-on-local-cbs-news-broadcast/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/Hawley-gainesville-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/Hawley-gainesville-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/Hawley-gainesville-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/02/Hawley-gainesville-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Nate Van Wagnen</span> | February 5, 2017</span>
								<h2>Frank Hawley&#8217;s Drag Racing School Featured on Local CBS News Broadcast</h2>
								<p>	
		Frank Hawley&#8217;s Drag Racing School was recently featured in a piece that aired on CBS4-WGFL, the local CBS...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/bme-introduces-radial-contingency-program/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/BME_Radial_Contingency_660x400-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/BME_Radial_Contingency_660x400-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/BME_Radial_Contingency_660x400-150x91.jpg 150w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/BME_Radial_Contingency_660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/BME_Radial_Contingency_660x400-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Drag Illustrated</span> | January 26, 2017</span>
								<h2>BME Introduces Radial Contingency Program</h2>
								<p>	
		Bill Miller Engineering (BME), one of the most established and respected names in forged aluminum pistons and connecting...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/stroud-releases-2017-trackside-support-schedule/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/stroudbanner-400x242.png" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/stroudbanner-400x242.png 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/stroudbanner-660x400.png 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/stroudbanner-270x164.png 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Drag Illustrated</span> | January 25, 2017</span>
								<h2>Stroud Releases 2017 Trackside Support Schedule</h2>
								<p>	
		Stroud Safety has released its list of dealers who will offer trackside sales and product support for the...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/qa1-expands-front-and-rear-sway-bar-offerings/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/52873_64-72_GM_Sway_Bar_Kit-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/52873_64-72_GM_Sway_Bar_Kit-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/52873_64-72_GM_Sway_Bar_Kit-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/52873_64-72_GM_Sway_Bar_Kit-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Drag Illustrated</span> | January 24, 2017</span>
								<h2>QA1 Expands Front and Rear Sway Bar Offerings</h2>
								<p>	
		QA1 is proud to expand its line of sway bars to even more vehicles, including front and rear...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/tech-finite-element-analysis-is-the-new-shape-of-piston-creation/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/MG6_8713_LOW-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/MG6_8713_LOW-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/MG6_8713_LOW-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/MG6_8713_LOW-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Jeff Smith</span> | January 11, 2017</span>
								<h2>TECH: Finite Element Analysis is the New Shape of Piston Creation</h2>
								<p>	
		You hear it all the time – change is good. Some of that change has to do with...</p>
							</div><!--home-list-content-->
							</a>
						</li>
											</ul>


		</div> 		</div><!--sidebar-wrapper-->					</div><!--content-wrapper-->
</div><!--main-wrapper-->
		<div id="footer-wrapper">
			<div id="footer-top">

		<div id="footer-top">
				<div id="footer-nav">

	<div class="ad-rotate-widget-footer"><div class="ad-rotate-widget-widget"><ul><li><div class="g g-7"><div class="g-single a-338"><a class="gofollow" data-track="MzM4LDcsMSw2MA==" href="http://www.mahlemotorsports.com?utm_source=dragillustrated&utm_campaign=elitesportsman&utm_medium=banner" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/01/MAH-01-1195-Drag-Ill-2017-728x90.jpg" /></a></div></div></li></ul></div></div><!-- end .ad-rotate-widget --><div id="ad-rotate-footer-bottom"></div>				<div id="footer-nav">
					<div class="menu-about-di-container"><ul id="menu-about-di" class="menu"><li id="menu-item-21282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21282"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/">Subscribe</a></li>
<li id="menu-item-15093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15093"><a href="https://dragillustrated.com/about/">About</a></li>
<li id="menu-item-15089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15089"><a href="https://dragillustrated.com/our-team/">Our Team</a></li>
<li id="menu-item-15091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15091"><a href="https://dragillustrated.com/advertise/">Advertise</a></li>
<li id="menu-item-15090" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15090"><a href="https://dragillustrated.com/contact/">Contact</a></li>
</ul></div>				</div><!--footer-nav-->
								<div id="footer-widget-wrapper">
										<div class="footer-widget">
												<div id="logo-footer">
							<img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2014/05/DragIllustratedMediablackRGBSMALL.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
						</div><!--logo-footer-->
												<p>Drag Illustrated is not affiliated with, nor is it bound by any sanctioning body or association. From groundbreaking stories on underground grudge and outlaw racing to in-depth interviews with world-renowned racers and exclusive event coverage, Drag Illustrated shines the spotlight on the hottest stories in drag racing. When drivers, builders, and hardcore fans want the unbiased truth, Drag Illustrated is where they turn.</p>						<div id="footer-social">
							<ul>
																<li class="fb-item">
									<a href="https://www.facebook.com/DragIllustrated/" alt="Facebook" class="fb-but2" target="_blank"></a>
								</li>
																								<li class="twitter-item">
									<a href="https://twitter.com/DragIllustrated" alt="Twitter" class="twitter-but2" target="_blank"></a>
								</li>
																																								<li class="instagram-item">
									<a href="https://www.instagram.com/dragillustrated/" alt="Instagram" class="instagram-but2" target="_blank"></a>
								</li>
																																								<li><a href="https://dragillustrated.com/feed/rss/" alt="RSS Feed" class="rss-but2"></a></li>
															</ul>
						</div><!--footer-social-->
						<div id="copyright">
							<p>Copyright © 2015 Drag Illustrated Media, LLC.</p>
						</div><!--copyright-->
					</div><!--footer-widget-->
															<div class="footer-widget">
						<h3 class="footer-widget-header">Latest News</h3>
						<ul class="home-list">
														<li>
								<a href="https://dragillustrated.com/di-30-under-30-2016-ty-tutterow/" rel="bookmark">
								<div class="home-list-content">
									<h2>DI 30 UNDER 30 2016: Ty Tutterow</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/jim-dunn-racing-returns-with-mooneyes-funny-car-to-nhra-winternationals/" rel="bookmark">
								<div class="home-list-content">
									<h2>Jim Dunn Racing Returns with Mooneyes Funny Car to NHRA Winternationals</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/erica-enders-opens-up-on-character-building-2016-anxious-for-fresh-start-in-nhra-pro-stock/" rel="bookmark">
								<div class="home-list-content">
									<h2>Erica Enders Opens Up on Character-Building 2016, Anxious for Fresh Start in NHRA Pro Stock</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/troy-coughlin-jr-talks-top-fuel-debut/" rel="bookmark">
								<div class="home-list-content">
									<h2>Troy Coughlin Jr. Talks Top Fuel Debut</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/baldwin-returns-home-to-winternationals-with-baldwin-filters-and-mcleod-racing/" rel="bookmark">
								<div class="home-list-content">
									<h2>Baldwin Returns Home to Winternationals with Baldwin Filters and McLeod Racing</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/pritchett-delivers-unofficial-tf-record-capps-second-quickest-at-phx-test/" rel="bookmark">
								<div class="home-list-content">
									<h2>Pritchett Delivers Unofficial TF Record, Capps Second Quickest at PHX Test</h2>
								</div><!--home-list-content-->
								</a>
							</li>
													</ul>
					</div><!--footer-widget-->
					<div class="footer-widget">
						<h3 class="footer-widget-header">Tags</h3>
						<div class="tag-cloud">
						<a href='https://dragillustrated.com/tag/wes-buck/' class='tag-link-1284 tag-link-position-1' title='726 topics' style='font-size: 12px;'>wes buck</a>
<a href='https://dragillustrated.com/tag/yahoo/' class='tag-link-1321 tag-link-position-2' title='725 topics' style='font-size: 12px;'>yahoo</a>
<a href='https://dragillustrated.com/tag/ian-tocher/' class='tag-link-553 tag-link-position-3' title='721 topics' style='font-size: 12px;'>ian tocher</a>
<a href='https://dragillustrated.com/tag/drag-illistrated/' class='tag-link-376 tag-link-position-4' title='712 topics' style='font-size: 12px;'>drag illistrated</a>
<a href='https://dragillustrated.com/tag/drag-illustrated/' class='tag-link-377 tag-link-position-5' title='710 topics' style='font-size: 12px;'>drag illustrated</a>
<a href='https://dragillustrated.com/tag/dragillistrated/' class='tag-link-382 tag-link-position-6' title='708 topics' style='font-size: 12px;'>dragillistrated</a>
<a href='https://dragillustrated.com/tag/dragillustrated/' class='tag-link-383 tag-link-position-7' title='706 topics' style='font-size: 12px;'>dragillustrated</a>
<a href='https://dragillustrated.com/tag/google/' class='tag-link-501 tag-link-position-8' title='689 topics' style='font-size: 12px;'>google</a>
<a href='https://dragillustrated.com/tag/bing/' class='tag-link-163 tag-link-position-9' title='673 topics' style='font-size: 12px;'>bing</a>
<a href='https://dragillustrated.com/tag/drag-racing/' class='tag-link-378 tag-link-position-10' title='671 topics' style='font-size: 12px;'>drag racing</a>
<a href='https://dragillustrated.com/tag/nhra/' class='tag-link-840 tag-link-position-11' title='547 topics' style='font-size: 12px;'>nhra</a>
<a href='https://dragillustrated.com/tag/nhra-photos/' class='tag-link-879 tag-link-position-12' title='430 topics' style='font-size: 12px;'>nhra photos</a>
<a href='https://dragillustrated.com/tag/pro-stock/' class='tag-link-973 tag-link-position-13' title='258 topics' style='font-size: 12px;'>pro stock</a>
<a href='https://dragillustrated.com/tag/funny-car/' class='tag-link-462 tag-link-position-14' title='240 topics' style='font-size: 12px;'>funny car</a>
<a href='https://dragillustrated.com/tag/top-fuel/' class='tag-link-1222 tag-link-position-15' title='222 topics' style='font-size: 12px;'>top fuel</a>
<a href='https://dragillustrated.com/tag/pro-mod/' class='tag-link-968 tag-link-position-16' title='206 topics' style='font-size: 12px;'>pro mod</a>
<a href='https://dragillustrated.com/tag/pro-modified/' class='tag-link-970 tag-link-position-17' title='206 topics' style='font-size: 12px;'>pro modified</a>
<a href='https://dragillustrated.com/tag/adrl/' class='tag-link-55 tag-link-position-18' title='152 topics' style='font-size: 12px;'>ADRL</a>
<a href='https://dragillustrated.com/tag/john-force/' class='tag-link-639 tag-link-position-19' title='144 topics' style='font-size: 12px;'>john force</a>
<a href='https://dragillustrated.com/tag/don-schumacher/' class='tag-link-361 tag-link-position-20' title='123 topics' style='font-size: 12px;'>don schumacher</a>
<a href='https://dragillustrated.com/tag/jeg-coughlin-jr/' class='tag-link-597 tag-link-position-21' title='123 topics' style='font-size: 12px;'>jeg coughlin jr</a>
<a href='https://dragillustrated.com/tag/courtney-force/' class='tag-link-298 tag-link-position-22' title='121 topics' style='font-size: 12px;'>courtney force</a>
<a href='https://dragillustrated.com/tag/antron-brown/' class='tag-link-107 tag-link-position-23' title='118 topics' style='font-size: 12px;'>antron brown</a>
<a href='https://dragillustrated.com/tag/jack-beckman/' class='tag-link-576 tag-link-position-24' title='105 topics' style='font-size: 12px;'>jack beckman</a>
<a href='https://dragillustrated.com/tag/tony-schumacher/' class='tag-link-1217 tag-link-position-25' title='103 topics' style='font-size: 12px;'>tony schumacher</a>
<a href='https://dragillustrated.com/tag/american-drag-racing-league/' class='tag-link-95 tag-link-position-26' title='101 topics' style='font-size: 12px;'>american drag racing league</a>
<a href='https://dragillustrated.com/tag/erica-enders/' class='tag-link-419 tag-link-position-27' title='96 topics' style='font-size: 12px;'>erica enders</a>
<a href='https://dragillustrated.com/tag/allen-johnson/' class='tag-link-88 tag-link-position-28' title='95 topics' style='font-size: 12px;'>allen johnson</a>
<a href='https://dragillustrated.com/tag/greg-anderson/' class='tag-link-505 tag-link-position-29' title='89 topics' style='font-size: 12px;'>greg anderson</a>
<a href='https://dragillustrated.com/tag/spencer-massey/' class='tag-link-1119 tag-link-position-30' title='88 topics' style='font-size: 12px;'>spencer massey</a>						</div>
					</div><!--footer-widget-->
					 									</div><!--footer-widget-wrapper-->
			</div><!--footer-top-->
		</div><!--footer-wrapper-->
	</div><!--body-wrapper-->
</div><!--site-->

<!-- ngg_resource_manager_marker --><script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.responsive.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/tps.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/fast-e6-digital-cd-ignition-box-approved-by-nhra\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View Cart","cart_url":"https:\/\/dragillustrated.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='//dragillustrated.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js'></script>
<script type='text/javascript' src='//dragillustrated.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/fast-e6-digital-cd-ignition-box-approved-by-nhra\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='//dragillustrated.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js'></script>
<script type='text/javascript' src='//dragillustrated.com/wp-content/plugins/woocommerce/assets/js/jquery-cookie/jquery.cookie.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/fast-e6-digital-cd-ignition-box-approved-by-nhra\/?wc-ajax=%%endpoint%%","fragment_name":"wc_fragments"};
/* ]]> */
</script>
<script type='text/javascript' src='//dragillustrated.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */

var nextgen_lightbox_settings = {"static_path":"https:\/\/dragillustrated.com\/wp-content\/plugins\/nextgen-gallery\/products\/photocrati_nextgen\/modules\/lightbox\/static","context":"all_images_direct"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_gallery_display/static/common.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */

var nextgen_thickbox_i18n = {"next":"Next &gt;","prev":"&lt; Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them."};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/lightbox_context.min.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/thickbox/nextgen_thickbox_init.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/dragillustrated.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/thickbox/thickbox.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var MyAjax = {"ajaxurl":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/authnet-cim-for-woo/assets/js/cardpay-authnet.js'></script>
<script type='text/javascript' src='//dragillustrated.com/wp-content/plugins/woocommerce/assets/js/jquery-payment/jquery.payment.min.js'></script>
<script type='text/javascript' src='//dragillustrated.com/wp-content/plugins/woocommerce/assets/js/frontend/credit-card-form.min.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/braxton/js/jquery.iosslider.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/braxton/js/scripts.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/braxton/js/respond.min.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/braxton/js/retina.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/wp-spamshield/js/jscripts-ftr-min.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/wp-embed.min.js'></script>
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=297668800418060&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='f50b073219c897814bca8e910b7843c0';
hf4V='46420926c8f867ff435dfff117c10740';
cm4S="form[action='https://dragillustrated.com/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form, .wpcf7-form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(e);return true;});$("#comment").attr({minlength:"15",maxlength:"15360"})});
/* ]]> */
</script> 
		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		
<script type="text/javascript">
jQuery(document).ready(function($) {

	// Main Menu Dropdown Toggle
	$('.menu-item-has-children a').click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$('.menu-item-has-children').click(function(){
    	  $(this).addClass('toggled');
    	  if($('.menu-item-has-children').hasClass('toggled'))
    	  {
    	  $(this).children('ul').toggle();
	  $('.fly-nav-menu').getNiceScroll().resize();
	  }
	  $(this).toggleClass('tog-minus');
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});

});
</script>


<script type='text/javascript'> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script><div style="display: none;"><a href="http://inoplugs.com">WP-Backgrounds Lite by InoPlugs Web Design</a> and <a href="http://schoenmann.at/">Juwelier Sch&ouml;nmann 1010 Wien</a></div><script type="text/css" id="tmpl-tribe_customizer_css">.tribe-events-list .tribe-events-loop .tribe-event-featured,
				.tribe-events-list #tribe-events-day.tribe-events-loop .tribe-event-featured,
				.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap,
				.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap:hover {
					background-color: #0ea0d7;
				}

				#tribe-events-content table.tribe-events-calendar .type-tribe_events.tribe-event-featured {
					background-color: #0ea0d7;
				}

				.tribe-events-list-widget .tribe-event-featured,
				.tribe-events-venue-widget .tribe-event-featured,
				.tribe-mini-calendar-list-wrapper .tribe-event-featured,
				.tribe-events-adv-list-widget .tribe-event-featured .tribe-mini-calendar-event {
					background-color: #0ea0d7;
				}

				.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single {
					background-color: rgba(14,160,215, .7 );
					border-color: #0ea0d7;
				}

				.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single:hover {
					background-color: #0ea0d7;
				}</script><style type="text/css" id="tribe_customizer_css">.tribe-events-list .tribe-events-loop .tribe-event-featured,
				.tribe-events-list #tribe-events-day.tribe-events-loop .tribe-event-featured,
				.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap,
				.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap:hover {
					background-color: #0ea0d7;
				}

				#tribe-events-content table.tribe-events-calendar .type-tribe_events.tribe-event-featured {
					background-color: #0ea0d7;
				}

				.tribe-events-list-widget .tribe-event-featured,
				.tribe-events-venue-widget .tribe-event-featured,
				.tribe-mini-calendar-list-wrapper .tribe-event-featured,
				.tribe-events-adv-list-widget .tribe-event-featured .tribe-mini-calendar-event {
					background-color: #0ea0d7;
				}

				.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single {
					background-color: rgba(14,160,215, .7 );
					border-color: #0ea0d7;
				}

				.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single:hover {
					background-color: #0ea0d7;
				}</style><!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
}
});
</script>
<!-- /AdRotate JS -->

<script type='text/javascript' src='https://stats.wp.com/e-201706.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.6',blog:'37035244',post:'25459',tz:'-8',srv:'dragillustrated.com'} ]);
	_stq.push([ 'clickTrackerInit', '37035244', '25459' ]);
</script>
<script type="text/javascript">

window.onload = function() {
  window.addEventListener("scroll",wallpaper_reset_top,false);
}

var wallpaper_top=450;

function wallpaper_reset_top() {
  var scrollTop = document.documentElement.scrollTop || document.body.scrollTop;
  if(scrollTop > wallpaper_top && document.getElementById("wallpaper").className === "wallpaper_absolute") {
    document.getElementById("wallpaper").className = "wallpaper_fixed";
  }
  else if(scrollTop < wallpaper_top && document.getElementById("wallpaper").className === "wallpaper_fixed") {
    document.getElementById("wallpaper").className = "wallpaper_absolute";
  }
}
</script>
</body>
</html>