<!DOCTYPE html> <html lang="en-US" xmlns:fb="http://www.facebook.com/2008/fbml"> <head> <meta charset="UTF-8" > <meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" /> <meta property="og:image" content="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/06/IMG_4282-400x242.jpg" /> <link rel="shortcut icon" href="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2014/06/DI_16x16_favicon.png" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://dragillustrated.com/feed/" /> <link rel="alternate" type="text/xml" title="RSS .92" href="https://dragillustrated.com/feed/rss/" /> <link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://dragillustrated.com/feed/atom/" /> <link rel="pingback" href="https://dragillustrated.com/xmlrpc.php" /> <title>Fickler&#8217;s Super Comp Win Caps Off Big Weekend In Topeka For Aeromotive At Hometown NHRA Heartland Nationals &#8211; Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</title>  <link rel='dns-prefetch' href='//s0.wp.com' /> <link rel='dns-prefetch' href='//use.fontawesome.com' /> <link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' /> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Feed" href="https://dragillustrated.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Comments Feed" href="https://dragillustrated.com/comments/feed/" /> <link rel="alternate" type="text/calendar" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; iCal Feed" href="https://dragillustrated.com/events/?ical=1" /> <link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Fickler&#8217;s Super Comp Win Caps Off Big Weekend In Topeka For Aeromotive At Hometown NHRA Heartland Nationals Comments Feed" href="https://dragillustrated.com/ficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals/feed/" /> <link rel='stylesheet' id='front-css-css' href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/facebook-comment-by-vivacity/css/fb-comments-hidewpcomments.css?ver=1464982304' type='text/css' media='all' /> <link rel='stylesheet' id='inoplugs_backgrounds_css-css' href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/wp-backgrounds-lite/includes/wp-backgrounds.css?ver=1424209751' type='text/css' media='all' /> <link rel='stylesheet' id='tribe-tooltip-css' href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=1560306051' type='text/css' media='all' /> <link rel='stylesheet' id='contact-form-7-css' href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=1558371468' type='text/css' media='all' /> <link rel='stylesheet' id='digg-digg-css' href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/digg-digg/css/diggdigg-style.css?ver=1421190495' type='text/css' media='screen' /> <link rel='stylesheet' id='dashicons-css' href='https://c0.wp.com/c/4.9.8/wp-includes/css/dashicons.min.css' type='text/css' media='all' /> <link rel='stylesheet' id='thickbox-css' href='https://c0.wp.com/c/4.9.8/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' /> <link rel='stylesheet' id='fontawesome_v4_shim_style-css' href='https://use.fontawesome.com/releases/v5.3.1/css/v4-shims.css?ver=7e4faa5bd2535c2a79dc88913303c8ff' type='text/css' media='all' /> <link rel='stylesheet' id='fontawesome-css' href='https://use.fontawesome.com/releases/v5.3.1/css/all.css?ver=7e4faa5bd2535c2a79dc88913303c8ff' type='text/css' media='all' /> <link rel='stylesheet' id='woocommerce-layout-css' href='https://c0.wp.com/p/woocommerce/3.6.4/assets/css/woocommerce-layout.css' type='text/css' media='all' /> <style id='woocommerce-layout-inline-css' type='text/css'>

	.infinite-scroll .woocommerce-pagination {
		display: none;
	}
</style> <link rel='stylesheet' id='woocommerce-smallscreen-css' href='https://c0.wp.com/p/woocommerce/3.6.4/assets/css/woocommerce-smallscreen.css' type='text/css' media='only screen and (max-width: 768px)' /> <link rel='stylesheet' id='woocommerce-general-css' href='https://c0.wp.com/p/woocommerce/3.6.4/assets/css/woocommerce.css' type='text/css' media='all' /> <style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style> <link rel='stylesheet' id='mvp-style-css' href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/Braxton-Child/style.css?ver=1548773882' type='text/css' media='all' /> <!--[if lt IE 10]> <link rel='stylesheet' id='mvp-iecss-css' href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/Braxton-Child/css/iecss.css?ver=7e4faa5bd2535c2a79dc88913303c8ff' type='text/css' media='all' /> <![endif]--> <link rel='stylesheet' id='reset-css' href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/css/reset.css?ver=1510873624' type='text/css' media='all' /> <link rel='stylesheet' id='mvp-fontawesome-css' href='//netdna.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.css?ver=7e4faa5bd2535c2a79dc88913303c8ff' type='text/css' media='all' /> <link rel='stylesheet' id='media-queries-css' href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/css/media-queries.css?ver=1510873624' type='text/css' media='all' /> <link rel='stylesheet' id='studio-fonts-css' href='//fonts.googleapis.com/css?family=Montserrat%3A400%7CQuicksand%3A300%2C400%7CVidaloka%7CPlayfair+Display%3A400%2C700%2C900%7COpen+Sans+Condensed%3A300%2C700%7COpen+Sans%3A400%2C800%7COswald%3A300%2C400%2C700%7CRaleway%3A200%2C300%2C400%2C500%2C600%2C700%2C800%26subset%3Dlatin%2Clatin-ext&#038;ver=1.0.0' type='text/css' media='all' /> <link rel='stylesheet' id='fw-ext-builder-frontend-grid-css' href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/unyson/framework/extensions/builder/static/css/frontend-grid.css?ver=1550785709' type='text/css' media='all' /> <link rel='stylesheet' id='fw-ext-forms-default-styles-css' href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/unyson/framework/extensions/forms/static/css/frontend.css?ver=1550785709' type='text/css' media='all' /> <link rel='stylesheet' id='tablepress-default-css' href='https://dragil-jagrllc.netdna-ssl.com/wp-content/tablepress-combined.min.css?ver=1551219115' type='text/css' media='all' /> <link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/7.1.1/css/jetpack.css' type='text/css' media='all' />         <link rel='https://api.w.org/' href='https://dragillustrated.com/wp-json/' /> <link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dragillustrated.com/xmlrpc.php?rsd" /> <link rel='prev' title='TF&#8217;s Brittany Force Has Something Special Planned In Bristol For Father&#8217;s Day' href='https://dragillustrated.com/tfs-brittany-force-has-something-special-planned-in-bristol-for-fathers-day/' /> <link rel='shortlink' href='https://dragillustrated.com/?p=34926' /> <link rel="alternate" type="application/json+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Fficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Fficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals%2F&#038;format=xml" />  <style type="text/css" media="screen">
	.gformba { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.gformba img { height:auto; }
	.gformba-col { position:relative; float:left; }
	.gformba-col:first-child { margin-left: 0; }
	.gformba-col:last-child { margin-right: 0; }
	.gformba-1 {  margin: 0 auto; }
	.gformba-2 { margin:1px 1px 1px 1px; }
	.gformba-3 { margin:1px 1px 1px 1px; }
	.gformba-4 { margin:1px 1px 1px 1px; }
	.gformba-5 { margin:1px 1px 1px 1px; }
	.gformba-6 { margin:1px 1px 1px 1px; }
	.gformba-7 { margin:1px 1px 1px 1px; }
	.gformba-8 { min-width:3px; max-width:618px; }
	.bformba-8 { margin:1px 3px 1px 3px; }
	.gformba-9 { margin:1px 1px 1px 1px; }
	.gformba-10 { margin:1px 1px 1px 1px; }
	.gformba-16 { min-width:5px; max-width:150px; margin: 0 auto; }
	.bformba-16 { margin:0px 5px 0px 5px; }
	@media only screen and (max-width: 480px) {
		.gformba-col, .gformba-dyn, .gformba-single { width:100%; margin-left:0; margin-right:0; }
	}
</style> <link rel="image_src" href="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/06/IMG_4281-800x600.jpg" /><meta property="fb:app_id" content="297668800418060"/> <meta property="fb:admins" content=""/> <meta property="og:locale" content="en_US" /> <meta property="og:locale:alternate" content="en_US" /> <style type="text/css">
			.wpsdc-drop-cap {
				float : left;				
				padding : 0.25em 0.05em 0.25em 0;				
				font-size : 5em;
				line-height : 0.4em;color : #0a0a0a;}
		</style><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://dragillustrated.com"><link rel="https://theeventscalendar.com/" href="https://dragillustrated.com/wp-json/tribe/events/v1/" /> <link rel='dns-prefetch' href='//c0.wp.com'/> <style type='text/css'>img#wpstats{display:none}</style> <style type='text/css'>

@import url(//fonts.googleapis.com/css?family=Vidaloka:100,200,300,400,500,600,700,800,900|Raleway:100,200,300,400,500,600,700,800,900|Playfair+Display:100,200,300,400,500,600,700,800,900|Oswald:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese);

#nav-wrapper,
#nav-top-wrap {
	background: #ff0000;
	}

.fly-but-wrap span {
	background: #555555;
	}

#main-nav .menu li a:hover,
#main-nav .menu li.current-menu-item a,
#search-button:hover,
.home-widget h3.widget-cat,
span.post-tags-header,
.post-tags a:hover,
.tag-cloud a:hover,
.woocommerce .widget_price_filter .ui-slider .ui-slider-range {
	background: #ff0000;
	}

.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce span.onsale,
.woocommerce #respond input#submit.alt,
.woocommerce a.button.alt,
.woocommerce button.button.alt,
.woocommerce input.button.alt,
.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt:hover {
	background-color: #ff0000;
	}

.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt:hover {
	opacity: 0.8;
	}

#main-nav .menu-item-home a:hover {
	background: #ff0000 !important;
	}

#top-story-left h3,
#top-story-right h3 {
	border-bottom: 3px solid #ff0000;
	}

a, a:visited,
ul.top-stories li:hover h2,
ul.top-stories li:hover h2,
#top-story-middle:hover h2,
#top-story-wrapper:hover #feat2-main-text h2,
#feat1-left-wrapper:hover .feat1-left-text h2,
#feat1-right-wrapper:hover .feat1-right-text h2,
ul.split-columns li:hover h2,
.home-widget ul.wide-widget li:hover h2,
.home-widget ul.home-list li:hover h2,
h3.story-cat,
h3.story-cat a,
.sidebar-widget ul.home-list li:hover h2,
.sidebar-widget ul.wide-widget li:hover h2,
.sidebar-widget ul.split-columns li:hover h2,
#footer-nav .menu li a:hover,
.footer-widget ul.home-list li:hover h2,
.footer-widget ul.wide-widget li:hover h2,
.footer-widget ul.split-columns li:hover h2,
.prev,
.next {
	color: #ff0000;
	}

#wallpaper {
	background: url() no-repeat 50% 0;
	}

.featured-text h2,
.featured-text h2 a,
.feat1-main-text h2,
.feat1-main-text h2 a {
	font-family: 'Vidaloka', serif;
	}

#main-nav .menu li a,
#main-nav .menu li:hover ul li a {
	font-family: 'Raleway', sans-serif;
	}

#top-story-left h2,
#top-story-right h2,
.feat1-left-text h2,
.feat1-right-text h2,
#feat2-main-text h2,
#middle-text h2,
ul.split-columns li h2,
.home-widget .wide-text h2,
.home-widget .home-list-content h2,
h1.story-title,
.sidebar-widget .wide-text h2,
.sidebar-widget ul.split-columns li h2,
.footer-widget .wide-text h2,
.footer-widget ul.split-columns li h2,
#post-404 h1 {
	font-family: 'Playfair Display', serif;
	}

#top-story-left h3,
#top-story-right h3,
#middle-text h3,
h1.home-widget-header,
#woo-content h1.page-title,
h3.home-widget-header,
h1.archive-header,
h3.story-cat,
h3.story-cat a,
#content-area h1,
#content-area h2,
#content-area h3,
#content-area h4,
#content-area h5,
#content-area h6,
h4.post-header,
h3.sidebar-widget-header,
h3.footer-widget-header {
	font-family: 'Oswald', sans-serif;
	}

@media screen and (max-width: 767px) and (min-width: 480px) {

	.sidebar-widget .home-list-content h2 {
		font-family: 'Playfair Display', serif;
		}

	}

#menufication-outer-wrap.menufication-transition-in #menufication-scroll-container {
	overflow-y: auto !important;
	}

</style> <style type="text/css">



</style> <style type="text/css">
#wallpaper {
	background-size: 100%;
}</style> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript> <style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e7e7e7; }
</style> <meta property="og:type" content="article" /> <meta property="og:title" content="Fickler&#8217;s Super Comp Win Caps Off Big Weekend In Topeka For Aeromotive At Hometown NHRA Heartland Nationals" /> <meta property="og:url" content="https://dragillustrated.com/ficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals/" /> <meta property="og:description" content="TOPEKA, Kan. (June 12, 2019) – Kyle Fickler has been with Aeromotive Fuel Systems since the company opened in 1994, and he got to celebrate the company’s 25th anniversary in style last weekend at H…" /> <meta property="article:published_time" content="2019-06-13T20:57:12+00:00" /> <meta property="article:modified_time" content="2019-06-13T20:57:12+00:00" /> <meta property="og:site_name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" /> <meta property="og:image" content="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/06/IMG_4282.jpg" /> <meta property="og:image:width" content="960" /> <meta property="og:image:height" content="720" /> <meta property="og:locale" content="en_US" /> <meta name="twitter:text:title" content="Fickler&#8217;s Super Comp Win Caps Off Big Weekend In Topeka For Aeromotive At Hometown NHRA Heartland Nationals" /> <meta name="twitter:image" content="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/06/IMG_4282.jpg?w=640" /> <meta name="twitter:card" content="summary_large_image" />   <script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/jquery.js'></script><script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/jquery-migrate.min.js'></script><script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.1.1/_inc/build/related-posts/related-posts.min.js'></script><script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/ajax/static/ajax.min.js?ver=1559753452'></script><script type='text/javascript' src='https://use.fontawesome.com/releases/v5.3.1/js/v4-shims.js?ver=5.3.1'></script><script type='text/javascript' defer integrity="sha384-kW+oWsYx3YpxvjtZjFXqazFpA7UP/MbiY4jvs+RWZo2+N94PFZ36T6TFkc9O3qoB" crossorigin="anonymous" data-auto-replace-svg="false" data-keep-original-source="false" data-search-pseudo-elements src='https://use.fontawesome.com/releases/v5.3.1/js/all.js?ver=5.3.1'></script><script type="text/javascript" src="https://paywall.subscriptiongenius.com/load.js"></script><script async src='https://stats.wp.com/s-201924.js'></script><script src='http://static.ak.fbcdn.net/connect.php/js/FB.Share' type='text/javascript'></script><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script><script type='text/javascript' src='https://stats.wp.com/e-201924.js' async='async' defer='defer'></script><script type="text/javascript" src="https://dragillustrated.com/wp-content/cache/borlabs_cache/1/js/9fe3c5cde5e19e763413593e5ca91da990768a2d_https.js"></script></head> <body class="post-template-default single single-post postid-34926 single-format-standard custom-background woocommerce-no-js tribe-no-js"> <div id="site"> <div id="fly-wrap"> <div class="fly-wrap-out"> <div class="fly-side-wrap"> <ul class="fly-bottom-soc left relative"> <li class="fb-soc"> <a href="https://www.facebook.com/DragIllustrated/" target="_blank"> <i class="fa fa-facebook-square fa-2"></i> </a> </li> <li class="twit-soc"> <a href="https://twitter.com/DragIllustrated" target="_blank"> <i class="fa fa-twitter fa-2"></i> </a> </li> <li class="inst-soc"> <a href="https://www.instagram.com/dragillustrated/" target="_blank"> <i class="fa fa-instagram fa-2"></i> </a> </li> <li class="rss-soc"> <a href="https://dragillustrated.com/feed/rss/" target="_blank"> <i class="fa fa-rss fa-2"></i> </a> </li> </ul> </div> <div class="fly-wrap-in"> <div id="fly-menu-wrap"> <nav class="fly-nav-menu left relative"> <div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-15084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15084"><a href="https://dragillustrated.com/category/features/">Features</a> <ul class="sub-menu"> <li id="menu-item-20226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20226"><a href="https://dragillustrated.com/category/blogs/driver-blogs/">Blogs</a></li> <li id="menu-item-15087" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15087"><a href="https://dragillustrated.com/category/tech/">Tech</a></li> <li id="menu-item-15100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15100"><a href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a></li> </ul> </li> <li id="menu-item-15104" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15104"><a href="https://dragillustrated.com/shop/">Store</a></li> <li id="menu-item-34161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34161"><a href="https://dragillustrated.com/category/thewesbuckshow/">The Wes Buck Show</a></li> <li id="menu-item-15094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" href="http://digital.dragillustrated.com">Latest Issue</a></li> <li id="menu-item-15102" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li> </ul></div> </nav> </div> </div> </div> </div> <div id="nav-top-wrap" class="left relative"> <div id="nav-top-mid" class="relative"> <div id="nav-top-cont" class="left relative"> </div> </div> </div> <div id="nav-wrapper"> <div class="nav-wrap-out"> <div class="nav-wrap-in"> <div id="nav-inner"> <div class="fly-but-wrap left relative"> <span></span> <span></span> <span></span> <span></span> </div> <div id="logo-small" itemscope itemtype="http://schema.org/Organization"> <a itemprop="url" href="https://dragillustrated.com"><img itemprop="logo" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2015/01/DI_141x54_white_shadow.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" /></a> </div> <div id="main-nav"> <div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15084"><a href="https://dragillustrated.com/category/features/">Features</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20226"><a href="https://dragillustrated.com/category/blogs/driver-blogs/">Blogs</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15087"><a href="https://dragillustrated.com/category/tech/">Tech</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15100"><a href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a></li> </ul> </li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15104"><a href="https://dragillustrated.com/shop/">Store</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34161"><a href="https://dragillustrated.com/category/thewesbuckshow/">The Wes Buck Show</a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" href="http://digital.dragillustrated.com">Latest Issue</a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li> </ul></div> </div> <div id="search-button"> <img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/images/search-icon.png" /> </div> <div id="search-bar"> <form method="get" id="searchform" action="https://dragillustrated.com/"> <input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' /> <input type="hidden" id="searchsubmit" value="Search" /> </form> </div> </div> </div> </div> </div> <div id="body-wrapper"> <div id="main-wrapper"> <div id="ad-area-wrap"><div class="ad-rotate-widget"><div class="ad-rotate-widget-widget"> <div class="textwidget"><div class="gformba gformba-7"><div class="gformba-single aformba-549"><a class="gofollow" data-track="NTQ5LDcsMSw2MA==" href="https://www.epartrade.com/" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/05/ePar-BannerAd-728x90-2.jpg" /></a></div></div> </div> </div></div><div class="subscribe-now"><div class="subscribe-now"> <div class="textwidget"><p><a href="http://www.dragracingmastermind.com/"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/03/MasterMind_160x90.png" alt="Drag Racing Master Mind" width="160" height="90" /></a></p> </div> </div></div></div> <div id="content-wrapper"> <div id="content-main"> <div id="featured-image" itemscope itemtype="http://schema.org/Article"> <img itemprop="image" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/06/IMG_4282-660x400.jpg" /> </div> <div id="home-main"> <div id="post-area" itemscope itemtype="http://schema.org/Article" class="post-34926 post type-post status-publish format-standard has-post-thumbnail hentry category-news"> <h3 class="story-cat">News</h3> <h1 class="story-title" itemprop="name">Fickler&#8217;s Super Comp Win Caps Off Big Weekend In Topeka For Aeromotive At Hometown NHRA Heartland Nationals</h1> <div id="post-info"> By&nbsp;<span class="author" itemprop="author"><a href="https://dragillustrated.com/author/josh/" title="Posts by Josh Hachat" rel="author">Josh Hachat</a></span>&nbsp;|&nbsp;<time class="post-date" itemprop="datePublished" datetime="2019-06-13" pubdate>June 13, 2019</time> </div> <div class="social-sharing-top"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://dragillustrated.com/ficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals/&t=Fickler&#8217;s Super Comp Win Caps Off Big Weekend In Topeka For Aeromotive At Hometown NHRA Heartland Nationals', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"></span><p>Share</p></div></a> <a href="#" onclick="window.open('http://twitter.com/share?text=Fickler&#8217;s Super Comp Win Caps Off Big Weekend In Topeka For Aeromotive At Hometown NHRA Heartland Nationals -&url=https://dragillustrated.com/ficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"></span><p>Tweet</p></div></a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://dragillustrated.com/ficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals/&media=https://dragillustrated.com/wp-content/uploads/2019/06/IMG_4282-660x400.jpg&description=Fickler&#8217;s Super Comp Win Caps Off Big Weekend In Topeka For Aeromotive At Hometown NHRA Heartland Nationals', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"></span><p>Share</p></div></a> <a href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https://dragillustrated.com/ficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"><div class="google-share"><span class="google-but1"></span><p>Share</p></div></a> <a href="https://dragillustrated.com/ficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals/#respond"><div class="social-comments"><p>0 comments</p></div></a> </div> <div id="content-area"> <p>TOPEKA, Kan. (June 12, 2019) – Kyle Fickler has been with Aeromotive Fuel Systems since the company opened in 1994, and he got to celebrate the company’s 25th anniversary in style last weekend at Heartland Motorsports Park during the NHRA Heartland Nationals. <p>Racing in Topeka, just an hour from Aeromotive’s Lenexa, Kan. headquarters, the weekend was a big one for the company, and Fickler’s win in Super Comp was the perfect capper. <p>Fickler, who is the Director of Business Development at Aeromotive, picked up his second career NHRA national event win – and first since 2003 – going 8.913 at 161.63 mph in the final round. <p>“I’ve got a smile on my face that’s probably not going to go away for a while,” Fickler said. “To win during Aeromotive’s 25th anniversary, I couldn’t have planned it any better. It was a pretty special day and I feel fortunate to be able to close the deal.” <p>Added Aeromotive Founder Steve Matusek: “For him to bring the Wally home at our home track, it’s truly rewarding. Hats off to Kyle because he did a great job.” <p>The Aeromotive camaraderie was evident throughout the successful weekend at Heartland Motorsports Park, both on the track and in the pits. <p>The company had another long list of winners using their industry-leading fuel delivery systems and components, while Fickler and Matusek also enjoyed success. <p>In the pits, it was another opportunity to talk with fans and racers about the brand, and Matusek commended all of them for a job well done. <p>“Our staff did an unbelievable job entertaining everyone,” Matusek said. “A lot of times these home races are very difficult, but they did a great job. That’s just our company and how all of us operate. It’s truly impressive.” <p>Fickler said the mixture of business and racing is something he enjoys most about a race weekend in Topeka. The company is engrained in motorsports and that pays dividends, both in company culture and with the innovative products Aeromotive produces. <p>“If I was just there to race, I wouldn’t race as well,” Fickler said. “We all play a lot of roles and we were all there at the track to be productive. Nobody is there who’s just along for the ride. It’s very much a company of enthusiasts and that’s the culture there. It’s a unique element that has made the company successful, and I’m proud to be with a company that supports the sport like they do.” <p><img class="aligncenter size-medium wp-image-34928" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/06/IMG_4281-800x600.jpg" alt="" width="800" height="600" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/06/IMG_4281-800x600.jpg 800w, https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/06/IMG_4281-150x113.jpg 150w, https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/06/IMG_4281-768x576.jpg 768w, https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/06/IMG_4281-600x450.jpg 600w, https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/06/IMG_4281.jpg 960w" sizes="(max-width: 800px) 100vw, 800px" /> <p>Matusek qualified fifth in Pro Mod driving his turbocharged 25th anniversary Ford Mustang with an impressive 5.827 at 258.12 mph, stepping it up to a 5.794 at 259.26 in a first-round win. <p>A parts failure on the starting line before his second-round matchup prevented Matusek from advancing further, but he remains excited about the team’s progress. <p>“Our confidence going into round two was very, very high, but it was just one of those unfortunate things,” Matusek said. “But we were getting applause in the stands for our efforts, and that was truly rewarding to see.” <p>More applause came later in the day for Fickler, as his Aeromotive colleagues cheered him on en route to the victory. They all celebrated the win with him, but Fickler felt something special was in the air all day. <p>“I was just at ease all day,” Fickler said. “I’ve been doing this for 30 years, but sometimes you get in the car and things feel good. It was just a great weekend.&#8221; <div class='dd_post_share'><div class='dd_buttons'><div class='dd_button'><a name='fb_share' type='button_count' share_url='https://dragillustrated.com/ficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals/' href='http://www.facebook.com/sharer.php'></a></div><div class='dd_button'><a href="http://twitter.com/share" class="twitter-share-button" data-url="https://dragillustrated.com/ficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals/" data-count="horizontal" data-text="Fickler's Super Comp Win Caps Off Big Weekend In Topeka For Aeromotive At Hometown NHRA Heartland Nationals" data-via="dragillustrated" ></a></div><div class='dd_button'><iframe src='http://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fdragillustrated.com%2Fficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals%2F&amp;locale=en_US&amp;layout=standard&amp;action=like&amp;width=350&amp;height=24&amp;colorscheme=light' scrolling='no' frameborder='0' style='border:none; overflow:hidden; width:500px; height:24px;' allowTransparency='true'></iframe></div></div><div style='clear:both'></div></div><h3 class='coments-title'>Comments</h3><p class='commentcount'><fb:comments-count href="https://dragillustrated.com/ficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals/"></fb:comments-count> comments<div class="fb-comments" data-href="https://dragillustrated.com/ficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals/" data-numposts="6" data-width="100%" data-colorscheme="light"></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-512"><a class="gofollow" data-track="NTEyLDE2LDEsNjA=" href="https://wilwood.com/" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/02/Drag-Illustrated-300x300_v2.jpg" /></a></div></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-41"><a class="gofollow" data-track="NDEsMTYsMSw2MA==" href="http://www.racingconverters.com/" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/03/dragillustrated-300x300banner.png" /></a></div></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-371"><a class="gofollow" data-track="MzcxLDE2LDEsNjA=" href="http://moroso.com/"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/04/MorosoSq1.jpg" target="_blank" /></a></div></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-452"><a class="gofollow" data-track="NDUyLDE2LDEsNjA=" href="http://www.pbm-erson.com/Catalog/Erson" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/03/Erson_Cams_300x300.jpg" /></a></div></div> <div id='jp-relatedposts' class='jp-relatedposts' > <h3 class="jp-relatedposts-headline"><em>Related</em></h3> </div> <div class="post-tags"> <span class="post-tags-header">Related Items</span> </div> </div> </div> <div id="author-wrapper"> <div id="author-info"> <img alt='' src='https://secure.gravatar.com/avatar/bc6a58ed969035ee6ffbbaf16b4c0060?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bc6a58ed969035ee6ffbbaf16b4c0060?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /> <div id="author-text"> <span class="author-name"><a href="https://dragillustrated.com/author/josh/" title="Posts by Josh Hachat" rel="author">Josh Hachat</a></span> <p></p> <ul> </ul> </div> </div> </div> <div class="prev-next-wrapper"> <div class="prev-post"> &larr; Previous Story <a href="https://dragillustrated.com/tfs-brittany-force-has-something-special-planned-in-bristol-for-fathers-day/" rel="prev">TF&#8217;s Brittany Force Has Something Special Planned In Bristol For Father&#8217;s Day</a> </div> <div class="next-post"> </div> </div> <div id="comments"> <div id="respond" class="comment-respond"> <h3 id="reply-title" class="comment-reply-title"><h4 class="post-header"><span class="post-header">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/ficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals/#respond" style="display:none;">Cancel reply</a></small></h3> <form action="https://dragillustrated.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"> <p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p> <p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p> <p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p> <p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='34926' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> </p>  <noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript> <noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript> </form> </div> </div> </div> </div> <div id="sidebar-wrapper"> <div id="text-26" class="sidebar-widget widget_text"> <div class="textwidget"><div id="adblock" align="center"><div class="gformba gformba-1"><div class="gformba-single aformba-259"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="MjU5LDEsMSw2MA==" href="http://www.hogansracingmanifolds.com/"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/06/hogansquare052417.jpg" width="300" height="203"/></a></div></div></div> </div> </div><div id="text-45" class="sidebar-widget widget_text"> <div class="textwidget"><div id="adblock" align="center"><div class="gformba gformba-1"><div class="gformba-single aformba-548"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="NTQ4LDEsMSw2MA==" href="http://libertysgears.com/" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/04/lib.jpg" /></a></div></div></div> </div> </div><div id="text-27" class="sidebar-widget widget_text"> <div class="textwidget"><div align="center" id="adblock"><div class="gformba gformba-2"><div class="gformba-single aformba-562"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="NTYyLDIsMSw2MA==" href="https://www.mickeythompsontires.com/" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/05/MT-2019-NHRA-BANNER-300x300.jpg" /></a></div></div></div> </div> </div> </div> </div> </div> <div id="footer-wrapper"> <div id="footer-top"> <div class="ad-rotate-widget-footer"><div class="ad-rotate-widget-widget"> <div class="textwidget"><div class="gformba gformba-7"><div class="gformba-single aformba-519"><a class="gofollow" data-track="NTE5LDcsMSw2MA==" href="https://frankensteined.net/" target="_blank"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2019/02/728x90_gif.gif" /></a></div></div> </div> </div></div><div id="ad-rotate-footer-bottom"></div> <div id="footer-nav"> <div class="menu-about-di-container"><ul id="menu-about-di" class="menu"><li id="menu-item-21282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21282"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/">Subscribe</a></li> <li id="menu-item-15093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15093"><a href="https://dragillustrated.com/about/">About</a></li> <li id="menu-item-15089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15089"><a href="https://dragillustrated.com/our-team/">Our Team</a></li> <li id="menu-item-15091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15091"><a href="https://dragillustrated.com/advertise/">Advertise</a></li> <li id="menu-item-15090" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15090"><a href="https://dragillustrated.com/contact/">Contact</a></li> </ul></div> </div> <div id="footer-widget-wrapper"> <div class="footer-widget"> <div id="logo-footer"> <img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2014/05/DragIllustratedMediablackRGBSMALL.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" /> </div> <p>Drag Illustrated is not affiliated with, nor is it bound by any sanctioning body or association. From groundbreaking stories on underground grudge and outlaw racing to in-depth interviews with world-renowned racers and exclusive event coverage, Drag Illustrated shines the spotlight on the hottest stories in drag racing. When drivers, builders, and hardcore fans want the unbiased truth, Drag Illustrated is where they turn.</p> <div id="footer-social"> <ul> <li class="fb-item"> <a href="https://www.facebook.com/DragIllustrated/" alt="Facebook" class="fb-but2" target="_blank"></a> </li> <li class="twitter-item"> <a href="https://twitter.com/DragIllustrated" alt="Twitter" class="twitter-but2" target="_blank"></a> </li> <li class="instagram-item"> <a href="https://www.instagram.com/dragillustrated/" alt="Instagram" class="instagram-but2" target="_blank"></a> </li> <li><a href="https://dragillustrated.com/feed/rss/" alt="RSS Feed" class="rss-but2"></a></li> </ul> </div> <div id="copyright"> <p>Copyright © 2019 Drag Illustrated Media, LLC.</p> </div> </div> <div class="footer-widget"> <h3 class="footer-widget-header">Latest News</h3> <ul class="home-list"> <li> <a href="https://dragillustrated.com/ficklers-super-comp-win-caps-off-big-weekend-in-topeka-for-aeromotive-at-hometown-nhra-heartland-nationals/" rel="bookmark"> <div class="home-list-content"> <h2>Fickler&#8217;s Super Comp Win Caps Off Big Weekend In Topeka For Aeromotive At Hometown NHRA Heartland Nationals</h2> </div> </a> </li> <li> <a href="https://dragillustrated.com/tfs-brittany-force-has-something-special-planned-in-bristol-for-fathers-day/" rel="bookmark"> <div class="home-list-content"> <h2>TF&#8217;s Brittany Force Has Something Special Planned In Bristol For Father&#8217;s Day</h2> </div> </a> </li> <li> <a href="https://dragillustrated.com/wchra-hits-the-strip-at-las-vegas-motor-speedway-for-the-battle/" rel="bookmark"> <div class="home-list-content"> <h2>WCHRA Hits The Strip at Las Vegas Motor Speedway for &#8216;The Battle&#8217;</h2> </div> </a> </li> <li> <a href="https://dragillustrated.com/defending-world-series-of-pro-mod-champion-carl-stevens-jr-ready-to-defend-title-in-2019/" rel="bookmark"> <div class="home-list-content"> <h2>Reigning World Series Of Pro Mod Champion Carl Stevens Jr. Ready To Defend Title In 2019</h2> </div> </a> </li> <li> <a href="https://dragillustrated.com/your-car-your-data-your-choice-partners-with-clay-millican-as-co-primary-sponsor-at-nhra-thunder-valley-nationals/" rel="bookmark"> <div class="home-list-content"> <h2>Your Car. Your Data. Your Choice. Partners with Clay Millican as Co-Primary Sponsor at NHRA Thunder Valley Nationals</h2> </div> </a> </li> <li> <a href="https://dragillustrated.com/e3-spark-plugs-extend-multi-year-sponsorship-agreement-with-nhra/" rel="bookmark"> <div class="home-list-content"> <h2>E3 Spark Plugs Extend Multi-Year Sponsorship Agreement With NHRA</h2> </div> </a> </li> </ul> </div> <div class="footer-widget"> <h3 class="footer-widget-header">Tags</h3> <div class="tag-cloud"> <a href="https://dragillustrated.com/tag/drag-illustrated/" class="tag-cloud-link tag-link-377 tag-link-position-1" style="font-size: 12px;">drag illustrated</a> <a href="https://dragillustrated.com/tag/wes-buck/" class="tag-cloud-link tag-link-1284 tag-link-position-2" style="font-size: 12px;">wes buck</a> <a href="https://dragillustrated.com/tag/yahoo/" class="tag-cloud-link tag-link-1321 tag-link-position-3" style="font-size: 12px;">yahoo</a> <a href="https://dragillustrated.com/tag/ian-tocher/" class="tag-cloud-link tag-link-553 tag-link-position-4" style="font-size: 12px;">ian tocher</a> <a href="https://dragillustrated.com/tag/drag-illistrated/" class="tag-cloud-link tag-link-376 tag-link-position-5" style="font-size: 12px;">drag illistrated</a> <a href="https://dragillustrated.com/tag/dragillistrated/" class="tag-cloud-link tag-link-382 tag-link-position-6" style="font-size: 12px;">dragillistrated</a> <a href="https://dragillustrated.com/tag/dragillustrated/" class="tag-cloud-link tag-link-383 tag-link-position-7" style="font-size: 12px;">dragillustrated</a> <a href="https://dragillustrated.com/tag/google/" class="tag-cloud-link tag-link-501 tag-link-position-8" style="font-size: 12px;">google</a> <a href="https://dragillustrated.com/tag/drag-racing/" class="tag-cloud-link tag-link-378 tag-link-position-9" style="font-size: 12px;">drag racing</a> <a href="https://dragillustrated.com/tag/bing/" class="tag-cloud-link tag-link-163 tag-link-position-10" style="font-size: 12px;">bing</a> <a href="https://dragillustrated.com/tag/nhra/" class="tag-cloud-link tag-link-840 tag-link-position-11" style="font-size: 12px;">nhra</a> <a href="https://dragillustrated.com/tag/nhra-photos/" class="tag-cloud-link tag-link-879 tag-link-position-12" style="font-size: 12px;">nhra photos</a> <a href="https://dragillustrated.com/tag/pro-stock/" class="tag-cloud-link tag-link-973 tag-link-position-13" style="font-size: 12px;">pro stock</a> <a href="https://dragillustrated.com/tag/funny-car/" class="tag-cloud-link tag-link-462 tag-link-position-14" style="font-size: 12px;">funny car</a> <a href="https://dragillustrated.com/tag/top-fuel/" class="tag-cloud-link tag-link-1222 tag-link-position-15" style="font-size: 12px;">top fuel</a> <a href="https://dragillustrated.com/tag/pro-mod/" class="tag-cloud-link tag-link-968 tag-link-position-16" style="font-size: 12px;">pro mod</a> <a href="https://dragillustrated.com/tag/pro-modified/" class="tag-cloud-link tag-link-970 tag-link-position-17" style="font-size: 12px;">pro modified</a> <a href="https://dragillustrated.com/tag/adrl/" class="tag-cloud-link tag-link-55 tag-link-position-18" style="font-size: 12px;">ADRL</a> <a href="https://dragillustrated.com/tag/john-force/" class="tag-cloud-link tag-link-639 tag-link-position-19" style="font-size: 12px;">john force</a> <a href="https://dragillustrated.com/tag/jeg-coughlin-jr/" class="tag-cloud-link tag-link-597 tag-link-position-20" style="font-size: 12px;">jeg coughlin jr</a> <a href="https://dragillustrated.com/tag/courtney-force/" class="tag-cloud-link tag-link-298 tag-link-position-21" style="font-size: 12px;">courtney force</a> <a href="https://dragillustrated.com/tag/don-schumacher/" class="tag-cloud-link tag-link-361 tag-link-position-22" style="font-size: 12px;">don schumacher</a> <a href="https://dragillustrated.com/tag/antron-brown/" class="tag-cloud-link tag-link-107 tag-link-position-23" style="font-size: 12px;">antron brown</a> <a href="https://dragillustrated.com/tag/jack-beckman/" class="tag-cloud-link tag-link-576 tag-link-position-24" style="font-size: 12px;">jack beckman</a> <a href="https://dragillustrated.com/tag/tony-schumacher/" class="tag-cloud-link tag-link-1217 tag-link-position-25" style="font-size: 12px;">tony schumacher</a> <a href="https://dragillustrated.com/tag/american-drag-racing-league/" class="tag-cloud-link tag-link-95 tag-link-position-26" style="font-size: 12px;">american drag racing league</a> <a href="https://dragillustrated.com/tag/erica-enders/" class="tag-cloud-link tag-link-419 tag-link-position-27" style="font-size: 12px;">erica enders</a> <a href="https://dragillustrated.com/tag/allen-johnson/" class="tag-cloud-link tag-link-88 tag-link-position-28" style="font-size: 12px;">allen johnson</a> <a href="https://dragillustrated.com/tag/greg-anderson/" class="tag-cloud-link tag-link-505 tag-link-position-29" style="font-size: 12px;">greg anderson</a> <a href="https://dragillustrated.com/tag/spencer-massey/" class="tag-cloud-link tag-link-1119 tag-link-position-30" style="font-size: 12px;">spencer massey</a> </div> </div> </div> </div> </div> </div> </div> <div id="fb-root"></div>     <div style="display: none;"><a href="http://inoplugs.com">WP-Backgrounds Lite by InoPlugs Web Design</a> and <a href="http://schoenmann.at/">Juwelier Sch&ouml;nmann 1010 Wien</a></div>    </body> </html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 0.42842984 sec
Time to load cache: 0.07776904
Cache file created on: 2019-06-13T20:57:49+00:00
Current time: 2019-06-14T03:07:05+00:00
-->