<!DOCTYPE html> <html lang="en-US" xmlns:fb="http://www.facebook.com/2008/fbml"> <head> <meta charset="UTF-8" > <meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" /> <meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2019/05/110-WinnersCircle-Sunday-Atlanta-400x242.jpg" /> <link rel="shortcut icon" href="https://dragillustrated.com/wp-content/uploads/2014/06/DI_16x16_favicon.png" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://dragillustrated.com/feed/" /> <link rel="alternate" type="text/xml" title="RSS .92" href="https://dragillustrated.com/feed/rss/" /> <link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://dragillustrated.com/feed/atom/" /> <link rel="pingback" href="https://dragillustrated.com/xmlrpc.php" /> <title>Torrence, Capps &#038; Hines Have The Meats &#8211; And Score Wins At Arby&#8217;s NHRA Southern Nationals &#8211; Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</title> <script>window._wca = window._wca || [];</script> <link rel='dns-prefetch' href='//s0.wp.com' /> <link rel='dns-prefetch' href='//use.fontawesome.com' /> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' /> <link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Feed" href="https://dragillustrated.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Comments Feed" href="https://dragillustrated.com/comments/feed/" /> <link rel="alternate" type="text/calendar" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; iCal Feed" href="https://dragillustrated.com/events/?ical=1" /> <link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Torrence, Capps &#038; Hines Have The Meats &#8211; And Score Wins At Arby&#8217;s NHRA Southern Nationals Comments Feed" href="https://dragillustrated.com/torrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals/feed/" /> <link rel='stylesheet' id='front-css-css' href='https://dragillustrated.com/wp-content/plugins/facebook-comment-by-vivacity/css/fb-comments-hidewpcomments.css?ver=1464982304' type='text/css' media='all' /> <link rel='stylesheet' id='inoplugs_backgrounds_css-css' href='https://dragillustrated.com/wp-content/plugins/wp-backgrounds-lite/includes/wp-backgrounds.css?ver=1424209751' type='text/css' media='all' /> <link rel='stylesheet' id='contact-form-7-css' href='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=1545234470' type='text/css' media='all' /> <link rel='stylesheet' id='digg-digg-css' href='https://dragillustrated.com/wp-content/plugins/digg-digg/css/diggdigg-style.css?ver=1421190495' type='text/css' media='screen' /> <link rel='stylesheet' id='essential-grid-plugin-settings-css' href='https://dragillustrated.com/wp-content/plugins/essential-grid/public/assets/css/settings.css?ver=1547841922' type='text/css' media='all' /> <link rel='stylesheet' id='tp-open-sans-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700%2C800&#038;ver=7e4faa5bd2535c2a79dc88913303c8ff' type='text/css' media='all' /> <link rel='stylesheet' id='tp-raleway-css' href='https://fonts.googleapis.com/css?family=Raleway%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900&#038;ver=7e4faa5bd2535c2a79dc88913303c8ff' type='text/css' media='all' /> <link rel='stylesheet' id='tp-droid-serif-css' href='https://fonts.googleapis.com/css?family=Droid+Serif%3A400%2C700&#038;ver=7e4faa5bd2535c2a79dc88913303c8ff' type='text/css' media='all' /> <link rel='stylesheet' id='tp-fontello-css' href='https://dragillustrated.com/wp-content/plugins/essential-grid/public/assets/font/fontello/css/fontello.css?ver=1547841922' type='text/css' media='all' /> <link rel='stylesheet' id='dashicons-css' href='https://c0.wp.com/c/4.9.8/wp-includes/css/dashicons.min.css' type='text/css' media='all' /> <link rel='stylesheet' id='thickbox-css' href='https://c0.wp.com/c/4.9.8/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' /> <link rel='stylesheet' id='fontawesome_v4_shim_style-css' href='https://use.fontawesome.com/releases/v5.3.1/css/v4-shims.css?ver=7e4faa5bd2535c2a79dc88913303c8ff' type='text/css' media='all' /> <link rel='stylesheet' id='fontawesome-css' href='https://use.fontawesome.com/releases/v5.3.1/css/all.css?ver=7e4faa5bd2535c2a79dc88913303c8ff' type='text/css' media='all' /> <link rel='stylesheet' id='woocommerce-layout-css' href='https://c0.wp.com/p/woocommerce/3.6.2/assets/css/woocommerce-layout.css' type='text/css' media='all' /> <style id='woocommerce-layout-inline-css' type='text/css'>

	.infinite-scroll .woocommerce-pagination {
		display: none;
	}
</style> <link rel='stylesheet' id='woocommerce-smallscreen-css' href='https://c0.wp.com/p/woocommerce/3.6.2/assets/css/woocommerce-smallscreen.css' type='text/css' media='only screen and (max-width: 768px)' /> <link rel='stylesheet' id='woocommerce-general-css' href='https://c0.wp.com/p/woocommerce/3.6.2/assets/css/woocommerce.css' type='text/css' media='all' /> <style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style> <link rel='stylesheet' id='mvp-style-css' href='https://dragillustrated.com/wp-content/themes/Braxton-Child/style.css?ver=1548773882' type='text/css' media='all' /> <!--[if lt IE 10]> <link rel='stylesheet' id='mvp-iecss-css' href='https://dragillustrated.com/wp-content/themes/Braxton-Child/css/iecss.css?ver=7e4faa5bd2535c2a79dc88913303c8ff' type='text/css' media='all' /> <![endif]--> <link rel='stylesheet' id='reset-css' href='https://dragillustrated.com/wp-content/themes/braxton/css/reset.css?ver=1510873624' type='text/css' media='all' /> <link rel='stylesheet' id='mvp-fontawesome-css' href='//netdna.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.css?ver=7e4faa5bd2535c2a79dc88913303c8ff' type='text/css' media='all' /> <link rel='stylesheet' id='media-queries-css' href='https://dragillustrated.com/wp-content/themes/braxton/css/media-queries.css?ver=1510873624' type='text/css' media='all' /> <link rel='stylesheet' id='studio-fonts-css' href='//fonts.googleapis.com/css?family=Montserrat%3A400%7CQuicksand%3A300%2C400%7CVidaloka%7CPlayfair+Display%3A400%2C700%2C900%7COpen+Sans+Condensed%3A300%2C700%7COpen+Sans%3A400%2C800%7COswald%3A300%2C400%2C700%7CRaleway%3A200%2C300%2C400%2C500%2C600%2C700%2C800%26subset%3Dlatin%2Clatin-ext&#038;ver=1.0.0' type='text/css' media='all' /> <link rel='stylesheet' id='fw-ext-builder-frontend-grid-css' href='https://dragillustrated.com/wp-content/plugins/unyson/framework/extensions/builder/static/css/frontend-grid.css?ver=1550785709' type='text/css' media='all' /> <link rel='stylesheet' id='fw-ext-forms-default-styles-css' href='https://dragillustrated.com/wp-content/plugins/unyson/framework/extensions/forms/static/css/frontend.css?ver=1550785709' type='text/css' media='all' /> <link rel='stylesheet' id='tablepress-default-css' href='https://dragillustrated.com/wp-content/tablepress-combined.min.css?ver=1551219115' type='text/css' media='all' /> <link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/7.1.1/css/jetpack.css' type='text/css' media='all' /> <script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/jquery-migrate.min.js'></script> <script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.1.1/_inc/build/related-posts/related-posts.min.js'></script> <script type='text/javascript'>
/* <![CDATA[ */
var photocrati_ajax = {"url":"https:\/\/dragillustrated.com\/?photocrati_ajax=1","wp_home_url":"https:\/\/dragillustrated.com","wp_site_url":"https:\/\/dragillustrated.com","wp_root_url":"https:\/\/dragillustrated.com","wp_plugins_url":"https:\/\/dragillustrated.com\/wp-content\/plugins","wp_content_url":"https:\/\/dragillustrated.com\/wp-content","wp_includes_url":"https:\/\/dragillustrated.com\/wp-includes\/","ngg_param_slug":"nggallery"};
/* ]]> */
</script> <script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/ajax/static/ajax.min.js?ver=1554235291'></script> <script type='text/javascript' src='https://use.fontawesome.com/releases/v5.3.1/js/v4-shims.js?ver=5.3.1'></script> <script type='text/javascript' defer integrity="sha384-kW+oWsYx3YpxvjtZjFXqazFpA7UP/MbiY4jvs+RWZo2+N94PFZ36T6TFkc9O3qoB" crossorigin="anonymous" data-auto-replace-svg="false" data-keep-original-source="false" data-search-pseudo-elements src='https://use.fontawesome.com/releases/v5.3.1/js/all.js?ver=5.3.1'></script> <link rel='https://api.w.org/' href='https://dragillustrated.com/wp-json/' /> <link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dragillustrated.com/xmlrpc.php?rsd" /> <link rel='prev' title='Castellana Breaks Through After Early-Season Struggles With NHRA Pro Mod Win In Atlanta' href='https://dragillustrated.com/castellana-breaks-through-after-early-season-struggles-with-nhra-pro-mod-win-in-atlanta/' /> <link rel='shortlink' href='https://dragillustrated.com/?p=34255' /> <link rel="alternate" type="application/json+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Ftorrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Ftorrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals%2F&#038;format=xml" /> <script type="text/javascript" src="https://paywall.subscriptiongenius.com/load.js"></script> <style type="text/css" media="screen">
	.gformba { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.gformba img { height:auto; }
	.gformba-col { position:relative; float:left; }
	.gformba-col:first-child { margin-left: 0; }
	.gformba-col:last-child { margin-right: 0; }
	.gformba-1 {  margin: 0 auto; }
	.gformba-2 { margin:1px 1px 1px 1px; }
	.gformba-3 { margin:1px 1px 1px 1px; }
	.gformba-4 { margin:1px 1px 1px 1px; }
	.gformba-5 { margin:1px 1px 1px 1px; }
	.gformba-6 { margin:1px 1px 1px 1px; }
	.gformba-7 { margin:1px 1px 1px 1px; }
	.gformba-8 { min-width:3px; max-width:618px; }
	.bformba-8 { margin:1px 3px 1px 3px; }
	.gformba-9 { margin:1px 1px 1px 1px; }
	.gformba-10 { margin:1px 1px 1px 1px; }
	.gformba-16 { min-width:5px; max-width:150px; margin: 0 auto; }
	.bformba-16 { margin:0px 5px 0px 5px; }
	@media only screen and (max-width: 480px) {
		.gformba-col, .gformba-dyn, .gformba-single { width:100%; margin-left:0; margin-right:0; }
	}
</style> <link rel="image_src" href="https://dragillustrated.com/wp-content/uploads/2019/05/108-SteveTorrence-Sunday-Atlanta-660x440.jpg" /><meta property="fb:app_id" content="297668800418060"/> <meta property="fb:admins" content=""/> <meta property="og:locale" content="en_US" /> <meta property="og:locale:alternate" content="en_US" /> <style type="text/css">
			.wpsdc-drop-cap {
				float : left;				
				padding : 0.25em 0.05em 0.25em 0;				
				font-size : 5em;
				line-height : 0.4em;color : #0a0a0a;}
		</style><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://dragillustrated.com"><link rel="https://theeventscalendar.com/" href="https://dragillustrated.com/wp-json/tribe/events/v1/" /> <link rel='dns-prefetch' href='//c0.wp.com'/> <style type='text/css'>img#wpstats{display:none}</style> <style type='text/css'>

@import url(//fonts.googleapis.com/css?family=Vidaloka:100,200,300,400,500,600,700,800,900|Raleway:100,200,300,400,500,600,700,800,900|Playfair+Display:100,200,300,400,500,600,700,800,900|Oswald:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese);

#nav-wrapper,
#nav-top-wrap {
	background: #ff0000;
	}

.fly-but-wrap span {
	background: #555555;
	}

#main-nav .menu li a:hover,
#main-nav .menu li.current-menu-item a,
#search-button:hover,
.home-widget h3.widget-cat,
span.post-tags-header,
.post-tags a:hover,
.tag-cloud a:hover,
.woocommerce .widget_price_filter .ui-slider .ui-slider-range {
	background: #ff0000;
	}

.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce span.onsale,
.woocommerce #respond input#submit.alt,
.woocommerce a.button.alt,
.woocommerce button.button.alt,
.woocommerce input.button.alt,
.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt:hover {
	background-color: #ff0000;
	}

.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt:hover {
	opacity: 0.8;
	}

#main-nav .menu-item-home a:hover {
	background: #ff0000 !important;
	}

#top-story-left h3,
#top-story-right h3 {
	border-bottom: 3px solid #ff0000;
	}

a, a:visited,
ul.top-stories li:hover h2,
ul.top-stories li:hover h2,
#top-story-middle:hover h2,
#top-story-wrapper:hover #feat2-main-text h2,
#feat1-left-wrapper:hover .feat1-left-text h2,
#feat1-right-wrapper:hover .feat1-right-text h2,
ul.split-columns li:hover h2,
.home-widget ul.wide-widget li:hover h2,
.home-widget ul.home-list li:hover h2,
h3.story-cat,
h3.story-cat a,
.sidebar-widget ul.home-list li:hover h2,
.sidebar-widget ul.wide-widget li:hover h2,
.sidebar-widget ul.split-columns li:hover h2,
#footer-nav .menu li a:hover,
.footer-widget ul.home-list li:hover h2,
.footer-widget ul.wide-widget li:hover h2,
.footer-widget ul.split-columns li:hover h2,
.prev,
.next {
	color: #ff0000;
	}

#wallpaper {
	background: url() no-repeat 50% 0;
	}

.featured-text h2,
.featured-text h2 a,
.feat1-main-text h2,
.feat1-main-text h2 a {
	font-family: 'Vidaloka', serif;
	}

#main-nav .menu li a,
#main-nav .menu li:hover ul li a {
	font-family: 'Raleway', sans-serif;
	}

#top-story-left h2,
#top-story-right h2,
.feat1-left-text h2,
.feat1-right-text h2,
#feat2-main-text h2,
#middle-text h2,
ul.split-columns li h2,
.home-widget .wide-text h2,
.home-widget .home-list-content h2,
h1.story-title,
.sidebar-widget .wide-text h2,
.sidebar-widget ul.split-columns li h2,
.footer-widget .wide-text h2,
.footer-widget ul.split-columns li h2,
#post-404 h1 {
	font-family: 'Playfair Display', serif;
	}

#top-story-left h3,
#top-story-right h3,
#middle-text h3,
h1.home-widget-header,
#woo-content h1.page-title,
h3.home-widget-header,
h1.archive-header,
h3.story-cat,
h3.story-cat a,
#content-area h1,
#content-area h2,
#content-area h3,
#content-area h4,
#content-area h5,
#content-area h6,
h4.post-header,
h3.sidebar-widget-header,
h3.footer-widget-header {
	font-family: 'Oswald', sans-serif;
	}

@media screen and (max-width: 767px) and (min-width: 480px) {

	.sidebar-widget .home-list-content h2 {
		font-family: 'Playfair Display', serif;
		}

	}

#menufication-outer-wrap.menufication-transition-in #menufication-scroll-container {
	overflow-y: auto !important;
	}

</style> <style type="text/css">



</style> <style type="text/css">
#wallpaper {
	background-size: 100%;
}</style> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript> <style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e7e7e7; }
</style> <meta property="og:type" content="article" /> <meta property="og:title" content="Torrence, Capps &#038; Hines Have The Meats &#8211; And Score Wins At Arby&#8217;s NHRA Southern Nationals" /> <meta property="og:url" content="https://dragillustrated.com/torrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals/" /> <meta property="og:description" content="COMMERCE, Ga. – Defending Top Fuel world champion Steve Torrence rolled to his second straight victory on Sunday with a win at the 39th annual Arby’s NHRA Southern Nationals at Atlanta Dragway. Ron…" /> <meta property="article:published_time" content="2019-05-06T01:38:41+00:00" /> <meta property="article:modified_time" content="2019-05-06T01:39:47+00:00" /> <meta property="og:site_name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" /> <meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2019/05/110-WinnersCircle-Sunday-Atlanta.jpg" /> <meta property="og:image:width" content="2200" /> <meta property="og:image:height" content="1467" /> <meta property="og:locale" content="en_US" /> <meta name="twitter:text:title" content="Torrence, Capps &#038; Hines Have The Meats &#8211; And Score Wins At Arby&#8217;s NHRA Southern Nationals" /> <meta name="twitter:image" content="https://dragillustrated.com/wp-content/uploads/2019/05/110-WinnersCircle-Sunday-Atlanta.jpg?w=640" /> <meta name="twitter:card" content="summary_large_image" /> <script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-21052018-1', 'auto');
  ga('send', 'pageview');
</script> <script async src='https://stats.wp.com/s-201919.js'></script> </head> <body class="post-template-default single single-post postid-34255 single-format-standard custom-background woocommerce-no-js tribe-no-js"> <div id="site"> <div id="fly-wrap"> <div class="fly-wrap-out"> <div class="fly-side-wrap"> <ul class="fly-bottom-soc left relative"> <li class="fb-soc"> <a href="https://www.facebook.com/DragIllustrated/" target="_blank"> <i class="fa fa-facebook-square fa-2"></i> </a> </li> <li class="twit-soc"> <a href="https://twitter.com/DragIllustrated" target="_blank"> <i class="fa fa-twitter fa-2"></i> </a> </li> <li class="inst-soc"> <a href="https://www.instagram.com/dragillustrated/" target="_blank"> <i class="fa fa-instagram fa-2"></i> </a> </li> <li class="rss-soc"> <a href="https://dragillustrated.com/feed/rss/" target="_blank"> <i class="fa fa-rss fa-2"></i> </a> </li> </ul> </div> <div class="fly-wrap-in"> <div id="fly-menu-wrap"> <nav class="fly-nav-menu left relative"> <div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-15084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15084"><a href="https://dragillustrated.com/category/features/">Features</a> <ul class="sub-menu"> <li id="menu-item-20226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20226"><a href="https://dragillustrated.com/category/blogs/driver-blogs/">Blogs</a></li> <li id="menu-item-15087" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15087"><a href="https://dragillustrated.com/category/tech/">Tech</a></li> <li id="menu-item-15100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15100"><a href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a></li> </ul> </li> <li id="menu-item-15104" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15104"><a href="https://dragillustrated.com/shop/">Store</a></li> <li id="menu-item-34161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34161"><a href="https://dragillustrated.com/category/thewesbuckshow/">The Wes Buck Show</a></li> <li id="menu-item-15094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" href="http://digital.dragillustrated.com">Latest Issue</a></li> <li id="menu-item-15102" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li> </ul></div> </nav> </div> </div> </div> </div> <div id="nav-top-wrap" class="left relative"> <div id="nav-top-mid" class="relative"> <div id="nav-top-cont" class="left relative"> </div> </div> </div> <div id="nav-wrapper"> <div class="nav-wrap-out"> <div class="nav-wrap-in"> <div id="nav-inner"> <div class="fly-but-wrap left relative"> <span></span> <span></span> <span></span> <span></span> </div> <div id="logo-small" itemscope itemtype="http://schema.org/Organization"> <a itemprop="url" href="https://dragillustrated.com"><img itemprop="logo" src="https://dragillustrated.com/wp-content/uploads/2015/01/DI_141x54_white_shadow.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" /></a> </div> <div id="main-nav"> <div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15084"><a href="https://dragillustrated.com/category/features/">Features</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20226"><a href="https://dragillustrated.com/category/blogs/driver-blogs/">Blogs</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15087"><a href="https://dragillustrated.com/category/tech/">Tech</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15100"><a href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a></li> </ul> </li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15104"><a href="https://dragillustrated.com/shop/">Store</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34161"><a href="https://dragillustrated.com/category/thewesbuckshow/">The Wes Buck Show</a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" href="http://digital.dragillustrated.com">Latest Issue</a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li> </ul></div> </div> <div id="search-button"> <img src="https://dragillustrated.com/wp-content/themes/braxton/images/search-icon.png" /> </div> <div id="search-bar"> <form method="get" id="searchform" action="https://dragillustrated.com/"> <input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' /> <input type="hidden" id="searchsubmit" value="Search" /> </form> </div> </div> </div> </div> </div> <div id="body-wrapper"> <div id="main-wrapper"> <div id="ad-area-wrap"><div class="ad-rotate-widget"><div class="ad-rotate-widget-widget"> <div class="textwidget"><div class="gformba gformba-7"><div class="gformba-single aformba-469"><a class="gofollow" data-track="NDY5LDcsMSw2MA==" href="https://www.turbobygarrett.com/turbobygarrett/turbochargers/gtx5544r-gen-ii" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2018/07/banner_728x90_GTX5544R.jpg" /></a></div></div> </div> </div></div><div class="subscribe-now"><div class="subscribe-now"> <div class="textwidget"><p><a href="http://www.dragracingmastermind.com/"><img src="https://dragillustrated.com/wp-content/uploads/2018/03/MasterMind_160x90.png" alt="Drag Racing Master Mind" width="160" height="90" /></a></p> </div> </div></div></div> <div id="content-wrapper"> <div id="content-main"> <div id="featured-image" itemscope itemtype="http://schema.org/Article"> <img itemprop="image" src="https://dragillustrated.com/wp-content/uploads/2019/05/110-WinnersCircle-Sunday-Atlanta-660x400.jpg" /> </div> <div id="home-main"> <div id="post-area" itemscope itemtype="http://schema.org/Article" class="post-34255 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-nhra-race-coverage"> <h3 class="story-cat">News</h3> <h1 class="story-title" itemprop="name">Torrence, Capps &#038; Hines Have The Meats &#8211; And Score Wins At Arby&#8217;s NHRA Southern Nationals</h1> <div id="post-info"> By&nbsp;<span class="author" itemprop="author"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span>&nbsp;|&nbsp;<time class="post-date" itemprop="datePublished" datetime="2019-05-05" pubdate>May 5, 2019</time> </div> <div class="social-sharing-top"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://dragillustrated.com/torrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals/&t=Torrence, Capps &#038; Hines Have The Meats &#8211; And Score Wins At Arby&#8217;s NHRA Southern Nationals', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"></span><p>Share</p></div></a> <a href="#" onclick="window.open('http://twitter.com/share?text=Torrence, Capps &#038; Hines Have The Meats &#8211; And Score Wins At Arby&#8217;s NHRA Southern Nationals -&url=https://dragillustrated.com/torrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"></span><p>Tweet</p></div></a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://dragillustrated.com/torrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals/&media=https://dragillustrated.com/wp-content/uploads/2019/05/110-WinnersCircle-Sunday-Atlanta-660x400.jpg&description=Torrence, Capps &#038; Hines Have The Meats &#8211; And Score Wins At Arby&#8217;s NHRA Southern Nationals', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"></span><p>Share</p></div></a> <a href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https://dragillustrated.com/torrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"><div class="google-share"><span class="google-but1"></span><p>Share</p></div></a> <a href="https://dragillustrated.com/torrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals/#respond"><div class="social-comments"><p>0 comments</p></div></a> </div> <div id="content-area"> <p>COMMERCE, Ga. – Defending Top Fuel world champion Steve Torrence rolled to his second straight victory on Sunday with a win at the 39th annual Arby’s NHRA Southern Nationals at Atlanta Dragway. <p>Ron Capps (Funny Car) and Andrew Hines (Pro Stock Motorcycle) were also winners in their respective categories at the seventh of 24 events during the 2019 NHRA Mello Yello Drag Racing Series season. <p>Torrence, whose first career Top Fuel win came in Atlanta in 2012, used his 3.863-second pass at 320.20 mph in his Capco Contractors dragster to defeat Brittany Force’s 3.989 at 274.00 in a final round matchup that featured the top two qualifiers of the weekend and the two most recent Top Fuel world champs. It is the 29th career win for the Top Fuel points leader and third at the track. <p>Torrence, who became the first repeat winner in the class this season, also picked up round wins against Luigi Novelli, Scott Palmer and Shawn Reed to earn his second victory in three years at Georgia’s House of Speed. <p>“When you have a group of guys that sticks together and that continuity is there, that’s the reason for success,” Torrence said. “As a driver, I need to do my job and give them the best driving ability I possible can because they’re giving me the best race car they possibly can. My guys are second to none and I would put them up against anybody out here. We went down the track every time we needed to and we’ve had a really good car. It’s really cool to have Arby’s out here and be the first guy to ever win the Arby’s Southern Nationals.” <p><img class="size-medium wp-image-34258 aligncenter" src="https://dragillustrated.com/wp-content/uploads/2019/05/108-SteveTorrence-Sunday-Atlanta-660x440.jpg" alt="" width="660" height="440" srcset="https://dragillustrated.com/wp-content/uploads/2019/05/108-SteveTorrence-Sunday-Atlanta-660x440.jpg 660w, https://dragillustrated.com/wp-content/uploads/2019/05/108-SteveTorrence-Sunday-Atlanta-150x100.jpg 150w, https://dragillustrated.com/wp-content/uploads/2019/05/108-SteveTorrence-Sunday-Atlanta-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2019/05/108-SteveTorrence-Sunday-Atlanta-600x400.jpg 600w" sizes="(max-width: 660px) 100vw, 660px" /> <p>Force, the No. 1 qualifier, reached the final round with wins against Cameron Ferre, Antron Brown and Jordan Vandergriff. <p>In Funny Car, Ron Capps secured his first win of the 2019 season in his NAPA Auto Parts Dodge Charger SRT Hellcat, going 4.068 at 315.34 to win on a holeshot against Tim Wilkerson’s 4.052 at 310.05 in the final round. It also gives Capps his 62nd career victory, continuing his impressive string of 11 straight seasons with at least one win. <p>Capps beat Shawn Langdon, John Force and Don Schumacher Racing teammate Tommy Johnson Jr. to reach the final round, earning his third career win at Atlanta Dragway. <p>“An average race car driver could have probably won in that car today,” said Capps, whose first win with crew chief Rahn Tobler came in Atlanta in 2012. “This was a car you dream about driving. Rahn Tobler pulled out the vintage Rahn Tobler, and that just gave me more and more confidence. It was just amazing and to get a Hellcat win was huge.” <p>Wilkerson beat Cruz Pedregon, Bob Tasca III and points leader Robert Hight to reach the finals. <p><img class="size-medium wp-image-34256 aligncenter" src="https://dragillustrated.com/wp-content/uploads/2019/05/106-RonCapps-Sunday-Atlanta-660x440.jpg" alt="" width="660" height="440" srcset="https://dragillustrated.com/wp-content/uploads/2019/05/106-RonCapps-Sunday-Atlanta-660x440.jpg 660w, https://dragillustrated.com/wp-content/uploads/2019/05/106-RonCapps-Sunday-Atlanta-150x100.jpg 150w, https://dragillustrated.com/wp-content/uploads/2019/05/106-RonCapps-Sunday-Atlanta-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2019/05/106-RonCapps-Sunday-Atlanta-600x400.jpg 600w" sizes="(max-width: 660px) 100vw, 660px" /> <p>Five-time Pro Stock Motorcycle world champion Hines earned his second straight victory, third overall of 2019 and 51st in his career after going 6.865 at 195.05 on his Screamin’ Eagle Vance &amp; Hines Harley-Davidson to defeat Jerry Savoie in the final round. It also marked the 100th career win for Harley-Davidson in the class, a streak that Hines started with his first career victory in 2004. <p>It was another noteworthy accomplishment for Hines, who became the first rider to claim 50 wins in the class last weekend and has three victories in four races to open the 2019 Pro Stock Motorcycle season. The class points leader beat Melissa Surber, Ryan Oehler and Hector Arana Jr. to reach the final round. <p>“It was a good day and my motorcycle is nothing like I’ve ever had in my career,” said Hines, who now has three wins at Atlanta Dragway. “It’s working really well and doesn’t do much wrong. All in all, it was a fantastic day. To get 100 wins for Harley-Davidson, it’s monumental. It was a very big struggle at first, and there’s been trials and tribulations, but it’s really nice to get the 100th.” <p>Savoie knocked off Cory Reed, Steve Johnson and Eddie Krawiec en route to the finals. <p>The Mello Yello Drag Racing Series continues May 17-19 with the Virginia NHRA Nationals at Virginia Motorsports Park in Richmond, Va. <p><img class="aligncenter size-medium wp-image-34257" src="https://dragillustrated.com/wp-content/uploads/2019/05/104-AndrewHines-Sunday-Atlanta-660x440.jpg" alt="" width="660" height="440" srcset="https://dragillustrated.com/wp-content/uploads/2019/05/104-AndrewHines-Sunday-Atlanta-660x440.jpg 660w, https://dragillustrated.com/wp-content/uploads/2019/05/104-AndrewHines-Sunday-Atlanta-150x100.jpg 150w, https://dragillustrated.com/wp-content/uploads/2019/05/104-AndrewHines-Sunday-Atlanta-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2019/05/104-AndrewHines-Sunday-Atlanta-600x400.jpg 600w" sizes="(max-width: 660px) 100vw, 660px" /> <div class='dd_post_share'><div class='dd_buttons'><div class='dd_button'><a name='fb_share' type='button_count' share_url='https://dragillustrated.com/torrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals/' href='http://www.facebook.com/sharer.php'></a><script src='http://static.ak.fbcdn.net/connect.php/js/FB.Share' type='text/javascript'></script></div><div class='dd_button'><a href="http://twitter.com/share" class="twitter-share-button" data-url="https://dragillustrated.com/torrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals/" data-count="horizontal" data-text="Torrence, Capps & Hines Have The Meats - And Score Wins At Arby's NHRA Southern Nationals" data-via="dragillustrated" ></a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script></div><div class='dd_button'><iframe src='http://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fdragillustrated.com%2Ftorrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals%2F&amp;locale=en_US&amp;layout=standard&amp;action=like&amp;width=350&amp;height=24&amp;colorscheme=light' scrolling='no' frameborder='0' style='border:none; overflow:hidden; width:500px; height:24px;' allowTransparency='true'></iframe></div></div><div style='clear:both'></div></div><h3 class='coments-title'>Comments</h3><p class='commentcount'><fb:comments-count href="https://dragillustrated.com/torrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals/"></fb:comments-count> comments<div class="fb-comments" data-href="https://dragillustrated.com/torrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals/" data-numposts="6" data-width="100%" data-colorscheme="light"></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-473"><a class="gofollow" data-track="NDczLDE2LDEsNjA=" href="https://www.jerrybickel.com/" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2018/04/imgad-8-18.jpg" /></a></div></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-467"><a class="gofollow" data-track="NDY3LDE2LDEsNjA=" href="http://brodix.com/heads-2/big-block-chevrolet-compatible-heads/dragon-slayer-series-26" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2018/04/square-1.jpg" /></a></div></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-407"><a class="gofollow" data-track="NDA3LDE2LDEsNjA=" href="http://rcdengineering.com/" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2017/11/rcd.jpg" /></a></div></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-537"><a class="gofollow" data-track="NTM3LDE2LDEsNjA=" href="http://brodix.com/uncategorized/dragon-slayer-sale" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2019/04/brodix-square.jpg" /></a></div></div> <div id='jp-relatedposts' class='jp-relatedposts' > <h3 class="jp-relatedposts-headline"><em>Related</em></h3> </div> <div class="post-tags"> <span class="post-tags-header">Related Items</span> </div> </div> </div> <div id="author-wrapper"> <div id="author-info"> <img alt='' src='https://secure.gravatar.com/avatar/19114ff647afcd14a1c84568b6be9a46?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/19114ff647afcd14a1c84568b6be9a46?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /> <div id="author-text"> <span class="author-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span> <p></p> <ul> </ul> </div> </div> </div> <div class="prev-next-wrapper"> <div class="prev-post"> &larr; Previous Story <a href="https://dragillustrated.com/castellana-breaks-through-after-early-season-struggles-with-nhra-pro-mod-win-in-atlanta/" rel="prev">Castellana Breaks Through After Early-Season Struggles With NHRA Pro Mod Win In Atlanta</a> </div> <div class="next-post"> </div> </div> <div id="comments"> <div id="respond" class="comment-respond"> <h3 id="reply-title" class="comment-reply-title"><h4 class="post-header"><span class="post-header">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/torrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals/#respond" style="display:none;">Cancel reply</a></small></h3> <form action="https://dragillustrated.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"> <p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p> <p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p> <p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p> <p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='34255' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> </p> <script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf1N='a27a67ccae601ca7b7ea9eb7581c801b';
hf1V='60e59e25cabc21b471f56bbf1c2b4c34';
document.write("<input type='hidden' name='r3f5x9JS' value='"+r3f5x9JS+"' /><input type='hidden' name='"+hf1N+"' value='"+hf1V+"' />");
/* ]]> */
</script> <noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript> <noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript> </form> </div> </div> </div> </div> <div id="sidebar-wrapper"> <div id="text-26" class="sidebar-widget widget_text"> <div class="textwidget"><div id="adblock" align="center"><div class="gformba gformba-1"><div class="gformba-single aformba-246"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="MjQ2LDEsMSw2MA==" href="https://www.cokertire.com/tires/styles/dragster-racing.html?utm_source=dragillustrated&utm_medium=banner&utm_campaign=dragillustratedweb" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2017/05/170509-PH-Banner-Ad-300x300.jpg" /></a></div></div></div> </div> </div><div id="text-45" class="sidebar-widget widget_text"> <div class="textwidget"><div id="adblock" align="center"><div class="gformba gformba-1"><div class="gformba-single aformba-259"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="MjU5LDEsMSw2MA==" href="http://www.hogansracingmanifolds.com/"><img src="https://dragillustrated.com/wp-content/uploads/2017/06/hogansquare052417.jpg" width="300" height="203"/></a></div></div></div> </div> </div><div id="text-27" class="sidebar-widget widget_text"> <div class="textwidget"><div align="center" id="adblock"><div class="gformba gformba-2"><div class="gformba-single aformba-475"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="NDc1LDIsMSw2MA==" href="https://www.appliedracing.com/" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2019/03/ARTBanner_2019.jpg" /></a></div></div></div> </div> </div> </div> </div> </div> <div id="footer-wrapper"> <div id="footer-top"> <div class="ad-rotate-widget-footer"><div class="ad-rotate-widget-widget"> <div class="textwidget"><div class="gformba gformba-7"><div class="gformba-single aformba-438"><a class="gofollow" data-track="NDM4LDcsMSw2MA==" href="http://www.manleyperformance.com/master_catalog.shtml" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2018/03/Manleyleaderboard_more-RPM.gif" /></a></div></div> </div> </div></div><div id="ad-rotate-footer-bottom"></div> <div id="footer-nav"> <div class="menu-about-di-container"><ul id="menu-about-di" class="menu"><li id="menu-item-21282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21282"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/">Subscribe</a></li> <li id="menu-item-15093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15093"><a href="https://dragillustrated.com/about/">About</a></li> <li id="menu-item-15089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15089"><a href="https://dragillustrated.com/our-team/">Our Team</a></li> <li id="menu-item-15091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15091"><a href="https://dragillustrated.com/advertise/">Advertise</a></li> <li id="menu-item-15090" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15090"><a href="https://dragillustrated.com/contact/">Contact</a></li> </ul></div> </div> <div id="footer-widget-wrapper"> <div class="footer-widget"> <div id="logo-footer"> <img src="https://dragillustrated.com/wp-content/uploads/2014/05/DragIllustratedMediablackRGBSMALL.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" /> </div> <p>Drag Illustrated is not affiliated with, nor is it bound by any sanctioning body or association. From groundbreaking stories on underground grudge and outlaw racing to in-depth interviews with world-renowned racers and exclusive event coverage, Drag Illustrated shines the spotlight on the hottest stories in drag racing. When drivers, builders, and hardcore fans want the unbiased truth, Drag Illustrated is where they turn.</p> <div id="footer-social"> <ul> <li class="fb-item"> <a href="https://www.facebook.com/DragIllustrated/" alt="Facebook" class="fb-but2" target="_blank"></a> </li> <li class="twitter-item"> <a href="https://twitter.com/DragIllustrated" alt="Twitter" class="twitter-but2" target="_blank"></a> </li> <li class="instagram-item"> <a href="https://www.instagram.com/dragillustrated/" alt="Instagram" class="instagram-but2" target="_blank"></a> </li> <li><a href="https://dragillustrated.com/feed/rss/" alt="RSS Feed" class="rss-but2"></a></li> </ul> </div> <div id="copyright"> <p>Copyright © 2017 Drag Illustrated Media, LLC.</p> </div> </div> <div class="footer-widget"> <h3 class="footer-widget-header">Latest News</h3> <ul class="home-list"> <li> <a href="https://dragillustrated.com/torrence-capps-hines-have-the-meats-and-score-wins-at-arbys-nhra-southern-nationals/" rel="bookmark"> <div class="home-list-content"> <h2>Torrence, Capps &#038; Hines Have The Meats &#8211; And Score Wins At Arby&#8217;s NHRA Southern Nationals</h2> </div> </a> </li> <li> <a href="https://dragillustrated.com/castellana-breaks-through-after-early-season-struggles-with-nhra-pro-mod-win-in-atlanta/" rel="bookmark"> <div class="home-list-content"> <h2>Castellana Breaks Through After Early-Season Struggles With NHRA Pro Mod Win In Atlanta</h2> </div> </a> </li> <li> <a href="https://dragillustrated.com/thunderstorms-push-pdra-mid-atlantic-showdown-final-rounds-to-next-race/" rel="bookmark"> <div class="home-list-content"> <h2>Thunderstorms Push PDRA Mid-Atlantic Showdown Final Rounds to Next Race</h2> </div> </a> </li> <li> <a href="https://dragillustrated.com/tommy-cable-earns-50000-payday-takes-third-spring-fling-trophy/" rel="bookmark"> <div class="home-list-content"> <h2>Tommy Cable Earns $50,000 Payday, Takes Third Spring Fling Trophy</h2> </div> </a> </li> <li> <a href="https://dragillustrated.com/b-force-hight-krawiec-stevie-fast-grab-top-spots-at-arbys-nhra-southern-nationals/" rel="bookmark"> <div class="home-list-content"> <h2>B. Force, Hight, Krawiec &#038; Stevie Fast Grab Top Spots At Arby&#8217;s NHRA Southern Nationals</h2> </div> </a> </li> <li> <a href="https://dragillustrated.com/dobbins-pluchino-drag-out-extreme-pro-stock-burndown-over-four-minutes/" rel="bookmark"> <div class="home-list-content"> <h2>Dobbins, Pluchino Drag Out Extreme Pro Stock Burndown Over Four Minutes</h2> </div> </a> </li> </ul> </div> <div class="footer-widget"> <h3 class="footer-widget-header">Tags</h3> <div class="tag-cloud"> <a href="https://dragillustrated.com/tag/drag-illustrated/" class="tag-cloud-link tag-link-377 tag-link-position-1" style="font-size: 12px;">drag illustrated</a> <a href="https://dragillustrated.com/tag/wes-buck/" class="tag-cloud-link tag-link-1284 tag-link-position-2" style="font-size: 12px;">wes buck</a> <a href="https://dragillustrated.com/tag/yahoo/" class="tag-cloud-link tag-link-1321 tag-link-position-3" style="font-size: 12px;">yahoo</a> <a href="https://dragillustrated.com/tag/ian-tocher/" class="tag-cloud-link tag-link-553 tag-link-position-4" style="font-size: 12px;">ian tocher</a> <a href="https://dragillustrated.com/tag/drag-illistrated/" class="tag-cloud-link tag-link-376 tag-link-position-5" style="font-size: 12px;">drag illistrated</a> <a href="https://dragillustrated.com/tag/dragillistrated/" class="tag-cloud-link tag-link-382 tag-link-position-6" style="font-size: 12px;">dragillistrated</a> <a href="https://dragillustrated.com/tag/dragillustrated/" class="tag-cloud-link tag-link-383 tag-link-position-7" style="font-size: 12px;">dragillustrated</a> <a href="https://dragillustrated.com/tag/google/" class="tag-cloud-link tag-link-501 tag-link-position-8" style="font-size: 12px;">google</a> <a href="https://dragillustrated.com/tag/drag-racing/" class="tag-cloud-link tag-link-378 tag-link-position-9" style="font-size: 12px;">drag racing</a> <a href="https://dragillustrated.com/tag/bing/" class="tag-cloud-link tag-link-163 tag-link-position-10" style="font-size: 12px;">bing</a> <a href="https://dragillustrated.com/tag/nhra/" class="tag-cloud-link tag-link-840 tag-link-position-11" style="font-size: 12px;">nhra</a> <a href="https://dragillustrated.com/tag/nhra-photos/" class="tag-cloud-link tag-link-879 tag-link-position-12" style="font-size: 12px;">nhra photos</a> <a href="https://dragillustrated.com/tag/pro-stock/" class="tag-cloud-link tag-link-973 tag-link-position-13" style="font-size: 12px;">pro stock</a> <a href="https://dragillustrated.com/tag/funny-car/" class="tag-cloud-link tag-link-462 tag-link-position-14" style="font-size: 12px;">funny car</a> <a href="https://dragillustrated.com/tag/top-fuel/" class="tag-cloud-link tag-link-1222 tag-link-position-15" style="font-size: 12px;">top fuel</a> <a href="https://dragillustrated.com/tag/pro-mod/" class="tag-cloud-link tag-link-968 tag-link-position-16" style="font-size: 12px;">pro mod</a> <a href="https://dragillustrated.com/tag/pro-modified/" class="tag-cloud-link tag-link-970 tag-link-position-17" style="font-size: 12px;">pro modified</a> <a href="https://dragillustrated.com/tag/adrl/" class="tag-cloud-link tag-link-55 tag-link-position-18" style="font-size: 12px;">ADRL</a> <a href="https://dragillustrated.com/tag/john-force/" class="tag-cloud-link tag-link-639 tag-link-position-19" style="font-size: 12px;">john force</a> <a href="https://dragillustrated.com/tag/jeg-coughlin-jr/" class="tag-cloud-link tag-link-597 tag-link-position-20" style="font-size: 12px;">jeg coughlin jr</a> <a href="https://dragillustrated.com/tag/courtney-force/" class="tag-cloud-link tag-link-298 tag-link-position-21" style="font-size: 12px;">courtney force</a> <a href="https://dragillustrated.com/tag/don-schumacher/" class="tag-cloud-link tag-link-361 tag-link-position-22" style="font-size: 12px;">don schumacher</a> <a href="https://dragillustrated.com/tag/antron-brown/" class="tag-cloud-link tag-link-107 tag-link-position-23" style="font-size: 12px;">antron brown</a> <a href="https://dragillustrated.com/tag/jack-beckman/" class="tag-cloud-link tag-link-576 tag-link-position-24" style="font-size: 12px;">jack beckman</a> <a href="https://dragillustrated.com/tag/tony-schumacher/" class="tag-cloud-link tag-link-1217 tag-link-position-25" style="font-size: 12px;">tony schumacher</a> <a href="https://dragillustrated.com/tag/american-drag-racing-league/" class="tag-cloud-link tag-link-95 tag-link-position-26" style="font-size: 12px;">american drag racing league</a> <a href="https://dragillustrated.com/tag/erica-enders/" class="tag-cloud-link tag-link-419 tag-link-position-27" style="font-size: 12px;">erica enders</a> <a href="https://dragillustrated.com/tag/allen-johnson/" class="tag-cloud-link tag-link-88 tag-link-position-28" style="font-size: 12px;">allen johnson</a> <a href="https://dragillustrated.com/tag/greg-anderson/" class="tag-cloud-link tag-link-505 tag-link-position-29" style="font-size: 12px;">greg anderson</a> <a href="https://dragillustrated.com/tag/spencer-massey/" class="tag-cloud-link tag-link-1119 tag-link-position-30" style="font-size: 12px;">spencer massey</a> </div> </div> </div> </div> </div> </div> </div> <div id="fb-root"></div> <script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=297668800418060&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> <script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='a27a67ccae601ca7b7ea9eb7581c801b';
hf4V='60e59e25cabc21b471f56bbf1c2b4c34';
cm4S="form[action='https://dragillustrated.com/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form, .wpcf7-form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);return true;});var h="form[method='post']";$(h).submit(function(){$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(h);return true;});});
/* ]]> */
</script> <script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script> <script type="text/javascript">
jQuery(document).ready(function($) {

	// Main Menu Dropdown Toggle
	$('.menu-item-has-children a').click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$('.menu-item-has-children').click(function(){
    	  $(this).addClass('toggled');
    	  if($('.menu-item-has-children').hasClass('toggled'))
    	  {
    	  $(this).children('ul').toggle();
	  $('.fly-nav-menu').getNiceScroll().resize();
	  }
	  $(this).toggleClass('tog-minus');
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});

});
</script> <script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};var tribe_system_info = {"sysinfo_optin_nonce":"25ee0b8b81","clipboard_btn_text":"Copy to clipboard","clipboard_copied_text":"System info copied","clipboard_fail_text":"Press \"Cmd + C\" to copy"};/* ]]> */ </script><div style="display: none;"><a href="http://inoplugs.com">WP-Backgrounds Lite by InoPlugs Web Design</a> and <a href="http://schoenmann.at/">Juwelier Sch&ouml;nmann 1010 Wien</a></div> <script type="text/javascript">
		var c = document.body.className;
		c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
		document.body.className = c;
	</script> <script type='text/javascript' src='https://stats.wp.com/e-201919.js' async='async' defer='defer'></script> <script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.1.1',blog:'37035244',post:'34255',tz:'-5',srv:'dragillustrated.com'} ]);
	_stq.push([ 'clickTrackerInit', '37035244', '34255' ]);
</script>
</body></html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 1.49027109 sec
Time to load cache: 0.2641139
Cache file created on: 2019-05-06T01:39:49+00:00
Current time: 2019-05-06T03:05:58+00:00
-->