<!DOCTYPE html>
<html lang="en-US"
 xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />

<meta property="og:image" content="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/DI-RBPhotography-9_web-400x242.jpg" />


<link rel="shortcut icon" href="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2014/06/DI_16x16_favicon.png" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://dragillustrated.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://dragillustrated.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://dragillustrated.com/feed/atom/" />
<link rel="pingback" href="https://dragillustrated.com/xmlrpc.php" />


<title>KING OF THE JUNGLE: Tommy Franklin and his &#039;Jungle Rat&#039; Rule Pro Nitrous | Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</title>

<!-- All in One SEO Pack 2.4.5.1 by Michael Torbert of Semper Fi Web Designob_start_detected [-1,-1] -->
<meta name="description"  content="A fresh layer of snow coats the sidewalk as Tommy Franklin walks up to the office occupied by Franklin Electric, one of the four businesses Franklin operates with his wife, Judy. It&#039;s only 7 a.m., but Franklin&#039;s phone is already ringing off the hook. On the other line could be one of the 80-plus employees he has" />

<link rel="canonical" href="https://dragillustrated.com/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Feed" href="https://dragillustrated.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Comments Feed" href="https://dragillustrated.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; iCal Feed" href="https://dragillustrated.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; KING OF THE JUNGLE: Tommy Franklin and his &#8216;Jungle Rat&#8217; Rule Pro Nitrous Comments Feed" href="https://dragillustrated.com/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/dragillustrated.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='front-css-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/facebook-comment-by-vivacity/css/fb-comments-hidewpcomments.css' type='text/css' media='all' />
<link rel='stylesheet' id='inoplugs_backgrounds_css-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/wp-backgrounds-lite/includes/wp-backgrounds.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='digg-digg-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/digg-digg/css/diggdigg-style.css' type='text/css' media='screen' />
<link rel='stylesheet' id='woocommerce-layout-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-style-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/Braxton-Child/style.css' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='mvp-iecss-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/Braxton-Child/css/iecss.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='reset-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/css/reset.css' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.css' type='text/css' media='all' />
<link rel='stylesheet' id='media-queries-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/css/media-queries.css' type='text/css' media='all' />
<link rel='stylesheet' id='studio-fonts-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A400%7CQuicksand%3A300%2C400%7CVidaloka%7CPlayfair+Display%3A400%2C700%2C900%7COpen+Sans+Condensed%3A300%2C700%7COpen+Sans%3A400%2C800%7COswald%3A300%2C400%2C700%7CRaleway%3A200%2C300%2C400%2C500%2C600%2C700%2C800%26subset%3Dlatin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='fw-ext-builder-frontend-grid-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/unyson/framework/extensions/builder/static/css/frontend-grid.css' type='text/css' media='all' />
<link rel='stylesheet' id='fw-ext-forms-default-styles-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/unyson/framework/extensions/forms/static/css/frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/tablepress-combined.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var photocrati_ajax = {"url":"https:\/\/dragillustrated.com\/?photocrati_ajax=1","wp_home_url":"https:\/\/dragillustrated.com","wp_site_url":"https:\/\/dragillustrated.com","wp_root_url":"https:\/\/dragillustrated.com","wp_plugins_url":"https:\/\/dragillustrated.com\/wp-content\/plugins","wp_content_url":"https:\/\/dragillustrated.com\/wp-content","wp_includes_url":"https:\/\/dragillustrated.com\/wp-includes\/","ngg_param_slug":"nggallery"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragil-jagrllc.netdna-ssl.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/ajax/static/ajax.min.js'></script>
<link rel='https://api.w.org/' href='https://dragillustrated.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dragillustrated.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dragillustrated.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='C. Force, Torrence and McGaha Win NHRA Arizona Nationals' href='https://dragillustrated.com/c-force-torrence-and-mcgaha-win-nhra-arizona-nationals/' />
<link rel='shortlink' href='https://dragillustrated.com/?p=28883' />
<link rel="alternate" type="application/json+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Fking-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Fking-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous%2F&#038;format=xml" />
<script type="text/javascript" src="https://paywall.subscriptiongenius.com/load.js"></script>

<!-- This site is using AdRotate v4.11 Professional to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 {  margin: 0 auto; }
	.g-2 { margin:1px 1px 1px 1px; }
	.g-3 { margin:1px 1px 1px 1px; }
	.g-4 { margin:1px 1px 1px 1px; }
	.g-5 { margin:1px 1px 1px 1px; }
	.g-6 { margin:1px 1px 1px 1px; }
	.g-7 { margin:1px 1px 1px 1px; }
	.g-8 { min-width:3px; max-width:618px; }
	.b-8 { margin:1px 3px 1px 3px; }
	.g-9 { margin:1px 1px 1px 1px; }
	.g-10 { margin:1px 1px 1px 1px; }
	.g-16 { min-width:5px; max-width:150px; margin: 0 auto; }
	.b-16 { margin:0px 5px 0px 5px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<link rel="image_src" href="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/129_Tommy_Franklin_cover-660x797.jpg" /><meta property="fb:app_id" content="297668800418060"/>
<meta property="fb:admins" content=""/>
<meta property="og:locale" content="en_US" />
<meta property="og:locale:alternate" content="en_US" />
<style type="text/css">
			.wpsdc-drop-cap {
				float : left;				
				padding : 0.25em 0.05em 0.25em 0;				
				font-size : 5em;
				line-height : 0.4em;color : #0a0a0a;}
		</style><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//dragillustrated.com/?wordfence_lh=1&hid=89D6F4CE5CA0A7BFE85D5A21D2DA7086');
</script><!-- <meta name="NextGEN" version="2.2.50" /> -->
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://dragillustrated.com"><link rel="https://theeventscalendar.com/" href="https://dragillustrated.com/wp-json/tribe/events/v1/" /><style type='text/css'>img#wpstats{display:none}</style>
<style type='text/css'>

@import url(//fonts.googleapis.com/css?family=Vidaloka:100,200,300,400,500,600,700,800,900|Raleway:100,200,300,400,500,600,700,800,900|Playfair+Display:100,200,300,400,500,600,700,800,900|Oswald:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese);

#nav-wrapper,
#nav-top-wrap {
	background: #ff0000;
	}

.fly-but-wrap span {
	background: #555555;
	}

#main-nav .menu li a:hover,
#main-nav .menu li.current-menu-item a,
#search-button:hover,
.home-widget h3.widget-cat,
span.post-tags-header,
.post-tags a:hover,
.tag-cloud a:hover,
.woocommerce .widget_price_filter .ui-slider .ui-slider-range {
	background: #ff0000;
	}

.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce span.onsale,
.woocommerce #respond input#submit.alt,
.woocommerce a.button.alt,
.woocommerce button.button.alt,
.woocommerce input.button.alt,
.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt:hover {
	background-color: #ff0000;
	}

.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt:hover {
	opacity: 0.8;
	}

#main-nav .menu-item-home a:hover {
	background: #ff0000 !important;
	}

#top-story-left h3,
#top-story-right h3 {
	border-bottom: 3px solid #ff0000;
	}

a, a:visited,
ul.top-stories li:hover h2,
ul.top-stories li:hover h2,
#top-story-middle:hover h2,
#top-story-wrapper:hover #feat2-main-text h2,
#feat1-left-wrapper:hover .feat1-left-text h2,
#feat1-right-wrapper:hover .feat1-right-text h2,
ul.split-columns li:hover h2,
.home-widget ul.wide-widget li:hover h2,
.home-widget ul.home-list li:hover h2,
h3.story-cat,
h3.story-cat a,
.sidebar-widget ul.home-list li:hover h2,
.sidebar-widget ul.wide-widget li:hover h2,
.sidebar-widget ul.split-columns li:hover h2,
#footer-nav .menu li a:hover,
.footer-widget ul.home-list li:hover h2,
.footer-widget ul.wide-widget li:hover h2,
.footer-widget ul.split-columns li:hover h2,
.prev,
.next {
	color: #ff0000;
	}

#wallpaper {
	background: url() no-repeat 50% 0;
	}

.featured-text h2,
.featured-text h2 a,
.feat1-main-text h2,
.feat1-main-text h2 a {
	font-family: 'Vidaloka', serif;
	}

#main-nav .menu li a,
#main-nav .menu li:hover ul li a {
	font-family: 'Raleway', sans-serif;
	}

#top-story-left h2,
#top-story-right h2,
.feat1-left-text h2,
.feat1-right-text h2,
#feat2-main-text h2,
#middle-text h2,
ul.split-columns li h2,
.home-widget .wide-text h2,
.home-widget .home-list-content h2,
h1.story-title,
.sidebar-widget .wide-text h2,
.sidebar-widget ul.split-columns li h2,
.footer-widget .wide-text h2,
.footer-widget ul.split-columns li h2,
#post-404 h1 {
	font-family: 'Playfair Display', serif;
	}

#top-story-left h3,
#top-story-right h3,
#middle-text h3,
h1.home-widget-header,
#woo-content h1.page-title,
h3.home-widget-header,
h1.archive-header,
h3.story-cat,
h3.story-cat a,
#content-area h1,
#content-area h2,
#content-area h3,
#content-area h4,
#content-area h5,
#content-area h6,
h4.post-header,
h3.sidebar-widget-header,
h3.footer-widget-header {
	font-family: 'Oswald', sans-serif;
	}

@media screen and (max-width: 767px) and (min-width: 480px) {

	.sidebar-widget .home-list-content h2 {
		font-family: 'Playfair Display', serif;
		}

	}

#menufication-outer-wrap.menufication-transition-in #menufication-scroll-container {
	overflow-y: auto !important;
	}

</style>
	
<style type="text/css">



</style>

<style type="text/css">
#wallpaper {
	background-size: 100%;
}</style>

	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e7e7e7; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="KING OF THE JUNGLE: Tommy Franklin and his &#8216;Jungle Rat&#8217; Rule Pro Nitrous" />
<meta property="og:url" content="https://dragillustrated.com/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/" />
<meta property="og:description" content="A fresh layer of snow coats the sidewalk as Tommy Franklin walks up to the office occupied by Franklin Electric, one of the four businesses Franklin operates with his wife, Judy. It’s only 7 a.m., …" />
<meta property="article:published_time" content="2018-02-26T14:00:30+00:00" />
<meta property="article:modified_time" content="2018-02-24T21:30:18+00:00" />
<meta property="og:site_name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
<meta property="og:image" content="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/DI-RBPhotography-9_web.jpg" />
<meta property="og:image:width" content="2000" />
<meta property="og:image:height" content="1333" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="KING OF THE JUNGLE: Tommy Franklin and his &#8216;Jungle Rat&#8217; Rule Pro Nitrous" />
<meta name="twitter:image" content="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/DI-RBPhotography-9_web.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<!-- BEGIN GADWP v5.2.2 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-21052018-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->

<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/wp-spamshield/js/jscripts.php'></script> 

</head>

<body data-rsssl=1 class="post-template-default single single-post postid-28883 single-format-standard custom-background tribe-no-js">
<div id="site">
	<div id="fly-wrap">
	<div class="fly-wrap-out">
		<div class="fly-side-wrap">
			<ul class="fly-bottom-soc left relative">
									<li class="fb-soc">
						<a href="https://www.facebook.com/DragIllustrated/" target="_blank">
						<i class="fa fa-facebook-square fa-2"></i>
						</a>
					</li>
													<li class="twit-soc">
						<a href="https://twitter.com/DragIllustrated" target="_blank">
						<i class="fa fa-twitter fa-2"></i>
						</a>
					</li>
																	<li class="inst-soc">
						<a href="https://www.instagram.com/dragillustrated/" target="_blank">
						<i class="fa fa-instagram fa-2"></i>
						</a>
					</li>
																													<li class="rss-soc">
						<a href="https://dragillustrated.com/feed/rss/" target="_blank">
						<i class="fa fa-rss fa-2"></i>
						</a>
					</li>
							</ul>
		</div><!--fly-side-wrap-->
		<div class="fly-wrap-in">
			<div id="fly-menu-wrap">
				<nav class="fly-nav-menu left relative">
					<div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-15084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15084"><a href="https://dragillustrated.com/category/features/">Features</a></li>
<li id="menu-item-17722" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17722"><a>Blogs</a>
<ul  class="sub-menu">
	<li id="menu-item-17723" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17723"><a href="https://dragillustrated.com/category/blogs/ian-tocher/">Ian Tocher</a></li>
	<li id="menu-item-17724" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17724"><a href="https://dragillustrated.com/category/blogs/wes-buck/">Wes Buck</a></li>
	<li id="menu-item-17725" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17725"><a href="https://dragillustrated.com/category/blogs/ontheroad/">On The Road</a></li>
	<li id="menu-item-17726" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17726"><a href="https://dragillustrated.com/category/blogs/lucky-hudson/">Lucky Hudson</a></li>
	<li id="menu-item-17727" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17727"><a href="https://dragillustrated.com/category/blogs/tommy-d/">Tommy D</a></li>
	<li id="menu-item-20226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20226"><a href="https://dragillustrated.com/category/blogs/driver-blogs/">Driver Blogs</a></li>
</ul>
</li>
<li id="menu-item-15087" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15087"><a href="https://dragillustrated.com/category/tech/">Tech</a></li>
<li id="menu-item-15086" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-15086"><a href="https://dragillustrated.com/category/race-coverage/">Coverage</a>
<ul  class="sub-menu">
	<li id="menu-item-15096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15096"><a href="https://dragillustrated.com/category/race-coverage/nhra-race-coverage/">NHRA</a></li>
	<li id="menu-item-15100" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15100"><a href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a></li>
	<li id="menu-item-15098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15098"><a href="https://dragillustrated.com/category/race-coverage/ihra-race-coverage/">IHRA</a></li>
	<li id="menu-item-15099" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15099"><a href="https://dragillustrated.com/category/race-coverage/outlaw/">Outlaw Presented by Strange</a></li>
	<li id="menu-item-21234" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21234"><a href="https://dragillustrated.com/category/lightsout7/">Lights Out 7</a></li>
	<li id="menu-item-15101" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15101"><a href="https://dragillustrated.com/category/race-coverage/sportsman-race-coverage/">Sportsman</a></li>
</ul>
</li>
<li id="menu-item-15104" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15104"><a href="https://dragillustrated.com/shop/">Store</a></li>
<li id="menu-item-15094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li id="menu-item-15102" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
</ul></div>				</nav>
			</div><!--fly-menu-wrap-->
		</div><!--fly-wrap-in-->
	</div><!--fly-wrap-out-->
</div><!--fly-wrap-->	<div id="nav-top-wrap" class="left relative">
		<div id="nav-top-mid" class="relative">
			<div id="nav-top-cont" class="left relative">
																</div><!--nav-top-cont-->
		</div><!--nav-top-mid-->
	</div><!--nav-top-wrap-->
	<div id="nav-wrapper">
		<div class="nav-wrap-out">
		<div class="nav-wrap-in">
			<div id="nav-inner">
			<div class="fly-but-wrap left relative">
				<span></span>
				<span></span>
				<span></span>
				<span></span>
			</div><!--fly-but-wrap-->
							<div id="logo-small" itemscope itemtype="http://schema.org/Organization">
											<a itemprop="url" href="https://dragillustrated.com"><img itemprop="logo" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2015/01/DI_141x54_white_shadow.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" /></a>
									</div><!--logo-small-->
						<div id="main-nav">
				<div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15084"><a href="https://dragillustrated.com/category/features/">Features</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17722"><a>Blogs</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17723"><a href="https://dragillustrated.com/category/blogs/ian-tocher/">Ian Tocher</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17724"><a href="https://dragillustrated.com/category/blogs/wes-buck/">Wes Buck</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17725"><a href="https://dragillustrated.com/category/blogs/ontheroad/">On The Road</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17726"><a href="https://dragillustrated.com/category/blogs/lucky-hudson/">Lucky Hudson</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17727"><a href="https://dragillustrated.com/category/blogs/tommy-d/">Tommy D</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20226"><a href="https://dragillustrated.com/category/blogs/driver-blogs/">Driver Blogs</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15087"><a href="https://dragillustrated.com/category/tech/">Tech</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-15086"><a href="https://dragillustrated.com/category/race-coverage/">Coverage</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15096"><a href="https://dragillustrated.com/category/race-coverage/nhra-race-coverage/">NHRA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15100"><a href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15098"><a href="https://dragillustrated.com/category/race-coverage/ihra-race-coverage/">IHRA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15099"><a href="https://dragillustrated.com/category/race-coverage/outlaw/">Outlaw Presented by Strange</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21234"><a href="https://dragillustrated.com/category/lightsout7/">Lights Out 7</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15101"><a href="https://dragillustrated.com/category/race-coverage/sportsman-race-coverage/">Sportsman</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15104"><a href="https://dragillustrated.com/shop/">Store</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
</ul></div>			</div><!--main-nav-->
			<div id="search-button">
				<img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/themes/braxton/images/search-icon.png" />
			</div><!--search-button-->
			<div id="search-bar">
				<form method="get" id="searchform" action="https://dragillustrated.com/">
	<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>			</div><!--search-bar-->
			</div><!--nav-inner-->
		</div><!--nav-wrap-in-->
		</div><!--nav-wrap-out-->
	</div><!--nav-wrapper-->
		<div id="body-wrapper">
				<div id="main-wrapper">
										
    <div id="ad-area-wrap"><div class="ad-rotate-widget"><div class="ad-rotate-widget-widget"><ul><li><div class="g g-7"><div class="g-single a-285"><a class="gofollow" data-track="Mjg1LDcsMSw2MA==" target="_blank" href="http://www.fueltech.net/"><img src="https://i0.wp.com/dragillustrated.com/wp-content/uploads/2017/02/Leaderboard.png" /></a></div></div></li></ul></div></div><!-- end .ad-rotate-widget --><div class="subscribe-now"><div class="subscribe-now">			<div class="textwidget"><a href="https://dragillustrated.com/product/make-drag-racing-great-again-hat/"><img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2016/02/MDRGA_Hats.png" alt="Make Drag Racing Great Again" height="90" width="180"></a></div>
		</div></div><!-- end .subscribe-now --></div><!-- end #ad-area-wrap -->	
	<div id="content-wrapper">
						<div id="content-main">
																										<div id="featured-image" itemscope itemtype="http://schema.org/Article">
																													<img itemprop="image" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/DI-RBPhotography-9_web-660x400.jpg" />
														<span class="photo-credit">Rick Belden</span>
													</div><!--featured-image-->
																					<div id="home-main">
				<div id="post-area" itemscope itemtype="http://schema.org/Article" class="post-28883 post type-post status-publish format-standard has-post-thumbnail hentry category-exclusive category-features category-interviews category-pdra-race-coverage">
					<h3 class="story-cat">Exclusive</h3>
					<h1 class="story-title" itemprop="name">KING OF THE JUNGLE: Tommy Franklin and his &#8216;Jungle Rat&#8217; Rule Pro Nitrous</h1>
					<div id="post-info">
						By&nbsp;<span class="author" itemprop="author"><a href="https://dragillustrated.com/author/nate/" title="Posts by Nate Van Wagnen" rel="author">Nate Van Wagnen</a></span>&nbsp;|&nbsp;<time class="post-date" itemprop="datePublished" datetime="2018-02-26" pubdate>February 26, 2018</time>
					</div><!--post-info-->
											<div class="social-sharing-top">
							<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://dragillustrated.com/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/&t=KING OF THE JUNGLE: Tommy Franklin and his &#8216;Jungle Rat&#8217; Rule Pro Nitrous', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"></span><p>Share</p></div></a>
							<a href="#" onclick="window.open('http://twitter.com/share?text=KING OF THE JUNGLE: Tommy Franklin and his &#8216;Jungle Rat&#8217; Rule Pro Nitrous -&url=https://dragillustrated.com/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"></span><p>Tweet</p></div></a>
							<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://dragillustrated.com/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/&media=https://dragillustrated.com/wp-content/uploads/2018/02/DI-RBPhotography-9_web-660x400.jpg&description=KING OF THE JUNGLE: Tommy Franklin and his &#8216;Jungle Rat&#8217; Rule Pro Nitrous', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"></span><p>Share</p></div></a>
							<a href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https://dragillustrated.com/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"><div class="google-share"><span class="google-but1"></span><p>Share</p></div></a>
							<a href="https://dragillustrated.com/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/#respond"><div class="social-comments"><p>0 comments</p></div></a>
						</div><!--social-sharing-top-->
										<div id="content-area">
							
		<p>A fresh layer of snow coats the sidewalk as Tommy Franklin walks up to the office occupied by Franklin Electric, one of the four businesses Franklin operates with his wife, Judy. It’s only 7 a.m., but Franklin’s phone is already ringing off the hook. On the other line could be one of the 80-plus employees he has working at Franklin Electric and SmartCom Home Technologies, or maybe one of his trusted staff members at the Professional Drag Racers Association or Virginia Motorsports Park, which Franklin purchased in late October. The caller turns out to be one of the subcontractors working with SmartCom, the security company Franklin started in 2003 to compliment his thriving electrical contracting firm. Franklin addresses the issue at hand and returns to some paperwork.</p>
<p>“My day’s work is really a combination of all of the companies,” Franklin says. “I don&#8217;t think there&#8217;s any possible way of saying today is for this company, tomorrow is for that company – it doesn&#8217;t happen that way. The work just comes as it comes.”</p>
<p>Franklin seems to thrive on work. Maybe it’s the work itself, but the more likely explanation for Franklin’s continuous undertaking of business challenges is the overwhelming reward of seeing them through to success. It all started when Franklin left his high school job, working the counter at a local auto parts store, to get into the electrical trade. When he realized that wasn’t paying enough to cover his increasingly expensive racing habit, he started his own electrical business with one employee in January of 1997. Today, Franklin Electric wires up around 1,500 new homes in Maryland and Virginia every year.</p>
<p><img class="alignleft wp-image-28696" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/129_Tommy_Franklin_cover-660x797.jpg" alt="" width="300" height="362" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/129_Tommy_Franklin_cover-660x797.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/129_Tommy_Franklin_cover-124x150.jpg 124w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/129_Tommy_Franklin_cover-768x928.jpg 768w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/129_Tommy_Franklin_cover.jpg 1350w" sizes="(max-width: 300px) 100vw, 300px" />The success of Franklin Electric and SmartCom gave Franklin the confidence and freedom to extend his reach into drag racing. When the ADRL folded at the end of 2013, Franklin was one of the five racers who banded together to form the Professional Drag Racers Association. The PDRA ownership group, headed up by Jason and Mitchell Scruggs, brought a level of stability to outlaw eighth-mile drag racing, something the scene was missing at the time. The Franklins quickly took a hands-on approach to their ownership stake, all while Tommy fielded a competitive Pro Nitrous entry. He finished second to Jason Harris in 2014, the PDRA’s debut season, then notched another second-place championship finish in 2015, eventually losing the title to doorslammer racing legend Rickie Smith.</p>
<p>Two runner-up finishes clearly weighed on Franklin, as he came out swinging in 2016 and never let up. His Jerry Bickel Race Cars-built ’69 Camaro won three races, including the PDRA World Finals, where he secured his first Pro Nitrous world championship over Jay Cox. Franklin and his purple-and-green “Jungle Rat” remained consistently quick on the 2017 tour, appearing in six of the seven contested final rounds. He finished the season as a two-time champion with one event win and the PDRA Pro Nitrous elapsed-time world record. To make the season’s accomplishments even sweeter, Franklin was able to share the championship stage with his 15-year-old daughter, Amber, who won the PDRA Pro Junior Dragster world championship on the strength of an event win and three runner-up finishes. The Franklins’ youngest daughter, Ashley, was named the 2017 Rookie of the Year after finishing fifth in her Top Junior Dragster rookie season.</p>
<p>When Franklin was crowned the 2017 Pro Nitrous world champion at the World Finals at Virginia Motorsports Park, he was just four days into his career as a track owner. He never intended to purchase a racetrack, but such an opportunity had yet to present itself. Tommy dove right in to the challenge – with Judy by his side, of course – but he didn’t make any drastic changes. He left most of the previous staff in place at the quarter-mile facility just south of Richmond. Franklin says 2018 will be a year of improvements to the property, including a new track surface, while he works with the veteran staff to learn the racetrack business.</p>
<p>For our annual Champions Issue, <em>DRAG ILLUSTRATED</em> spoke with Franklin to learn more about his path to success in business and racing.</p>
<p><strong><em>What have you learned in business that you’ve been able to apply to racing?</em></strong></p>
<p>I think with anything it all starts with work. I tell my kids that every day. I think anybody can have everything they want, it&#8217;s just all about how much you&#8217;re willing to work for it. That&#8217;s really the extent of it. I think whoever works the hardest is who gets there.</p>
<p>You&#8217;ve got to surround yourself with good people because one of the biggest challenges I&#8217;ve probably had <img class="alignright wp-image-28888" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/TB15_web-660x440.jpg" alt="" width="300" height="200" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/TB15_web-660x440.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/TB15_web-150x100.jpg 150w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/TB15_web-768x512.jpg 768w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/TB15_web-600x400.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" />as a business owner is delegating. Judy accuses me of being a control freak, but it&#8217;s not as much about control as it is wanting to have my fingers on things. I found that with the PDRA, I found that with the racetrack – I get involved and I have this great plan that I&#8217;m going to let people get involved – and I do –&nbsp; I&#8217;m much better at it today than I ever was, but as we&#8217;ve grown I&#8217;ve realized I can&#8217;t do it all.</p>
<p>That&#8217;s what&#8217;s taught me that you need to have good people. You need people who have the same common goal that you have. That&#8217;s what it takes. I can&#8217;t do it all by myself, and anytime that I&#8217;ve tried, one part is successful and the other one will suffer from it. You go to work on the other one to make it successful, then the first one suffers. You&#8217;ve got to have good people, and that&#8217;s what I’ve tried to do here in the last four or five years – surround myself with a good staff, surround myself with people who care for what we’re doing and are willing to put in the work to get there.</p>
<p>On our racing team, it&#8217;s the same way. It&#8217;s a family deal, so we all obviously have the care for one another, but even Chris Murray, my main crew guy, he prepares everything, gets the car maintenanced and loaded so I can just hop in the truck and go. At the racetrack, we share duties there and do everything we can to help each other, but he&#8217;s a big, key part of the deal – doing the maintenance, looking for problems and having the drive to continue to be better and faster.</p>
<p>I spent many, many years going to races and not qualifying or wondering how these other guys continue to stay up front and run so good – probably guilty at times of thinking, “It&#8217;s just not fair; they&#8217;re doing this, they&#8217;re doing that.” Now when I look at it, I&#8217;m happy to say that we&#8217;re on the other side of that. And I know you never stay there forever, but that&#8217;s the big challenge now&#8230;how long can we stay on top?</p>
<p><img class="alignnone size-medium wp-image-28890" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_9144_web-660x440.jpg" alt="" width="660" height="440" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_9144_web-660x440.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_9144_web-150x100.jpg 150w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_9144_web-768x512.jpg 768w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_9144_web-600x400.jpg 600w" sizes="(max-width: 660px) 100vw, 660px" /></p>
<p><strong><em>How did finishing second twice drive you to really fight for that first championship in 2016?</em></strong></p>
<p>I honestly thought it would never happen. I thought it was just not meant to be. In 2014, Jason Harris pretty much dominated in the PDRA. We were in second, but we were a distant second. Then in 2015, we were actually racing against Rickie Smith for the championship. It came down to the final race and I had an opportunity to win, but I just kind of left that one sitting on the table. That gives you the drive to go back and continue.</p>
<p>I think what drives me the most is to be able to race guys like Rickie. You race these guys who are legends, guys who do this for a living. We try to race like we&#8217;re professionals and doing it for a living, but in all honesty, it&#8217;s a hobby for us. To be able to race against the caliber of teams that we are, that&#8217;s what drives me to do it. As a kid, you grow up dreaming of exactly that – setting world records, winning races and winning championships. To get that close, it really gives you a taste of it. It felt really good when we got it last year, almost like a relief. But then as the year started going on, you start having that desire to get back there. I think the worst thing is thinking that you might have to peel the number one off the window. I don&#8217;t want that. It all just drives you to step up your game and make it happen.</p>
<p><strong><em>How rewarding has it been to win two championships during a time when Pro Nitrous has been at its best?</em></strong></p>
<p>Not taking away from any win at any point, but when you see the level of competition that&#8217;s so close, I think that says a lot for the PDRA and what it&#8217;s become. When you go out and win a round going 3.65 like we did at Virginia to finish the year, you didn&#8217;t just win the championship, you raised the bar to another level. I think that&#8217;s what&#8217;s more rewarding to me, to know that we&#8217;re winning championships at a time when the class is the most competitive that it&#8217;s ever been, I believe. I say that because you have parity between not only 16 cars, but really, probably 20-22 cars that show up and have an opportunity to win every single round.</p>
<p><img class="alignnone size-medium wp-image-28893" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/TB43-660x440.jpg" alt="" width="660" height="440" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/TB43-660x440.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/TB43-150x100.jpg 150w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/TB43-768x512.jpg 768w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/TB43-600x400.jpg 600w" sizes="(max-width: 660px) 100vw, 660px" /></p>
<p><strong><em>Amber won the Pro Junior Dragster championship and Ashley won Rookie of the Year honors. How exciting is it for you to see your daughters reach levels of success alongside you like that?</em></strong></p>
<p>For all of us to be able to go out and race together at a high level means a lot. Growing up, my parents did the same thing with me – we did a lot of things together. There was never a time where I got left behind and they went and did the fun stuff. I think that probably kept me out of a lot of trouble at times. I&#8217;ve done the same thing with my family. Luckily, my kids enjoy it still and they enjoy being here with us. I recognize that that might not always be the case, but I&#8217;m trying to make sure it is always the case if possible.</p>
<p><strong><em>Some people might say that it’s only Jr. Dragster racing, but the competition in the PDRA’s Jr. Dragster classes isn’t easy. </em></strong></p>
<p>I think the Jr. classes can be tougher than the rest of the classes. Those kids out there are amazing. Ashley was in her first year of competition, really green to it. To see her come around from where she started the year off, she qualified for every single race. Top Jr. Dragster qualifies based on reaction time, so that says a lot for her. I believe she was No. 1 qualifier two or three times. I was really proud when they voted her Rookie of the Year. The last thing I would want is for my kids to get something they didn&#8217;t deserve, but she raced hard, qualified for every race, had a few No. 1 qualifiers and even a couple perfect lights, so she definitely deserved it.</p>
<p>With Amber, she&#8217;s ate up with racing&#8230;bad. It&#8217;s delighting to see, by all means. She&#8217;s very focused. It&#8217;s a <img class="alignright wp-image-28887" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/DI-RBPhotography-6_web-660x440.jpg" alt="" width="400" height="267" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/DI-RBPhotography-6_web-660x440.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/DI-RBPhotography-6_web-150x100.jpg 150w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/DI-RBPhotography-6_web-768x512.jpg 768w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/DI-RBPhotography-6_web-600x400.jpg 600w" sizes="(max-width: 400px) 100vw, 400px" />learning time, so as the years started going by she would get her reaction times down, then we would talk about driving the finish line. As a parent, sometimes you think it should be easier for them to learn it. We came out this year and all of a sudden Amber is tightening up the finish line to a hundredth or so and I&#8217;m like, “That&#8217;s a little bit tight,” and she&#8217;s like, “Oh no, Dad, I got it.” Her confidence level is really high, and I think any form of racing requires that. You have to be able to go in and be confident and know that you have a chance to win.</p>
<p>They&#8217;ve definitely impressed me more than I&#8217;ve ever impressed myself, that&#8217;s for sure. Being able to travel around with my family, including Judy and any of my other family members who come to the races, it&#8217;s just enjoyable. It&#8217;s memories that I hope they&#8217;ll recognize for the rest of their lives.</p>
<p><strong><em>You and Amber made history when you became the first father-daughter champions of a national drag racing series. How did you two work together to accomplish that?</em></strong></p>
<p>All year long, we were in three or four finals together. The PDRA typically runs the Jr. Dragsters before Pro Nitrous, so she would win her rounds long before I won my rounds and put the pressure back on me and I let it down. We didn&#8217;t get to share the winner&#8217;s circle all year. It felt like another one of those things that wasn&#8217;t meant to be, but then the championships came along. Amber made a speech at the PDRA banquet that really summed it up: There were bigger things planned. To win the championship together, that&#8217;s much more memorable than one race would be. It&#8217;s exciting. Just as any parent, watching my kids win is much more gratifying than winning myself.</p>
<p><strong><em>Amber is approaching the age when she’ll have to move out of Jr. Dragsters. What’s the next step for her?</em></strong></p>
<p><img class="alignleft wp-image-28886" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_3102.JPG_web-600x800.jpeg" alt="" width="225" height="300" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_3102.JPG_web-600x800.jpeg 600w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_3102.JPG_web-113x150.jpeg 113w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_3102.JPG_web-768x1024.jpeg 768w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_3102.JPG_web-1350x1800.jpeg 1350w" sizes="(max-width: 225px) 100vw, 225px" />Eventually we’re going to put her in the car I drove for the past few seasons. I&#8217;ve got a new car for 2018. I&#8217;m going to keep my old car for now for two reasons: it&#8217;s too good to race against, but also because there&#8217;s no sense in selling that car and buying another car for Amber. We don&#8217;t know exactly what the process will look like. She&#8217;ll get her license later this year, but I don&#8217;t plan on putting her in anything real fast real soon. We&#8217;re going to see what happens. She has a big interest in the Outlaw 632 class right now, which I think is a really cool class. Not that it&#8217;s cheap, but it&#8217;s a starter class. It looks like it&#8217;s something that you can get in and get your feet wet. The cars are running 4.20s and 4.30s. Whether it be that or Top Sportsman or something like that, I&#8217;m sure that&#8217;s the direction she&#8217;ll take.</p>
<p>We&#8217;ve talked about maybe putting her in a dragster for a little bit, but I&#8217;m not sure about that. She wants to be in a door car. She wants to run Pro Nitrous. I don&#8217;t think her mom is ready for that, and I&#8217;m not sure I&#8217;m ready for that, so we&#8217;ll take it slow and make sure she&#8217;s ready. At the end of the day, she&#8217;s still our daughter and she&#8217;s a kid. We&#8217;re going to try to protect her from herself as much as we can.</p>
<p><strong><em>How have you prepared yourself for the tense moments that will come with putting Amber in a Pro Mod-style car?</em></strong></p>
<p>I&#8217;m not sure I&#8217;m completely prepared for it. My mom and dad told me it was the hardest thing in the world. My dad&#8217;s actually told me don&#8217;t do it. He was right beside me when I went out there and started racing. He enjoyed watching it, but at the same time I&#8217;m sure it&#8217;s nerve-wracking. The Jr. Dragsters are fast for what they are. I think with anything, as the girls make laps their confidence level improves. I don&#8217;t know that I&#8217;m fully prepared for Amber racing in Pro Nitrous, but I do know that that&#8217;s what she wants. And I&#8217;ve told both of my kids that if any point they decide they don&#8217;t want to do this, I&#8217;m not going to make them do it. But right now I don&#8217;t have that problem. They both beg to go racing.</p>
<p>It&#8217;s different sitting on the starting line and watching them race. The seat-of-the-pants feel in the car, you never think that you&#8217;re as far out of shape as it looks from the starting line. I&#8217;m sure there will be some tense moments like that, but as long as she does the smart thing and respects the car and respects what it is, that&#8217;s what matters to me. Anything can happen at any point, but we have to try to eliminate the things that can be eliminated.</p>
<p><img class="alignnone size-medium wp-image-28885" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/OPENING-SPREAD-DI-RBPhotography-2_web-660x440.jpg" alt="" width="660" height="440" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/OPENING-SPREAD-DI-RBPhotography-2_web-660x440.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/OPENING-SPREAD-DI-RBPhotography-2_web-150x100.jpg 150w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/OPENING-SPREAD-DI-RBPhotography-2_web-768x512.jpg 768w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/OPENING-SPREAD-DI-RBPhotography-2_web-600x400.jpg 600w" sizes="(max-width: 660px) 100vw, 660px" /></p>
<p>&nbsp;</p>
<p><strong><em>You talked about ordering a new car, another Bickel-built ’69 Camaro with Pat Musi power between the frame rails. How hard was the decision to start phasing out the car you’ve been driving? It’s become one of the most consistent race cars in all of drag racing over the last few years. </em></strong></p>
<p>That thing has been good since the start when we brought it out in 2014. We&#8217;ve picked away at it and do all of our own tuning. There&#8217;s always input and help from the outside. Pat Musi has actually become a good friend on top of being in a business deal together with the engine program. We share a lot of things and bounce ideas of each other. The car has just been unreal good. I&#8217;d like to be arrogant enough and say that the new car will be just the same, and that&#8217;s my hope. I&#8217;ll be honest and say there&#8217;s a little bit of a chip on my shoulder that I want to prove that this car can be just as good. I&#8217;m anxious. I&#8217;m nervous that it won&#8217;t be as good, but I have a lot of confidence in what Jerry Bickel builds.</p>
<p>Chris (Murray) and I have talked about how I want to prove that this car is just as good. We&#8217;ll see how it goes. We might just step all over our toes, but at least – worst case scenario – the other one is still sitting in the shop. If it&#8217;s back out by Race 2, you might know why.</p>
<p><strong><em>You recently added “racetrack owner” to your list of titles. What inspired you to buy Virginia Motorsports Park?</em></strong></p>
<p><strong><em>&nbsp;</em></strong>It&#8217;s always been one of my favorite tracks. Not that I had a real interest in being a racetrack owner, but it&#8217;s something that drove me. I think it&#8217;s something that will help me build on the brand of the PDRA. We&#8217;re working towards being able to have a team that has a core to build on. That&#8217;s where it stemmed from when I started thinking about it. It gives us a place to call home and have a staff that works together. We&#8217;re scattered around in multiple states, but at the same time you&#8217;ve gotta have that core business.</p>
<p><strong><em>You’re now a few months into track ownership. How’s it going?</em></strong></p>
<p>We&#8217;ve gotten our feet wet for a couple months and had a couple good races. My first race since having VMP was the PDRA World Finals, and that one was a home run. It was funny because Dale Foley, the previous owner, he came up to me and asked, “How in the world did you drum up this weather report?” I said it&#8217;s beginner&#8217;s luck, buddy.</p>
<p>We finished off the year really solid. Mr. Foley put a lot into building a great facility, and he just aged out, let&#8217;s say. He was ready to move on. But the really cool thing was he wanted it to stay a racetrack and that&#8217;s why we were able to get a deal put together. We&#8217;re going to do some cleaning up and painting, things like that. The biggest piece we’re actually working on is the new track surface that we&#8217;re trying to do for 2018. We&#8217;re in the final stages of deciding whether it will be all concrete or not, but we will have a new surface for the year.</p>
<p><img class="alignnone size-medium wp-image-28889" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_6818_web-660x440.jpg" alt="" width="660" height="440" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_6818_web-660x440.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_6818_web-150x100.jpg 150w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_6818_web-768x512.jpg 768w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/IMG_6818_web-600x400.jpg 600w" sizes="(max-width: 660px) 100vw, 660px" /></p>
<p><strong><em>That seems like a pretty substantial early investment. </em></strong></p>
<p>We&#8217;re trying to put together one of the best tracks in the country. There&#8217;s a lot to compare to so I don&#8217;t want to say it&#8217;ll be the best, but we&#8217;re definitely going to put it right there with the best of them. I think it&#8217;s a facility that everybody already loves going to. There&#8217;s a ton of room on the property, and some epic races have happened there. That&#8217;s what I want – I want some big events. We&#8217;re going to continue to support our sportsman racers, but I also want some big races. It&#8217;s going to be exciting.</p>
<p><strong><em>How do you think this will compare to your other business ventures?</em></strong></p>
<p>It&#8217;s definitely a lot more exciting than electrical. It&#8217;s got the pizzazz, it&#8217;s got the sexiness, so it&#8217;s going to be fun. Everything comes with work and everything comes with its headaches, but I think at the end of the day it&#8217;s going to be fun. It&#8217;s already a great facility, I just want to see it grow. It&#8217;s about putting back into something that&#8217;s consumed my life. I love the sport and I love the people. That&#8217;s what it&#8217;s really about for me.</p>
<p><strong><em>You entered the racetrack business with the experience of a racer, businessman and sanctioning body official. How do you plan to use all of those different skillsets and standpoints to improve the racetrack?</em></strong><strong><em>&nbsp;</em></strong></p>
<p><img class="alignleft wp-image-26611" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/06/PN_Cox-far-lane-over-Franklin-660x502.jpg" alt="" width="300" height="228" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/06/PN_Cox-far-lane-over-Franklin-660x502.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/06/PN_Cox-far-lane-over-Franklin-150x114.jpg 150w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/06/PN_Cox-far-lane-over-Franklin-768x584.jpg 768w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/06/PN_Cox-far-lane-over-Franklin.jpg 1000w" sizes="(max-width: 300px) 100vw, 300px" />I&#8217;ll be honest – one of the first things I wanted to see when we had our first PDRA event there once I had taken over was seeing what the racetrack side of it experienced. There&#8217;s definitely a lot to see from both sides. There&#8217;s expenses that go hand-in-hand, but one of the biggest things that we learned in the PDRA is that we have to be aligned with racetracks that want to be in a partnership. These races need to be promoted together between the track and the PDRA. We need to be able to access the tracks&#8217; local fan base. That&#8217;s what&#8217;s hard about the PDRA when you go state-to-state basically one a month, being able to dive into that local fan base. That&#8217;s the biggest challenge that the PDRA has had, and we&#8217;ve gotten much better with it. Quite honestly, the way we get better at it is aligning ourselves with facilities that are willing to be partners. That&#8217;s what&#8217;s been good about it.</p>
<p>From the racetrack side of it, that gives us a huge advantage because I recognize, coming from the PDRA, how important it is to have a local base and have a stream of information you can get out to people all the time. By having two PDRA races, that will just give us an upper hand on those events because we know that we&#8217;re both definitely looking out for the same end result.</p>
<p>We&#8217;ve had it in the past where people look at (PDRA races) as a track rental and they don&#8217;t really invest into it – that&#8217;s not the way it is. We really look for partnerships. To be able to go into our track and know what we know from the PDRA side, seeing the trends that are successful, we get a little bit of an insight into how and why they&#8217;re successful. My ears are always open. My eyes are always open. I&#8217;m always watching what other successful people do to try to build upon that. I think that will help the racetrack as well as it will help the PDRA.</p>
<p><strong><em>The PDRA is going into its fifth year with a full head of steam – six professional classes and six sportsman categories racing at eight events held at tracks like GALOT Motorsports Park, Darlington Dragway, Maryland International Raceway, National Trail Raceway, and Virginia Motorsports Park, of course. What do you expect from the PDRA this season?</em></strong></p>
<p>From a car-count perspective and a fan perspective, I believe we&#8217;re going to have the biggest year yet. That&#8217;s the way I&#8217;m going into the season. As I&#8217;ve said, we spent a lot of time making sure we&#8217;re aligned with tracks that want to work together to promote successful events, and we have that with every track that&#8217;s on our schedule. I think the locations are great for the racers because we have so many racers in those regions. By expanding our sportsman classes, I think we&#8217;re going to have a great car count at every event. I&#8217;m excited for 2018. We&#8217;re coming off of a really strong 2017. Our last two races of the year just really knocked it out of the park. To go into 2018 with that momentum is huge. It all goes back to everybody knowing your brand. Sometimes I think it just takes time.</p>
<div id="attachment_26100" style="width: 670px" class="wp-caption alignnone"><img class="size-medium wp-image-26100" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/03/PDRA-at-GALOT-2016-660x439.jpg" alt="" width="660" height="439" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/03/PDRA-at-GALOT-2016-660x439.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/03/PDRA-at-GALOT-2016-150x100.jpg 150w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2017/03/PDRA-at-GALOT-2016-768x511.jpg 768w" sizes="(max-width: 660px) 100vw, 660px" /><p class="wp-caption-text">Joe McHugh photo</p></div>
<p><strong><em>What is the PDRA’s brand? For someone who’s never been to a PDRA race, what should they expect?</em></strong></p>
<p>I believe our racers are the best in the world. Hands down, bar none, it doesn&#8217;t matter what series you&#8217;re talking about, I think we have the best racers in the world. I think we have the best racing in the world. We have fast cars, side-by-side racing, and it&#8217;s not like there&#8217;s just one guy out there doing it. There&#8217;s so many people out there putting up numbers and raising the bar.</p>
<p>To the fans, it&#8217;s an experience that I don&#8217;t think anybody should miss. This year is going to take us to another level of that. I&#8217;m excited for that, I really am. Every year has kind of surprised us and we&#8217;d take a little bit bigger step than we thought we&#8217;d take. I&#8217;d like to say that&#8217;s happened every year, but this year just feels different. Everybody knows what the PDRA is, and that&#8217;s the exciting part. That&#8217;s what keeps driving me toward taking it to another level. I want to see success and I want to see everybody enjoy what we&#8217;re putting out. I can really say that myself and all the staff at PDRA are really looking forward to 2018.</p>
<p><strong><em>On that note, is there anything you’d like to add?</em></strong></p>
<p>Thank you to all the family, friends, fans; all the supporters of Tommy Franklin Motorsports, PDRA and Virginia Motorsports Park; and my employees at Franklin Electric and SmartCom. My wife, Judy, is right there beside me all the time. We work crazy hours together.</p>
<p>I always say in every interview I&#8217;ve done that I&#8217;ve gotta thank God for everything I do. None of it&#8217;s possible without Him. I still have to be able to put in the work for it, but just to be able to have the wisdom and ability to make the right decisions. I&#8217;m thankful for where I&#8217;m at.</p>
<p><em>This story originally appeared in DI #129, the Champions Issue, in January of 2018.&nbsp;</em></p>
<p><em>Photographs by Rick Belden, Tara Bowker and Roger Richards.</em></p>
<div class='dd_post_share'><div class='dd_buttons'><div class='dd_button'><a name='fb_share' type='button_count' share_url='https://dragillustrated.com/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/' href='http://www.facebook.com/sharer.php'></a><script src='https://static.ak.fbcdn.net/connect.php/js/FB.Share' type='text/javascript'></script></div><div class='dd_button'><a href="http://twitter.com/share" class="twitter-share-button" data-url="https://dragillustrated.com/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/" data-count="horizontal" data-text="KING OF THE JUNGLE: Tommy Franklin and his 'Jungle Rat' Rule Pro Nitrous" data-via="dragillustrated" ></a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script></div><div class='dd_button'><iframe src='https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fdragillustrated.com%2Fking-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous%2F&amp;locale=en_US&amp;layout=standard&amp;action=like&amp;width=350&amp;height=24&amp;colorscheme=light' scrolling='no' frameborder='0' style='border:none; overflow:hidden; width:500px; height:24px;' allowTransparency='true'></iframe></div></div><div style='clear:both'></div></div><!-- Social Buttons Generated by Digg Digg plugin v5.3.6,
    Author : Buffer, Inc
    Website : http://bufferapp.com/diggdigg --><!-- FB Comments For Wp: http://www.vivacityinfotech.com --><h3 class='coments-title'>Comments</h3><p class='commentcount'><fb:comments-count href="https://dragillustrated.com/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/"></fb:comments-count> comments</p><div class="fb-comments" data-href="https://dragillustrated.com/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/" data-numposts="6" data-width="100%" data-colorscheme="light"></div><div class="g g-16"><div class="g-col b-16 a-421"><a class="gofollow" data-track="NDIxLDE2LDEsNjA=" href="http://www.edelbrock.com/automotive/mc/cylinder-heads/chrysler/performer-rpm-hemi.shtml" target="_blank"><img src="https://i0.wp.com/dragillustrated.com/wp-content/uploads/2017/12/DI-g3-heads-300x300.jpg" /></a></div></div><div class="g g-16"><div class="g-col b-16 a-299"><a class="gofollow" data-track="Mjk5LDE2LDEsNjA=" href="http://www.ultimateconverter.com/racers-using-ultimate-torque-converters" target="_blank"><img src="https://i1.wp.com/dragillustrated.com/wp-content/uploads/2016/07/web-ulaima.jpg" /></a></div></div><div class="g g-16"><div class="g-col b-16 a-423"><a class="gofollow" data-track="NDIzLDE2LDEsNjA=" href="https://kinsler.com/Shop/shop/" target="_blank"><img src="https://i2.wp.com/dragillustrated.com/wp-content/uploads/2018/01/Kinsler_F_I_Web_Ad18.jpg" /></a></div></div><div class="g g-16"><div class="g-col b-16 a-428"><a class="gofollow" data-track="NDI4LDE2LDEsNjA=" href="https://www.weldwheels.com/product-category/weld-racing/" target="_blank"><img src="https://i0.wp.com/dragillustrated.com/wp-content/uploads/2018/02/1-WELD-Drag-Illustrated-Banner-300x300.jpg" /></a></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>																		<div class="post-tags">
							<span class="post-tags-header">Related Items</span>						</div><!--post-tags-->
					</div><!--content-area-->
				</div><!--post-area-->
										<div id="author-wrapper">
						<div id="author-info">
							<img alt='' src='https://secure.gravatar.com/avatar/7ef2bd3121d8ee25ecf7cdcdd67255a1?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7ef2bd3121d8ee25ecf7cdcdd67255a1?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' />							<div id="author-text">
								<span class="author-name"><a href="https://dragillustrated.com/author/nate/" title="Posts by Nate Van Wagnen" rel="author">Nate Van Wagnen</a></span>
								<p></p>
								<ul>
																																																														</ul>
							</div><!--author-text-->
						</div><!--author-info-->
					</div><!--author-wrapper-->
													<div class="prev-next-wrapper">
					<div class="prev-post">
						&larr; Previous Story <a href="https://dragillustrated.com/qa-brittany-force-discusses-recovery-return-to-drivers-seat-after-pomona-crash/" rel="prev">Q&#038;A: Brittany Force Discusses Recovery, Return to Driver&#8217;s Seat After Pomona Crash</a>					</div><!--prev-post-->
					<div class="next-post">
											</div><!--next-post-->
				</div><!--prev-next-wrapper-->
												<div id="comments">
				
	
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><h4 class="post-header"><span class="post-header">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://dragillustrated.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='28883' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>
<noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript>
<noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript>
			</form>
			</div><!-- #respond -->
	
</div><!--comments-->			</div><!--home-main-->
				</div><!--content-main-->
		<div id="sidebar-wrapper">
	<div id="text-26" class="sidebar-widget widget_text">			<div class="textwidget"><div align="center" id="adblock">
<div class="g g-1">
<div class="g-single a-377"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="Mzc3LDEsMSw2MA==" href="http://moroso.com/"><img src="https://i1.wp.com/dragillustrated.com/wp-content/uploads/2017/04/MorosoSq2.jpg" target="_blank" /></a></div>
</div>
</div>
</div>
		</div><div id="ajdg_grpwidgets-3" class="sidebar-widget ajdg_grpwidgets"><ul><li><div class="g g-1"><div class="g-single a-288"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="Mjg4LDEsMSw2MA==" href="http://www.fueltech.net/"><img src="https://i2.wp.com/dragillustrated.com/wp-content/uploads/2017/02/DI-300x300.png" /></a></div></div></li></ul></div><div id="mvp_list_widget-7" class="sidebar-widget mvp_list_widget"><span class="sidebar-widget-header"><h3 class="sidebar-widget-header">Exclusives</h3></span>

					<ul class="home-list">
												<li>
							<a href="https://dragillustrated.com/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/DI-RBPhotography-9_web-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/DI-RBPhotography-9_web-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/DI-RBPhotography-9_web-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/DI-RBPhotography-9_web-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Nate Van Wagnen</span> | February 26, 2018</span>
								<h2>KING OF THE JUNGLE: Tommy Franklin and his &#8216;Jungle Rat&#8217; Rule Pro Nitrous</h2>
								<p>	
		A fresh layer of snow coats the sidewalk as Tommy Franklin walks up to the office occupied by...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/wes-buck-forms-drag-racing-promotion-mastermind-group/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Mastermind-Feature-Image-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Mastermind-Feature-Image-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Mastermind-Feature-Image-150x91.jpg 150w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Mastermind-Feature-Image.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Mastermind-Feature-Image-270x164.jpg 270w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Mastermind-Feature-Image-600x364.jpg 600w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Josh Hachat</span> | February 13, 2018</span>
								<h2>Wes Buck Forms Drag Racing Promotion Mastermind Group</h2>
								<p>	
		Drag Illustrated Editor-In-Chief Wes Buck announced today the formation of “Wes Buck’s Drag Racing Promotion Mastermind,” an exclusive...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/di-return-road-nhra-winternationals/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/20-MattHagan-Sunday-Pomona1-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/20-MattHagan-Sunday-Pomona1-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/20-MattHagan-Sunday-Pomona1-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/20-MattHagan-Sunday-Pomona1-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Josh Hachat</span> | February 12, 2018</span>
								<h2>DI RETURN ROAD: NHRA Winternationals</h2>
								<p>	
		Before the season started, Matt Hagan talked about how it would take some time for all teams, his...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/drag-radial-racers-wetherbee-and-newcome-join-forces-to-reopen-crossville-dragway/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Rick-Wetherbee-and-Michael-Newcome-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Rick-Wetherbee-and-Michael-Newcome-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Rick-Wetherbee-and-Michael-Newcome-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Rick-Wetherbee-and-Michael-Newcome-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Tyler Crossnoe</span> | February 12, 2018</span>
								<h2>Drag Radial Racers Wetherbee and Newcome Join Forces to Reopen Crossville Dragway</h2>
								<p>	
		Drag racing is a huge sport and it’s also an expensive sport. A host of people forget that...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/longtime-dragster-guy-shawn-langdon-embracing-move-to-funny-car/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Langdon-preseason-2018_web-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Langdon-preseason-2018_web-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Langdon-preseason-2018_web-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Langdon-preseason-2018_web-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Josh Hachat</span> | February 8, 2018</span>
								<h2>Longtime &#8216;Dragster Guy&#8217; Shawn Langdon Embracing Move to Funny Car</h2>
								<p>	
		Demanding perfection and struggling to wrap his head around everything that was going on inside a Funny Car...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/anticipation-sky-high-for-longs-lights-out-9/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2015/11/90_Duck-2_JF3-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2015/11/90_Duck-2_JF3-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2015/11/90_Duck-2_JF3-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2015/11/90_Duck-2_JF3-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Josh Hachat</span> | February 7, 2018</span>
								<h2>Anticipation Sky-High for Long&#8217;s Lights Out 9</h2>
								<p>	
		About 3-4 weeks out, Donald “Duck” Long can get a gauge of where the excitement level is for...</p>
							</div><!--home-list-content-->
							</a>
						</li>
											</ul>


		</div><div id="text-27" class="sidebar-widget widget_text">			<div class="textwidget"><div align="center" id="adblock">
<div class="g g-2">
<div class="g-single a-288"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="Mjg4LDIsMSw2MA==" href="http://www.fueltech.net/"><img src="https://i2.wp.com/dragillustrated.com/wp-content/uploads/2017/02/DI-300x300.png" /></a></div>
</div>
</div>
</div>
		</div><div id="mvp_list_widget-8" class="sidebar-widget mvp_list_widget"><span class="sidebar-widget-header"><h3 class="sidebar-widget-header">TECH</h3></span>

					<ul class="home-list">
												<li>
							<a href="https://dragillustrated.com/video-dart-machinerys-new-shp-ls-next-pro-block/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/dart_shp_ls_next_pro_angle_800x600-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/dart_shp_ls_next_pro_angle_800x600-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/dart_shp_ls_next_pro_angle_800x600-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/dart_shp_ls_next_pro_angle_800x600-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Drag Illustrated</span> | February 12, 2018</span>
								<h2>VIDEO: Dart Machinery&#8217;s New SHP LS Next Pro Block</h2>
								<p>	
		Dart Machinery continues the evolution of the LS Next platform by releasing the all-new SHP LS Next PRO...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/gary-and-troy-williams-to-rely-on-vp-racing-fuels/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/09f4013a-f1e0-476b-94d1-5339f52b703b-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/09f4013a-f1e0-476b-94d1-5339f52b703b-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/09f4013a-f1e0-476b-94d1-5339f52b703b-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Drag Illustrated</span> | February 11, 2018</span>
								<h2>Gary and Troy Williams to Rely on VP Racing Fuels</h2>
								<p>	
		VP Racing Fuels announced today that both Gary and Troy Williams will rely on VP fuels for the...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/all-new-precision-ls-series-pt7576-turbocharger-released/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Precision-7675-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Precision-7675-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Precision-7675-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/Precision-7675-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Drag Illustrated</span> | February 6, 2018</span>
								<h2>All-New Precision LS-Series PT7576 Turbocharger Released</h2>
								<p>	
		PRECISION TURBO AND ENGINE is proud to announce the release of its long-awaited LS-Series PT7675 turbocharger.&nbsp;Featuring a 76mm...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/champion-oil-now-available-at-keystone-automotive/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/keystone-automotive-logo-400x242.png" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/keystone-automotive-logo-400x242.png 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/02/keystone-automotive-logo-270x164.png 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Drag Illustrated</span> | February 5, 2018</span>
								<h2>Champion Oil Now Available at Keystone Automotive</h2>
								<p>	
		Keystone Automotive Operations, Inc., based in Exeter, Pennsylvania now offers the complete line of Champion Racing and Performance...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/atis-new-4l85e-street-rod-packages-for-up-to-1500-hp/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/01/slack-imgs.com-2-400x242.jpeg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/01/slack-imgs.com-2-400x242.jpeg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/01/slack-imgs.com-2-660x400.jpeg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/01/slack-imgs.com-2-270x164.jpeg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Drag Illustrated</span> | January 31, 2018</span>
								<h2>ATI&#8217;s New 4L85E Street Rod Packages for up to 1500 HP</h2>
								<p>	
		ATI Performance Racing® Transmissions are well known in the drag racing world for both their reliability and horsepower...</p>
							</div><!--home-list-content-->
							</a>
						</li>
												<li>
							<a href="https://dragillustrated.com/moroso-introduces-rocker-led-switch-panel-with-usb-ports/" rel="bookmark">
							<div class="home-list-img">
																	<img width="400" height="242" src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/01/Moroso-LED-Panel-USB-400x242.jpg" class="attachment-medium-thumb size-medium-thumb wp-post-image" alt="" srcset="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/01/Moroso-LED-Panel-USB-400x242.jpg 400w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/01/Moroso-LED-Panel-USB-660x400.jpg 660w,  https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2018/01/Moroso-LED-Panel-USB-270x164.jpg 270w" sizes="(max-width: 400px) 100vw, 400px" />															</div><!--home-list-img-->
							<div class="home-list-content">
								<span class="widget-info"><span class="widget-author">Drag Illustrated</span> | January 18, 2018</span>
								<h2>Moroso Introduces Rocker LED Switch Panel with USB ports</h2>
								<p>	
		&nbsp; &nbsp; As more racers use Action Cameras to record the in car action of a race, smart...</p>
							</div><!--home-list-content-->
							</a>
						</li>
											</ul>


		</div> 		</div><!--sidebar-wrapper-->					</div><!--content-wrapper-->
</div><!--main-wrapper-->
		<div id="footer-wrapper">
			<div id="footer-top">
			   <div class="ad-rotate-widget-footer"><div class="ad-rotate-widget-widget"><ul><li><div class="g g-7"><div class="g-single a-424"><a class="gofollow" data-track="NDI0LDcsMSw2MA==" href="https://goo.gl/fmuKui" target="_blank"><img src="https://i0.wp.com/dragillustrated.com/wp-content/uploads/2018/02/728x90-SHOCKS.jpg" /></a></div></div></li></ul></div></div><!-- end .ad-rotate-widget --><div id="ad-rotate-footer-bottom"></div>				<div id="footer-nav">
					<div class="menu-about-di-container"><ul id="menu-about-di" class="menu"><li id="menu-item-21282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21282"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/">Subscribe</a></li>
<li id="menu-item-15093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15093"><a href="https://dragillustrated.com/about/">About</a></li>
<li id="menu-item-15089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15089"><a href="https://dragillustrated.com/our-team/">Our Team</a></li>
<li id="menu-item-15091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15091"><a href="https://dragillustrated.com/advertise/">Advertise</a></li>
<li id="menu-item-15090" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15090"><a href="https://dragillustrated.com/contact/">Contact</a></li>
</ul></div>				</div><!--footer-nav-->
								<div id="footer-widget-wrapper">
										<div class="footer-widget">
												<div id="logo-footer">
							<img src="https://dragil-jagrllc.netdna-ssl.com/wp-content/uploads/2014/05/DragIllustratedMediablackRGBSMALL.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
						</div><!--logo-footer-->
												<p>Drag Illustrated is not affiliated with, nor is it bound by any sanctioning body or association. From groundbreaking stories on underground grudge and outlaw racing to in-depth interviews with world-renowned racers and exclusive event coverage, Drag Illustrated shines the spotlight on the hottest stories in drag racing. When drivers, builders, and hardcore fans want the unbiased truth, Drag Illustrated is where they turn.</p>						<div id="footer-social">
							<ul>
																<li class="fb-item">
									<a href="https://www.facebook.com/DragIllustrated/" alt="Facebook" class="fb-but2" target="_blank"></a>
								</li>
																								<li class="twitter-item">
									<a href="https://twitter.com/DragIllustrated" alt="Twitter" class="twitter-but2" target="_blank"></a>
								</li>
																																								<li class="instagram-item">
									<a href="https://www.instagram.com/dragillustrated/" alt="Instagram" class="instagram-but2" target="_blank"></a>
								</li>
																																								<li><a href="https://dragillustrated.com/feed/rss/" alt="RSS Feed" class="rss-but2"></a></li>
															</ul>
						</div><!--footer-social-->
						<div id="copyright">
							<p>Copyright © 2017 Drag Illustrated Media, LLC.</p>
						</div><!--copyright-->
					</div><!--footer-widget-->
															<div class="footer-widget">
						<h3 class="footer-widget-header">Latest News</h3>
						<ul class="home-list">
														<li>
								<a href="https://dragillustrated.com/king-of-the-jungle-tommy-franklin-and-his-jungle-rat-rule-pro-nitrous/" rel="bookmark">
								<div class="home-list-content">
									<h2>KING OF THE JUNGLE: Tommy Franklin and his &#8216;Jungle Rat&#8217; Rule Pro Nitrous</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/c-force-torrence-and-mcgaha-win-nhra-arizona-nationals/" rel="bookmark">
								<div class="home-list-content">
									<h2>C. Force, Torrence and McGaha Win NHRA Arizona Nationals</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/schumacher-c-force-and-kramer-claim-no-1-spots-at-phoenix/" rel="bookmark">
								<div class="home-list-content">
									<h2>Schumacher, C. Force and Kramer Claim No. 1 Spots at Phoenix</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/schumacher-sets-top-fuel-record-joins-beckman-and-laughlin-as-phoenix-friday-leaders/" rel="bookmark">
								<div class="home-list-content">
									<h2>Schumacher Sets Top Fuel Record, Joins Beckman and Laughlin as Phoenix Friday Leaders</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/qa-brittany-force-discusses-recovery-return-to-drivers-seat-after-pomona-crash/" rel="bookmark">
								<div class="home-list-content">
									<h2>Q&#038;A: Brittany Force Discusses Recovery, Return to Driver&#8217;s Seat After Pomona Crash</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/huge-manufacturers-midway-planned-for-nmra-spring-break-shootout/" rel="bookmark">
								<div class="home-list-content">
									<h2>Huge Manufacturer&#8217;s Midway Planned for NMRA Spring Break Shootout</h2>
								</div><!--home-list-content-->
								</a>
							</li>
													</ul>
					</div><!--footer-widget-->
					<div class="footer-widget">
						<h3 class="footer-widget-header">Tags</h3>
						<div class="tag-cloud">
						<a href="https://dragillustrated.com/tag/wes-buck/" class="tag-cloud-link tag-link-1284 tag-link-position-1" style="font-size: 12px;">wes buck</a>
<a href="https://dragillustrated.com/tag/yahoo/" class="tag-cloud-link tag-link-1321 tag-link-position-2" style="font-size: 12px;">yahoo</a>
<a href="https://dragillustrated.com/tag/ian-tocher/" class="tag-cloud-link tag-link-553 tag-link-position-3" style="font-size: 12px;">ian tocher</a>
<a href="https://dragillustrated.com/tag/drag-illistrated/" class="tag-cloud-link tag-link-376 tag-link-position-4" style="font-size: 12px;">drag illistrated</a>
<a href="https://dragillustrated.com/tag/drag-illustrated/" class="tag-cloud-link tag-link-377 tag-link-position-5" style="font-size: 12px;">drag illustrated</a>
<a href="https://dragillustrated.com/tag/dragillistrated/" class="tag-cloud-link tag-link-382 tag-link-position-6" style="font-size: 12px;">dragillistrated</a>
<a href="https://dragillustrated.com/tag/dragillustrated/" class="tag-cloud-link tag-link-383 tag-link-position-7" style="font-size: 12px;">dragillustrated</a>
<a href="https://dragillustrated.com/tag/google/" class="tag-cloud-link tag-link-501 tag-link-position-8" style="font-size: 12px;">google</a>
<a href="https://dragillustrated.com/tag/bing/" class="tag-cloud-link tag-link-163 tag-link-position-9" style="font-size: 12px;">bing</a>
<a href="https://dragillustrated.com/tag/drag-racing/" class="tag-cloud-link tag-link-378 tag-link-position-10" style="font-size: 12px;">drag racing</a>
<a href="https://dragillustrated.com/tag/nhra/" class="tag-cloud-link tag-link-840 tag-link-position-11" style="font-size: 12px;">nhra</a>
<a href="https://dragillustrated.com/tag/nhra-photos/" class="tag-cloud-link tag-link-879 tag-link-position-12" style="font-size: 12px;">nhra photos</a>
<a href="https://dragillustrated.com/tag/pro-stock/" class="tag-cloud-link tag-link-973 tag-link-position-13" style="font-size: 12px;">pro stock</a>
<a href="https://dragillustrated.com/tag/funny-car/" class="tag-cloud-link tag-link-462 tag-link-position-14" style="font-size: 12px;">funny car</a>
<a href="https://dragillustrated.com/tag/top-fuel/" class="tag-cloud-link tag-link-1222 tag-link-position-15" style="font-size: 12px;">top fuel</a>
<a href="https://dragillustrated.com/tag/pro-mod/" class="tag-cloud-link tag-link-968 tag-link-position-16" style="font-size: 12px;">pro mod</a>
<a href="https://dragillustrated.com/tag/pro-modified/" class="tag-cloud-link tag-link-970 tag-link-position-17" style="font-size: 12px;">pro modified</a>
<a href="https://dragillustrated.com/tag/adrl/" class="tag-cloud-link tag-link-55 tag-link-position-18" style="font-size: 12px;">ADRL</a>
<a href="https://dragillustrated.com/tag/john-force/" class="tag-cloud-link tag-link-639 tag-link-position-19" style="font-size: 12px;">john force</a>
<a href="https://dragillustrated.com/tag/don-schumacher/" class="tag-cloud-link tag-link-361 tag-link-position-20" style="font-size: 12px;">don schumacher</a>
<a href="https://dragillustrated.com/tag/jeg-coughlin-jr/" class="tag-cloud-link tag-link-597 tag-link-position-21" style="font-size: 12px;">jeg coughlin jr</a>
<a href="https://dragillustrated.com/tag/courtney-force/" class="tag-cloud-link tag-link-298 tag-link-position-22" style="font-size: 12px;">courtney force</a>
<a href="https://dragillustrated.com/tag/antron-brown/" class="tag-cloud-link tag-link-107 tag-link-position-23" style="font-size: 12px;">antron brown</a>
<a href="https://dragillustrated.com/tag/jack-beckman/" class="tag-cloud-link tag-link-576 tag-link-position-24" style="font-size: 12px;">jack beckman</a>
<a href="https://dragillustrated.com/tag/tony-schumacher/" class="tag-cloud-link tag-link-1217 tag-link-position-25" style="font-size: 12px;">tony schumacher</a>
<a href="https://dragillustrated.com/tag/american-drag-racing-league/" class="tag-cloud-link tag-link-95 tag-link-position-26" style="font-size: 12px;">american drag racing league</a>
<a href="https://dragillustrated.com/tag/erica-enders/" class="tag-cloud-link tag-link-419 tag-link-position-27" style="font-size: 12px;">erica enders</a>
<a href="https://dragillustrated.com/tag/allen-johnson/" class="tag-cloud-link tag-link-88 tag-link-position-28" style="font-size: 12px;">allen johnson</a>
<a href="https://dragillustrated.com/tag/greg-anderson/" class="tag-cloud-link tag-link-505 tag-link-position-29" style="font-size: 12px;">greg anderson</a>
<a href="https://dragillustrated.com/tag/spencer-massey/" class="tag-cloud-link tag-link-1119 tag-link-position-30" style="font-size: 12px;">spencer massey</a>						</div>
					</div><!--footer-widget-->
					 									</div><!--footer-widget-wrapper-->
			</div><!--footer-top-->
		</div><!--footer-wrapper-->
	</div><!--body-wrapper-->
</div><!--site-->

<!-- ngg_resource_manager_marker --><script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/dragillustrated.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"https:\/\/dragillustrated.com\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/dragillustrated.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"https:\/\/dragillustrated.com\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"https:\/\/dragillustrated.com\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_ccfa0b2ec94b01644b6860fba0d2d074","fragment_name":"wc_fragments_ccfa0b2ec94b01644b6860fba0d2d074"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */

var nextgen_lightbox_settings = {"static_path":"https:\/\/dragillustrated.com\/wp-content\/plugins\/nextgen-gallery\/products\/photocrati_nextgen\/modules\/lightbox\/static","context":"all_images_direct"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_gallery_display/static/common.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */

var nextgen_thickbox_i18n = {"next":"Next &gt;","prev":"&lt; Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them."};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/lightbox_context.min.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/thickbox/nextgen_thickbox_init.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/dragillustrated.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/thickbox/thickbox.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/braxton/js/jquery.iosslider.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/braxton/js/scripts.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/braxton/js/respond.min.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/braxton/js/retina.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/wp-spamshield/js/jscripts-ftr-min.js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/wp-embed.min.js'></script>
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=297668800418060&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='e27f391e81d02ac2dbdcc5e844e1b523';
hf4V='b9c933c36ea8b503d2bd2c8d375cbe17';
cm4S="form[action='https://dragillustrated.com/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form, .wpcf7-form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(e);return true;});$("#comment").attr({minlength:"15",maxlength:"15360"})});
/* ]]> */
</script> 
		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		
<script type="text/javascript">
jQuery(document).ready(function($) {

	// Main Menu Dropdown Toggle
	$('.menu-item-has-children a').click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$('.menu-item-has-children').click(function(){
    	  $(this).addClass('toggled');
    	  if($('.menu-item-has-children').hasClass('toggled'))
    	  {
    	  $(this).children('ul').toggle();
	  $('.fly-nav-menu').getNiceScroll().resize();
	  }
	  $(this).toggleClass('tog-minus');
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});

});
</script>


<script type='text/javascript'> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script><div style="display: none;"><a href="http://inoplugs.com">WP-Backgrounds Lite by InoPlugs Web Design</a> and <a href="http://schoenmann.at/">Juwelier Sch&ouml;nmann 1010 Wien</a></div><!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
}});
</script>
<!-- /AdRotate JS -->

<script type='text/javascript' src='https://stats.wp.com/e-201809.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.8',blog:'37035244',post:'28883',tz:'-6',srv:'dragillustrated.com'} ]);
	_stq.push([ 'clickTrackerInit', '37035244', '28883' ]);
</script>

</body>
</html>