<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script>window._wca = window._wca || [];</script>

<title>Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023 - Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</title>
<link rel="canonical" href="https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023" />
<meta property="og:description" content="JEGS, a leading online national retailer and distributor of high-performance aftermarket auto parts and accessories, is continuing its sponsorship of Elite Motorsports in 2023. This sponsor partnership includes acting as [&hellip;]" />
<meta property="og:url" content="https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/" />
<meta property="og:site_name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
<meta property="article:publisher" content="https://www.facebook.com/dragillustrated" />
<meta property="article:published_time" content="2022-12-14T17:56:06+00:00" />
<meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr.jpg" />
<meta property="og:image:width" content="1600" />
<meta property="og:image:height" content="900" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="Drag Illustrated" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@dragillustrated" />
<meta name="twitter:site" content="@dragillustrated" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Drag Illustrated" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Feed" href="https://dragillustrated.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Comments Feed" href="https://dragillustrated.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; iCal Feed" href="https://dragillustrated.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023 Comments Feed" href="https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/feed/" />

<script src="//www.googletagmanager.com/gtag/js?id=UA-21052018-1" data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>

<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/dragillustrated.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=81582bdb254a94e4464424087c6479a8"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(p&&p.fillText)switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<script id="dragi-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wc-blocks-integration-css' href='https://dragillustrated.com/wp-content/plugins/woocommerce-subscriptions/vendor/woocommerce/subscriptions-core/build/index.css?ver=4.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://dragillustrated.com/wp-includes/css/dist/block-library/style.min.css?ver=81582bdb254a94e4464424087c6479a8' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://dragillustrated.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.17' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://dragillustrated.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=81582bdb254a94e4464424087c6479a8' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css' href='https://dragillustrated.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-vendors-style.css?ver=8.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css' href='https://dragillustrated.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-style.css?ver=8.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='classic-theme-styles-css' href='https://dragillustrated.com/wp-includes/css/classic-themes.min.css?ver=1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='dashicons-css' href='https://dragillustrated.com/wp-includes/css/dashicons.min.css?ver=81582bdb254a94e4464424087c6479a8' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css' href='https://dragillustrated.com/wp-includes/js/thickbox/thickbox.css?ver=81582bdb254a94e4464424087c6479a8' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome_v4_shim_style-css' href='https://use.fontawesome.com/releases/v5.3.1/css/v4-shims.css?ver=81582bdb254a94e4464424087c6479a8' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://use.fontawesome.com/releases/v5.3.1/css/all.css?ver=81582bdb254a94e4464424087c6479a8' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-css' href='https://dragillustrated.com/wp-content/plugins/theia-post-slider/css/buttons-red.css?ver=1.15.1' type='text/css' media='all' />
<link rel='stylesheet' id='ql-jquery-ui-css' href='//ajax.googleapis.com/ajax/libs/jqueryui/1.12.1/themes/smoothness/jquery-ui.css?ver=81582bdb254a94e4464424087c6479a8' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-photoswipe-css' href='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/css/photoswipe.css?ver=3.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-public-css' href='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/css/reviewer-public.css?ver=3.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='zox-custom-style-css' href='https://dragillustrated.com/wp-content/themes/zoxpress/style.css?ver=81582bdb254a94e4464424087c6479a8' type='text/css' media='all' />
<style id='zox-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='fontawesome-child-css' href='https://use.fontawesome.com/releases/v5.5.0/css/all.css?ver=81582bdb254a94e4464424087c6479a8' type='text/css' media='all' />
<link rel='stylesheet' id='zox-custom-child-style-css' href='https://dragillustrated.com/wp-content/themes/zoxpress-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='zox-fonts-css' href='//fonts.googleapis.com/css?family=Heebo%3A300%2C400%2C500%2C700%2C800%2C900%7CAlegreya%3A400%2C500%2C700%2C800%2C900%7CJosefin+Sans%3A300%2C400%2C600%2C700%7CLibre+Franklin%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CFrank+Ruhl+Libre%3A300%2C400%2C500%2C700%2C900%7CNunito+Sans%3A300%2C400%2C600%2C700%2C800%2C900%7CMontserrat%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CAnton%3A400%7CNoto+Serif%3A400%2C700%7CNunito%3A300%2C400%2C600%2C700%2C800%2C900%7CRajdhani%3A300%2C400%2C500%2C600%2C700%7CTitillium+Web%3A300%2C400%2C600%2C700%2C900%7CPT+Serif%3A400%2C400i%2C700%2C700i%7CAmiri%3A400%2C400i%2C700%2C700i%7COswald%3A300%2C400%2C500%2C600%2C700%7CRoboto+Mono%3A400%2C700%7CBarlow+Semi+Condensed%3A700%2C800%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto+Condensed%3A300%2C400%2C700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7CPT+Serif%3A400%2C700%7COpen+Sans+Condensed%3A300%2C700%7COpen+Sans%3A700%7CSource+Serif+Pro%3A400%2C600%2C700%7CIM+Fell+French+Canon%3A400%2C400i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' type='text/css' media='all' />
<link rel='stylesheet' id='zox-media-queries-css' href='https://dragillustrated.com/wp-content/themes/zoxpress/css/media-queries.css?ver=81582bdb254a94e4464424087c6479a8' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://dragillustrated.com/wp-content/tablepress-combined.min.css?ver=41' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css' href='https://dragillustrated.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=14.1.4.1' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel='stylesheet' id='jetpack_css-css' href='https://dragillustrated.com/wp-content/plugins/jetpack/css/jetpack.css?ver=11.6' type='text/css' media='all' />
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/exactmetrics-premium/assets/js/frontend-gtag.min.js?ver=7.10.1' id='exactmetrics-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='exactmetrics-frontend-script-js-extra'>/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/dragillustrated.com","hash_tracking":"false","ua":"UA-21052018-1","v4_id":""};/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='photocrati_ajax-js-extra'>
/* <![CDATA[ */
var photocrati_ajax = {"url":"https:\/\/dragillustrated.com\/index.php?photocrati_ajax=1","wp_home_url":"https:\/\/dragillustrated.com","wp_site_url":"https:\/\/dragillustrated.com","wp_root_url":"https:\/\/dragillustrated.com","wp_plugins_url":"https:\/\/dragillustrated.com\/wp-content\/plugins","wp_content_url":"https:\/\/dragillustrated.com\/wp-content","wp_includes_url":"https:\/\/dragillustrated.com\/wp-includes\/","ngg_param_slug":"nggallery"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/ajax/static/ajax.min.js?ver=3.30' id='photocrati_ajax-js'></script>
<script type='text/javascript' src='https://use.fontawesome.com/releases/v5.3.1/js/v4-shims.js?ver=5.3.1' id='fontawesome_v4_shim-js'></script>
<script type='text/javascript' defer integrity="sha384-kW+oWsYx3YpxvjtZjFXqazFpA7UP/MbiY4jvs+RWZo2+N94PFZ36T6TFkc9O3qoB" crossorigin="anonymous" data-auto-replace-svg="false" data-keep-original-source="false" data-search-pseudo-elements src='https://use.fontawesome.com/releases/v5.3.1/js/all.js?ver=5.3.1' id='fontawesome-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/balupton-history.js/jquery.history.js?ver=1.7.1' id='history.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/async.min.js?ver=14.09.2014' id='async.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/tps.js?ver=1.15.1' id='theiaPostSlider/theiaPostSlider.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/main.js?ver=1.15.1' id='theiaPostSlider/main.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/tps-transition-slide.js?ver=1.15.1' id='theiaPostSlider/transition.js-js'></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.37.2' id='advanced-ads-advanced-js-js'></script>
<script defer type='text/javascript' src='https://stats.wp.com/s-202250.js' id='woocommerce-analytics-js'></script>
<script type='text/javascript' id='__ytprefs__-js-extra'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","security":"ce9414938d","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/dragillustrated.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"https:\/\/dragillustrated.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"14.1.4.1","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","pause_others":"","stopMobileBuffer":"1","facade_mode":"","not_live_on_channel":"","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=14.1.4.1' id='__ytprefs__-js'></script>
<link rel="https://api.w.org/" href="https://dragillustrated.com/wp-json/" /><link rel="alternate" type="application/json" href="https://dragillustrated.com/wp-json/wp/v2/posts/55925" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dragillustrated.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Ftroy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Ftroy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023%2F&#038;format=xml" />
<script type="text/javascript" src="https://paywall.subscriptiongenius.com/load.js"></script>


<script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window, document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init', '634980329980573');fbq('track', 'PageView');</script><noscript><img height="1" width="1" style="display:none"src="https://www.facebook.com/tr?id=634980329980573&ev=PageView&noscript=1"/></noscript>


<style type="text/css">
			.wpsdc-drop-cap {
				float : left;				
				padding : 0.25em 0.05em 0.25em 0;				
				font-size : 5em;
				line-height : 0.4em;color : #0a0a0a;}
		</style> <meta name="theme-color" content="#000" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-1024x576.jpg" />
<meta name="twitter:image" content="https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-1024x576.jpg" />
<meta property="og:url" content="https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/" />
<meta property="og:title" content="Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023" />
<meta property="og:description" content="JEGS, a leading online national retailer and distributor of high-performance aftermarket auto parts and accessories, is continuing its sponsorship of Elite Motorsports in 2023. This sponsor partnership includes acting as [&hellip;]" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:url" content="https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/">
<meta name="twitter:title" content="Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023">
<meta name="twitter:description" content="JEGS, a leading online national retailer and distributor of high-performance aftermarket auto parts and accessories, is continuing its sponsorship of Elite Motorsports in 2023. This sponsor partnership includes acting as [&hellip;]">
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://dragillustrated.com"><link rel="alternate" href="https://dragillustrated.com/wp-json/tribe/events/v1/" /> <style>img#wpstats{display:none}</style>
<script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
<link rel="pingback" href="https://dragillustrated.com/xmlrpc.php"> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
<link rel="icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-180x180.png" />
<meta name="msapplication-TileImage" content="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-270x270.png" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-55925 single-format-standard custom-background wp-embed-responsive theme-zoxpress theiaPostSlider_body woocommerce-no-js tribe-no-js page-template-zoxpress-child zox-sport2 zox-s6 elementor-default elementor-kit-42099 aa-prefix-dragi- aa-disabled-bots">
<div id="zox-site" class="left zoxrel ">
<div id="zox-fly-wrap">
<div id="zox-fly-menu-top" class="left relative">
<div id="zox-fly-logo" class="left relative">
<a href="https://dragillustrated.com/"><img src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
</div>
<div class="zox-fly-but-wrap zox-fly-but-menu zox-fly-but-click">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</div>
<div id="zox-fly-menu-wrap">
<nav class="zox-fly-nav-menu left relative">
<div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-49701" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49701"><a href="https://dragillustrated.com/category/news/">News</a></li>
<li id="menu-item-49702" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49702"><a href="https://dragillustrated.com/category/race-coverage/">Race Coverage</a></li>
<li id="menu-item-49703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49703"><a href="https://dragillustrated.com/category/tech/">Tech</a></li>
<li id="menu-item-52430" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52430"><a href="https://dragillustrated.com/category/thewesbuckshow/">The Wes Buck Show</a></li>
<li id="menu-item-15094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" rel="noopener" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li id="menu-item-15102" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
<li id="menu-item-55204" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55204"><a href="https://dragillustrated.com/contests/">Contests</a></li>
<li id="menu-item-53657" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-53657"><a href="https://dragillustrated.com/top-8/">Top 8</a></li>
</ul></div> </nav>
</div>
<div id="zox-fly-soc-wrap">
<span class="zox-fly-soc-head">Connect with us</span>
<ul class="zox-fly-soc-list left relative">
<li><a href="https://www.facebook.com/DragIllustrated" target="_blank" class="fab fa-facebook-f"></a></li>
<li><a href="https://twitter.com/DragIllustrated" target="_blank" class="fab fa-twitter"></a></li>
<li><a href="https://www.instagram.com/dragillustrated" target="_blank" class="fab fa-instagram"></a></li>
<li><a href="https://bit.ly/3y2ogFR" target="_blank" class="fab fa-youtube"></a></li>
</ul>
</div>
</div> <div id="zox-search-wrap">
<div class="zox-search-cont">
<p class="zox-search-p">Hi, what are you looking for?</p>
<div class="zox-search-box">
<form method="get" id="zox-search-form" action="https://dragillustrated.com/">
<input type="text" name="s" id="zox-search-input" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "Search") { this.value = ""; }' />
<input type="submit" id="zox-search-submit" value="Search" />
</form> </div>
</div>
<div class="zox-search-but-wrap zox-search-click">
<span></span>
<span></span>
</div>
</div>
<div id="zox-site-wall" class="left zoxrel">
<div id="zox-lead-top-wrap">
<div id="zox-lead-top-in">
<div id="zox-lead-top">
</div>
</div>
</div>
<div id="zox-site-main" class="left zoxrel">
<header id="zox-main-head-wrap" class="left zoxrel zox-trans-head">
<div id="zox-bot-head-wrap" class="left zoxrel">
<div class="zox-head-width">
<div id="zox-bot-head">
<div id="zox-bot-head-left">
<div class="zox-fly-but-wrap zoxrel zox-fly-but-click">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</div>
<div id="zox-bot-head-mid" class="relative">
<div class="zox-bot-head-logo">
<div class="zox-bot-head-logo-main">
<a href="https://dragillustrated.com/"><img class="zox-logo-stand" src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /><img class="zox-logo-dark" src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
</div>
<h2 class="zox-logo-title">Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</h2>
</div>
<div class="zox-bot-head-menu">
<div class="zox-nav-menu">
<div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49701 zox-mega-drop"><a href="https://dragillustrated.com/category/news/">News</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023</p></a></li><li><a href="https://dragillustrated.com/kalitta-motorsports-dhl-donate-750000-meals-to-feeding-america-with-drive-for-purpose-challenge/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Kalitta Motorsports, DHL Donate 750,000 Meals to Feeding America with Drive For Purpose Challenge</p></a></li><li><a href="https://dragillustrated.com/mark-tydo-werdehausen-to-race-in-memory-of-tim-slavens-at-wsopm/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Mark-Werdehausen_NVW-photo-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Mark-Werdehausen_NVW-photo-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Mark-Werdehausen_NVW-photo-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Mark-Werdehausen_NVW-photo-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Mark-Werdehausen_NVW-photo-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Mark-Werdehausen_NVW-photo-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Mark-Werdehausen_NVW-photo-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Mark-Werdehausen_NVW-photo.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Mark ‘Tydo’ Werdehausen to Race in Memory of Tim Slavens at WSOPM</p></a></li><li><a href="https://dragillustrated.com/mahle-motorsport-introduces-new-small-block-chevy-dish-powerpak-piston-set-with-a-lighter-stronger-forging-design/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/12/SBC-Dish-New-Forging-Design_Web-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/12/SBC-Dish-New-Forging-Design_Web-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/12/SBC-Dish-New-Forging-Design_Web-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/12/SBC-Dish-New-Forging-Design_Web-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/12/SBC-Dish-New-Forging-Design_Web-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/12/SBC-Dish-New-Forging-Design_Web-1536x865.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/12/SBC-Dish-New-Forging-Design_Web-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/12/SBC-Dish-New-Forging-Design_Web.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>MAHLE Motorsport Introduces New Small Block Chevy Dish PowerPak Piston Set with a Lighter, Stronger Forging Design</p></a></li><li><a href="https://dragillustrated.com/travis-the-carolina-kid-harvey-on-wsopm-just-getting-in-felt-like-winning/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Travis-Harvey_Chris-Sears-photo-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Travis-Harvey_Chris-Sears-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Travis-Harvey_Chris-Sears-photo-1320x742.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Travis-Harvey_Chris-Sears-photo-1000x562.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Travis-Harvey_Chris-Sears-photo-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Travis-Harvey_Chris-Sears-photo-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Travis-Harvey_Chris-Sears-photo-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/12/WSOPM_Travis-Harvey_Chris-Sears-photo.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Travis ‘The Carolina Kid’ Harvey on WSOPM: ‘Just Getting in Felt Like Winning’</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49702 zox-mega-drop"><a href="https://dragillustrated.com/category/race-coverage/">Race Coverage</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/kalitta-motorsports-dhl-donate-750000-meals-to-feeding-america-with-drive-for-purpose-challenge/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/12/Team-Kalitta-and-DHL-Donation_web.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Kalitta Motorsports, DHL Donate 750,000 Meals to Feeding America with Drive For Purpose Challenge</p></a></li><li><a href="https://dragillustrated.com/texas-motorplex-releases-2023-schedule/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/Austin-Prock-motorplex-2022-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/Austin-Prock-motorplex-2022-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/Austin-Prock-motorplex-2022-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/10/Austin-Prock-motorplex-2022-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/10/Austin-Prock-motorplex-2022-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/10/Austin-Prock-motorplex-2022-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/10/Austin-Prock-motorplex-2022-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/10/Austin-Prock-motorplex-2022.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Texas Motorplex Releases 2023 Schedule</p></a></li><li><a href="https://dragillustrated.com/john-force-racing-chevrolet-extend-storied-partnership/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/12/2022_John_Force_Action_Web-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/12/2022_John_Force_Action_Web-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/12/2022_John_Force_Action_Web-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/12/2022_John_Force_Action_Web-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/12/2022_John_Force_Action_Web-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/12/2022_John_Force_Action_Web-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/12/2022_John_Force_Action_Web-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/12/2022_John_Force_Action_Web.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>John Force Racing, Chevrolet Extend Storied Partnership</p></a></li><li><a href="https://dragillustrated.com/buddy-hull-announces-new-partnership-with-methanol-moonshine/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/12/318135327_679366260351275_2344717325504393809_n-1-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/12/318135327_679366260351275_2344717325504393809_n-1-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/12/318135327_679366260351275_2344717325504393809_n-1-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Buddy Hull Announces New Partnership with Methanol Moonshine</p></a></li><li><a href="https://dragillustrated.com/sportsman-driver-jerry-tucker-to-join-elite-pro-stock-team/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/12/unnamed-56-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" /></div><p>Sportsman Driver Jerry Tucker to Join Elite Pro Stock Team</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49703 zox-mega-drop"><a href="https://dragillustrated.com/category/tech/">Tech</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/rc-now-offers-gdi-gasoline-direct-injection-blueprinting/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/11/RC-Direct-Injectors-1-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/11/RC-Direct-Injectors-1-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/11/RC-Direct-Injectors-1-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>RC Now Offers GDI (Gasoline Direct Injection) Blueprinting</p></a></li><li><a href="https://dragillustrated.com/system-1-expands-oil-filter-offerings/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/11/System-1-filters_1600x900-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/11/System-1-filters_1600x900-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/11/System-1-filters_1600x900-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/11/System-1-filters_1600x900-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/11/System-1-filters_1600x900-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/11/System-1-filters_1600x900-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/11/System-1-filters_1600x900-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/11/System-1-filters_1600x900.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>System 1 Expands Oil Filter Offerings</p></a></li><li><a href="https://dragillustrated.com/drag-illustrated-partners-with-simpson-race-products-for-new-giveaway/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/11/Simpson_Bag-Formula-Bag_web-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/11/Simpson_Bag-Formula-Bag_web-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/11/Simpson_Bag-Formula-Bag_web-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Drag Illustrated Partners With Simpson Race Products for New Giveaway</p></a></li><li><a href="https://dragillustrated.com/sonnax-introduces-game-changing-new-th400-drum-upgrade/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/B1BB06E7-F2FB-4656-9EC8-3FD0DEFFFE4B-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/B1BB06E7-F2FB-4656-9EC8-3FD0DEFFFE4B-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/B1BB06E7-F2FB-4656-9EC8-3FD0DEFFFE4B-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/10/B1BB06E7-F2FB-4656-9EC8-3FD0DEFFFE4B-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/10/B1BB06E7-F2FB-4656-9EC8-3FD0DEFFFE4B-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/10/B1BB06E7-F2FB-4656-9EC8-3FD0DEFFFE4B-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/10/B1BB06E7-F2FB-4656-9EC8-3FD0DEFFFE4B-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/10/B1BB06E7-F2FB-4656-9EC8-3FD0DEFFFE4B.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Sonnax Introduces Game-Changing New TH400 Drum Upgrade</p></a></li><li><a href="https://dragillustrated.com/nhra-crew-chief-dave-connolly-race-promoter-jennifer-folk-purchase-competitive-suspension/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/Folk-Connolly_Competition-Suspension-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/Folk-Connolly_Competition-Suspension-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/Folk-Connolly_Competition-Suspension-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>NHRA Crew Chief Dave Connolly, Race Promoter Jennifer Folk Purchase Competitive Suspension</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52430 zox-mega-drop"><a href="https://dragillustrated.com/category/thewesbuckshow/">The Wes Buck Show</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/wbs-champ-talk-erica-enders-brittany-force-talk-shop-plus-angie-smith/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283-4-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283-4-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283-4-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283-4-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283-4-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283-4.jpg 1280w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>WBS: CHAMP TALK: Erica Enders &#038; Brittany Force Talk Shop! Plus Angie Smith</p></a></li><li><a href="https://dragillustrated.com/wbs-champ-talk-ron-capps-matt-smith-plus-angie-smith-wsopm-driver-reveal/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283.jpg 1280w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>WBS: CHAMP TALK: Ron Capps, Matt Smith, Plus Angie Smith &#038; WSOPM Driver Reveal</p></a></li><li><a href="https://dragillustrated.com/wbs-dr-jamie-meyer-melanie-salemi-ryan-mccain/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-282-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-282-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-282-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-282-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-282-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-282.jpg 1280w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>WBS: Dr. Jamie Meyer, Melanie Salemi &#038; Ryan McCain</p></a></li><li><a href="https://dragillustrated.com/wbs-major-announcement-plus-mark-micke-tommy-franklin-victor-alvarez/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-281-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-281-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-281-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-281-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-281-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-281.jpg 1280w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>WBS: Major Announcement, Plus Mark Micke, Tommy Franklin &#038; Victor Alvarez</p></a></li><li><a href="https://dragillustrated.com/wbs-tony-stewart-top-alcohol-debut-enders-potential-for-5th-pro-stock-title-npk-dallas-more/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-280-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-280-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-280-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-280-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-280-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-280.jpg 1280w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>WBS: Tony Stewart Top Alcohol Debut, Enders Potential for 5th Pro Stock Title, NPK Dallas &#038; More!</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" rel="noopener" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55204"><a href="https://dragillustrated.com/contests/">Contests</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-53657"><a href="https://dragillustrated.com/top-8/">Top 8</a></li>
</ul></div> </div>
</div>
</div>
<div id="zox-bot-head-right">
<span class="zox-night zox-night-mode fas fa-moon"></span>
<span class="zox-nav-search-but fas fa-search zox-search-click"></span>
</div>
</div>
</div>
</div> </header>
<div id="zox-site-grid">
<div id="zox-site-wall-small">
<div id="zox-lead-bot">
<div class="dragi-669cb6bf90a79373794d2d66ca56b477" id="dragi-669cb6bf90a79373794d2d66ca56b477"></div> </div>
<div id="zox-main-body-wrap" class="left relative"> <article id="post-55925" class="post-55925 post type-post status-publish format-standard has-post-thumbnail hentry category-news" itemscope itemtype="http://schema.org/NewsArticle">
<div class="zox-article-wrap zoxrel left zox100">
<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/" />
<div class="zox-post-top-wrap zoxrel left zox100">
<div class="zox-post-title-wrap zox-tit2">
<div class="zox-post-width">
<header class="zox-post-head-wrap left zoxrel zox100">
<div class="zox-post-head zoxrel">
<h3 class="zox-post-cat">
<a class="zox-post-cat-link" href="https://dragillustrated.com/category/news/"><span class="zox-post-cat">News</span></a>
</h3>
<h1 class="zox-post-title left entry-title" itemprop="headline">Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023</h1>
<div class="zox-post-info-wrap">
<div class="zox-post-byline-wrap">
<div class="zox-author-thumb">
<img alt='' src='https://secure.gravatar.com/avatar/19114ff647afcd14a1c84568b6be9a46?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/19114ff647afcd14a1c84568b6be9a46?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy' decoding='async' /> </div>
<div class="zox-author-info-wrap">
<div class="zox-author-name-wrap" itemprop="author" itemscope itemtype="https://schema.org/Person">
<p>By</p><span class="zox-author-name vcard fn author" itemprop="name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span>
</div>
<div class="zox-post-date-wrap">
<p>Published</p> <span class="zox-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-12-14">53 seconds ago</time></span>
<meta itemprop="dateModified" content="2022-12-14" />
</div>
</div>
</div>
<div class="zox-post-soc-top-wrap">
<div class="zox-post-soc-stat">
<ul class="zox-post-soc-stat-list left zoxrel">
<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/&amp;t=Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="zox-post-soc-fb">
<i class="fab fa-facebook-f"></i>
</li>
</a>
<a href="#" onclick="window.open('https://twitter.com/share?text=Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023 -&amp;url=https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="zox-post-soc-twit">
<i class="fab fa-twitter"></i>
</li>
</a>
<li class="zox-post-soc-copy">
<i class="fas fa-link"></i>
</li>
<li class="zox-post-soc-more zox-soc-stat-click-55925">
<i class="fas fa-ellipsis-h"></i>
<div class="zox-soc-more-stat zox-more-click-55925">
<ul class="zox-soc-more-list">
<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023&url=https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
<li class="zox-post-soc-flip">
<p>Flipboard</p>
<i class="fab fa-flipboard"></i>
</li>
</a>
<a href="#" onclick="window.open('https://www.reddit.com/submit?url=https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/&title=Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023', 'redditShare', 'width=626,height=436'); return false;" title="Share on Reddit">
<li class="zox-post-soc-redd">
<p>Reddit</p>
<i class="fab fa-reddit-alien"></i>
</li>
</a>
<a href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/&amp;media=https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr.jpg&amp;description=Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<li class="zox-post-soc-pin">
<p>Pinterest</p>
<i class="fab fa-pinterest-p" aria-hidden="true"></i>
</li>
</a>
<a class="zox-whats-main" href="https://web.whatsapp.com/send?text=Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023 https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a class="zox-whats-mob" href="whatsapp://send?text=Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023 https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a href="/cdn-cgi/l/email-protection#7e410d0b1c141b1d0a432a0c11075e3d110b19161217105e340c505e291712125e31101d1b5e3f191f17105e2e1712110a5e343b392d5e2e0c115e2d0a111d151b0c5e18110c5e3b12170a1b5e33110a110c0d0e110c0a0d5e17105e4c4e4c4d581f130e453c313a2743375e18110b101a5e0a16170d5e1f0c0a171d121b5e17100a1b0c1b0d0a1710195e1f101a5e0a16110b19160a5e11185e0d161f0c1710195e170a5e09170a165e07110b505e3d161b1d155e170a5e110b0a445e160a0a0e0d4451511a0c1f191712120b0d0a0c1f0a1b1a501d1113510a0c1107531d110b191612171053140c53091712125311101d1b531f191f1710530e1712110a53141b190d530e0c11530d0a111d151b0c5318110c531b12170a1b5313110a110c0d0e110c0a0d531710534c4e4c4d51">
<li class="zox-post-soc-email">
<p>Email</p>
<i class="fas fa-envelope"></i>
</li>
</a>
</ul>
</div>
</li>
</ul>
</div>
</div>
</div>
</div>
</header> </div>
</div>
</div>
<div class="zox-post-main-grid">
<div class="zox-post-width">
<div class="zox-post-main-wrap zoxrel left zox100">
<div class="zox-post-main">
<div class="zox-post-bot-wrap">
<div class="zox-post-img-wrap">
<div class="zox-post-img left zoxrel zoxlh0" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
<img width="1600" height="900" src="https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr.jpg" class="flipboard-image wp-post-image" alt="" decoding="async" srcset="https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr.jpg 1600w, https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr-600x338.jpg 600w" sizes="(max-width: 1600px) 100vw, 1600px" /> <meta itemprop="url" content="https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr.jpg">
<meta itemprop="width" content="1600">
<meta itemprop="height" content="900">
</div>
<span class="zox-post-img-cap"></span>
</div>
</div>
<div class="zox-post-body-wrap left zoxrel">
<div class="zox-post-body left zoxrel zox100">
<div id="tps_slideContainer_55925" class="theiaPostSlider_slides"><div class="theiaPostSlider_preloadedSlide">
<p>
<p align="left">JEGS, a leading online national retailer and distributor of high-performance aftermarket auto parts and accessories, is continuing its sponsorship of Elite Motorsports in 2023. This sponsor partnership includes acting as the primary sponsor for Pro Stock up-and-comer Troy Coughlin Jr.&nbsp;
<p align="left">Elite Motorsports is the largest professional team in the NHRA with eight Pro Stock cars slated to compete in the 2023 NHRA Camping World Drag Racing Series season. JEGS has a longstanding relationship with Elite Motorsports and NHRA drag racing. When it was sold in early 2022, the new ownership group, Greenbriar, quickly recognized the valuable and powerful brand recognition the company receives through this sponsorship affiliation.
<p align="left">“Drag racing has been paramount to JEGS’ success since the beginning,” said Ralph Mondeaux, Vice President of Marketing for JEGS. “We want to continue to build on the powerful relationship that JEGS has with drag racers and fans as we enter a new era. It’s this connection to drag racing that allows our brand to thrive. We appreciate all of the loyal customers we’ve developed through drag racing over the years and want to demonstrate that appreciation in a tangible way by supporting the sport that made all of this possible.”
<p align="left">The Elite Motorsports Pro Stock team is thrilled to have JEGS on board and looks forward to a stellar season with the reputable brand on board.
<p align="left">“JEGS has been an outstanding partner for Elite Motorsports,” said Richard Freeman, owner of Elite Motorsports. “We appreciate everything they contribute to our team as a whole, especially their sponsorship of Troy Coughlin Jr. He’s a great driver and we feel confident that he will continue to be a leader in Pro Stock with JEGS on his car in 2023.”
<p align="left">Coming off of his best-performing season in Pro Stock with two national event wins to his credit, Coughlin feels he has a bright future ahead of him, especially knowing that JEGS will continue to sponsor him in his pursuit of excellence in one of the most competitive categories in drag racing.
<p align="left">“I’m absolutely honored to carry on the tradition of representing one of the industry’s most beloved brands,” said Coughlin. “I love JEGS with all my heart and getting to wear the logo and represent the wonderful people who are a part of it has always been my dream. I’m going to give everything I have behind the wheel. Major thank you to the entire JEGS team for supporting us.”
<p align="left">The Elite Motorsports Pro Stock team will take to the track for the 2023 NHRA Camping World Drag Racing Series season opener, the Amalie Motor Oil NHRA Gatornationals, March 9-12, 2023 in Gainesville, Fla.<div class="zox-post-ad-wrap"><span class="zox-ad-label">Advertisement. Scroll to continue reading.</span><div class="zox-post-ad"><div class="zox-post-ad-in1"><div class="zox-post-ad-in2"><div class="dragi-a9c6af8562b49a0a76e90bd61445cda0" id="dragi-a9c6af8562b49a0a76e90bd61445cda0"></div></div></div></div></div>
<p>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>
</div></div><div class="theiaPostSlider_footer _footer"></div><div data-theiaPostSlider-sliderOptions='{&quot;slideContainer&quot;:&quot;#tps_slideContainer_55925&quot;,&quot;nav&quot;:[&quot;.theiaPostSlider_nav&quot;],&quot;navText&quot;:&quot;%{currentSlide} of %{totalSlides}&quot;,&quot;helperText&quot;:&quot;Use your \u2190 \u2192 (arrow) keys to browse&quot;,&quot;defaultSlide&quot;:0,&quot;transitionEffect&quot;:&quot;slide&quot;,&quot;transitionSpeed&quot;:400,&quot;keyboardShortcuts&quot;:true,&quot;scrollAfterRefresh&quot;:true,&quot;numberOfSlides&quot;:1,&quot;slides&quot;:[],&quot;useSlideSources&quot;:null,&quot;themeType&quot;:&quot;classic&quot;,&quot;prevText&quot;:&quot;Prev&quot;,&quot;nextText&quot;:&quot;Next&quot;,&quot;buttonWidth&quot;:0,&quot;buttonWidth_post&quot;:0,&quot;postUrl&quot;:&quot;https:\/\/dragillustrated.com\/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023\/&quot;,&quot;postId&quot;:55925,&quot;refreshAds&quot;:false,&quot;refreshAdsEveryNSlides&quot;:1,&quot;adRefreshingMechanism&quot;:&quot;javascript&quot;,&quot;ajaxUrl&quot;:&quot;https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php&quot;,&quot;loopSlides&quot;:false,&quot;scrollTopOffset&quot;:0,&quot;hideNavigationOnFirstSlide&quot;:false,&quot;isRtl&quot;:false,&quot;excludedWords&quot;:[&quot;&quot;]}' data-theiaPostSlider-onChangeSlide='&quot;&quot;'></div> </div>
<div class="zox-post-body-bot left zoxrel zox100">
<div class="zox-post-body-width">
<div class="zox-post-tags left zoxrel zox100">
<span class="zox-post-tags-header">In this article:</span><span itemprop="keywords"></span>
</div>
<div class="zox-posts-nav-link">
</div>
<div class="zox-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<div class="zox-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<img src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" />
<meta itemprop="url" content="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg">
</div>
<meta itemprop="name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More">
</div>
</div>
</div>
</div> </div>
<div class="zox-post-side-wrap zox-post-side-noalp zoxrel zox-sticky-side">
<div id="zox-side-wrap" class="zoxrel zox-divs">
<div id="zox_ad_widget-13" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
<div class="dragi-3ded4d0830e00d80c8291d9fe4f1b00c" id="dragi-3ded4d0830e00d80c8291d9fe4f1b00c"></div> </div>
</div><div id="zox_side_trend_widget-4" class="zox-side-widget zox_side_trend_widget"><div class="zox-widget-side-head"><h4 class="zox-widget-side-title"><span class="zox-widget-side-title">Trending</span></h4></div>
<div class="zox-widget-side-trend-wrap left zoxrel zox100">
<section class="zox-art-wrap zoxrel zox-art-small">
<div class="zox-art-grid">
<a href="https://dragillustrated.com/nhra-top-fuel-star-antron-brown-joins-team-buginga-for-pro-275-debut-at-snowbird-outlaw-nationals/" rel="bookmark">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/12/Brown_Buginga_David-Hilner-photo-100x100.jpg" class="lazy-load wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/12/Brown_Buginga_David-Hilner-photo-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/12/Brown_Buginga_David-Hilner-photo-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </div>
</a>
<div class="zox-art-text">
<h3 class="zox-s-cat"><span class="zox-s-cat">Drag Radial</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/nhra-top-fuel-star-antron-brown-joins-team-buginga-for-pro-275-debut-at-snowbird-outlaw-nationals/" rel="bookmark">
<h2 class="zox-s-title3">NHRA Top Fuel Star Antron Brown Joins Team Buginga for Pro 275 Debut at Snowbird Outlaw Nationals</h2>
</a>
</div>
</div> </div>
</section> <section class="zox-art-wrap zoxrel zox-art-small">
<div class="zox-art-grid">
<a href="https://dragillustrated.com/wbs-champ-talk-erica-enders-brittany-force-talk-shop-plus-angie-smith/" rel="bookmark">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283-4-100x100.jpg" class="lazy-load wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283-4-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/11/WBS-EPISODE-283-4-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </div>
</a>
<div class="zox-art-text">
<h3 class="zox-s-cat"><span class="zox-s-cat">The Wes Buck Show</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/wbs-champ-talk-erica-enders-brittany-force-talk-shop-plus-angie-smith/" rel="bookmark">
<h2 class="zox-s-title3">WBS: CHAMP TALK: Erica Enders &#038; Brittany Force Talk Shop! Plus Angie Smith</h2>
</a>
</div>
</div> </div>
</section> <section class="zox-art-wrap zoxrel zox-art-small">
<div class="zox-art-grid">
<a href="https://dragillustrated.com/drag-illustrated-releases-2022-30-under-30-issue-ahead-of-pri-show/" rel="bookmark">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/12/30Under30-2022-Feature-Image-1600x900-1-100x100.jpg" class="lazy-load wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/12/30Under30-2022-Feature-Image-1600x900-1-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/12/30Under30-2022-Feature-Image-1600x900-1-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </div>
</a>
<div class="zox-art-text">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/drag-illustrated-releases-2022-30-under-30-issue-ahead-of-pri-show/" rel="bookmark">
<h2 class="zox-s-title3">Drag Illustrated Releases 2022 30 Under 30 Issue Ahead of PRI Show</h2>
</a>
</div>
</div> </div>
</section> <section class="zox-art-wrap zoxrel zox-art-small">
<div class="zox-art-grid">
<a href="https://dragillustrated.com/elite-motorsports-expands-drag-racing-presence-with-mountain-motor-pro-stock-program/" rel="bookmark">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/12/Elite-MMPS-100x100.jpg" class="lazy-load wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/12/Elite-MMPS-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/12/Elite-MMPS-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </div>
</a>
<div class="zox-art-text">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/elite-motorsports-expands-drag-racing-presence-with-mountain-motor-pro-stock-program/" rel="bookmark">
<h2 class="zox-s-title3">Richard Freeman, Erica Enders to Wheel Elite Motorsports Mountain Motor Pro Stockers in 2023</h2>
</a>
</div>
</div> </div>
</section> <section class="zox-art-wrap zoxrel zox-art-small">
<div class="zox-art-grid">
<a href="https://dragillustrated.com/dan-jesel-to-transition-to-executive-chairman-rich-runne-to-assume-controlling-interest-and-chief-executive-role-at-jesel/" rel="bookmark">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Jesel-News-100x100.jpg" class="lazy-load wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Jesel-News-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Jesel-News-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </div>
</a>
<div class="zox-art-text">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/dan-jesel-to-transition-to-executive-chairman-rich-runne-to-assume-controlling-interest-and-chief-executive-role-at-jesel/" rel="bookmark">
<h2 class="zox-s-title3">Dan Jesel to Transition to Executive Chairman; Rich Runne to Assume Controlling Interest and Chief Executive Role at Jesel</h2>
</a>
</div>
</div> </div>
</section> </div>
</div><div id="zox_ad_widget-16" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
<div class="dragi-ade285d3dc8456a949f18a2029ae8ab3" id="dragi-ade285d3dc8456a949f18a2029ae8ab3"></div> </div>
</div><div id="zox_ad_widget-14" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
<div class="dragi-c610f9890be0dbb8e3b0374bb38f7ba8" id="dragi-c610f9890be0dbb8e3b0374bb38f7ba8"></div> </div>
</div><div id="zox_ad_widget-15" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
<div class="dragi-88f5b5c007e78ffded04f73f5b0519a4" id="dragi-88f5b5c007e78ffded04f73f5b0519a4"></div> </div>
</div> </div>
</div>
</div>
</div>
</div>
<div class="zox-post-soc-scroll">
<ul class="zox-post-soc-list left zoxrel">
<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/&amp;t=Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="zox-post-soc-fb">
<i class="fab fa-facebook-f"></i>
</li>
</a>
<a href="#" onclick="window.open('https://twitter.com/share?text=Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023 -&amp;url=https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="zox-post-soc-twit">
<i class="fab fa-twitter"></i>
</li>
</a>
<li class="zox-post-soc-copy">
<i class="fas fa-link"></i>
</li>
<li class="zox-post-soc-more zox-soc-scroll-click">
<i class="fas fa-ellipsis-h"></i>
<div class="zox-soc-more-scroll">
<ul class="zox-soc-more-list">
<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023&url=https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
<li class="zox-post-soc-flip">
<p>Flipboard</p>
<i class="fab fa-flipboard"></i>
</li>
</a>
<a href="#" onclick="window.open('https://www.reddit.com/submit?url=https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/&title=Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023', 'redditShare', 'width=626,height=436'); return false;" title="Share on Reddit">
<li class="zox-post-soc-redd">
<p>Reddit</p>
<i class="fab fa-reddit-alien"></i>
</li>
</a>
<a href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/&amp;media=https://dragillustrated.com/wp-content/uploads/2022/12/DIFeatureImage-Troy-Coughlin-Jr.jpg&amp;description=Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<li class="zox-post-soc-pin">
<p>Pinterest</p>
<i class="fab fa-pinterest-p" aria-hidden="true"></i>
</li>
</a>
<a class="zox-whats-main" href="https://web.whatsapp.com/send?text=Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023 https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a class="zox-whats-mob" href="whatsapp://send?text=Troy Coughlin Jr. Will Once Again Pilot JEGS Pro Stocker for Elite Motorsports in 2023 https://dragillustrated.com/troy-coughlin-jr-will-once-again-pilot-jegs-pro-stocker-for-elite-motorsports-in-2023/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a href="/cdn-cgi/l/email-protection#2e115d5b4c444b4d5a137a5c41570e6d415b49464247400e645c000e794742420e61404d4b0e6f494f47400e7e4742415a0e646b697d0e7e5c410e7d5a414d454b5c0e48415c0e6b42475a4b0e63415a415c5d5e415c5a5d0e47400e1c1e1c1d084f435e156c616a7713670e48415b404a0e5a46475d0e4f5c5a474d424b0e47405a4b5c4b5d5a4740490e4f404a0e5a46415b49465a0e41480e5d464f5c4740490e475a0e59475a460e57415b000e6d464b4d450e475a0e415b5a140e465a5a5e5d1401014a5c4f494742425b5d5a5c4f5a4b4a004d4143015a5c4157034d415b494642474003445c03594742420341404d4b034f494f4740035e4742415a03444b495d035e5c41035d5a414d454b5c0348415c034b42475a4b0343415a415c5d5e415c5a5d034740031c1e1c1d01">
<li class="zox-post-soc-email">
<p>Email</p>
<i class="fas fa-envelope"></i>
</li>
</a>
</ul>
</div>
</li>
</ul>
</div>
</div>
<div class="zox-post-more-wrap left zoxrel zox100">
<div class="zox-post-width">
<div class="zox-post-more left zoxrel zox100">
<div class="zox-post-main-head left zoxrel zox100">
<h4 class="zox-post-main-title">
<span class="zox-post-main-title">You May Also Like</span>
</h4>
</div>
<div class="zox-post-more-grid zox-div4 left zoxrel zox100">
<div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/pro-street-legend-tony-christian-passes/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-600x337.jpg" class="zox-reg-img wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-100x100.jpg" class="zox-mob-img wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/pro-street-legend-tony-christian-passes/" rel="bookmark">
<h2 class="zox-s-title2">Pro Street Legend Tony Christian Passes</h2>
</a>
</div>
<p class="zox-s-graph">Tony Christian, one of the pioneering drivers of the Pro Street movement, passed away Thursday, June 9. Christian was infamous for his battles with...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>June 9, 2022</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/mwdrs-mourns-loss-of-pro-mod-driver-ronnie-hobbs-at-great-bend-nationals/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-600x337.jpg" class="zox-reg-img wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-100x100.jpg" class="zox-mob-img wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/mwdrs-mourns-loss-of-pro-mod-driver-ronnie-hobbs-at-great-bend-nationals/" rel="bookmark">
<h2 class="zox-s-title2">MWDRS Mourns Loss of Pro Mod Driver Ronnie Hobbs at Great Bend Nationals</h2>
</a>
</div>
<p class="zox-s-graph">The Mid-West Drag Racing Series (MWDRS) is saddened over the passing of Pro Mod driver Ronnie Hobbs following an on-track incident during Friday night...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>June 6, 2022</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/leah-pruett-through-the-years/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-600x337.jpg" class="zox-reg-img wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-100x100.jpg" class="zox-mob-img wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Exclusive</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/leah-pruett-through-the-years/" rel="bookmark">
<h2 class="zox-s-title2">Leah Pruett Through the Years</h2>
</a>
</div>
<p class="zox-s-graph">Leah Pruett scored the first NHRA Top Fuel win for her and husband Tony Stewart&#8217;s professional drag racing team this past weekend in Denver,...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>July 21, 2022</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/big-money-bracket-racer-sean-serra-dies-at-27/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-600x337.jpg" class="zox-reg-img wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-100x100.jpg" class="zox-mob-img wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/big-money-bracket-racer-sean-serra-dies-at-27/" rel="bookmark">
<h2 class="zox-s-title2">Big Money Bracket Racer Sean Serra Dies at 27</h2>
</a>
</div>
<p class="zox-s-graph">Drag racer Sean Serra has passed away in a tragic car accident. He was 27 years old. Serra was involved in a single-car rollover...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/kayla-zadel/" title="Posts by Kayla Zadel" rel="author">Kayla Zadel</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>July 7, 2022</span>
</div>
</div>
</div> </div>
</div> </div>
</div>
</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
	jQuery(document).ready(function($) {
  		$(".zox-soc-stat-click-55925").on("click", function(){
	  		$(".zox-more-click-55925").toggleClass("zox-soc-more-open");
  		});
	});
    </script> </article> </div>
<footer id="zox-foot-wrap" class="left zoxrel zox100">
<div class="zox-head-width">
<div class="zox-foot-grid left zoxrel zox100">
<div class="zox-foot-left-wrap">
<div class="zox-foot-logo left zox-lh0">
<a href="https://dragillustrated.com/"><img src="https://dragillustrated.com/wp-content/uploads/2022/03/DragIllustrated_flat_white-200px.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
</div>
<div class="zox-foot-left left">
<div class="zox-foot-menu">
<div class="menu-about-di-container"><ul id="menu-about-di" class="menu"><li id="menu-item-52480" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52480"><a href="https://dragillustrated.com/about-di/">About DI</a></li>
<li id="menu-item-50895" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50895"><a href="https://dragillustrated.com/join-newsletter/?swcfpc=1">Newsletter</a></li>
<li id="menu-item-21282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21282"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/">Subscribe</a></li>
<li id="menu-item-50896" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50896"><a href="https://dragillustrated.com/contact-page">Customer Service</a></li>
<li id="menu-item-50897" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50897"><a href="https://dragillustrated.com/careers">Careers</a></li>
<li id="menu-item-50898" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50898"><a href="https://dragillustrated.com/press-center/">Public Relations</a></li>
<li id="menu-item-52947" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52947"><a href="https://dragillustrated.com/advertise/">Advertise</a></li>
<li id="menu-item-50899" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50899"><a href="https://mediakit.dragillustrated.com/">Media Kit</a></li>
<li id="menu-item-50900" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50900"><a href="https://dragillustrated.com/masthead">Masthead</a></li>
</ul></div> </div>
<div class="zox-foot-copy">
 <p>Since 2005, DI has informed, inspired and educated drag racers from every walk of the racing life - weekend warrior and street/strip enthusiasts to pro-level doorslammer and Top Fuel racers. From award-winning writing and photography to binge-worthy videos to electric live events, DI meets hundreds of thousands of racers where they live, creating the moments that create conversations.</p>
</div>
</div>
</div>
<div class="zox-foot-right-wrap">
<div class="zox-foot-soc right relative">
<ul class="zox-foot-soc-list left relative">
<li><a href="https://www.facebook.com/DragIllustrated" target="_blank" class="fab fa-facebook-f"></a></li>
<li><a href="https://twitter.com/DragIllustrated" target="_blank" class="fab fa-twitter"></a></li>
<li><a href="https://www.instagram.com/dragillustrated" target="_blank" class="fab fa-instagram"></a></li>
<li><a href="https://bit.ly/3y2ogFR" target="_blank" class="fab fa-youtube"></a></li>
</ul>
</div>
</div>
</div>
</div>
</footer>
</div>
</div>
</div>
</div>
<div class="zox-fly-top back-to-top">
<span class="fas fa-angle-up"></span>
</div>
</div>
<div class="zox-fly-fade zox-fly-but-click">
</div>
<script type='text/javascript' id='ngg_common-js-extra'>
/* <![CDATA[ */

var nextgen_lightbox_settings = {"static_path":"https:\/\/dragillustrated.com\/wp-content\/plugins\/nextgen-gallery\/products\/photocrati_nextgen\/modules\/lightbox\/static\/{placeholder}","context":"all_images_direct"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_gallery_display/static/common.js?ver=3.30' id='ngg_common-js'></script>
<script type='text/javascript' id='ngg_lightbox_context-js-extra'>
/* <![CDATA[ */

var nextgen_thickbox_i18n = {"next":"Next &gt;","prev":"&lt; Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them."};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/lightbox_context.js?ver=3.30' id='ngg_lightbox_context-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/thickbox/nextgen_thickbox_init.js?ver=3.30' id='thickbox-0-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/thickbox/thickbox.js?ver=3.30' id='thickbox-1-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/ResizeSensor.js?ver=1.7.0' id='theia-sticky-sidebar/ResizeSensor.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.7.0' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.7.0' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.2' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/zoxpress-plugin//scripts/jquery.sticky-kit.min.js?ver=6.1.1' id='jquery-sticky-kit-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/zoxpress-plugin//scripts/jquery.waypoints.min.js?ver=6.1.1' id='jquery-waypoints-js'></script>
<script type='text/javascript' id='advanced-ads-responsive-js-extra'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.10.5' id='advanced-ads-responsive-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/jquery.nouislider.all.min.js?ver=3.14.2' id='reviewer-nouislider-plugin-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/photoswipe.js?ver=3.14.2' id='reviewer-photoswipe-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/jquery.knob.js?ver=3.14.2' id='reviewer-knob-plugin-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer.public.min.js?ver=3.14.2' id='reviewer-public-script-js'></script>
<script type='text/javascript' id='reviewer-reviews-boxes-script-js-extra'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerRatingObj = {"ajax_nonce":"06c72216b2","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_rating"};
var reviewerJudgeObj = {"ajax_nonce":"0e48eb62d0","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_like"};
var reviewerQueryURs = {"ajax_nonce":"5db976364d","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer-reviews-boxes.js?ver=3.14.2' id='reviewer-reviews-boxes-script-js'></script>
<script type='text/javascript' id='reviewer-widget-users-reviews-script-js-extra'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerQueryAllURs = {"ajax_nonce":"bf657a033e","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_all_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer-widget-users-reviews.js?ver=3.14.2' id='reviewer-widget-users-reviews-script-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/woocommerce-subscriptions-gifting/js/wcs-gifting.js?ver=2.0.0' id='woocommerce_subscriptions_gifting-js'></script>
<script type='text/javascript' id='advanced-ads-pro/front-js-extra'>
/* <![CDATA[ */
var advadsCfpInfo = {"cfpExpHours":"1","cfpClickLimit":"8","cfpBan":"1","cfpPath":"","cfpDomain":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-pro/assets/js/advanced-ads-pro.min.js?ver=2.19.1' id='advanced-ads-pro/front-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/zoxcustom.js?ver=6.1.1' id='zox-custom-js'></script>
<script type='text/javascript' id='zox-custom-js-after'>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</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/scripts.js?ver=6.1.1' id='zox-scripts-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/retina.js?ver=6.1.1' id='zox-retina-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/jquery.infinitescroll.min.js?ver=6.1.1' id='zox-infinitescroll-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/comment-reply.min.js?ver=81582bdb254a94e4464424087c6479a8' id='comment-reply-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/intersection-observer.js' id='zox-intersection-observer-polyfill-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/lozad.min.js' id='zox-lozad-js'></script>
<script type='text/javascript' id='zox-lozad-js-after'>

	var zoxWidgets = document.querySelectorAll("#zox-home-widget-wrap img");
	lozad(zoxWidgets, {
		rootMargin: "0px 0px",
		loaded: function (el) {
			el.classList.add("is-loaded");
		}
	}).observe();
</script>
<script type='text/javascript' id='advanced-ads-pro/cache_busting-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":"","wp_timezone_offset":"-21600"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-pro/assets/js/base.min.js?ver=2.19.1' id='advanced-ads-pro/cache_busting-js'></script>
<script type='text/javascript' id='advadsTrackingScript-js-extra'>
/* <![CDATA[ */
var advadsTracking = {"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"dragi-target","blogId":"1","frontendPrefix":"dragi-"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/tracking.min.js?ver=2.4.0' id='advadsTrackingScript-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=14.1.4.1' id='__ytprefsfitvids__-js'></script>
<div data-theiaStickySidebar-sidebarSelector='".zox-sticky-side"' data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":70,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":1004,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script> <script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
<script type="text/javascript">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</script> 
<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">

<div class="pswp__bg"></div>

<div class="pswp__scroll-wrap">

<div class="pswp__container">
<div class="pswp__item"></div>
<div class="pswp__item"></div>
<div class="pswp__item"></div>
</div>

<div class="pswp__ui pswp__ui--hidden">
<div class="pswp__top-bar">

<div class="pswp__counter"></div>
<button class="pswp__button pswp__button--close" title="Close (Esc)"></button>
 <button class="pswp__button pswp__button--share" title="Share"></button>
<button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>
<button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>


<div class="pswp__preloader">
<div class="pswp__preloader__icn">
<div class="pswp__preloader__cut">
<div class="pswp__preloader__donut"></div>
</div>
</div>
</div>
</div>
<div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
<div class="pswp__share-tooltip"></div>
</div>
<button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
</button>
<button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
</button>
<div class="pswp__caption">
<div class="pswp__caption__center"></div>
</div>
</div>
</div>
</div>
<script>window.advads_admin_bar_items = [];</script><script>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</script><script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script> <script src='https://stats.wp.com/e-202250.js' defer></script>
<script>
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'37035244',post:'55925',tz:'-6',srv:'dragillustrated.com',j:'1:11.6'} ]);
		_stq.push([ 'clickTrackerInit', '37035244', '55925' ]);
	</script><script id="dragi-tracking">var advads_tracking_ads = {};var advads_tracking_urls = {"1":"https:\/\/dragillustrated.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods = {"1":"frontend"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"https:\/\/dragillustrated.com\/linkout\/"};</script>
</body>
</html>