<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script>window._wca = window._wca || [];</script>

	<!-- This site is optimized with the Yoast SEO Premium plugin v16.0 (Yoast SEO v18.4.1) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way - Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Heebo%3A300%2C400%2C500%2C700%2C800%2C900%7CAlegreya%3A400%2C500%2C700%2C800%2C900%7CJosefin%20Sans%3A300%2C400%2C600%2C700%7CLibre%20Franklin%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CFrank%20Ruhl%20Libre%3A300%2C400%2C500%2C700%2C900%7CNunito%20Sans%3A300%2C400%2C600%2C700%2C800%2C900%7CMontserrat%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CAnton%3A400%7CNoto%20Serif%3A400%2C700%7CNunito%3A300%2C400%2C600%2C700%2C800%2C900%7CRajdhani%3A300%2C400%2C500%2C600%2C700%7CTitillium%20Web%3A300%2C400%2C600%2C700%2C900%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CAmiri%3A400%2C400i%2C700%2C700i%7COswald%3A300%2C400%2C500%2C600%2C700%7CRoboto%20Mono%3A400%2C700%7CBarlow%20Semi%20Condensed%3A700%2C800%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%20Condensed%3A300%2C400%2C700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7CPT%20Serif%3A400%2C700%7COpen%20Sans%20Condensed%3A300%2C700%7COpen%20Sans%3A700%7CSource%20Serif%20Pro%3A400%2C600%2C700%7CIM%20Fell%20French%20Canon%3A400%2C400i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%26amp%3Bsubset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Heebo%3A300%2C400%2C500%2C700%2C800%2C900%7CAlegreya%3A400%2C500%2C700%2C800%2C900%7CJosefin%20Sans%3A300%2C400%2C600%2C700%7CLibre%20Franklin%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CFrank%20Ruhl%20Libre%3A300%2C400%2C500%2C700%2C900%7CNunito%20Sans%3A300%2C400%2C600%2C700%2C800%2C900%7CMontserrat%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CAnton%3A400%7CNoto%20Serif%3A400%2C700%7CNunito%3A300%2C400%2C600%2C700%2C800%2C900%7CRajdhani%3A300%2C400%2C500%2C600%2C700%7CTitillium%20Web%3A300%2C400%2C600%2C700%2C900%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CAmiri%3A400%2C400i%2C700%2C700i%7COswald%3A300%2C400%2C500%2C600%2C700%7CRoboto%20Mono%3A400%2C700%7CBarlow%20Semi%20Condensed%3A700%2C800%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%20Condensed%3A300%2C400%2C700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7CPT%20Serif%3A400%2C700%7COpen%20Sans%20Condensed%3A300%2C700%7COpen%20Sans%3A700%7CSource%20Serif%20Pro%3A400%2C600%2C700%7CIM%20Fell%20French%20Canon%3A400%2C400i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%26amp%3Bsubset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Heebo%3A300%2C400%2C500%2C700%2C800%2C900%7CAlegreya%3A400%2C500%2C700%2C800%2C900%7CJosefin%20Sans%3A300%2C400%2C600%2C700%7CLibre%20Franklin%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CFrank%20Ruhl%20Libre%3A300%2C400%2C500%2C700%2C900%7CNunito%20Sans%3A300%2C400%2C600%2C700%2C800%2C900%7CMontserrat%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CAnton%3A400%7CNoto%20Serif%3A400%2C700%7CNunito%3A300%2C400%2C600%2C700%2C800%2C900%7CRajdhani%3A300%2C400%2C500%2C600%2C700%7CTitillium%20Web%3A300%2C400%2C600%2C700%2C900%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CAmiri%3A400%2C400i%2C700%2C700i%7COswald%3A300%2C400%2C500%2C600%2C700%7CRoboto%20Mono%3A400%2C700%7CBarlow%20Semi%20Condensed%3A700%2C800%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%20Condensed%3A300%2C400%2C700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7CPT%20Serif%3A400%2C700%7COpen%20Sans%20Condensed%3A300%2C700%7COpen%20Sans%3A700%7CSource%20Serif%20Pro%3A400%2C600%2C700%7CIM%20Fell%20French%20Canon%3A400%2C400i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%26amp%3Bsubset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese&#038;display=swap" /></noscript>
	<link rel="canonical" href="https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way - Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
	<meta property="og:description" content="When the PDRA launched its Pro Street class as a three-race trial in 2020, the class allowed drag radials or slicks to attract racers from multiple different small-tire classes. But after a reworking of the rules for 2021, the category’s first year as a PDRA world championship category, Pro Street has found its new purpose: [&hellip;]" />
	<meta property="og:url" content="https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/" />
	<meta property="og:site_name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
	<meta property="article:publisher" content="https://www.facebook.com/dragillustrated" />
	<meta property="article:published_time" content="2022-04-05T13:00:31+00:00" />
	<meta property="article:modified_time" content="2022-04-01T14:34:11+00:00" />
	<meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834.jpg" />
	<meta property="og:image:width" content="1800" />
	<meta property="og:image:height" content="1200" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@dragillustrated" />
	<meta name="twitter:site" content="@dragillustrated" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Nate Van Wagnen" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="5 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://dragillustrated.com/#organization","name":"Drag Illustrated","url":"https://dragillustrated.com/","sameAs":["https://www.facebook.com/dragillustrated","https://www.instagram.com/dragillustrated","https://www.youtube.com/channel/UCbREkYFDiSOs8JCRTsqEMeg","https://twitter.com/dragillustrated"],"logo":{"@type":"ImageObject","@id":"https://dragillustrated.com/#logo","inLanguage":"en-US","url":"https://dragillustrated.com/wp-content/uploads/2012/03/Drag_Illustrated_Logo_RED.png","contentUrl":"https://dragillustrated.com/wp-content/uploads/2012/03/Drag_Illustrated_Logo_RED.png","width":2150,"height":592,"caption":"Drag Illustrated"},"image":{"@id":"https://dragillustrated.com/#logo"}},{"@type":"WebSite","@id":"https://dragillustrated.com/#website","url":"https://dragillustrated.com/","name":"Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More","description":"","publisher":{"@id":"https://dragillustrated.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://dragillustrated.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/#primaryimage","inLanguage":"en-US","url":"https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834.jpg","contentUrl":"https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834.jpg","width":1800,"height":1200},{"@type":"WebPage","@id":"https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/#webpage","url":"https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/","name":"Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way - Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More","isPartOf":{"@id":"https://dragillustrated.com/#website"},"primaryImageOfPage":{"@id":"https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/#primaryimage"},"datePublished":"2022-04-05T13:00:31+00:00","dateModified":"2022-04-01T14:34:11+00:00","breadcrumb":{"@id":"https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/"]}]},{"@type":"BreadcrumbList","@id":"https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://dragillustrated.com/"},{"@type":"ListItem","position":2,"name":"Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way"}]},{"@type":"Article","@id":"https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/#article","isPartOf":{"@id":"https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/#webpage"},"author":{"@id":"https://dragillustrated.com/#/schema/person/39dbc8e6c713b844fd9037046110f529"},"headline":"Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way","datePublished":"2022-04-05T13:00:31+00:00","dateModified":"2022-04-01T14:34:11+00:00","mainEntityOfPage":{"@id":"https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/#webpage"},"wordCount":1020,"publisher":{"@id":"https://dragillustrated.com/#organization"},"image":{"@id":"https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/#primaryimage"},"thumbnailUrl":"https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834.jpg","articleSection":["Exclusive","Features","PDRA"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://dragillustrated.com/#/schema/person/39dbc8e6c713b844fd9037046110f529","name":"Nate Van Wagnen","image":{"@type":"ImageObject","@id":"https://dragillustrated.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/7ef2bd3121d8ee25ecf7cdcdd67255a1?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/7ef2bd3121d8ee25ecf7cdcdd67255a1?s=96&d=mm&r=g","caption":"Nate Van Wagnen"},"sameAs":["https://dragillustrated.com"],"url":"https://dragillustrated.com/author/nate/"}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Feed" href="https://dragillustrated.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Comments Feed" href="https://dragillustrated.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; iCal Feed" href="https://dragillustrated.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way Comments Feed" href="https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/feed/" />
		<!-- This site uses the Google Analytics by ExactMetrics plugin v7.4.0 - Using Analytics tracking - https://www.exactmetrics.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-21052018-1"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by ExactMetrics -->
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://dragillustrated.com/wp-includes/css/dist/block-library/style.min.css?ver=03a33f7c50641a33c9d3faaacceef61c' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://dragillustrated.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://dragillustrated.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=03a33f7c50641a33c9d3faaacceef61c' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css'  href='https://dragillustrated.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-vendors-style.css?ver=6.9.0' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css'  href='https://dragillustrated.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-style.css?ver=6.9.0' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-css'  href='https://dragillustrated.com/wp-content/plugins/theia-post-slider/css/buttons-red.css?ver=1.15.1' type='text/css' media='all' />
<link rel='stylesheet' id='ql-jquery-ui-css'  href='//ajax.googleapis.com/ajax/libs/jqueryui/1.12.1/themes/smoothness/jquery-ui.css?ver=03a33f7c50641a33c9d3faaacceef61c' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-photoswipe-css'  href='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/css/photoswipe.css?ver=3.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://dragillustrated.com/wp-includes/css/dashicons.min.css?ver=03a33f7c50641a33c9d3faaacceef61c' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-public-css'  href='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/css/reviewer-public.css?ver=3.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='zox-custom-style-css'  href='https://dragillustrated.com/wp-content/themes/zoxpress/style.css?ver=03a33f7c50641a33c9d3faaacceef61c' type='text/css' media='all' />
<style id='zox-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='fontawesome-child-css'  href='https://use.fontawesome.com/releases/v5.5.0/css/all.css?ver=03a33f7c50641a33c9d3faaacceef61c' type='text/css' media='all' />
<link rel='stylesheet' id='zox-custom-child-style-css'  href='https://dragillustrated.com/wp-content/themes/zoxpress-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://dragillustrated.com/wp-content/themes/zoxpress-child/font-awesome/css/all.css?ver=03a33f7c50641a33c9d3faaacceef61c' type='text/css' media='all' />

<link rel='stylesheet' id='zox-media-queries-css'  href='https://dragillustrated.com/wp-content/themes/zoxpress/css/media-queries.css?ver=03a33f7c50641a33c9d3faaacceef61c' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://dragillustrated.com/wp-content/tablepress-combined.min.css?ver=41' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://dragillustrated.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.7' type='text/css' media='all' />
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209' id='jetpack_related-posts-js'></script>
<script type='text/javascript' id='exactmetrics-frontend-script-js-extra'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/dragillustrated.com","hash_tracking":"false","ua":"UA-21052018-1","v4_id":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend-gtag.min.js?ver=7.4.0' id='exactmetrics-frontend-script-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/balupton-history.js/jquery.history.js?ver=1.7.1' id='history.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/async.min.js?ver=14.09.2014' id='async.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/tps.js?ver=1.15.1' id='theiaPostSlider/theiaPostSlider.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/main.js?ver=1.15.1' id='theiaPostSlider/main.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/tps-transition-slide.js?ver=1.15.1' id='theiaPostSlider/transition.js-js'></script>
<script defer type='text/javascript' src='https://stats.wp.com/s-202214.js' id='woocommerce-analytics-js'></script>
<link rel="https://api.w.org/" href="https://dragillustrated.com/wp-json/" /><link rel="alternate" type="application/json" href="https://dragillustrated.com/wp-json/wp/v2/posts/49931" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dragillustrated.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dragillustrated.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p2voyE-cZl' />
<link rel="alternate" type="application/json+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Fsmall-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Fsmall-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way%2F&#038;format=xml" />
<script type="text/javascript" src="https://paywall.subscriptiongenius.com/load.js"></script>

<!-- This site is using AdRotate v5.8.18 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.gformba { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.gformba img { height:auto; }
	.gformba-col { position:relative; float:left; }
	.gformba-col:first-child { margin-left: 0; }
	.gformba-col:last-child { margin-right: 0; }
	.gformba-1 {  margin: 0 auto; }
	.gformba-2 { margin:1px; 1px 1px 1px; }
	.gformba-3 { margin:1px; 1px 1px 1px; float:right; clear:right; }
	.gformba-4 { margin:1px 1px 1px 1px; }
	.gformba-5 { margin:1px 1px 1px 1px; }
	.gformba-6 { margin:1px 1px 1px 1px; }
	.gformba-7 { margin:1px 1px 1px 1px; }
	.gformba-8 { min-width:3px; max-width:618px; }
	.bformba-8 { margin:1px 3px 1px 3px; }
	.gformba-9 { margin:1px 1px 1px 1px; }
	.gformba-10 { margin:1px 1px 1px 1px; }
	.gformba-16 { min-width:5px; max-width:150px; margin: 0 auto; }
	.bformba-16 { margin:0px 5px 0px 5px; }
	.gformba-26 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.gformba-col, .gformba-dyn, .gformba-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<style type="text/css">
			.wpsdc-drop-cap {
				float : left;				
				padding : 0.25em 0.05em 0.25em 0;				
				font-size : 5em;
				line-height : 0.4em;color : #0a0a0a;}
		</style><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//dragillustrated.com/?wordfence_lh=1&hid=4392F76B1AB1B315A303657A21639E1B');
</script>	<meta name="theme-color" content="#000" />
			<meta property="og:type" content="article" />
													<meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834-1024x576.jpg" />
				<meta name="twitter:image" content="https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834-1024x576.jpg" />
						<meta property="og:url" content="https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/" />
			<meta property="og:title" content="Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way" />
			<meta property="og:description" content="When the PDRA launched its Pro Street class as a three-race trial in 2020, the class allowed drag radials or slicks to attract racers from multiple different small-tire classes. But after a reworking of the rules for 2021, the category’s first year as a PDRA world championship category, Pro Street has found its new purpose: [&hellip;]" />
			<meta name="twitter:card" content="summary_large_image">
			<meta name="twitter:url" content="https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">
			<meta name="twitter:title" content="Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way">
			<meta name="twitter:description" content="When the PDRA launched its Pro Street class as a three-race trial in 2020, the class allowed drag radials or slicks to attract racers from multiple different small-tire classes. But after a reworking of the rules for 2021, the category’s first year as a PDRA world championship category, Pro Street has found its new purpose: [&hellip;]">
			<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://dragillustrated.com"><link rel="alternate" href="https://dragillustrated.com/wp-json/tribe/events/v1/" /><style type='text/css'>img#wpstats{display:none}</style>
	<link rel="pingback" href="https://dragillustrated.com/xmlrpc.php">	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
	<link rel="amphtml" href="https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/amp/"><link rel="icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-180x180.png" />
<meta name="msapplication-TileImage" content="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-270x270.png" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-49931 single-format-standard custom-background wp-embed-responsive theme-zoxpress theiaPostSlider_body woocommerce-no-js tribe-no-js zox-sport2 zox-s6" >
	<div id="zox-site" class="left zoxrel ">
		<div id="zox-fly-wrap">
	<div id="zox-fly-menu-top" class="left relative">
		<div id="zox-fly-logo" class="left relative">
							<a href="https://dragillustrated.com/"><img src="https://dragillustrated.com/wp-content/uploads/2022/03/DragIllustrated_flat_white-150px.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
					</div><!--zox-fly-logo-->
		<div class="zox-fly-but-wrap zox-fly-but-menu zox-fly-but-click">
			<span></span>
			<span></span>
			<span></span>
			<span></span>
		</div><!--zox-fly-but-wrap-->
	</div><!--zox-fly-menu-top-->
	<div id="zox-fly-menu-wrap">
		<nav class="zox-fly-nav-menu left relative">
			<div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-49701" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49701"><a href="https://dragillustrated.com/category/news/">News</a></li>
<li id="menu-item-49702" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-49702"><a href="https://dragillustrated.com/category/race-coverage/">Race Coverage</a></li>
<li id="menu-item-49703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49703"><a href="https://dragillustrated.com/category/tech/">Tech</a></li>
<li id="menu-item-15094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" rel="noopener" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li id="menu-item-15102" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
</ul></div>		</nav>
	</div><!--zox-fly-menu-wrap-->
	<div id="zox-fly-soc-wrap">
		<span class="zox-fly-soc-head">Connect with us</span>
		<ul class="zox-fly-soc-list left relative">
							<li><a href="https://www.facebook.com/DragIllustrated/" target="_blank" class="fab fa-facebook-f"></a></li>
										<li><a href="https://twitter.com/DragIllustrated" target="_blank" class="fab fa-twitter"></a></li>
										<li><a href="https://www.instagram.com/dragillustrated/" target="_blank" class="fab fa-instagram"></a></li>
																				</ul>
	</div><!--zox-fly-soc-wrap-->
</div><!--zox-fly-wrap-->		<div id="zox-search-wrap">
			<div class="zox-search-cont">
				<p class="zox-search-p">Hi, what are you looking for?</p>
				<div class="zox-search-box">
					<form method="get" id="zox-search-form" action="https://dragillustrated.com/">
	<input type="text" name="s" id="zox-search-input" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "Search") { this.value = ""; }' />
	<input type="submit" id="zox-search-submit" value="Search" />
</form>				</div><!--zox-search-box-->
			</div><!--zox-serach-cont-->
			<div class="zox-search-but-wrap zox-search-click">
				<span></span>
				<span></span>
			</div><!--zox-search-but-wrap-->
		</div><!--zox-search-wrap-->
				<div id="zox-site-wall" class="left zoxrel">
			<div id="zox-lead-top-wrap">
				<div id="zox-lead-top-in">
					<div id="zox-lead-top">
											</div><!--zox-lead-top-->
				</div><!--zox-lead-top-in-->
			</div><!--zox-lead-top-wrap-->
			<div id="zox-site-main" class="left zoxrel">
				<header id="zox-main-head-wrap" class="left zoxrel zox-trans-head">
																<div id="zox-bot-head-wrap" class="left zoxrel">
	<div class="zox-head-width">
		<div id="zox-bot-head">
			<div id="zox-bot-head-left">
				<div class="zox-fly-but-wrap zoxrel zox-fly-but-click">
					<span></span>
					<span></span>
					<span></span>
					<span></span>
				</div><!--zox-fly-but-wrap-->
			</div><!--zox-bot-head-left-->
			<div id="zox-bot-head-mid" class="relative">
				<div class="zox-bot-head-logo">
					<div class="zox-bot-head-logo-main">
													<a href="https://dragillustrated.com/"><img class="zox-logo-stand" src="https://dragillustrated.com/wp-content/uploads/2022/03/DragIllustrated_flat_white-150px.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /><img class="zox-logo-dark" src="https://dragillustrated.com/wp-content/uploads/2022/03/DragIllustrated_flat_white-150px.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
											</div><!--zox-bot-head-logo-main-->
																<h2 class="zox-logo-title">Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</h2>
									</div><!--zox-bot-head-logo-->
				<div class="zox-bot-head-menu">
					<div class="zox-nav-menu">
						<div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49701 zox-mega-drop"><a href="https://dragillustrated.com/category/news/">News</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/2022-pdra-world-championship-chase-begins-this-weekend-at-east-coast-nationals/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/PDRA_GALOT-1-Preview-w-logo_Tara-Bowker-photo-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/PDRA_GALOT-1-Preview-w-logo_Tara-Bowker-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/PDRA_GALOT-1-Preview-w-logo_Tara-Bowker-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>2022 PDRA World Championship Chase Begins This Weekend at East Coast Nationals</p></a></li><li><a href="https://dragillustrated.com/justin-lamb-reels-in-another-vegas-win-to-tie-as-second-most-winning-nhra-driver-at-the-strip/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/2214-15141-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" /></div><p>Justin Lamb Reels in Another Vegas Win to Tie as Second-Most Winning NHRA Driver at The Strip</p></a></li><li><a href="https://dragillustrated.com/pro-stock-standout-erica-enders-wins-nhra-four-wide-nationals-in-las-vegas-for-second-year-in-a-row/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/Enders_JFA-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/Enders_JFA-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/Enders_JFA-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Pro Stock Standout Erica Enders Wins NHRA Four-Wide Nationals in Las Vegas for Second Year in a Row</p></a></li><li><a href="https://dragillustrated.com/brittany-force-monster-energy-top-fuel-team-hit-jackpot-at-nhra-las-vegas-four-wide-nationals/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/Force_JFA-1-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/Force_JFA-1-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/Force_JFA-1-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Brittany Force, Monster Energy Top Fuel Team Hit Jackpot at NHRA Las Vegas Four-Wide Nationals</p></a></li><li><a href="https://dragillustrated.com/ron-capps-captures-first-victory-as-nhra-funny-car-team-owner/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/Capps_JFA-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/Capps_JFA-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/Capps_JFA-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Ron Capps Captures First Victory as NHRA Funny Car Team Owner</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-49702 zox-mega-drop"><a href="https://dragillustrated.com/category/race-coverage/">Race Coverage</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way</p></a></li><li><a href="https://dragillustrated.com/2022-pdra-world-championship-chase-begins-this-weekend-at-east-coast-nationals/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/PDRA_GALOT-1-Preview-w-logo_Tara-Bowker-photo-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/PDRA_GALOT-1-Preview-w-logo_Tara-Bowker-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/PDRA_GALOT-1-Preview-w-logo_Tara-Bowker-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>2022 PDRA World Championship Chase Begins This Weekend at East Coast Nationals</p></a></li><li><a href="https://dragillustrated.com/justin-lamb-reels-in-another-vegas-win-to-tie-as-second-most-winning-nhra-driver-at-the-strip/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/2214-15141-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" /></div><p>Justin Lamb Reels in Another Vegas Win to Tie as Second-Most Winning NHRA Driver at The Strip</p></a></li><li><a href="https://dragillustrated.com/pro-stock-standout-erica-enders-wins-nhra-four-wide-nationals-in-las-vegas-for-second-year-in-a-row/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/Enders_JFA-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/Enders_JFA-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/Enders_JFA-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Pro Stock Standout Erica Enders Wins NHRA Four-Wide Nationals in Las Vegas for Second Year in a Row</p></a></li><li><a href="https://dragillustrated.com/brittany-force-monster-energy-top-fuel-team-hit-jackpot-at-nhra-las-vegas-four-wide-nationals/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/Force_JFA-1-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/Force_JFA-1-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/Force_JFA-1-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Brittany Force, Monster Energy Top Fuel Team Hit Jackpot at NHRA Las Vegas Four-Wide Nationals</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49703 zox-mega-drop"><a href="https://dragillustrated.com/category/tech/">Tech</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/first-look-roderjan-busatos-new-rj-built-pro-boost-22-camaro/"><div class="zox-mega-img"><img width="506" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/03/2.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/03/2.jpg 1280w, https://dragillustrated.com/wp-content/uploads/2022/03/2-1200x800.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2022/03/2-1000x666.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/03/2-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/03/2-600x400.jpg 600w" sizes="(max-width: 506px) 100vw, 506px" /></div><p>First Look: Roderjan Busato&#8217;s New RJ-Built Pro Boost &#8217;22 Camaro</p></a></li><li><a href="https://dragillustrated.com/weld-announces-contingency-program-for-2022-nhra-competitors/"><div class="zox-mega-img"><img width="506" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/02/WELD_NHRA_2.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/02/WELD_NHRA_2.jpg 1280w, https://dragillustrated.com/wp-content/uploads/2022/02/WELD_NHRA_2-1200x800.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2022/02/WELD_NHRA_2-1000x666.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/02/WELD_NHRA_2-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/02/WELD_NHRA_2-600x400.jpg 600w" sizes="(max-width: 506px) 100vw, 506px" /></div><p>WELD Announces Contingency Program for 2022 NHRA Competitors</p></a></li><li><a href="https://dragillustrated.com/new-sema-emissions-certification-program-helps-manufacturers-get-products-to-market-faster/"><div class="zox-mega-img"><img width="505" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/02/56d47fa2-0941-4a9e-8ee3-913f8d6086fd-scaled.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/02/56d47fa2-0941-4a9e-8ee3-913f8d6086fd-scaled.jpg 2560w, https://dragillustrated.com/wp-content/uploads/2022/02/56d47fa2-0941-4a9e-8ee3-913f8d6086fd-1200x800.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2022/02/56d47fa2-0941-4a9e-8ee3-913f8d6086fd-2000x1333.jpg 2000w, https://dragillustrated.com/wp-content/uploads/2022/02/56d47fa2-0941-4a9e-8ee3-913f8d6086fd-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/02/56d47fa2-0941-4a9e-8ee3-913f8d6086fd-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/02/56d47fa2-0941-4a9e-8ee3-913f8d6086fd-1536x1024.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/02/56d47fa2-0941-4a9e-8ee3-913f8d6086fd-2048x1365.jpg 2048w, https://dragillustrated.com/wp-content/uploads/2022/02/56d47fa2-0941-4a9e-8ee3-913f8d6086fd-600x400.jpg 600w" sizes="(max-width: 505px) 100vw, 505px" /></div><p>New SEMA Emissions Certification Program Helps Manufacturers Get Products to Market Faster</p></a></li><li><a href="https://dragillustrated.com/sonnax-debuts-aftermarkets-toughest-ford-9-pinion-yokes/"><div class="zox-mega-img"><img width="506" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/01/Sonnax_9-inch-ford-pinion-yoke.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/01/Sonnax_9-inch-ford-pinion-yoke.jpg 1500w, https://dragillustrated.com/wp-content/uploads/2022/01/Sonnax_9-inch-ford-pinion-yoke-1200x800.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2022/01/Sonnax_9-inch-ford-pinion-yoke-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/01/Sonnax_9-inch-ford-pinion-yoke-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/01/Sonnax_9-inch-ford-pinion-yoke-600x400.jpg 600w" sizes="(max-width: 506px) 100vw, 506px" /></div><p>Sonnax Debuts Aftermarket’s Toughest Ford 9&#8243; Pinion Yokes</p></a></li><li><a href="https://dragillustrated.com/thermo-tecs-header-manifold-blanket-provides-heat-retention-for-exhaust-headers-and-manifolds/"><div class="zox-mega-img"><img width="506" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/01/Thermotec-header-manifold-blanket.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/01/Thermotec-header-manifold-blanket.jpg 1500w, https://dragillustrated.com/wp-content/uploads/2022/01/Thermotec-header-manifold-blanket-1200x800.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2022/01/Thermotec-header-manifold-blanket-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/01/Thermotec-header-manifold-blanket-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/01/Thermotec-header-manifold-blanket-600x400.jpg 600w" sizes="(max-width: 506px) 100vw, 506px" /></div><p>Thermo-Tec&#8217;s Header Manifold Blanket Provides Heat Retention for Exhaust Headers and Manifolds</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" rel="noopener" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
</ul></div>					</div><!--zox-nav-menu-->
				</div><!--zox-bot-head-menu-->
			</div><!--zox-bot-head-mid-->
			<div id="zox-bot-head-right">
									<span class="zox-night zox-night-mode fas fa-moon"></span>
								<span class="zox-nav-search-but fas fa-search zox-search-click"></span>
			</div><!--zox-bot-head-right-->
		</div><!--zox-bot-head-->
	</div><!--zox-head-width-->
</div><!--zox-bot-head-wrap-->				</header><!---zox-main-header-wrap-->
				<div id="zox-site-grid">
					<div id="zox-site-wall-small">
																																								<div id="zox-main-body-wrap" class="left relative">	<div class="zox-alp-width">
	<div class="zox-auto-post-grid">
		<div class="zox-alp-side zox-sticky-side">
			<div class="zox-alp-side-in">
				<div class="alp-related-posts-wrapper">
	<div class="alp-related-posts">
				<div class="alp-related-post post-49931 current" data-id="49931" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&amp;t=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way &amp;url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
					<div class="alp-advert">
									<span class="zox-ad-label">Advertisement</span>
					<div class="gformba gformba-1"><div class="gformba-single aformba-288"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="Mjg4LDEsMSwxMA==" href="http://www.fueltech.net/"><img src="https://dragillustrated.com/wp-content/uploads/2022/02/DI-300x300-1.png" /></a></div></div>							</div>
				<div class="alp-related-post post-49922 " data-id="49922" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/mountain-motors-moment-pdra-extreme-pro-stock-drivers-gearing-up-for-year-of-growth/">Mountain Motor&#039;s Moment: PDRA Extreme Pro Stock Drivers Gearing Up for Year of Growth</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&amp;t=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way &amp;url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-49772 " data-id="49772" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/race-coverage/drag-radial-race-coverage/">Drag Radial</a>
													<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/2021-di-pass-of-the-year-daniel-pharris-3-49-in-radial-vs-the-world-at-sweet-16/">2021 DI Pass of the Year: Daniel Pharris’ 3.49 in Radial vs. the World at Sweet 16</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&amp;t=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way &amp;url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-49776 " data-id="49776" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/race-coverage/nhra-race-coverage/">NHRA</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/2021-di-drag-racing-ambassador-of-the-year-brian-lohnes/">2021 DI Drag Racing Ambassador of the Year: Brian Lohnes</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&amp;t=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way &amp;url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-49769 " data-id="49769" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/race-coverage/sportsman-race-coverage/">Sportsman</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/after-joining-exclusive-million-winners-club-tyler-bohannon-chasing-more-big-wins-in-2022/">After Joining Exclusive &#039;Million&#039; Winners Club, Tyler Bohannon Chasing More Big Wins in 2022</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&amp;t=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way &amp;url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-49860 " data-id="49860" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/news/">News</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/three-races-in-nhra-top-performers-teams-to-watch-headed-into-las-vegas/">THREE RACES IN: NHRA Top Performers &amp; Teams to Watch Headed into Las Vegas</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&amp;t=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way &amp;url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-49764 " data-id="49764" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/news/">News</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/golden-child-paige-coughlin-looks-to-carve-her-own-path-in-no-prep-world/">Golden Child: Paige Coughlin Looks to Carve Her Own Path in No Prep World</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&amp;t=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way &amp;url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-49823 " data-id="49823" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/race-coverage/nhra-race-coverage/">NHRA</a>
													<a class="post-category" href="https://dragillustrated.com/category/race-coverage/">Race Coverage</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/racers-win-battle-against-the-weather-at-64th-annual-march-meet/">Racers Win Battle Against the Weather at 64th Annual March Meet</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&amp;t=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way &amp;url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-49802 " data-id="49802" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/news/">News</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/di-tribute-scott-oksas/">DI Tribute: Scott Oksas</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&amp;t=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way &amp;url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-49778 " data-id="49778" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/interviews/">Interviews</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/di-interview-ryan-martin-plays-to-win-on-and-off-the-track/">DI Interview: Ryan Martin Plays to Win, On and Off the Track</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&amp;t=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way &amp;url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
			</div><!--alp-related-posts-->
</div><!--alp-related-posts-wrapper-->			</div><!--zox-alp-side-in-->
		</div><!--zox-alp-side-->
		<div class="zox-auto-post-main">
			<article id="post-49931" class="post-49931 post type-post status-publish format-standard has-post-thumbnail hentry category-exclusive category-features category-pdra-race-coverage" class="zox-post-wrap" itemscope itemtype="http://schema.org/NewsArticle">
														<div class="zox-article-wrap zoxrel left zox100">
						<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/"/>
													<div class="zox-post-top-wrap zoxrel left zox100">
																	<div class="zox-post-title-wrap zox-tit2">
										<div class="zox-post-width">
											<header class="zox-post-head-wrap left zoxrel zox100">
	<div class="zox-post-head zoxrel">
		<h3 class="zox-post-cat">
			<a class="zox-post-cat-link" href="https://dragillustrated.com/category/exclusive/"><span class="zox-post-cat">Exclusive</span></a>
		</h3>
		<h1 class="zox-post-title left entry-title" itemprop="headline">Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way</h1>
				<div class="zox-post-info-wrap">
							<div class="zox-post-byline-wrap">
					<div class="zox-author-thumb">
						<img alt='' src='https://secure.gravatar.com/avatar/7ef2bd3121d8ee25ecf7cdcdd67255a1?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7ef2bd3121d8ee25ecf7cdcdd67255a1?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy'/>					</div><!--zox-author-thumb-->
					<div class="zox-author-info-wrap">
						<div class="zox-author-name-wrap" itemprop="author" itemscope itemtype="https://schema.org/Person">
							<p>By</p><span class="zox-author-name vcard fn author" itemprop="name"><a href="https://dragillustrated.com/author/nate/" title="Posts by Nate Van Wagnen" rel="author">Nate Van Wagnen</a></span>
						</div><!--zox-author-name-wrap-->
						<div class="zox-post-date-wrap">
							<p>Published</p> <span class="zox-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-04-05">2 seconds ago</time></span>
							<meta itemprop="dateModified" content="2022-04-01"/>
						</div><!--zox-post-date-wrap-->
					</div><!--zox-author-info-wrap-->
				</div><!--zox-post-byline-wrap-->
						<div class="zox-post-soc-top-wrap">
																<div class="zox-post-soc-stat">
		<ul class="zox-post-soc-stat-list left zoxrel">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&amp;t=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 			<li class="zox-post-soc-fb">
 				<i class="fab fa-facebook-f"></i>
 			</li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way -&amp;url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 			<li class="zox-post-soc-twit">
 				<i class="fab fa-twitter"></i>
 			</li>
 			</a>
 			<li class="zox-post-soc-copy">
			 	<i class="fas fa-link"></i>
 			</li>
 			 			<li class="zox-post-soc-more zox-soc-stat-click-49931">
				<i class="fas fa-ellipsis-h"></i>
				<div class="zox-soc-more-stat zox-more-click-49931">
					<ul class="zox-soc-more-list">
						<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
							<li class="zox-post-soc-flip">
								<p>Flipboard</p>
								<i class="fab fa-flipboard"></i>
							</li>
						</a>
						<a href="#" onclick="window.open('https://www.reddit.com/submit?url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&title=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way', 'redditShare', 'width=626,height=436'); return false;" title="Share on Reddit">
							<li class="zox-post-soc-redd">
								<p>Reddit</p>
								<i class="fab fa-reddit-alien"></i>
							</li>
						</a>
						<a href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/&amp;media=https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834.jpg&amp;description=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
							<li class="zox-post-soc-pin">
								<p>Pinterest</p>
								<i class="fab fa-pinterest-p" aria-hidden="true"></i>
							</li>
						</a>
						<a class="zox-whats-main" href="https://web.whatsapp.com/send?text=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">
							<li class="zox-post-soc-what">
								<p>Whatsapp</p>
								<i class="fab fa-whatsapp"></i>
							</li>
						</a>
						<a class="zox-whats-mob" href="whatsapp://send?text=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">
							<li class="zox-post-soc-what">
								<p>Whatsapp</p>
								<i class="fab fa-whatsapp"></i>
							</li>
						</a>
						<a href="mailto:?subject=Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">
							<li class="zox-post-soc-email">
								<p>Email</p>
								<i class="fas fa-envelope"></i>
							</li>
 						</a>
					</ul>
				</div><!--zox-soc-more-stat-->
 			</li>
 		</ul>
	</div><!--zox-post-soc-stat-->
 												</div><!--zox-post-soc-top-wrap-->
		</div><!--zox-post-info-wrap-->
	</div><!--zox-post-head-->
</header><!--zox-post-head-wrap-->										</div><!--zox-post-width-->
									</div><!--zox-post-title-wrap-->
																																							</div><!--zox-post-top-wrap-->
												<div class="zox-post-main-grid">
							<div class="zox-post-width">
								<div class="zox-post-main-wrap zoxrel left zox100">
									<div class="zox-post-main">
																					<div class="zox-post-bot-wrap">
																																																	<div class="zox-post-img-wrap">
																				<div class="zox-post-img left zoxrel zoxlh0" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
				<img width="1800" height="1200" src="https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834.jpg" class="flipboard-image wp-post-image" alt="" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834.jpg 1800w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834-1200x800.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834-1536x1024.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834-600x400.jpg 600w" sizes="(max-width: 1800px) 100vw, 1800px" />								<meta itemprop="url" content="https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_1834.jpg">
				<meta itemprop="width" content="1800">
				<meta itemprop="height" content="1200">
			</div><!--zox-post-img-->
							<span class="zox-post-img-cap"></span>
																</div><!--zox-post-img-wrap-->
																																			</div><!--zox-post-bot-wrap-->
																				<div class="zox-post-body-wrap left zoxrel">
	<div class="zox-post-body left zoxrel zox100">
		<div id="tps_slideContainer_49931" class="theiaPostSlider_slides"><div class="theiaPostSlider_preloadedSlide">

<p><!-- BEGIN THEIA POST SLIDER -->
<p>When the PDRA launched its Pro Street class as a three-race trial in 2020, the class allowed drag radials or slicks to attract racers from multiple different small-tire classes. But after a reworking of the rules for 2021, the category’s first year as a PDRA world championship category, Pro Street has found its new purpose: reviving the slicks-only, original Outlaw 10.5-style racing that was so popular with fans and racers.
<p>The plan is working, as several new participants are expected to join the class this season. The class will also race with new backing from title sponsor Menscer Motorsports and presenting sponsor AFCO.
<p><i>[Editor&#8217;s Note: This story originally appeared in DI #175, the Outlaw Issue, in March/April of 2022. Photos by Tara Bowker.]</i>
<p>For racers like Tim Essick, the defending world champion and a vocal proponent of the class, the increase in participation is exactly what he wants to see as he looks to go back to back in his ProCharger-boosted “Brown Sugar” ’18 Mustang.
<p>“There was a small, core group of guys that we had in the class last year and we&#8217;re all great friends,” Essick begins, “but the whole meaning behind this class is trying to revive Outlaw 10.5-style racing and grow the class. The more people we can get, the better off the whole show is.”
<p>Jesse Lambert, who finished second behind Essick, agrees that the class is heading in the right direction.
<p>“Back when Tyler [Crossnoe, PDRA race director] and I were talking about trying to implement the class into PDRA, I think we all agreed three years was the mark,” Lambert says. “The first year we got a good following, a stable base, and it grew last year. Honestly, what we&#8217;re seeing right now is what I was hoping would happen. Last year, let&#8217;s say we had 6-8 cars at each race. I&#8217;m hoping we can get 10-12 at each race and have a couple races where we have a full 16-car field.”
<div id="attachment_49934" style="width: 1010px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-49934" loading="lazy" class="size-thumbnail wp-image-49934" src="https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_5543-1000x667.jpg" alt="" width="1000" height="667" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_5543-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_5543-1200x800.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_5543-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_5543-1536x1024.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_5543-600x400.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_5543.jpg 1800w" sizes="(max-width: 1000px) 100vw, 1000px" /><p id="caption-attachment-49934" class="wp-caption-text">Tim Essick</p></div>
<p>One of the strengths of Pro Street are the limiting factors, which include factory wheelbase guidelines. But the max tire size – 33&#215;10.5W bias ply slicks – is what really makes Pro Street so attractive to racers like Essick and Lambert.
<p>“The tire takes away the big budget,” Essick says. “It doesn&#8217;t matter how great your equipment is, how much technology you have, or what resources you have behind you. The limiting factor is that little tire.<div class="zox-post-ad-wrap"><span class="zox-ad-label">Advertisement. Scroll to continue reading.</span><div class="zox-post-ad"><div class="zox-post-ad-in1"><div class="zox-post-ad-in2"><div class="gformba gformba-1"><div class="gformba-single aformba-627"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="NjI3LDEsMSwxMA==" href="http://www.callies.com/" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2020/02/300x-300-banner.jpg" /></a></div></div></div></div></div></div>
<p>“There&#8217;s a more level playing field,” Essick continues. “You&#8217;re always going to have a couple cars that are a little faster than the rest. That&#8217;s going to be in every single class across the board. But there&#8217;s more of a chance for anyone on the property to win on that particular tire than when it&#8217;s a slip or go situation on like a radial.”
<p>Lambert raced on radials from 2004 through 2015 before getting into his current car, a twin-turbocharged ’04 Mustang, to go Outlaw 10.5 racing. He switched back to radials when those tires started to take over Outlaw 10.5, and he believes the slicks-only arrangement in Pro Street is the way to go.
<p>“I think what you saw last year speaks for itself in that it goes back to being a driver and tuner race again,” Lambert says. “When you&#8217;re on radials for a while, you kind of become lazy as a driver. Being back on the 33-inch slicks, you&#8217;ve gotta get back up on the wheel and drive it a little bit. There were races where the whole field was within a tenth or two and the reaction time could make or break every round.”
<p>Beyond the competition aspect, Pro Street is developing a fan following for the exciting passes and the relatability of the cars. There’s just something special about stock-appearing cars with 3,000-horsepower engines charging down the track.
<p>“I think we&#8217;re putting on a good show,” Lambert says. “You have side-by-side, wheels-up passes, and not a lot of wasted passes for the people in the stands. We had many, many people – fans, racers, etc. – come by our pits last year and just tell us how much they loved the class. Fans can relate to the cars.”
<p>The competition level in Pro Street will only get tougher this season with the influx of new talent. Drivers who’ve publicly shared intentions to run Pro Street this year include Bill Lutz, Carmen Damiani, Andrew DeMarco, and Tommy Youmans.
<div id="attachment_49933" style="width: 1010px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-49933" loading="lazy" class="size-thumbnail wp-image-49933" src="https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_5534-1000x667.jpg" alt="" width="1000" height="667" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_5534-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_5534-1200x800.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_5534-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_5534-1536x1024.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_5534-600x400.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/Pro-Street-preview_IMG_5534.jpg 1800w" sizes="(max-width: 1000px) 100vw, 1000px" /><p id="caption-attachment-49933" class="wp-caption-text">Jesse Lambert</p><div class="gformba gformba-3"><div class="gformba-single aformba-714"><center><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="NzE0LDMsMSwxMA==" href="https://vpracingfuels.com/landing/lubricants-vp/?utm_source=dragillustrated&utm_medium=referral&utm_campaign=2022DragIllustrated" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2022/02/1-24-22-Drag-Illustrated-01.jpg" /></a></center><br></div></div></div>
<p>“We’re seeing the names that say they&#8217;re coming and they’re not newbies to racing,” Lambert says. “They&#8217;re very well-known and seasoned racers that are coming out to compete. I think we&#8217;re going to have some very close, competitive, and fast racing this year.”
<p>On the heels of Pro Street’s success in 2021, PDRA has added another small-tire class this season, AFCO Super Street presented by Menscer Motorsports. Numerous racers have already expressed interest in participating in the four-race program, including Essick’s crew chief, Dan Whetstine, who has a ProCharger-boosted small-block ’93 Fox body Mustang.
<p>“It fills a little void for a lot of stuff in our area,” Essick says of Super Street. “There&#8217;s a lot of 28-inch-tire cars. With some local stuff dying down, it gives them an arena to bolt on a set of 28&#215;10.5s and come race somewhere. I think it&#8217;s pretty big. We’ll bring Danny’s car to all of them. It fits perfectly in this class. I think Super Street is going to have as big or a bigger following than Pro Street.”
<p>Pro Street will be contested at six of the eight races on the 2022 PDRA schedule, sitting out the Doorslammer Derby, April 28-30 at Beech Bend Raceway Park and DragWars, Sept. 29-Oct. 1 at GALOT Motorsports Park. Super Street will race at the North vs. South Shootout (June 23-25) at Maryland International Raceway, the Summer Shootout (July 14-16) at Virginia Motorsports Park, the Northern Nationals (August 11-13) at Maple Grove Raceway, and the Brian Olson Memorial World Finals (Oct. 13-16) at VMP.<div class="zox-post-ad-wrap"><span class="zox-ad-label">Advertisement. Scroll to continue reading.</span><div class="zox-post-ad"><div class="zox-post-ad-in1"><div class="zox-post-ad-in2"><div class="gformba gformba-1"><div class="gformba-single aformba-604"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="NjA0LDEsMSwxMA==" href="https://www.holley.com/brands/holley_efi/products/fuel_systems/fuel_injection/dominator_efi/?utm_source=evforum&utm_medium=dragillustrated&utm_campaign=218011" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2022/03/218011_holleyefi_dominator_300x300.jpg" /></a></div></div></div></div></div></div>
<p><!-- END THEIA POST SLIDER -->
</p><div class="gformba gformba-7"><div class="gformba-single aformba-695"><a class="gofollow" data-track="Njk1LDcsMSwxMA==" href="http://redlineoil.com/" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2021/12/40355_RLO_Drag_Illustrated_Digital_Ads_FINAL_728x90.png" /></a></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>

</div></div><div class="theiaPostSlider_footer _footer"></div><div data-theiaPostSlider-sliderOptions='{&quot;slideContainer&quot;:&quot;#tps_slideContainer_49931&quot;,&quot;nav&quot;:[&quot;.theiaPostSlider_nav&quot;],&quot;navText&quot;:&quot;%{currentSlide} of %{totalSlides}&quot;,&quot;helperText&quot;:&quot;Use your \u2190 \u2192 (arrow) keys to browse&quot;,&quot;defaultSlide&quot;:0,&quot;transitionEffect&quot;:&quot;slide&quot;,&quot;transitionSpeed&quot;:400,&quot;keyboardShortcuts&quot;:true,&quot;scrollAfterRefresh&quot;:true,&quot;numberOfSlides&quot;:1,&quot;slides&quot;:[],&quot;useSlideSources&quot;:null,&quot;themeType&quot;:&quot;classic&quot;,&quot;prevText&quot;:&quot;Prev&quot;,&quot;nextText&quot;:&quot;Next&quot;,&quot;buttonWidth&quot;:0,&quot;buttonWidth_post&quot;:0,&quot;postUrl&quot;:&quot;https:\/\/dragillustrated.com\/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way\/&quot;,&quot;postId&quot;:49931,&quot;refreshAds&quot;:false,&quot;refreshAdsEveryNSlides&quot;:1,&quot;adRefreshingMechanism&quot;:&quot;javascript&quot;,&quot;ajaxUrl&quot;:&quot;https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php&quot;,&quot;loopSlides&quot;:false,&quot;scrollTopOffset&quot;:0,&quot;hideNavigationOnFirstSlide&quot;:false,&quot;isRtl&quot;:false,&quot;excludedWords&quot;:[&quot;&quot;]}' 
					 data-theiaPostSlider-onChangeSlide='&quot;&quot;'></div>			</div><!--zox-post-body-->
	<div class="zox-post-body-bot left zoxrel zox100">
		<div class="zox-post-body-width">
			<div class="zox-post-tags left zoxrel zox100">
				<span class="zox-post-tags-header">In this article:</span><span itemprop="keywords"></span>
			</div><!--zox-post-tags-->
						<div class="zox-posts-nav-link">
							</div><!--zox-posts-nav-link-->
						<div class="zox-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
				<div class="zox-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
											<img src="https://dragillustrated.com/wp-content/uploads/2022/03/DragIllustrated_flat_white-150px.png"/>
						<meta itemprop="url" content="https://dragillustrated.com/wp-content/uploads/2022/03/DragIllustrated_flat_white-150px.png">
									</div><!--zox-org-logo-->
				<meta itemprop="name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More">
			</div><!--zox-org-wrap-->
					</div><!--zox-post-body-width-->
	</div><!--zox-post-body-bot-->
</div><!--zox-post-body-wrap-->									</div><!--zox-post-main-->
								</div><!--zox-post-main-wrap-->
							</div><!--zox-post-width-->
						</div><!--zox-post-main-grid-->
																	</div><!--zox-article-wrap-->
						<div class="zox-post-more-wrap left zoxrel zox100">
		<div class="zox-post-width">
			<div class="zox-post-more left zoxrel zox100">
				<div class="zox-post-main-head left zoxrel zox100">
					<h4 class="zox-post-main-title">
						<span class="zox-post-main-title">You May Also Like</span>
					</h4>
				</div><!--zox-widget-main-head-->
									<div class="zox-post-more-grid zox-div4 left zoxrel zox100">
													<div class="zox-art-wrap zoxrel zox-art-mid">
			<div class="zox-art-grid">
			<div class="zox-art-img zoxrel zox100 zoxlh0">
				<a href="https://dragillustrated.com/qa-leah-pruett-dishes-on-four-wide-nationals-admits-gamesmanship-is-doubled/" rel="bookmark">
				<img width="556" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022-1000x606.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022-768x465.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022-660x400.jpg 660w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022-400x242.jpg 400w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022-270x164.jpg 270w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022-600x364.jpg 600w" sizes="(max-width: 556px) 100vw, 556px" />				<img width="100" height="61" src="https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022-1000x606.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022-768x465.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022-660x400.jpg 660w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022-400x242.jpg 400w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022-270x164.jpg 270w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Leah-Pruett-2022-600x364.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" />				</a>
			</div><!--zox-art-img-->
			<div class="zox-art-text">
	<div class="zox-art-text-cont">
					<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
				<div class="zox-art-title">
			<a href="https://dragillustrated.com/qa-leah-pruett-dishes-on-four-wide-nationals-admits-gamesmanship-is-doubled/" rel="bookmark">
			<h2 class="zox-s-title2">Q&#038;A: Leah Pruett Dishes on Four-Wide Nationals, Admits Gamesmanship is Doubled</h2>
			</a>
		</div><!--zox-art-title-->
		<p class="zox-s-graph">Only 48-hours prior to the kickoff of the NHRA&#8217;s first of two Four-Wide Nationals &#8211; the first coming this weekend at the luxurious Las...</p>
		<div class="zox-byline-wrap">
			<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>6 days ago</span>
		</div><!--zox-byline-wrap-->
	</div><!--zox-art-text-cont-->
</div><!--zox-art-text-->		</div><!--zox-art-grid-->
	</div><!--zox-art-wrap-->													<div class="zox-art-wrap zoxrel zox-art-mid">
			<div class="zox-art-grid">
			<div class="zox-art-img zoxrel zox100 zoxlh0">
				<a href="https://dragillustrated.com/lights-out-v-movers-shakers/" rel="bookmark">
				<img width="506" height="337" src="https://dragillustrated.com/wp-content/uploads/2014/02/DSC_1839.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2014/02/DSC_1839.jpg 600w, https://dragillustrated.com/wp-content/uploads/2014/02/DSC_1839-300x200.jpg 300w" sizes="(max-width: 506px) 100vw, 506px" />				<img width="100" height="67" src="https://dragillustrated.com/wp-content/uploads/2014/02/DSC_1839.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2014/02/DSC_1839.jpg 600w, https://dragillustrated.com/wp-content/uploads/2014/02/DSC_1839-300x200.jpg 300w" sizes="(max-width: 100px) 100vw, 100px" />				</a>
			</div><!--zox-art-img-->
			<div class="zox-art-text">
	<div class="zox-art-text-cont">
					<h3 class="zox-s-cat"><span class="zox-s-cat">Race Coverage</span></h3>
				<div class="zox-art-title">
			<a href="https://dragillustrated.com/lights-out-v-movers-shakers/" rel="bookmark">
			<h2 class="zox-s-title2">Movers &amp; Shakers: The People Who Make Lights Out</h2>
			</a>
		</div><!--zox-art-title-->
		<p class="zox-s-graph">Scotty G and Paul from Induction Solutions talk a little laughing gas in the staging lanes. ADVERTISEMENT</p>
		<div class="zox-byline-wrap">
			<span class="zox-byline-name"></span><span class="zox-byline-date"><i class="far fa-clock"></i>February 23, 2014</span>
		</div><!--zox-byline-wrap-->
	</div><!--zox-art-text-cont-->
</div><!--zox-art-text-->		</div><!--zox-art-grid-->
	</div><!--zox-art-wrap-->													<div class="zox-art-wrap zoxrel zox-art-mid">
			<div class="zox-art-grid">
			<div class="zox-art-img zoxrel zox100 zoxlh0">
				<a href="https://dragillustrated.com/top-fuel-star-brittany-force-talks-fast-approaching-four-wide-nationals/" rel="bookmark">
				<img width="556" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022-1000x606.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022-768x465.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022-660x400.jpg 660w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022-400x242.jpg 400w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022-270x164.jpg 270w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022-600x364.jpg 600w" sizes="(max-width: 556px) 100vw, 556px" />				<img width="100" height="61" src="https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022-1000x606.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022-768x465.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022-660x400.jpg 660w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022-400x242.jpg 400w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022-270x164.jpg 270w, https://dragillustrated.com/wp-content/uploads/2022/03/DI-Brittany-Force-2022-600x364.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" />				</a>
			</div><!--zox-art-img-->
			<div class="zox-art-text">
	<div class="zox-art-text-cont">
					<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
				<div class="zox-art-title">
			<a href="https://dragillustrated.com/top-fuel-star-brittany-force-talks-fast-approaching-four-wide-nationals/" rel="bookmark">
			<h2 class="zox-s-title2">Top Fuel Star Brittany Force Talks Fast-Approaching Four-Wide Nationals</h2>
			</a>
		</div><!--zox-art-title-->
		<p class="zox-s-graph">Brittany Force is a big fan of one of the most unique races in motorsports, but the Top Fuel star also recognizes the challenges...</p>
		<div class="zox-byline-wrap">
			<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>March 28, 2022</span>
		</div><!--zox-byline-wrap-->
	</div><!--zox-art-text-cont-->
</div><!--zox-art-text-->		</div><!--zox-art-grid-->
	</div><!--zox-art-wrap-->													<div class="zox-art-wrap zoxrel zox-art-mid">
			<div class="zox-art-grid">
			<div class="zox-art-img zoxrel zox100 zoxlh0">
				<a href="https://dragillustrated.com/pruett-j-force-and-stanfield-race-to-provisional-no-1-spots-at-nhra-four-wide-nationals/" rel="bookmark">
				<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/Pruett_MG-600x337.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/Pruett_MG-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/Pruett_MG-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" />				<img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/04/Pruett_MG-100x100.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/Pruett_MG-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/04/Pruett_MG-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" />				</a>
			</div><!--zox-art-img-->
			<div class="zox-art-text">
	<div class="zox-art-text-cont">
					<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
				<div class="zox-art-title">
			<a href="https://dragillustrated.com/pruett-j-force-and-stanfield-race-to-provisional-no-1-spots-at-nhra-four-wide-nationals/" rel="bookmark">
			<h2 class="zox-s-title2">Pruett, J. Force and Stanfield Race to Provisional No. 1 Spots at NHRA Four-Wide Nationals</h2>
			</a>
		</div><!--zox-art-title-->
		<p class="zox-s-graph">Top Fuel star Leah Pruett finished Friday in impressive fashion at The Strip at Las Vegas Motor Speedway, picking up the provisional No. 1...</p>
		<div class="zox-byline-wrap">
			<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>3 days ago</span>
		</div><!--zox-byline-wrap-->
	</div><!--zox-art-text-cont-->
</div><!--zox-art-text-->		</div><!--zox-art-grid-->
	</div><!--zox-art-wrap-->											</div><!--zox-post-more-grid-->
							</div><!--zox-post-more-->
		</div><!--zox-post-width-->
	</div><!--zox-post-more-wrap-->
	<div class="zox-post-bot-ad left zoxrel zox100 zox-lh0">
		<span class="zox-ad-label">Advertisement</span>
		<div class="gformba gformba-1"><div class="gformba-single aformba-689"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="Njg5LDEsMSwxMA==" href="https://www.fram.com/for-the-road-ahead-landing-page/?utm_source=caranddriver&utm_medium=banner&utm_campaign=theroadahead&utm_term=diy&utm_content=animated_banner" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2021/10/2021-0930-WEB-300x300-Fast-Furious-2.gif" /></a></div></div>	</div><!--zox-post-bot-ad-->

    <script type="text/javascript">
	jQuery(document).ready(function($) {
  		$(".zox-soc-stat-click-49931").on("click", function(){
	  		$(".zox-more-click-49931").toggleClass("zox-soc-more-open");
  		});
	});
    </script>							</article><!--zox-post-wrap-->
		</div><!--zox-auto-post-main-->
			</div><!--zox-auto-post-grid-->
</div><!--zox-alp-width-->							</div><!--zox-main-body-wrap-->
							<footer id="zox-foot-wrap" class="left zoxrel zox100">
								<div class="zox-head-width">
									<div class="zox-foot-grid left zoxrel zox100">
										<div class="zox-foot-left-wrap">
											<div class="zox-foot-logo left zox-lh0">
																									<a href="https://dragillustrated.com/"><img src="https://dragillustrated.com/wp-content/uploads/2022/03/DragIllustrated_flat_white-200px.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
																							</div><!--zox-foot-logo-->
											<div class="zox-foot-left left">
												<div class="zox-foot-menu">
													<div class="menu-about-di-container"><ul id="menu-about-di" class="menu"><li id="menu-item-21282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21282"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/">Subscribe</a></li>
<li id="menu-item-15093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15093"><a href="https://dragillustrated.com/about/">About</a></li>
<li id="menu-item-15089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15089"><a href="https://dragillustrated.com/our-team/">Our Team</a></li>
<li id="menu-item-15091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15091"><a href="https://dragillustrated.com/advertise/">Advertise</a></li>
<li id="menu-item-15090" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15090"><a href="https://dragillustrated.com/contact/">Contact</a></li>
</ul></div>												</div><!--zox-foot-menu-->
												<div class="zox-foot-copy">
													<p>Drag Illustrated is not affiliated with, nor is it bound by any sanctioning body or association.<br>
From groundbreaking stories on underground grudge and outlaw racing to in-depth interviews<br>
with world-renowned racers and exclusive event coverage, Drag Illustrated shines the spotlight<br>
on the hottest stories in drag racing.<br>
When drivers, builders, and hardcore fans want the unbiased truth, Drag Illustrated is where they turn.
<br><br>
Copyright © 2022 Drag Illustrated Media, LLC.</p>
												</div><!--zox-foot-copy-->
											</div><!--zox-foot-left-->
										</div><!--zox-foot-left-wrap-->
										<div class="zox-foot-right-wrap">
											<div class="zox-foot-soc right relative">
												<ul class="zox-foot-soc-list left relative">
																											<li><a href="https://www.facebook.com/DragIllustrated/" target="_blank" class="fab fa-facebook-f"></a></li>
																																								<li><a href="https://twitter.com/DragIllustrated" target="_blank" class="fab fa-twitter"></a></li>
																																								<li><a href="https://www.instagram.com/dragillustrated/" target="_blank" class="fab fa-instagram"></a></li>
																																																																																										</ul>
											</div><!--zox-foot-soc-->
										</div><!--zox-foot-right-wrap-->
									</div><!--zox-foot-grid-->
								</div><!--zox-head-width-->
							</footer><!--zox-foot-wrap-->
						</div><!--zox-site-wall-small-->
					</div><!--zox-site-grid-->
				</div><!--zox-site-main-->
			</div><!--zox-site-wall-->
			<div class="zox-fly-top back-to-top">
				<span class="fas fa-angle-up"></span>
			</div><!--zox-fly-top-->
		</div><!--zox-site-->
		<div class="zox-fly-fade zox-fly-but-click">
		</div><!--zox-fly-fade-->
				<div data-theiaStickySidebar-sidebarSelector='".zox-sticky-side"'
		     data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":70,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":1004,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script>	<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
			<!-- Root element of PhotoSwipe. Must have class pswp. -->
		<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">

		    <!-- Background of PhotoSwipe.
		         It's a separate element as animating opacity is faster than rgba(). -->
		    <div class="pswp__bg"></div>

		    <!-- Slides wrapper with overflow:hidden. -->
		    <div class="pswp__scroll-wrap">

		        <!-- Container that holds slides.
		            PhotoSwipe keeps only 3 of them in the DOM to save memory.
		            Don't modify these 3 pswp__item elements, data is added later on. -->
		        <div class="pswp__container">
		            <div class="pswp__item"></div>
		            <div class="pswp__item"></div>
		            <div class="pswp__item"></div>
		        </div>

		        <!-- Default (PhotoSwipeUI_Default) interface on top of sliding area. Can be changed. -->
		        <div class="pswp__ui pswp__ui--hidden">

		            <div class="pswp__top-bar">

		                <!--  Controls are self-explanatory. Order can be changed. -->

		                <div class="pswp__counter"></div>

		                <button class="pswp__button pswp__button--close" title="Close (Esc)"></button>

		                <button class="pswp__button pswp__button--share" title="Share"></button>

		                <button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>

		                <button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>

		                <!-- Preloader demo http://codepen.io/dimsemenov/pen/yyBWoR -->
		                <!-- element will get class pswp__preloader-active when preloader is running -->
		                <div class="pswp__preloader">
		                    <div class="pswp__preloader__icn">
		                      <div class="pswp__preloader__cut">
		                        <div class="pswp__preloader__donut"></div>
		                      </div>
		                    </div>
		                </div>
		            </div>

		            <div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
		                <div class="pswp__share-tooltip"></div>
		            </div>

		            <button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
		            </button>

		            <button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
		            </button>

		            <div class="pswp__caption">
		                <div class="pswp__caption__center"></div>
		            </div>

		        </div>

		    </div>

		</div>
		<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/dragillustrated.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.5.6' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/ResizeSensor.js?ver=1.7.0' id='theia-sticky-sidebar/ResizeSensor.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.7.0' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.7.0' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/zoxpress-plugin//scripts/jquery.sticky-kit.min.js?ver=03a33f7c50641a33c9d3faaacceef61c' id='jquery-sticky-kit-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/zoxpress-plugin//scripts/jquery.waypoints.min.js?ver=03a33f7c50641a33c9d3faaacceef61c' id='jquery-waypoints-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/jquery.nouislider.all.min.js?ver=3.14.2' id='reviewer-nouislider-plugin-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/photoswipe.js?ver=3.14.2' id='reviewer-photoswipe-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/jquery.knob.js?ver=3.14.2' id='reviewer-knob-plugin-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer.public.min.js?ver=3.14.2' id='reviewer-public-script-js'></script>
<script type='text/javascript' id='reviewer-reviews-boxes-script-js-extra'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerRatingObj = {"ajax_nonce":"bbb1aeaad2","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_rating"};
var reviewerJudgeObj = {"ajax_nonce":"6d0e4e0c08","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_like"};
var reviewerQueryURs = {"ajax_nonce":"7cc8b26f83","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer-reviews-boxes.js?ver=3.14.2' id='reviewer-reviews-boxes-script-js'></script>
<script type='text/javascript' id='reviewer-widget-users-reviews-script-js-extra'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerQueryAllURs = {"ajax_nonce":"fc8d2f2236","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_all_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer-widget-users-reviews.js?ver=3.14.2' id='reviewer-widget-users-reviews-script-js'></script>
<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/checkout\/|\/cart\/|\/my-account\/|\/wc-api\/v(.*)|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/dragillustrated.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/zoxcustom.js?ver=03a33f7c50641a33c9d3faaacceef61c' id='zox-custom-js'></script>
<script type='text/javascript' id='zox-custom-js-after'>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</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/scripts.js?ver=03a33f7c50641a33c9d3faaacceef61c' id='zox-scripts-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/retina.js?ver=03a33f7c50641a33c9d3faaacceef61c' id='zox-retina-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/jquery.infinitescroll.min.js?ver=03a33f7c50641a33c9d3faaacceef61c' id='zox-infinitescroll-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/alp.js?ver=03a33f7c50641a33c9d3faaacceef61c' id='zox-alp-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/comment-reply.min.js?ver=03a33f7c50641a33c9d3faaacceef61c' id='comment-reply-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/intersection-observer.js' id='zox-intersection-observer-polyfill-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/lozad.min.js' id='zox-lozad-js'></script>
<script type='text/javascript' id='zox-lozad-js-after'>

	var zoxWidgets = document.querySelectorAll("#zox-home-widget-wrap img");
	lozad(zoxWidgets, {
		rootMargin: "0px 0px",
		loaded: function (el) {
			el.classList.add("is-loaded");
		}
	}).observe();
</script>
<script src='https://stats.wp.com/e-202214.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.7',blog:'37035244',post:'49931',tz:'-5',srv:'dragillustrated.com'} ]);
	_stq.push([ 'clickTrackerInit', '37035244', '49931' ]);
</script>
	</body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1649163633 -->