<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script>window._wca = window._wca || [];</script>

<title>PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season - Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</title>
<link rel="canonical" href="https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season" />
<meta property="og:description" content="The Professional Drag Racers Association’s (PDRA) two newest classes, Menscer Motorsports Pro Street presented by AFCO and AFCO Super Street presented by Menscer Motorsports, will take things to the next level in 2023. As revealed during a driver’s meeting at the recent Drag 965 Summer Shootout presented by Classic Graphix, both classes will race at [&hellip;]" />
<meta property="og:url" content="https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/" />
<meta property="og:site_name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
<meta property="article:publisher" content="https://www.facebook.com/dragillustrated" />
<meta property="article:published_time" content="2022-08-17T15:03:43+00:00" />
<meta property="article:modified_time" content="2022-08-17T14:26:00+00:00" />
<meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo.jpg" />
<meta property="og:image:width" content="1798" />
<meta property="og:image:height" content="1090" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="Nate Van Wagnen" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@dragillustrated" />
<meta name="twitter:site" content="@dragillustrated" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Nate Van Wagnen" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="3 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://dragillustrated.com/#organization","name":"Drag Illustrated","url":"https://dragillustrated.com/","sameAs":["https://www.instagram.com/dragillustrated","https://www.youtube.com/channel/UCbREkYFDiSOs8JCRTsqEMeg","https://www.facebook.com/dragillustrated","https://twitter.com/dragillustrated"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://dragillustrated.com/#/schema/logo/image/","url":"https://dragillustrated.com/wp-content/uploads/2012/03/Drag_Illustrated_Logo_RED.png","contentUrl":"https://dragillustrated.com/wp-content/uploads/2012/03/Drag_Illustrated_Logo_RED.png","width":2150,"height":592,"caption":"Drag Illustrated"},"image":{"@id":"https://dragillustrated.com/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://dragillustrated.com/#website","url":"https://dragillustrated.com/","name":"Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More","description":"","publisher":{"@id":"https://dragillustrated.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://dragillustrated.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/#primaryimage","url":"https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo.jpg","contentUrl":"https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo.jpg","width":1798,"height":1090,"caption":"Nick Agostino (Tara Bowker photos)"},{"@type":"WebPage","@id":"https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/","url":"https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/","name":"PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season - Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More","isPartOf":{"@id":"https://dragillustrated.com/#website"},"primaryImageOfPage":{"@id":"https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/#primaryimage"},"image":{"@id":"https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/#primaryimage"},"thumbnailUrl":"https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo.jpg","datePublished":"2022-08-17T15:03:43+00:00","dateModified":"2022-08-17T14:26:00+00:00","breadcrumb":{"@id":"https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/"]}]},{"@type":"BreadcrumbList","@id":"https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://dragillustrated.com/"},{"@type":"ListItem","position":2,"name":"PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season"}]},{"@type":"Article","@id":"https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/#article","isPartOf":{"@id":"https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/"},"author":{"name":"Nate Van Wagnen","@id":"https://dragillustrated.com/#/schema/person/39dbc8e6c713b844fd9037046110f529"},"headline":"PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season","datePublished":"2022-08-17T15:03:43+00:00","dateModified":"2022-08-17T14:26:00+00:00","mainEntityOfPage":{"@id":"https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/"},"wordCount":638,"publisher":{"@id":"https://dragillustrated.com/#organization"},"image":{"@id":"https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/#primaryimage"},"thumbnailUrl":"https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo.jpg","articleSection":["News","PDRA"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://dragillustrated.com/#/schema/person/39dbc8e6c713b844fd9037046110f529","name":"Nate Van Wagnen","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://dragillustrated.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/7ef2bd3121d8ee25ecf7cdcdd67255a1?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/7ef2bd3121d8ee25ecf7cdcdd67255a1?s=96&d=mm&r=g","caption":"Nate Van Wagnen"},"sameAs":["https://dragillustrated.com"],"url":"https://dragillustrated.com/author/nate/"}]}</script>

<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Feed" href="https://dragillustrated.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Comments Feed" href="https://dragillustrated.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; iCal Feed" href="https://dragillustrated.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season Comments Feed" href="https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/feed/" />

<script src="//www.googletagmanager.com/gtag/js?id=UA-21052018-1" data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>

<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/dragillustrated.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<script id="dragi-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://dragillustrated.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://dragillustrated.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://dragillustrated.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css' href='https://dragillustrated.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-vendors-style.css?ver=7.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css' href='https://dragillustrated.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-style.css?ver=7.8.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-css' href='https://dragillustrated.com/wp-content/plugins/theia-post-slider/css/buttons-red.css?ver=1.15.1' type='text/css' media='all' />
<link rel='stylesheet' id='ql-jquery-ui-css' href='//ajax.googleapis.com/ajax/libs/jqueryui/1.12.1/themes/smoothness/jquery-ui.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-photoswipe-css' href='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/css/photoswipe.css?ver=3.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://dragillustrated.com/wp-includes/css/dashicons.min.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-public-css' href='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/css/reviewer-public.css?ver=3.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='zox-custom-style-css' href='https://dragillustrated.com/wp-content/themes/zoxpress/style.css?ver=6.0.1' type='text/css' media='all' />
<style id='zox-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='fontawesome-child-css' href='https://use.fontawesome.com/releases/v5.5.0/css/all.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='zox-custom-child-style-css' href='https://dragillustrated.com/wp-content/themes/zoxpress-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://dragillustrated.com/wp-content/themes/zoxpress-child/font-awesome/css/all.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='zox-fonts-css' href='//fonts.googleapis.com/css?family=Heebo%3A300%2C400%2C500%2C700%2C800%2C900%7CAlegreya%3A400%2C500%2C700%2C800%2C900%7CJosefin+Sans%3A300%2C400%2C600%2C700%7CLibre+Franklin%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CFrank+Ruhl+Libre%3A300%2C400%2C500%2C700%2C900%7CNunito+Sans%3A300%2C400%2C600%2C700%2C800%2C900%7CMontserrat%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CAnton%3A400%7CNoto+Serif%3A400%2C700%7CNunito%3A300%2C400%2C600%2C700%2C800%2C900%7CRajdhani%3A300%2C400%2C500%2C600%2C700%7CTitillium+Web%3A300%2C400%2C600%2C700%2C900%7CPT+Serif%3A400%2C400i%2C700%2C700i%7CAmiri%3A400%2C400i%2C700%2C700i%7COswald%3A300%2C400%2C500%2C600%2C700%7CRoboto+Mono%3A400%2C700%7CBarlow+Semi+Condensed%3A700%2C800%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto+Condensed%3A300%2C400%2C700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7CPT+Serif%3A400%2C700%7COpen+Sans+Condensed%3A300%2C700%7COpen+Sans%3A700%7CSource+Serif+Pro%3A400%2C600%2C700%7CIM+Fell+French+Canon%3A400%2C400i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' type='text/css' media='all' />
<link rel='stylesheet' id='zox-media-queries-css' href='https://dragillustrated.com/wp-content/themes/zoxpress/css/media-queries.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://dragillustrated.com/wp-content/tablepress-combined.min.css?ver=41' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://dragillustrated.com/wp-content/plugins/jetpack/css/jetpack.css?ver=11.2' type='text/css' media='all' />
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/exactmetrics-premium/assets/js/frontend-gtag.min.js?ver=7.7.0' id='exactmetrics-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='exactmetrics-frontend-script-js-extra'>/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/dragillustrated.com","hash_tracking":"false","ua":"UA-21052018-1","v4_id":""};/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/balupton-history.js/jquery.history.js?ver=1.7.1' id='history.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/async.min.js?ver=14.09.2014' id='async.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/tps.js?ver=1.15.1' id='theiaPostSlider/theiaPostSlider.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/main.js?ver=1.15.1' id='theiaPostSlider/main.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/tps-transition-slide.js?ver=1.15.1' id='theiaPostSlider/transition.js-js'></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.34.0' id='advanced-ads-advanced-js-js'></script>
<script defer type='text/javascript' src='https://stats.wp.com/s-202233.js' id='woocommerce-analytics-js'></script>
<link rel="https://api.w.org/" href="https://dragillustrated.com/wp-json/" /><link rel="alternate" type="application/json" href="https://dragillustrated.com/wp-json/wp/v2/posts/52734" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dragillustrated.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dragillustrated.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.1" />
<meta name="generator" content="WooCommerce 6.7.0" />
<link rel='shortlink' href='https://wp.me/p2voyE-dIy' />
<link rel="alternate" type="application/json+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Fpdra-announces-upgrades-to-pro-street-super-street-for-2023-season%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Fpdra-announces-upgrades-to-pro-street-super-street-for-2023-season%2F&#038;format=xml" />
<script type="text/javascript" src="https://paywall.subscriptiongenius.com/load.js"></script>


<script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window, document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init', '634980329980573');fbq('track', 'PageView');</script><noscript><img height="1" width="1" style="display:none"src="https://www.facebook.com/tr?id=634980329980573&ev=PageView&noscript=1"/></noscript>


<style type="text/css">
			.wpsdc-drop-cap {
				float : left;				
				padding : 0.25em 0.05em 0.25em 0;				
				font-size : 5em;
				line-height : 0.4em;color : #0a0a0a;}
		</style> <meta name="theme-color" content="#000" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo-1024x576.jpg" />
<meta name="twitter:image" content="https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo-1024x576.jpg" />
<meta property="og:url" content="https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/" />
<meta property="og:title" content="PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season" />
<meta property="og:description" content="The Professional Drag Racers Association’s (PDRA) two newest classes, Menscer Motorsports Pro Street presented by AFCO and AFCO Super Street presented by Menscer Motorsports, will take things to the next level in 2023. As revealed during a driver’s meeting at the recent Drag 965 Summer Shootout presented by Classic Graphix, both classes will race at [&hellip;]" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:url" content="https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/">
<meta name="twitter:title" content="PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season">
<meta name="twitter:description" content="The Professional Drag Racers Association’s (PDRA) two newest classes, Menscer Motorsports Pro Street presented by AFCO and AFCO Super Street presented by Menscer Motorsports, will take things to the next level in 2023. As revealed during a driver’s meeting at the recent Drag 965 Summer Shootout presented by Classic Graphix, both classes will race at [&hellip;]">
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://dragillustrated.com"><link rel="alternate" href="https://dragillustrated.com/wp-json/tribe/events/v1/" /><script type="text/javascript">
		;var advadsCfpExpHours = 1;
		var advadsCfpClickLimit = 8;
		var advadsCfpBan = 1;
		var advadsCfpPath = '';
		var advadsCfpDomain = '';
		</script><script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
<style>img#wpstats{display:none}</style>
<link rel="pingback" href="https://dragillustrated.com/xmlrpc.php"> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
<link rel="icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-180x180.png" />
<meta name="msapplication-TileImage" content="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-270x270.png" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-52734 single-format-standard custom-background wp-embed-responsive theme-zoxpress theiaPostSlider_body woocommerce-no-js tribe-no-js zox-sport2 zox-s6 elementor-default elementor-kit-42099 aa-prefix-dragi-">
<div id="zox-site" class="left zoxrel ">
<div id="zox-fly-wrap">
<div id="zox-fly-menu-top" class="left relative">
<div id="zox-fly-logo" class="left relative">
<a href="https://dragillustrated.com/"><img src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
</div>
<div class="zox-fly-but-wrap zox-fly-but-menu zox-fly-but-click">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</div>
<div id="zox-fly-menu-wrap">
<nav class="zox-fly-nav-menu left relative">
<div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-49701" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49701"><a href="https://dragillustrated.com/category/news/">News</a></li>
<li id="menu-item-49702" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-49702"><a href="https://dragillustrated.com/category/race-coverage/">Race Coverage</a></li>
<li id="menu-item-49703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49703"><a href="https://dragillustrated.com/category/tech/">Tech</a></li>
<li id="menu-item-52430" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52430"><a href="https://dragillustrated.com/category/thewesbuckshow/">The Wes Buck Show</a></li>
<li id="menu-item-15094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" rel="noopener" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li id="menu-item-15102" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
<li id="menu-item-50482" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50482"><a href="https://dragillustrated.com/advertise/">Advertise</a></li>
</ul></div> </nav>
</div>
<div id="zox-fly-soc-wrap">
<span class="zox-fly-soc-head">Connect with us</span>
<ul class="zox-fly-soc-list left relative">
<li><a href="https://www.facebook.com/DragIllustrated" target="_blank" class="fab fa-facebook-f"></a></li>
<li><a href="https://twitter.com/DragIllustrated" target="_blank" class="fab fa-twitter"></a></li>
<li><a href="https://www.instagram.com/dragillustrated" target="_blank" class="fab fa-instagram"></a></li>
<li><a href="https://bit.ly/3y2ogFR" target="_blank" class="fab fa-youtube"></a></li>
</ul>
</div>
</div> <div id="zox-search-wrap">
<div class="zox-search-cont">
<p class="zox-search-p">Hi, what are you looking for?</p>
<div class="zox-search-box">
<form method="get" id="zox-search-form" action="https://dragillustrated.com/">
<input type="text" name="s" id="zox-search-input" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "Search") { this.value = ""; }' />
<input type="submit" id="zox-search-submit" value="Search" />
</form> </div>
</div>
<div class="zox-search-but-wrap zox-search-click">
<span></span>
<span></span>
</div>
</div>
<div id="zox-site-wall" class="left zoxrel">
<div id="zox-lead-top-wrap">
<div id="zox-lead-top-in">
<div id="zox-lead-top">
</div>
</div>
</div>
<div id="zox-site-main" class="left zoxrel">
<header id="zox-main-head-wrap" class="left zoxrel zox-trans-head">
<div id="zox-bot-head-wrap" class="left zoxrel">
<div class="zox-head-width">
<div id="zox-bot-head">
<div id="zox-bot-head-left">
<div class="zox-fly-but-wrap zoxrel zox-fly-but-click">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</div>
<div id="zox-bot-head-mid" class="relative">
<div class="zox-bot-head-logo">
<div class="zox-bot-head-logo-main">
<a href="https://dragillustrated.com/"><img class="zox-logo-stand" src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /><img class="zox-logo-dark" src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
</div>
<h2 class="zox-logo-title">Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</h2>
</div>
<div class="zox-bot-head-menu">
<div class="zox-nav-menu">
<div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49701 zox-mega-drop"><a href="https://dragillustrated.com/category/news/">News</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season</p></a></li><li><a href="https://dragillustrated.com/travis-shumake-drops-narrow-decision-in-debut/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/Travis-Shumake-2022-Topeka-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/Travis-Shumake-2022-Topeka-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/Travis-Shumake-2022-Topeka-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/08/Travis-Shumake-2022-Topeka-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/08/Travis-Shumake-2022-Topeka-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/08/Travis-Shumake-2022-Topeka-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/08/Travis-Shumake-2022-Topeka-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/08/Travis-Shumake-2022-Topeka.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Travis Shumake Drops Narrow Decision in Debut</p></a></li><li><a href="https://dragillustrated.com/neopma-pro-mod-show-joins-mirs-ihra-sportsman-spectacular-weekend/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/NEOPMA_Derek-Ward_Van-Abernethy-photo-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/NEOPMA_Derek-Ward_Van-Abernethy-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/NEOPMA_Derek-Ward_Van-Abernethy-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>NEOPMA Pro Mod Show Joins MIR’s IHRA Sportsman Spectacular Weekend</p></a></li><li><a href="https://dragillustrated.com/rini-tanner-pluchino-stewart-essick-and-whetstine-find-winners-circle-at-pdra-northern-nationals/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/PN_Chris-Rini-4_Tara-Bowker-photo_web-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/PN_Chris-Rini-4_Tara-Bowker-photo_web-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/PN_Chris-Rini-4_Tara-Bowker-photo_web-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Rini, Tanner, Pluchino, Stewart, Essick and Whetstine Find Winner’s Circle at PDRA Northern Nationals</p></a></li><li><a href="https://dragillustrated.com/tasca-iii-salinas-anderson-and-gladstone-pick-up-no-1-qualifiers-at-topeka/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/Tasca_JF-1-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/Tasca_JF-1-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/Tasca_JF-1-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Tasca III, Salinas, Anderson and Gladstone Pick Up No. 1 Qualifiers at Topeka</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-49702 zox-mega-drop"><a href="https://dragillustrated.com/category/race-coverage/">Race Coverage</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season</p></a></li><li><a href="https://dragillustrated.com/after-monumental-win-top-fuels-antron-brown-looks-to-keep-rolling-in-brainerd/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/Brown_JFE-1-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/Brown_JFE-1-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/Brown_JFE-1-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>After Monumental Win, Top Fuel&#8217;s Antron Brown Looks to Keep Rolling in Brainerd</p></a></li><li><a href="https://dragillustrated.com/after-substantial-upgrades-historic-srca-dragstrip-ready-for-another-60-plus-years/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/SRCA_DSC_0216-600x337.jpeg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/SRCA_DSC_0216-600x337.jpeg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/SRCA_DSC_0216-1024x576.jpeg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>After Substantial Upgrades, Historic SRCA Dragstrip Ready for Another 60-Plus Years</p></a></li><li><a href="https://dragillustrated.com/top-fuels-buddy-hull-reflects-on-learning-experience-in-topeka/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/Buddy-Hull-2022-Topeka-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/Buddy-Hull-2022-Topeka-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/Buddy-Hull-2022-Topeka-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/08/Buddy-Hull-2022-Topeka-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/08/Buddy-Hull-2022-Topeka-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/08/Buddy-Hull-2022-Topeka-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/08/Buddy-Hull-2022-Topeka-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/08/Buddy-Hull-2022-Topeka.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Top Fuel&#8217;s Buddy Hull Reflects on &#8220;Learning Experience&#8221; in Topeka</p></a></li><li><a href="https://dragillustrated.com/steve-torrence-runner-up-in-top-fuel-final-during-nhra-series-stop-in-kansas/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/STEVE-TORRENCE-2022-Topeka-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/STEVE-TORRENCE-2022-Topeka-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/STEVE-TORRENCE-2022-Topeka-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/08/STEVE-TORRENCE-2022-Topeka-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/08/STEVE-TORRENCE-2022-Topeka-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/08/STEVE-TORRENCE-2022-Topeka-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/08/STEVE-TORRENCE-2022-Topeka-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/08/STEVE-TORRENCE-2022-Topeka.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Steve Torrence Runner-Up in Top Fuel Final During NHRA Series Stop in Kansas</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49703 zox-mega-drop"><a href="https://dragillustrated.com/category/tech/">Tech</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/stroud-safety-issues-warning-about-fake-sfi-tags/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/Stroud-fake-SFI-tags-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/Stroud-fake-SFI-tags-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/Stroud-fake-SFI-tags-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Stroud Safety Issues Warning About Fake SFI Tags</p></a></li><li><a href="https://dragillustrated.com/stroud-safetys-female-forward-workforce-makes-it-happen/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/Stroud-OKC-3048-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/Stroud-OKC-3048-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/Stroud-OKC-3048-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Stroud Safety&#8217;s Female-Forward Workforce Makes it Happen</p></a></li><li><a href="https://dragillustrated.com/race-winning-brands-continues-growth-into-new-markets/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/CORSA-Intake-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/CORSA-Intake-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/CORSA-Intake-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Race Winning Brands Continues Growth into New Markets</p></a></li><li><a href="https://dragillustrated.com/scoggin-dickey-parts-centers-raceshop-builds-reliability-into-each-engine-for-frank-hawleys-drag-racing-school/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/halweysdyno-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/halweysdyno-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/halweysdyno-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Scoggin Dickey Parts Center’s Raceshop Builds Reliability into Each Engine for Frank Hawley’s Drag Racing School</p></a></li><li><a href="https://dragillustrated.com/race-winning-brands-acquires-haltech/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/05/HalTech-Products-3-1-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/HalTech-Products-3-1-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/HalTech-Products-3-1-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Race Winning Brands Acquires Haltech</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52430 zox-mega-drop"><a href="https://dragillustrated.com/category/thewesbuckshow/">The Wes Buck Show</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/wbs-bob-tasca-antron-brown-marty-robertson-justin-bond-more/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/WBS-EPISODE-270-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/WBS-EPISODE-270-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/WBS-EPISODE-270-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/08/WBS-EPISODE-270-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/08/WBS-EPISODE-270-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/08/WBS-EPISODE-270.jpg 1280w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>WBS: Bob Tasca, Antron Brown, Marty Robertson, Justin Bond &#038; More</p></a></li><li><a href="https://dragillustrated.com/wbs-no-prep-kings-take-tulsa-nhra-returns-to-topeka-big-dog-shootout-more/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/WBS-EPISODE-269-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/WBS-EPISODE-269-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/WBS-EPISODE-269-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/08/WBS-EPISODE-269-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/08/WBS-EPISODE-269-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/08/WBS-EPISODE-269.jpg 1280w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>WBS: No Prep Kings Take Tulsa, NHRA Returns to Topeka, Big Dog Shootout &#038; More</p></a></li><li><a href="https://dragillustrated.com/wbs-tony-schumacher-troy-coughlin-jr-tony-gillig-ihra-news-more/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/WBS-Featured-Post-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/WBS-Featured-Post-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/WBS-Featured-Post-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/08/WBS-Featured-Post-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/08/WBS-Featured-Post-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/08/WBS-Featured-Post-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/08/WBS-Featured-Post-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/08/WBS-Featured-Post.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>WBS: Tony Schumacher, Troy Coughlin Jr., Tony Gillig, IHRA News &#038; More</p></a></li><li><a href="https://dragillustrated.com/the-wes-buck-show-ep-26-nhra-pro-mod-start-promoters-tracks-efforts-during-covid/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2020/07/ep-27-feature-image-scaled.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2020/07/ep-27-feature-image-scaled.jpg 2560w, https://dragillustrated.com/wp-content/uploads/2020/07/ep-27-feature-image-1320x740.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2020/07/ep-27-feature-image-2000x1121.jpg 2000w, https://dragillustrated.com/wp-content/uploads/2020/07/ep-27-feature-image-768x430.jpg 768w, https://dragillustrated.com/wp-content/uploads/2020/07/ep-27-feature-image-1536x861.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2020/07/ep-27-feature-image-2048x1147.jpg 2048w, https://dragillustrated.com/wp-content/uploads/2020/07/ep-27-feature-image-600x336.jpg 600w, https://dragillustrated.com/wp-content/uploads/2020/07/ep-27-feature-image-1000x560.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2020/07/ep-27-feature-image-350x196.jpg 350w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>The Wes Buck Show – Ep. 26: Bandimere Battle, NHRA Indy Recap, Promoters &#038; Tracks Efforts During COVID</p></a></li><li><a href="https://dragillustrated.com/the-wes-buck-show-ep-25-state-of-drag-nhra-indy-return-john-force-racing-absence-more/"><div class="zox-mega-img"><img width="600" height="335" src="https://dragillustrated.com/wp-content/uploads/2020/07/EP-25-FB-scaled.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2020/07/EP-25-FB-scaled.jpg 2560w, https://dragillustrated.com/wp-content/uploads/2020/07/EP-25-FB-1320x737.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2020/07/EP-25-FB-2000x1117.jpg 2000w, https://dragillustrated.com/wp-content/uploads/2020/07/EP-25-FB-768x429.jpg 768w, https://dragillustrated.com/wp-content/uploads/2020/07/EP-25-FB-1536x858.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2020/07/EP-25-FB-2048x1144.jpg 2048w, https://dragillustrated.com/wp-content/uploads/2020/07/EP-25-FB-600x335.jpg 600w, https://dragillustrated.com/wp-content/uploads/2020/07/EP-25-FB-1000x559.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2020/07/EP-25-FB-350x196.jpg 350w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>The Wes Buck Show &#8211; Ep. 25: &#8220;State of Drag&#8221;, NHRA Indy Return, John Force Racing Absence &#038; More</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" rel="noopener" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50482"><a href="https://dragillustrated.com/advertise/">Advertise</a></li>
</ul></div> </div>
</div>
</div>
<div id="zox-bot-head-right">
<span class="zox-night zox-night-mode fas fa-moon"></span>
<span class="zox-nav-search-but fas fa-search zox-search-click"></span>
</div>
</div>
</div>
</div> </header>
<div id="zox-site-grid">
<div id="zox-site-wall-small">
<div id="zox-main-body-wrap" class="left relative"> <article id="post-52734" class="post-52734 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-pdra-race-coverage" itemscope itemtype="http://schema.org/NewsArticle">
<div class="zox-article-wrap zoxrel left zox100">
<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/" />
<div class="zox-post-top-wrap zoxrel left zox100">
<div class="zox-post-title-wrap zox-tit2">
<div class="zox-post-width">
<header class="zox-post-head-wrap left zoxrel zox100">
<div class="zox-post-head zoxrel">
<h3 class="zox-post-cat">
<a class="zox-post-cat-link" href="https://dragillustrated.com/category/news/"><span class="zox-post-cat">News</span></a>
</h3>
<h1 class="zox-post-title left entry-title" itemprop="headline">PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season</h1>
<div class="zox-post-info-wrap">
<div class="zox-post-byline-wrap">
<div class="zox-author-thumb">
<img alt='' src='https://secure.gravatar.com/avatar/7ef2bd3121d8ee25ecf7cdcdd67255a1?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7ef2bd3121d8ee25ecf7cdcdd67255a1?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy' /> </div>
<div class="zox-author-info-wrap">
<div class="zox-author-name-wrap" itemprop="author" itemscope itemtype="https://schema.org/Person">
<p>By</p><span class="zox-author-name vcard fn author" itemprop="name"><a href="https://dragillustrated.com/author/nate/" title="Posts by Nate Van Wagnen" rel="author">Nate Van Wagnen</a></span>
</div>
<div class="zox-post-date-wrap">
<p>Published</p> <span class="zox-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-08-17">10 hours ago</time></span>
<meta itemprop="dateModified" content="2022-08-17" />
</div>
</div>
</div>
<div class="zox-post-soc-top-wrap">
<div class="zox-post-soc-stat">
<ul class="zox-post-soc-stat-list left zoxrel">
<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/&amp;t=PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="zox-post-soc-fb">
<i class="fab fa-facebook-f"></i>
</li>
</a>
<a href="#" onclick="window.open('https://twitter.com/share?text=PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season -&amp;url=https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="zox-post-soc-twit">
<i class="fab fa-twitter"></i>
</li>
</a>
<li class="zox-post-soc-copy">
<i class="fas fa-link"></i>
</li>
<li class="zox-post-soc-more zox-soc-stat-click-52734">
<i class="fas fa-ellipsis-h"></i>
<div class="zox-soc-more-stat zox-more-click-52734">
<ul class="zox-soc-more-list">
<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season&url=https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
<li class="zox-post-soc-flip">
<p>Flipboard</p>
<i class="fab fa-flipboard"></i>
</li>
</a>
<a href="#" onclick="window.open('https://www.reddit.com/submit?url=https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/&title=PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season', 'redditShare', 'width=626,height=436'); return false;" title="Share on Reddit">
<li class="zox-post-soc-redd">
<p>Reddit</p>
<i class="fab fa-reddit-alien"></i>
</li>
</a>
<a href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/&amp;media=https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo.jpg&amp;description=PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<li class="zox-post-soc-pin">
<p>Pinterest</p>
<i class="fab fa-pinterest-p" aria-hidden="true"></i>
</li>
</a>
<a class="zox-whats-main" href="https://web.whatsapp.com/send?text=PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a class="zox-whats-mob" href="whatsapp://send?text=PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a href="/cdn-cgi/l/email-protection#06397573646c6365723b564254472647686869736865637526537661746762637526726926567469265572746363722a265573766374265572746363722660697426343634352655636775696820676b763d4449425f3b4f26606973686226726e6f75266774726f656a63266f687263746375726f68612667686226726e6973616e7226696026756e67746f6861266f7226716f726e267f69732826456e63656d266f72266973723c266e727276753c2929627467616f6a6a73757274677263622865696b29766274672b6768686973686563752b73766174676263752b72692b7674692b7572746363722b75737663742b7572746363722b6069742b343634352b75636775696829">
<li class="zox-post-soc-email">
<p>Email</p>
<i class="fas fa-envelope"></i>
</li>
</a>
</ul>
</div>
</li>
</ul>
</div>
</div>
</div>
</div>
</header> </div>
</div>
</div>
<div class="zox-post-main-grid">
<div class="zox-post-width">
<div class="zox-post-main-wrap zoxrel left zox100">
<div class="zox-post-main">
<div class="zox-post-bot-wrap">
<div class="zox-post-img-wrap">
<div class="zox-post-img left zoxrel zoxlh0" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
<img width="1798" height="1090" src="https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo.jpg" class="flipboard-image wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo.jpg 1798w, https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo-1320x800.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo-1000x606.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo-768x466.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo-1536x931.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo-600x364.jpg 600w" sizes="(max-width: 1798px) 100vw, 1798px" /> <meta itemprop="url" content="https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo.jpg">
<meta itemprop="width" content="1798">
<meta itemprop="height" content="1090">
</div>
<span class="zox-post-img-cap">Nick Agostino (Tara Bowker photos)</span>
</div>
</div>
<div class="zox-post-body-wrap left zoxrel">
<div class="zox-post-body left zoxrel zox100">
<div id="tps_slideContainer_52734" class="theiaPostSlider_slides"><div class="theiaPostSlider_preloadedSlide">
<div class="dragi-ec4dc38a7b58110f86000955f3f3d43c dragi-leaderboard-post-inject" id="dragi-ec4dc38a7b58110f86000955f3f3d43c"></div><p>
<p style="font-weight: 400;">The Professional Drag Racers Association’s (PDRA) two newest classes, Menscer Motorsports Pro Street presented by AFCO and AFCO Super Street presented by Menscer Motorsports, will take things to the next level in 2023.
<p style="font-weight: 400;">As revealed during a driver’s meeting at the recent Drag 965 Summer Shootout presented by Classic Graphix, both classes will race at six points races as well as the third annual Summit Racing Equipment PDRA ProStars race in 2023. Super Street, in a trial phase this season, will race for a world championship next year.
<p style="font-weight: 400;">“Pro Street and Super Street have earned these opportunities for the 2023 season,” said Tyler Crossnoe, series director, PDRA. “Pro Street has continued to grow in terms of participation and the competition level. We introduced Super Street this year, and it’s already exceeding expectations just three races in. Racers have shown us there’s interest in these classes, and we’re proud to give them even more to look forward to in 2023.”
<p style="font-weight: 400;">Pro Street is a revival of the original Outlaw 10.5 class, with limiting factors that include factory wheelbase guidelines and a max tire size of 33×10.5W bias ply slicks. Tim Essick earned the first-ever PDRA Pro Street world championship last season in his ProCharger-boosted “Brown Sugar” ’18 Mustang. The class has seen three different winners in five races this season, with Bill Riddle joining two-time winners Ty Kasper and Essick. Canada’s Nick Agostino has qualified No. 1 at four races, and he’s still chasing his first win.
<p style="font-weight: 400;">“We really appreciate the opportunity to come and race,” Agostino said. “We love racing with PDRA. They put on a great venue. The Pro Street class is just going to keep growing. There&#8217;s a bunch of cars and teams that I know are coming out, they just haven&#8217;t found their way yet or they&#8217;re not ready. I think this class is going to do great things in the future. Looking forward to sticking with it.”
<p style="font-weight: 400;">Super Street was introduced this season as a slick-tire option for racers from numerous different small-tire classes. With no wheelie bars and a max tire size of 28&#215;10.5” non-W bias ply slicks, Super Street has seen thrilling and unpredictable racing at its first three of four races. Ultra Street racer Wes Ervin qualified No. 1 and won the first race at Maryland, then X275 star Ron Rhodes put the class on notice with his No. 1 qualifying and winning performance at Virginia. Dan Whetstine recently became the third different Super Street winner at Maple Grove.
<p><img loading="lazy" class="aligncenter size-medium wp-image-52736" src="https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Ron-Rhodes_Tara-Bowker-photo-1300x800.jpg" alt="" width="1300" height="800" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Ron-Rhodes_Tara-Bowker-photo-1300x800.jpg 1300w, https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Ron-Rhodes_Tara-Bowker-photo-1000x615.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Ron-Rhodes_Tara-Bowker-photo-768x473.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Ron-Rhodes_Tara-Bowker-photo-1536x945.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Ron-Rhodes_Tara-Bowker-photo-600x369.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Ron-Rhodes_Tara-Bowker-photo.jpg 1799w" sizes="(max-width: 1300px) 100vw, 1300px" />
<p style="font-weight: 400;">“I&#8217;ve been trying to find a way to get in [to PDRA] to race,” Rhodes said. “When this class came up, I was like, ‘This has me written all over it.’ With the slicks, I was excited about a new challenge. I can&#8217;t say enough about how great PDRA is. From start to finish, they do a great job. It&#8217;s a pleasure to be here. They really welcomed me in and I really appreciate it.”
<p style="font-weight: 400;">Pro Street will continue to compete at six races in 2023, while Super Street will expand from its current four-race schedule to six races. With a bigger schedule, Super Street will also compete for a PDRA world championship, complete with a championship points fund.<div class="zox-post-ad-wrap"><span class="zox-ad-label">Advertisement. Scroll to continue reading.</span><div class="zox-post-ad"><div class="zox-post-ad-in1"><div class="zox-post-ad-in2"><div class="dragi-852dfe83e01720b95ff84975ee451355" id="dragi-852dfe83e01720b95ff84975ee451355"></div></div></div></div></div>
<p style="font-weight: 400;">Both classes are also set to compete at the 2023 Summit Racing Equipment PDRA ProStars race during Virginia Motorsports Park’s Night of Fire. Both classes will run a four-car shootout, though they could expand to eight cars if season-long participation increases. Racers started earning ProStars points at the recent Summit Racing Equipment Northern Nationals presented by Penske Racing Shocks at Maple Grove Raceway.
<p style="font-weight: 400;">The 2023 schedule for Pro Street and Super Street will be released later this season along with the complete 2023 PDRA schedule.
<p style="font-weight: 400;">For more information on PDRA Pro Street and Super Street, visit <a href="http://www.pdra660.com/">www.PDRA660.com</a>.
<p>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>
</div></div><div class="theiaPostSlider_footer _footer"></div><div data-theiaPostSlider-sliderOptions='{&quot;slideContainer&quot;:&quot;#tps_slideContainer_52734&quot;,&quot;nav&quot;:[&quot;.theiaPostSlider_nav&quot;],&quot;navText&quot;:&quot;%{currentSlide} of %{totalSlides}&quot;,&quot;helperText&quot;:&quot;Use your \u2190 \u2192 (arrow) keys to browse&quot;,&quot;defaultSlide&quot;:0,&quot;transitionEffect&quot;:&quot;slide&quot;,&quot;transitionSpeed&quot;:400,&quot;keyboardShortcuts&quot;:true,&quot;scrollAfterRefresh&quot;:true,&quot;numberOfSlides&quot;:1,&quot;slides&quot;:[],&quot;useSlideSources&quot;:null,&quot;themeType&quot;:&quot;classic&quot;,&quot;prevText&quot;:&quot;Prev&quot;,&quot;nextText&quot;:&quot;Next&quot;,&quot;buttonWidth&quot;:0,&quot;buttonWidth_post&quot;:0,&quot;postUrl&quot;:&quot;https:\/\/dragillustrated.com\/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season\/&quot;,&quot;postId&quot;:52734,&quot;refreshAds&quot;:false,&quot;refreshAdsEveryNSlides&quot;:1,&quot;adRefreshingMechanism&quot;:&quot;javascript&quot;,&quot;ajaxUrl&quot;:&quot;https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php&quot;,&quot;loopSlides&quot;:false,&quot;scrollTopOffset&quot;:0,&quot;hideNavigationOnFirstSlide&quot;:false,&quot;isRtl&quot;:false,&quot;excludedWords&quot;:[&quot;&quot;]}' data-theiaPostSlider-onChangeSlide='&quot;&quot;'></div> </div>
<div class="zox-post-body-bot left zoxrel zox100">
<div class="zox-post-body-width">
<div class="zox-post-tags left zoxrel zox100">
<span class="zox-post-tags-header">In this article:</span><span itemprop="keywords"></span>
</div>
<div class="zox-posts-nav-link">
</div>
<div class="zox-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<div class="zox-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<img src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" />
<meta itemprop="url" content="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg">
</div>
<meta itemprop="name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More">
</div>
</div>
</div>
</div> </div>
<div class="zox-post-side-wrap zox-post-side-noalp zoxrel zox-sticky-side">
<div id="zox-side-wrap" class="zoxrel zox-divs">
<div id="zox_ad_widget-13" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
<div class="dragi-e18a0fe4d1125d91c3c812260e28b8c8" id="dragi-e18a0fe4d1125d91c3c812260e28b8c8"></div> </div>
</div><div id="zox_ad_widget-14" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
<div class="dragi-c9c49960f1a81db56fd66aa474676679" id="dragi-c9c49960f1a81db56fd66aa474676679"></div> </div>
</div><div id="zox_ad_widget-15" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
<div class="dragi-52d03ea69434e6cce0bda2f82ad7c8a0" id="dragi-52d03ea69434e6cce0bda2f82ad7c8a0"></div> </div>
</div><div id="zox_ad_widget-16" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
<div class="dragi-7dec211f29e842ffb2da5b384f223b3b" id="dragi-7dec211f29e842ffb2da5b384f223b3b"></div> </div>
</div> </div>
</div>
</div>
</div>
</div>
<div class="zox-post-soc-scroll">
<ul class="zox-post-soc-list left zoxrel">
<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/&amp;t=PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="zox-post-soc-fb">
<i class="fab fa-facebook-f"></i>
</li>
</a>
<a href="#" onclick="window.open('https://twitter.com/share?text=PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season -&amp;url=https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="zox-post-soc-twit">
<i class="fab fa-twitter"></i>
</li>
</a>
<li class="zox-post-soc-copy">
<i class="fas fa-link"></i>
</li>
<li class="zox-post-soc-more zox-soc-scroll-click">
<i class="fas fa-ellipsis-h"></i>
<div class="zox-soc-more-scroll">
<ul class="zox-soc-more-list">
<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season&url=https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
<li class="zox-post-soc-flip">
<p>Flipboard</p>
<i class="fab fa-flipboard"></i>
</li>
</a>
<a href="#" onclick="window.open('https://www.reddit.com/submit?url=https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/&title=PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season', 'redditShare', 'width=626,height=436'); return false;" title="Share on Reddit">
<li class="zox-post-soc-redd">
<p>Reddit</p>
<i class="fab fa-reddit-alien"></i>
</li>
</a>
<a href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/&amp;media=https://dragillustrated.com/wp-content/uploads/2022/08/PDRA_Nick-Agostino_Tara-Bowker-photo.jpg&amp;description=PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<li class="zox-post-soc-pin">
<p>Pinterest</p>
<i class="fab fa-pinterest-p" aria-hidden="true"></i>
</li>
</a>
<a class="zox-whats-main" href="https://web.whatsapp.com/send?text=PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a class="zox-whats-mob" href="whatsapp://send?text=PDRA Announces Upgrades to Pro Street, Super Street for 2023 Season https://dragillustrated.com/pdra-announces-upgrades-to-pro-street-super-street-for-2023-season/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a href="/cdn-cgi/l/email-protection#38074b4d5a525d5b4c05687c6a7918795656574d565b5d4b186d485f4a595c5d4b184c5718684a57186b4c4a5d5d4c14186b4d485d4a186b4c4a5d5d4c185e574a180a080a0b186b5d594b57561e595548037a777c610571185e574d565c184c50514b18594a4c515b545d1851564c5d4a5d4b4c51565f1859565c184c50574d5f504c18575e184b50594a51565f18514c184f514c501841574d16187b505d5b5318514c18574d4c0218504c4c484b0217175c4a595f5154544d4b4c4a594c5d5c165b575517485c4a5915595656574d565b5d4b154d485f4a595c5d4b154c5715484a57154b4c4a5d5d4c154b4d485d4a154b4c4a5d5d4c155e574a150a080a0b154b5d594b575617">
<li class="zox-post-soc-email">
<p>Email</p>
<i class="fas fa-envelope"></i>
</li>
</a>
</ul>
</div>
</li>
</ul>
</div>
</div>
<div class="zox-post-more-wrap left zoxrel zox100">
<div class="zox-post-width">
<div class="zox-post-more left zoxrel zox100">
<div class="zox-post-main-head left zoxrel zox100">
<h4 class="zox-post-main-title">
<span class="zox-post-main-title">You May Also Like</span>
</h4>
</div>
<div class="zox-post-more-grid zox-div4 left zoxrel zox100">
<div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/pro-street-legend-tony-christian-passes/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-600x337.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-100x100.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/pro-street-legend-tony-christian-passes/" rel="bookmark">
<h2 class="zox-s-title2">Pro Street Legend Tony Christian Passes</h2>
</a>
</div>
<p class="zox-s-graph">Tony Christian, one of the pioneering drivers of the Pro Street movement, passed away Thursday, June 9. Christian was infamous for his battles with...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>June 9, 2022</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/mwdrs-mourns-loss-of-pro-mod-driver-ronnie-hobbs-at-great-bend-nationals/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-600x337.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-100x100.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/mwdrs-mourns-loss-of-pro-mod-driver-ronnie-hobbs-at-great-bend-nationals/" rel="bookmark">
<h2 class="zox-s-title2">MWDRS Mourns Loss of Pro Mod Driver Ronnie Hobbs at Great Bend Nationals</h2>
</a>
</div>
<p class="zox-s-graph">The Mid-West Drag Racing Series (MWDRS) is saddened over the passing of Pro Mod driver Ronnie Hobbs following an on-track incident during Friday night...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>June 6, 2022</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/leah-pruett-through-the-years/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-600x337.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-100x100.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Exclusive</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/leah-pruett-through-the-years/" rel="bookmark">
<h2 class="zox-s-title2">Leah Pruett Through the Years</h2>
</a>
</div>
<p class="zox-s-graph">Leah Pruett scored the first NHRA Top Fuel win for her and husband Tony Stewart&#8217;s professional drag racing team this past weekend in Denver,...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>July 21, 2022</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/big-money-bracket-racer-sean-serra-dies-at-27/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-600x337.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-100x100.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
 <h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/big-money-bracket-racer-sean-serra-dies-at-27/" rel="bookmark">
<h2 class="zox-s-title2">Big Money Bracket Racer Sean Serra Dies at 27</h2>
</a>
</div>
<p class="zox-s-graph">Drag racer Sean Serra has passed away in a tragic car accident. He was 27 years old. Serra was involved in a single-car rollover...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/kayla-zadel/" title="Posts by Kayla Zadel" rel="author">Kayla Zadel</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>July 7, 2022</span>
</div>
</div>
</div> </div>
</div> </div>
</div>
</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
	jQuery(document).ready(function($) {
  		$(".zox-soc-stat-click-52734").on("click", function(){
	  		$(".zox-more-click-52734").toggleClass("zox-soc-more-open");
  		});
	});
    </script> </article> </div>
<footer id="zox-foot-wrap" class="left zoxrel zox100">
<div class="zox-head-width">
<div class="zox-foot-grid left zoxrel zox100">
<div class="zox-foot-left-wrap">
<div class="zox-foot-logo left zox-lh0">
<a href="https://dragillustrated.com/"><img src="https://dragillustrated.com/wp-content/uploads/2022/03/DragIllustrated_flat_white-200px.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
</div>
<div class="zox-foot-left left">
<div class="zox-foot-menu">
<div class="menu-about-di-container"><ul id="menu-about-di" class="menu"><li id="menu-item-52480" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52480"><a href="https://dragillustrated.com/about-di/">About DI</a></li>
<li id="menu-item-50895" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50895"><a href="https://dragillustrated.com/join-newsletter/?swcfpc=1">Newsletter</a></li>
<li id="menu-item-21282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21282"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/">Subscribe</a></li>
<li id="menu-item-50896" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50896"><a href="https://dragillustrated.com/contact-page">Customer Service</a></li>
<li id="menu-item-50897" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50897"><a href="https://dragillustrated.com/careers">Careers</a></li>
<li id="menu-item-50898" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50898"><a href="https://dragillustrated.com/press-center/">Public Relations</a></li>
<li id="menu-item-50899" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50899"><a href="https://mediakit.dragillustrated.com/">Media Kit</a></li>
<li id="menu-item-50900" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50900"><a href="https://dragillustrated.com/masthead">Masthead</a></li>
</ul></div> </div>
<div class="zox-foot-copy">
<p>Since 2005, DI has informed, inspired and educated drag racers from every walk of the racing life - weekend warrior and street/strip enthusiasts to pro-level doorslammer and Top Fuel racers. From award-winning writing and photography to binge-worthy videos to electric live events, DI meets hundreds of thousands of racers where they live, creating the moments that create conversations.</p>
</div>
</div>
</div>
<div class="zox-foot-right-wrap">
<div class="zox-foot-soc right relative">
<ul class="zox-foot-soc-list left relative">
<li><a href="https://www.facebook.com/DragIllustrated" target="_blank" class="fab fa-facebook-f"></a></li>
<li><a href="https://twitter.com/DragIllustrated" target="_blank" class="fab fa-twitter"></a></li>
<li><a href="https://www.instagram.com/dragillustrated" target="_blank" class="fab fa-instagram"></a></li>
<li><a href="https://bit.ly/3y2ogFR" target="_blank" class="fab fa-youtube"></a></li>
</ul>
</div>
</div>
</div>
</div>
</footer>
</div>
</div>
</div>
</div>
<div class="zox-fly-top back-to-top">
<span class="fas fa-angle-up"></span>
</div>
</div>
<div class="zox-fly-fade zox-fly-but-click">
</div>
<div data-theiaStickySidebar-sidebarSelector='".zox-sticky-side"' data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":70,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":1004,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script> <script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
<script type="text/javascript">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</script> 
<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">

<div class="pswp__bg"></div>

<div class="pswp__scroll-wrap">

<div class="pswp__container">
<div class="pswp__item"></div>
<div class="pswp__item"></div>
<div class="pswp__item"></div>
</div>

<div class="pswp__ui pswp__ui--hidden">
<div class="pswp__top-bar">

<div class="pswp__counter"></div>
<button class="pswp__button pswp__button--close" title="Close (Esc)"></button>
<button class="pswp__button pswp__button--share" title="Share"></button>
<button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>
<button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>


<div class="pswp__preloader">
<div class="pswp__preloader__icn">
<div class="pswp__preloader__cut">
<div class="pswp__preloader__donut"></div>
</div>
</div>
</div>
</div>
<div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
<div class="pswp__share-tooltip"></div>
</div>
<button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
</button>
<button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
</button>
 <div class="pswp__caption">
<div class="pswp__caption__center"></div>
</div>
</div>
</div>
</div>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/dragillustrated.com\/wp-json\/","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.6.1' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/ResizeSensor.js?ver=1.7.0' id='theia-sticky-sidebar/ResizeSensor.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.7.0' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.7.0' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/zoxpress-plugin//scripts/jquery.sticky-kit.min.js?ver=6.0.1' id='jquery-sticky-kit-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/zoxpress-plugin//scripts/jquery.waypoints.min.js?ver=6.0.1' id='jquery-waypoints-js'></script>
<script type='text/javascript' id='advanced-ads-responsive-js-extra'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.10.3' id='advanced-ads-responsive-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/jquery.nouislider.all.min.js?ver=3.14.2' id='reviewer-nouislider-plugin-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/photoswipe.js?ver=3.14.2' id='reviewer-photoswipe-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/jquery.knob.js?ver=3.14.2' id='reviewer-knob-plugin-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer.public.min.js?ver=3.14.2' id='reviewer-public-script-js'></script>
<script type='text/javascript' id='reviewer-reviews-boxes-script-js-extra'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerRatingObj = {"ajax_nonce":"2cb7fbdf0f","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_rating"};
var reviewerJudgeObj = {"ajax_nonce":"9abd714494","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_like"};
var reviewerQueryURs = {"ajax_nonce":"73ea9dde1a","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer-reviews-boxes.js?ver=3.14.2' id='reviewer-reviews-boxes-script-js'></script>
<script type='text/javascript' id='reviewer-widget-users-reviews-script-js-extra'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerQueryAllURs = {"ajax_nonce":"eea5d8816c","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_all_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer-widget-users-reviews.js?ver=3.14.2' id='reviewer-widget-users-reviews-script-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-pro/assets/js/advanced-ads-pro.min.js?ver=2.17.4' id='advanced-ads-pro/front-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/zoxcustom.js?ver=6.0.1' id='zox-custom-js'></script>
<script type='text/javascript' id='zox-custom-js-after'>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</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/scripts.js?ver=6.0.1' id='zox-scripts-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/retina.js?ver=6.0.1' id='zox-retina-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/jquery.infinitescroll.min.js?ver=6.0.1' id='zox-infinitescroll-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/comment-reply.min.js?ver=6.0.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/intersection-observer.js' id='zox-intersection-observer-polyfill-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/lozad.min.js' id='zox-lozad-js'></script>
<script type='text/javascript' id='zox-lozad-js-after'>

	var zoxWidgets = document.querySelectorAll("#zox-home-widget-wrap img");
	lozad(zoxWidgets, {
		rootMargin: "0px 0px",
		loaded: function (el) {
			el.classList.add("is-loaded");
		}
	}).observe();
</script>
<script type='text/javascript' id='advanced-ads-pro/cache_busting-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":"","wp_timezone_offset":"-18000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-pro/assets/js/base.min.js?ver=2.17.4' id='advanced-ads-pro/cache_busting-js'></script>
<script type='text/javascript' id='advadsTrackingScript-js-extra'>
/* <![CDATA[ */
var advadsTracking = {"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"dragi-target","blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/tracking.min.js?ver=2.3.1' id='advadsTrackingScript-js'></script>
<script>window.advads_admin_bar_items = [];</script><script>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</script><script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script src='https://stats.wp.com/e-202233.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.2',blog:'37035244',post:'52734',tz:'-5',srv:'dragillustrated.com'} ]);
	_stq.push([ 'clickTrackerInit', '37035244', '52734' ]);
</script>
<script id="dragi-tracking">var advads_tracking_ads = {};var advads_tracking_urls = {"1":"https:\/\/dragillustrated.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods = {"1":"frontend"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"https:\/\/dragillustrated.com\/linkout\/"};</script>
</body>
</html>