<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script>window._wca = window._wca || [];</script>

<title>Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &amp; the Mile-High Nationals - Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</title>
<link rel="canonical" href="https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &amp; the Mile-High Nationals" />
<meta property="og:description" content="Mike Salinas is having a career year driving his Top Fuel Dragster in the NHRA Camping World Series. The California-native is number one in the Top Fuel points after three stellar wins as the series heads into the Western Swing. However, it hasn&#8217;t come without significant changes that kicked off one of the craziest silly [&hellip;]" />
<meta property="og:url" content="https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/" />
<meta property="og:site_name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
<meta property="article:publisher" content="https://www.facebook.com/dragillustrated" />
<meta property="article:published_time" content="2022-07-15T00:55:26+00:00" />
<meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story.jpg" />
<meta property="og:image:width" content="1600" />
<meta property="og:image:height" content="900" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="Kayla Zadel" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@dragillustrated" />
<meta name="twitter:site" content="@dragillustrated" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Kayla Zadel" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="7 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://dragillustrated.com/#organization","name":"Drag Illustrated","url":"https://dragillustrated.com/","sameAs":["https://www.instagram.com/dragillustrated","https://www.youtube.com/channel/UCbREkYFDiSOs8JCRTsqEMeg","https://www.facebook.com/dragillustrated","https://twitter.com/dragillustrated"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://dragillustrated.com/#/schema/logo/image/","url":"https://dragillustrated.com/wp-content/uploads/2012/03/Drag_Illustrated_Logo_RED.png","contentUrl":"https://dragillustrated.com/wp-content/uploads/2012/03/Drag_Illustrated_Logo_RED.png","width":2150,"height":592,"caption":"Drag Illustrated"},"image":{"@id":"https://dragillustrated.com/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://dragillustrated.com/#website","url":"https://dragillustrated.com/","name":"Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More","description":"","publisher":{"@id":"https://dragillustrated.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://dragillustrated.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/#primaryimage","url":"https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story.jpg","contentUrl":"https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story.jpg","width":1600,"height":900},{"@type":"WebPage","@id":"https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/","url":"https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/","name":"Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship & the Mile-High Nationals - Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More","isPartOf":{"@id":"https://dragillustrated.com/#website"},"primaryImageOfPage":{"@id":"https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/#primaryimage"},"datePublished":"2022-07-15T00:55:26+00:00","dateModified":"2022-07-15T00:55:26+00:00","breadcrumb":{"@id":"https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/"]}]},{"@type":"BreadcrumbList","@id":"https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://dragillustrated.com/"},{"@type":"ListItem","position":2,"name":"Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals"}]},{"@type":"Article","@id":"https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/#article","isPartOf":{"@id":"https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/"},"author":{"name":"Kayla Zadel","@id":"https://dragillustrated.com/#/schema/person/1a1a16780b684dadbba4fb04223907e7"},"headline":"Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals","datePublished":"2022-07-15T00:55:26+00:00","dateModified":"2022-07-15T00:55:26+00:00","mainEntityOfPage":{"@id":"https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/"},"wordCount":1562,"publisher":{"@id":"https://dragillustrated.com/#organization"},"image":{"@id":"https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/#primaryimage"},"thumbnailUrl":"https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story.jpg","articleSection":["Exclusive","Features","News"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://dragillustrated.com/#/schema/person/1a1a16780b684dadbba4fb04223907e7","name":"Kayla Zadel","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://dragillustrated.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/e267c228123b4efb783d47b562ebd405?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/e267c228123b4efb783d47b562ebd405?s=96&d=mm&r=g","caption":"Kayla Zadel"},"url":"https://dragillustrated.com/author/kayla-zadel/"}]}</script>

<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Feed" href="https://dragillustrated.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Comments Feed" href="https://dragillustrated.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; iCal Feed" href="https://dragillustrated.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals Comments Feed" href="https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/feed/" />

<script src="//www.googletagmanager.com/gtag/js?id=UA-21052018-1" data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>

<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/dragillustrated.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<script id="dragi-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://dragillustrated.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://dragillustrated.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://dragillustrated.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css' href='https://dragillustrated.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-vendors-style.css?ver=7.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css' href='https://dragillustrated.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-style.css?ver=7.8.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-css' href='https://dragillustrated.com/wp-content/plugins/theia-post-slider/css/buttons-red.css?ver=1.15.1' type='text/css' media='all' />
<link rel='stylesheet' id='ql-jquery-ui-css' href='//ajax.googleapis.com/ajax/libs/jqueryui/1.12.1/themes/smoothness/jquery-ui.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-photoswipe-css' href='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/css/photoswipe.css?ver=3.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://dragillustrated.com/wp-includes/css/dashicons.min.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-public-css' href='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/css/reviewer-public.css?ver=3.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='zox-custom-style-css' href='https://dragillustrated.com/wp-content/themes/zoxpress/style.css?ver=6.0.1' type='text/css' media='all' />
<style id='zox-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='fontawesome-child-css' href='https://use.fontawesome.com/releases/v5.5.0/css/all.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='zox-custom-child-style-css' href='https://dragillustrated.com/wp-content/themes/zoxpress-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://dragillustrated.com/wp-content/themes/zoxpress-child/font-awesome/css/all.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='zox-fonts-css' href='//fonts.googleapis.com/css?family=Heebo%3A300%2C400%2C500%2C700%2C800%2C900%7CAlegreya%3A400%2C500%2C700%2C800%2C900%7CJosefin+Sans%3A300%2C400%2C600%2C700%7CLibre+Franklin%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CFrank+Ruhl+Libre%3A300%2C400%2C500%2C700%2C900%7CNunito+Sans%3A300%2C400%2C600%2C700%2C800%2C900%7CMontserrat%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CAnton%3A400%7CNoto+Serif%3A400%2C700%7CNunito%3A300%2C400%2C600%2C700%2C800%2C900%7CRajdhani%3A300%2C400%2C500%2C600%2C700%7CTitillium+Web%3A300%2C400%2C600%2C700%2C900%7CPT+Serif%3A400%2C400i%2C700%2C700i%7CAmiri%3A400%2C400i%2C700%2C700i%7COswald%3A300%2C400%2C500%2C600%2C700%7CRoboto+Mono%3A400%2C700%7CBarlow+Semi+Condensed%3A700%2C800%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto+Condensed%3A300%2C400%2C700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7CPT+Serif%3A400%2C700%7COpen+Sans+Condensed%3A300%2C700%7COpen+Sans%3A700%7CSource+Serif+Pro%3A400%2C600%2C700%7CIM+Fell+French+Canon%3A400%2C400i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' type='text/css' media='all' />
<link rel='stylesheet' id='zox-media-queries-css' href='https://dragillustrated.com/wp-content/themes/zoxpress/css/media-queries.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://dragillustrated.com/wp-content/tablepress-combined.min.css?ver=41' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://dragillustrated.com/wp-content/plugins/jetpack/css/jetpack.css?ver=11.1.1' type='text/css' media='all' />
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/exactmetrics-premium/assets/js/frontend-gtag.min.js?ver=7.7.0' id='exactmetrics-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='exactmetrics-frontend-script-js-extra'>/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/dragillustrated.com","hash_tracking":"false","ua":"UA-21052018-1","v4_id":""};/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/balupton-history.js/jquery.history.js?ver=1.7.1' id='history.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/async.min.js?ver=14.09.2014' id='async.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/tps.js?ver=1.15.1' id='theiaPostSlider/theiaPostSlider.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/main.js?ver=1.15.1' id='theiaPostSlider/main.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/tps-transition-slide.js?ver=1.15.1' id='theiaPostSlider/transition.js-js'></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.34.0' id='advanced-ads-advanced-js-js'></script>
<script defer type='text/javascript' src='https://stats.wp.com/s-202228.js' id='woocommerce-analytics-js'></script>
<link rel="https://api.w.org/" href="https://dragillustrated.com/wp-json/" /><link rel="alternate" type="application/json" href="https://dragillustrated.com/wp-json/wp/v2/posts/51776" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dragillustrated.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dragillustrated.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.1" />
<meta name="generator" content="WooCommerce 6.7.0" />
<link rel='shortlink' href='https://wp.me/p2voyE-dt6' />
<link rel="alternate" type="application/json+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Fmike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Fmike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals%2F&#038;format=xml" />
<script type="text/javascript" src="https://paywall.subscriptiongenius.com/load.js"></script>


<script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window, document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init', '634980329980573');fbq('track', 'PageView');</script><noscript><img height="1" width="1" style="display:none"src="https://www.facebook.com/tr?id=634980329980573&ev=PageView&noscript=1"/></noscript>


<style type="text/css">
			.wpsdc-drop-cap {
				float : left;				
				padding : 0.25em 0.05em 0.25em 0;				
				font-size : 5em;
				line-height : 0.4em;color : #0a0a0a;}
		</style> <meta name="theme-color" content="#000" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-1024x576.jpg" />
<meta name="twitter:image" content="https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-1024x576.jpg" />
<meta property="og:url" content="https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/" />
<meta property="og:title" content="Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals" />
<meta property="og:description" content="Mike Salinas is having a career year driving his Top Fuel Dragster in the NHRA Camping World Series. The California-native is number one in the Top Fuel points after three stellar wins as the series heads into the Western Swing. However, it hasn&#8217;t come without significant changes that kicked off one of the craziest silly [&hellip;]" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:url" content="https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/">
<meta name="twitter:title" content="Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals">
<meta name="twitter:description" content="Mike Salinas is having a career year driving his Top Fuel Dragster in the NHRA Camping World Series. The California-native is number one in the Top Fuel points after three stellar wins as the series heads into the Western Swing. However, it hasn&#8217;t come without significant changes that kicked off one of the craziest silly [&hellip;]">
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://dragillustrated.com"><link rel="alternate" href="https://dragillustrated.com/wp-json/tribe/events/v1/" /><script type="text/javascript">
		;var advadsCfpExpHours = 1;
		var advadsCfpClickLimit = 8;
		var advadsCfpBan = 1;
		var advadsCfpPath = '';
		var advadsCfpDomain = '';
		</script><script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
<style>img#wpstats{display:none}</style>
<link rel="pingback" href="https://dragillustrated.com/xmlrpc.php"> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
<link rel="icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-180x180.png" />
<meta name="msapplication-TileImage" content="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-270x270.png" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-51776 single-format-standard custom-background wp-embed-responsive theme-zoxpress theiaPostSlider_body woocommerce-no-js tribe-no-js zox-sport2 zox-s6 elementor-default elementor-kit-42099 aa-prefix-dragi-">
<div id="zox-site" class="left zoxrel ">
<div id="zox-fly-wrap">
<div id="zox-fly-menu-top" class="left relative">
<div id="zox-fly-logo" class="left relative">
<a href="https://dragillustrated.com/"><img src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
</div>
<div class="zox-fly-but-wrap zox-fly-but-menu zox-fly-but-click">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</div>
<div id="zox-fly-menu-wrap">
<nav class="zox-fly-nav-menu left relative">
<div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-49701" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49701"><a href="https://dragillustrated.com/category/news/">News</a></li>
<li id="menu-item-49702" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49702"><a href="https://dragillustrated.com/category/race-coverage/">Race Coverage</a></li>
<li id="menu-item-49703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49703"><a href="https://dragillustrated.com/category/tech/">Tech</a></li>
<li id="menu-item-15094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" rel="noopener" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li id="menu-item-15102" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
<li id="menu-item-50482" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50482"><a href="https://dragillustrated.com/advertise/">Advertise</a></li>
</ul></div> </nav>
</div>
<div id="zox-fly-soc-wrap">
<span class="zox-fly-soc-head">Connect with us</span>
<ul class="zox-fly-soc-list left relative">
<li><a href="https://www.facebook.com/DragIllustrated" target="_blank" class="fab fa-facebook-f"></a></li>
<li><a href="https://twitter.com/DragIllustrated" target="_blank" class="fab fa-twitter"></a></li>
<li><a href="https://www.instagram.com/dragillustrated" target="_blank" class="fab fa-instagram"></a></li>
<li><a href="https://bit.ly/3y2ogFR" target="_blank" class="fab fa-youtube"></a></li>
</ul>
</div>
</div> <div id="zox-search-wrap">
<div class="zox-search-cont">
<p class="zox-search-p">Hi, what are you looking for?</p>
<div class="zox-search-box">
<form method="get" id="zox-search-form" action="https://dragillustrated.com/">
<input type="text" name="s" id="zox-search-input" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "Search") { this.value = ""; }' />
<input type="submit" id="zox-search-submit" value="Search" />
</form> </div>
</div>
<div class="zox-search-but-wrap zox-search-click">
<span></span>
<span></span>
</div>
</div>
<div id="zox-site-wall" class="left zoxrel">
<div id="zox-lead-top-wrap">
<div id="zox-lead-top-in">
<div id="zox-lead-top">
</div>
</div>
</div>
<div id="zox-site-main" class="left zoxrel">
<header id="zox-main-head-wrap" class="left zoxrel zox-trans-head">
<div id="zox-bot-head-wrap" class="left zoxrel">
<div class="zox-head-width">
<div id="zox-bot-head">
<div id="zox-bot-head-left">
<div class="zox-fly-but-wrap zoxrel zox-fly-but-click">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</div>
<div id="zox-bot-head-mid" class="relative">
<div class="zox-bot-head-logo">
<div class="zox-bot-head-logo-main">
<a href="https://dragillustrated.com/"><img class="zox-logo-stand" src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /><img class="zox-logo-dark" src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
</div>
<h2 class="zox-logo-title">Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</h2>
</div>
<div class="zox-bot-head-menu">
<div class="zox-nav-menu">
<div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49701 zox-mega-drop"><a href="https://dragillustrated.com/category/news/">News</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals</p></a></li><li><a href="https://dragillustrated.com/sporty-bandimere-says-excitement-is-building-for-the-42nd-annual-nhra-mile-high-nationals/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/Sporty-Bandimere-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Sporty-Bandimere-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/Sporty-Bandimere-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/07/Sporty-Bandimere-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/07/Sporty-Bandimere-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/07/Sporty-Bandimere-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/07/Sporty-Bandimere-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/07/Sporty-Bandimere.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>&#8220;Sporty&#8221; Bandimere Says Excitement is Building for the 42nd annual NHRA Mile-High Nationals</p></a></li><li><a href="https://dragillustrated.com/five-race-deal-mixes-tequila-comisario-and-caruso-family-racing/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/Comisario-Tequila-Explore-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Comisario-Tequila-Explore-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/Comisario-Tequila-Explore-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Five-Race Deal Mixes Tequila Comisario and Caruso Family Racing</p></a></li><li><a href="https://dragillustrated.com/pdra-pulling-out-all-the-stops-for-second-annual-summit-racing-prostars/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/PDRA_ProStars-2021_Tara-Bowker-photo-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/PDRA_ProStars-2021_Tara-Bowker-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/PDRA_ProStars-2021_Tara-Bowker-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>PDRA Pulling Out All the Stops for Second Annual Summit Racing ProStars</p></a></li><li><a href="https://dragillustrated.com/will-smith-set-to-license-in-larry-dixons-top-fuel-dragster-at-us-131-northern-nationals/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/Will-Smith_Head_Tara-Bowker-photo-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Will-Smith_Head_Tara-Bowker-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/Will-Smith_Head_Tara-Bowker-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Will Smith Set to License in Larry Dixon&#8217;s Top Fuel Dragster at US 131 Northern Nationals</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49702 zox-mega-drop"><a href="https://dragillustrated.com/category/race-coverage/">Race Coverage</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/five-race-deal-mixes-tequila-comisario-and-caruso-family-racing/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/Comisario-Tequila-Explore-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Comisario-Tequila-Explore-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/Comisario-Tequila-Explore-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Five-Race Deal Mixes Tequila Comisario and Caruso Family Racing</p></a></li><li><a href="https://dragillustrated.com/pdra-pulling-out-all-the-stops-for-second-annual-summit-racing-prostars/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/PDRA_ProStars-2021_Tara-Bowker-photo-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/PDRA_ProStars-2021_Tara-Bowker-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/PDRA_ProStars-2021_Tara-Bowker-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>PDRA Pulling Out All the Stops for Second Annual Summit Racing ProStars</p></a></li><li><a href="https://dragillustrated.com/will-smith-set-to-license-in-larry-dixons-top-fuel-dragster-at-us-131-northern-nationals/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/Will-Smith_Head_Tara-Bowker-photo-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Will-Smith_Head_Tara-Bowker-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/Will-Smith_Head_Tara-Bowker-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Will Smith Set to License in Larry Dixon&#8217;s Top Fuel Dragster at US 131 Northern Nationals</p></a></li><li><a href="https://dragillustrated.com/gatornationals-to-kick-off-first-four-races-of-2023-nhra-camping-world-series-season/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/s10-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/s10-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/s10-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Gatornationals to Kick Off First Four Races of 2023 NHRA Camping World Series Season</p></a></li><li><a href="https://dragillustrated.com/doug-kalitta-to-fly-enhanced-revchem-composites-branding-on-western-swing/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/unnamed-32-1-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/unnamed-32-1-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/unnamed-32-1-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Doug Kalitta to Fly Enhanced Revchem Composites Branding on Western swing</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49703 zox-mega-drop"><a href="https://dragillustrated.com/category/tech/">Tech</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/stroud-safetys-female-forward-workforce-makes-it-happen/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/Stroud-OKC-3048-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/Stroud-OKC-3048-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/Stroud-OKC-3048-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Stroud Safety&#8217;s Female-Forward Workforce Makes it Happen</p></a></li><li><a href="https://dragillustrated.com/race-winning-brands-continues-growth-into-new-markets/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/CORSA-Intake-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/CORSA-Intake-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/CORSA-Intake-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Race Winning Brands Continues Growth into New Markets</p></a></li><li><a href="https://dragillustrated.com/scoggin-dickey-parts-centers-raceshop-builds-reliability-into-each-engine-for-frank-hawleys-drag-racing-school/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/halweysdyno-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/halweysdyno-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/halweysdyno-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Scoggin Dickey Parts Center’s Raceshop Builds Reliability into Each Engine for Frank Hawley’s Drag Racing School</p></a></li><li><a href="https://dragillustrated.com/race-winning-brands-acquires-haltech/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/05/HalTech-Products-3-1-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/HalTech-Products-3-1-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/HalTech-Products-3-1-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Race Winning Brands Acquires Haltech</p></a></li><li><a href="https://dragillustrated.com/sw-performance-group-acquired-by-private-investment-firm/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/05/sw_new_ownership_may_2022_1000-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" /></div><p>S&#038;W Performance Group Acquired by Private Investment Firm</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" rel="noopener" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50482"><a href="https://dragillustrated.com/advertise/">Advertise</a></li>
</ul></div> </div>
</div>
</div>
<div id="zox-bot-head-right">
<span class="zox-night zox-night-mode fas fa-moon"></span>
<span class="zox-nav-search-but fas fa-search zox-search-click"></span>
</div>
</div>
</div>
</div> </header>
<div id="zox-site-grid">
<div id="zox-site-wall-small">
<div id="zox-main-body-wrap" class="left relative"> <article id="post-51776" class="post-51776 post type-post status-publish format-standard has-post-thumbnail hentry category-exclusive category-features category-news" itemscope itemtype="http://schema.org/NewsArticle">
<div class="zox-article-wrap zoxrel left zox100">
<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/" />
<div class="zox-post-top-wrap zoxrel left zox100">
<div class="zox-post-title-wrap zox-tit2">
<div class="zox-post-width">
<header class="zox-post-head-wrap left zoxrel zox100">
<div class="zox-post-head zoxrel">
<h3 class="zox-post-cat">
<a class="zox-post-cat-link" href="https://dragillustrated.com/category/exclusive/"><span class="zox-post-cat">Exclusive</span></a>
</h3>
<h1 class="zox-post-title left entry-title" itemprop="headline">Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals</h1>
<div class="zox-post-info-wrap">
<div class="zox-post-byline-wrap">
<div class="zox-author-thumb">
<img alt='' src='https://secure.gravatar.com/avatar/e267c228123b4efb783d47b562ebd405?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e267c228123b4efb783d47b562ebd405?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy' /> </div>
<div class="zox-author-info-wrap">
<div class="zox-author-name-wrap" itemprop="author" itemscope itemtype="https://schema.org/Person">
<p>By</p><span class="zox-author-name vcard fn author" itemprop="name"><a href="https://dragillustrated.com/author/kayla-zadel/" title="Posts by Kayla Zadel" rel="author">Kayla Zadel</a></span>
</div>
<div class="zox-post-date-wrap">
<p>Published</p> <span class="zox-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-07-14">57 mins ago</time></span>
<meta itemprop="dateModified" content="2022-07-14" />
</div>
</div>
</div>
<div class="zox-post-soc-top-wrap">
<div class="zox-post-soc-stat">
<ul class="zox-post-soc-stat-list left zoxrel">
<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/&amp;t=Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="zox-post-soc-fb">
<i class="fab fa-facebook-f"></i>
</li>
</a>
<a href="#" onclick="window.open('https://twitter.com/share?text=Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals -&amp;url=https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="zox-post-soc-twit">
<i class="fab fa-twitter"></i>
</li>
</a>
<li class="zox-post-soc-copy">
<i class="fas fa-link"></i>
</li>
<li class="zox-post-soc-more zox-soc-stat-click-51776">
<i class="fas fa-ellipsis-h"></i>
<div class="zox-soc-more-stat zox-more-click-51776">
<ul class="zox-soc-more-list">
<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals&url=https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
<li class="zox-post-soc-flip">
<p>Flipboard</p>
<i class="fab fa-flipboard"></i>
</li>
</a>
<a href="#" onclick="window.open('https://www.reddit.com/submit?url=https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/&title=Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals', 'redditShare', 'width=626,height=436'); return false;" title="Share on Reddit">
<li class="zox-post-soc-redd">
<p>Reddit</p>
<i class="fab fa-reddit-alien"></i>
</li>
</a>
<a href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/&amp;media=https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story.jpg&amp;description=Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<li class="zox-post-soc-pin">
<p>Pinterest</p>
<i class="fab fa-pinterest-p" aria-hidden="true"></i>
</li>
</a>
<a class="zox-whats-main" href="https://web.whatsapp.com/send?text=Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a class="zox-whats-mob" href="whatsapp://send?text=Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a href="/cdn-cgi/l/email-protection#f3cc80869199969087cebe9a9896d3a0929f9a9d9280d3b79a809b9680d39c9dd3b09281969681d3aa969281d39a9dd3c1c3c1c1dfd3a39683b19c8a80d3a1969f92879a9c9d809b9a83d3d5d0c3c0cbc8d3879b96d3be9a9f96debb9a949bd3bd92879a9c9d929f80d5929e83c8b1bcb7aacebad3959c869d97d3879b9a80d39281879a909f96d39a9d8796819680879a9d94d3929d97d3879b9c86949b87d39c95d3809b92819a9d94d39a87d3849a879bd38a9c86ddd3b09b969098d39a87d39c8687c9d39b87878380c9dcdc978192949a9f9f8680878192879697dd909c9edc9e9a9896de80929f9a9d9280de979a809b9680de9c9dde909281969681de8a969281de9a9ddec1c3c1c1de839683919c8a80de81969f92879a9c9d809b9a83de879b96de9e9a9f96de9b9a949bde9d92879a9c9d929f80dc">
<li class="zox-post-soc-email">
<p>Email</p>
<i class="fas fa-envelope"></i>
</li>
</a>
</ul>
</div>
</li>
</ul>
</div>
</div>
</div>
</div>
</header>  </div>
</div>
</div>
<div class="zox-post-main-grid">
<div class="zox-post-width">
<div class="zox-post-main-wrap zoxrel left zox100">
<div class="zox-post-main">
<div class="zox-post-bot-wrap">
<div class="zox-post-img-wrap">
<div class="zox-post-img left zoxrel zoxlh0" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
<img width="1600" height="900" src="https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story.jpg" class="flipboard-image wp-post-image" alt="" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story.jpg 1600w, https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story-600x338.jpg 600w" sizes="(max-width: 1600px) 100vw, 1600px" /> <meta itemprop="url" content="https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story.jpg">
<meta itemprop="width" content="1600">
<meta itemprop="height" content="900">
</div>
<span class="zox-post-img-cap"></span>
</div>
</div>
<div class="zox-post-body-wrap left zoxrel">
<div class="zox-post-body left zoxrel zox100">
<div id="tps_slideContainer_51776" class="theiaPostSlider_slides"><div class="theiaPostSlider_preloadedSlide">
<div class="dragi-b80421db95b4bc71b922fb0e953c763a dragi-leaderboard-post-inject" id="dragi-b80421db95b4bc71b922fb0e953c763a"></div><p>
<div class="page" title="Page 1">
<div class="section">
<div class="layoutArea">
<div class="column">
<p>Mike Salinas is having a career year driving his Top Fuel Dragster in the NHRA Camping World Series. The California-native is number one in the Top Fuel points after three stellar wins as the series heads into the Western Swing. However, it hasn&#8217;t come without significant changes that kicked off one of the craziest silly seasons the NHRA has had in years.
<p>During the latter part of the 2021 season, Salinas found out that crew chiefs Alan Johnson and Brian Husen were leaving Scrappers Racing to go to Kalitta Motorsports. &#8220;When Alan and Brian told me they were leaving in St. Louis, I went over and talked to my guys and told them they&#8217;re leaving. Then I asked them what they wanted to do. If you want to stay, I&#8217;ll stay racing, but if you don&#8217;t, I&#8217;m not going to keep racing.&#8221;
<p>Salinas was ready to &#8220;hang it up and park&#8221; his dragster and figure out his next move. &#8220;I always thought the crew had been more important than the crew chiefs,&#8221; Salinas proclaimed. The pilot, who obtained his Top Fuel license in 2009, didn&#8217;t want to start over again with a new crew and guys he didn&#8217;t know. &#8220;All of them agreed to stay except one. After being at a top-tier team and watching what a top-tier team does, it&#8217;s hard to go backwards for a guy like me. I believed that when they all agreed to stay, I had the key component. All I had to do was get the key guy that could read the recipe and make it work.&#8221;
<p>That&#8217;s exactly what Salinas did. He announced Rob Flynn would take over crew chief duties for the Scrappers Racing Top Fuel Dragster. &#8220;I spent time with Rob on a road trip to the Nitro Revival, and I picked his brain apart,&#8221; said Salinas. It was during that road trip that he knew Flynn was the guy to lead the team. &#8220;I like the integrity that this man brings to the table. I like how humble and quiet he is. He knows so much that most people don&#8217;t understand this guy, and he&#8217;s just a nice, gentle man. He wants to race but doesn&#8217;t want to be in the limelight.&#8221; According to Salinas, Flynn&#8217;s options were limited, but when he and Mike got together, they started talking about the possibility of what could happen.
<p>&#8220;I like to find the guys that are hungry and want it, and that&#8217;s exactly what he is,&#8221; Salinas confessed.
<p>Salinas asked Johnson and Husen to show Flynn what they had been doing and share the data they had collected from previous years. &#8220;Lo and behold, when we went out to testing, the first test session was really nice because we did not skip a beat,&#8221; Salinas said, proudly. &#8220;Alan and Brian are great guys. They tune the fastest cars in the country and have more championships than anybody else. But the thing I learned about Rob Flynn is he took all the runs and all the information and built his own runs. We&#8217;re running the car our way &#8211; not Alan&#8217;s way anymore, and the car seems to like it better, along with the driver and the crew,&#8221; he said.
<p>Not only did the Top Fuel pilot orchestrate the changes within the team, he knew it was time to start evaluating his driving style. The 61-year-old might be old school, but he&#8217;s not stuck in his ways. Salinas found out that how he was sitting in the cockpit directly affected his driving. &#8220;Where we come from, we never ask for help,&#8221; he said. &#8220;Antron [Brown] was the first one I asked for help. Crew chiefs would ask me if I was comfortable in the car. But I never stopped to ask, &#8216;well, define comfortable.&#8217; Can you see? Ya, I can see. What am I supposed to see? No one ever broke it down for me,&#8221; continued Salinas. &#8220;I was sitting too low in the car at the beginning of the year. I never saw my front wheels or the front wing of my car. I was driving the car off the wall and the centerline. It was like driving the nostalgia dragster that I started with. I was always looking at the wall and the centerline, and then it started getting crazier because we started going faster and faster.&#8221;
</div>
</div>
</div>
</div>
<div class="page" title="Page 2">
<div class="section">
<div class="layoutArea">
<div class="column">
<p>Like Salinas said, fellow Top Fuel pilot Antron Brown drove the Scrappers Racing dragster and conveyed his findings to Mike. &#8220;You can&#8217;t see. I&#8217;m taller than you, and I can&#8217;t see,&#8221; Salinas said Brown explained to him. &#8220;He had me come and sit in his car and tell him what I saw. I could read all the stickers down his car to the nose.&#8221;<div class="zox-post-ad-wrap"><span class="zox-ad-label">Advertisement. Scroll to continue reading.</span><div class="zox-post-ad"><div class="zox-post-ad-in1"><div class="zox-post-ad-in2"><div class="dragi-d1db17b42e93a4edd9a930c247da294d" id="dragi-d1db17b42e93a4edd9a930c247da294d"></div></div></div></div></div>
<p>After getting a new seat poured and custom-fitted to Salinas and his cockpit, he found out he wasn&#8217;t strapped in the car correctly. Salinas confessed that he would move around in the driver&#8217;s seat during a run. After getting his seat and belts dialed in, Salinas then turned to another Top Fuel driver, Austin Prock. &#8220;I was having a hard time pedaling, so I asked Austin a couple of questions, and he told me what he was doing. I told him if I had a son, it would be you,&#8221; Salinas genuinely said. &#8220;That kid right there is the face of NHRA, and he&#8217;s the future of NHRA. He&#8217;s a good kid and a great driver.&#8221; For Salinas, Prock&#8217;s pedaling teachings are working. &#8220;Houston was the best pedaling I&#8217;ve ever done, and that was all Austin Prock right there. I got back and was like, &#8216;this is cool.&#8217;&#8221;
<p>Salinas is so well-situated in the car he admits that he drives the 330+ mph dragster one-handed. &#8220;I keep one hand on the wheel and one hand on the brake. I&#8217;m so comfortable now, it&#8217;s really awesome.&#8221; Not only does Salinas feel comfortable, but it shows in his reaction times. He&#8217;s been consistently getting off the starting line with the times of a seasoned professional.
<p>As the NHRA rounds the corner into the second part of the season, Salinas is ready to get back in the car and continue the blockbuster season he&#8217;s been having. When asked if he&#8217;s been working on his reaction times, he chuckled, &#8220;every stop light. I beat that old lady in the van next to me off the line.&#8221; And he&#8217;s not joking as Salinas continued with his practice techniques. &#8220;Honestly, I do that. I&#8217;m having fun with this thing. I&#8217;ve never seen my name number one. It&#8217;s a big deal for our family and our racing team.&#8221;
<p>The majority of Scrappers Racing consists of Mike&#8217;s family. Two of his four daughters are drag racers. Jianna fields a Pro Stock Motorcycle in the Camping World Series, and Jasmine is currently piloting a nitro-injected Top Alcohol Dragster in the Lucas Oil Series. However, Jasmine is looking to make the jump to Top Fuel. &#8220;We&#8217;re looking for funding for Jasmine&#8217;s Top Fuel car to bring her out next year. I&#8217;m hoping we can test the car in Brainerd, Minnesota.&#8221;
</div>
</div>
</div>
</div>
<div class="page" title="Page 3">
<div class="section">
<div class="layoutArea">
<div class="column">
<p>The way Salinas talks about this family and racing makes it easy to tell that he has truly found something special. &#8220;At the end of the day, where can you go and be with your family, have a great time, and live out your goals. I have four daughters, and they&#8217;re young, strong, confident women. If Jasmine wanted to drive this car and I had to step out, I wouldn&#8217;t blink an eye. I want them to be able to do what they want and have fun,&#8221; Salinas said, clearly speaking from the heart. &#8220;We&#8217;re working on getting everything ready for her [Jasmine]. It&#8217;d be nice to beat my kid, too.&#8221; Then he laughed and said, &#8220;I&#8217;m still going to jump on a Pro Stock Motorcycle to beat Jianna.&#8221;
<p>While Jasmine is going to Columbus, Ohio, this weekend, Jianna is entered to race her Scrappers Suzuki at the Mile-High Nationals. Mike is excited to return to one of his favorite tracks and see another prominent family in drag racing. &#8220;The Bandimeres are great people and friends of ours. We&#8217;re excited to see them,&#8221; he said. As far as the infamous elevation of the track, he&#8217;s putting his trust in Flynn and his crew. &#8220;It&#8217;s going to be challenging for everybody. There will probably be one or two stand-out cars, and we&#8217;ll find out after the first round. We&#8217;ll find out if our car likes it or not. Our car loves the heat. The hotter, the better for us,&#8221; Salinas confessed.
<p>In addition to the tuning changes, Salinas is bringing back a familiar sponsor to the mix. &#8220;Pep Boys will be riding with us in Denver, and we&#8217;re looking forward to working with them for a long time to come,&#8221; he said.
<p>Salinas&#8217; closing thoughts on the weekend are to stay positive and let his actions speak louder than words. &#8220;When I get on the track, I don&#8217;t let anybody get in my head. I&#8217;m playing Mike&#8217;s game. Instead of me talking about it, I&#8217;m going to show everybody,&#8221; Salinas confidently said. &#8220;When I get in the car, I have this saying before I light the second light: I&#8217;m happy, I&#8217;m having fun and whatever is going to happen is already written.&#8221;
</div>
</div>
</div>
</div>
<p><div class="zox-post-ad-wrap"><span class="zox-ad-label">Advertisement. Scroll to continue reading.</span><div class="zox-post-ad"><div class="zox-post-ad-in1"><div class="zox-post-ad-in2"><div class="dragi-6bbed5869d60bb43a3fa77af624d6cbd" id="dragi-6bbed5869d60bb43a3fa77af624d6cbd"></div></div></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>
</div></div><div class="theiaPostSlider_footer _footer"></div><div data-theiaPostSlider-sliderOptions='{&quot;slideContainer&quot;:&quot;#tps_slideContainer_51776&quot;,&quot;nav&quot;:[&quot;.theiaPostSlider_nav&quot;],&quot;navText&quot;:&quot;%{currentSlide} of %{totalSlides}&quot;,&quot;helperText&quot;:&quot;Use your \u2190 \u2192 (arrow) keys to browse&quot;,&quot;defaultSlide&quot;:0,&quot;transitionEffect&quot;:&quot;slide&quot;,&quot;transitionSpeed&quot;:400,&quot;keyboardShortcuts&quot;:true,&quot;scrollAfterRefresh&quot;:true,&quot;numberOfSlides&quot;:1,&quot;slides&quot;:[],&quot;useSlideSources&quot;:null,&quot;themeType&quot;:&quot;classic&quot;,&quot;prevText&quot;:&quot;Prev&quot;,&quot;nextText&quot;:&quot;Next&quot;,&quot;buttonWidth&quot;:0,&quot;buttonWidth_post&quot;:0,&quot;postUrl&quot;:&quot;https:\/\/dragillustrated.com\/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals\/&quot;,&quot;postId&quot;:51776,&quot;refreshAds&quot;:false,&quot;refreshAdsEveryNSlides&quot;:1,&quot;adRefreshingMechanism&quot;:&quot;javascript&quot;,&quot;ajaxUrl&quot;:&quot;https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php&quot;,&quot;loopSlides&quot;:false,&quot;scrollTopOffset&quot;:0,&quot;hideNavigationOnFirstSlide&quot;:false,&quot;isRtl&quot;:false,&quot;excludedWords&quot;:[&quot;&quot;]}' data-theiaPostSlider-onChangeSlide='&quot;&quot;'></div> </div>
<div class="zox-post-body-bot left zoxrel zox100">
<div class="zox-post-body-width">
<div class="zox-post-tags left zoxrel zox100">
<span class="zox-post-tags-header">In this article:</span><span itemprop="keywords"></span>
</div>
<div class="zox-posts-nav-link">
</div>
<div class="zox-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<div class="zox-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<img src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" />
<meta itemprop="url" content="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg">
</div>
<meta itemprop="name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More">
</div>
</div>
</div>
</div> </div>
<div class="zox-post-side-wrap zox-post-side-noalp zoxrel zox-sticky-side">
<div id="zox-side-wrap" class="zoxrel zox-divs">
<div id="zox_ad_widget-13" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
<div class="dragi-27492903dabb73e7e05d15385576ad35" id="dragi-27492903dabb73e7e05d15385576ad35"></div> </div>
</div><div id="zox_ad_widget-14" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
<div class="dragi-6a561fc471dd0b7c6d4adcec2beb047a" id="dragi-6a561fc471dd0b7c6d4adcec2beb047a"></div> </div>
</div><div id="zox_ad_widget-15" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
<div class="dragi-996e2f550ca84a7b28294ef4cc824475" id="dragi-996e2f550ca84a7b28294ef4cc824475"></div> </div>
</div><div id="zox_ad_widget-16" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
<div class="dragi-0603f687a0847cf5683bc7205ecae106" id="dragi-0603f687a0847cf5683bc7205ecae106"></div> </div>
</div> </div>
</div>
</div>
</div>
</div>
<div class="zox-post-soc-scroll">
<ul class="zox-post-soc-list left zoxrel">
<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/&amp;t=Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="zox-post-soc-fb">
<i class="fab fa-facebook-f"></i>
</li>
</a>
<a href="#" onclick="window.open('https://twitter.com/share?text=Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals -&amp;url=https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="zox-post-soc-twit">
<i class="fab fa-twitter"></i>
</li>
</a>
<li class="zox-post-soc-copy">
<i class="fas fa-link"></i>
</li>
<li class="zox-post-soc-more zox-soc-scroll-click">
<i class="fas fa-ellipsis-h"></i>
<div class="zox-soc-more-scroll">
<ul class="zox-soc-more-list">
<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals&url=https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
<li class="zox-post-soc-flip">
<p>Flipboard</p>
<i class="fab fa-flipboard"></i>
</li>
</a>
<a href="#" onclick="window.open('https://www.reddit.com/submit?url=https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/&title=Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals', 'redditShare', 'width=626,height=436'); return false;" title="Share on Reddit">
<li class="zox-post-soc-redd">
<p>Reddit</p>
<i class="fab fa-reddit-alien"></i>
</li>
</a>
<a href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/&amp;media=https://dragillustrated.com/wp-content/uploads/2022/07/TAD-story.jpg&amp;description=Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<li class="zox-post-soc-pin">
<p>Pinterest</p>
<i class="fab fa-pinterest-p" aria-hidden="true"></i>
</li>
</a>
<a class="zox-whats-main" href="https://web.whatsapp.com/send?text=Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a class="zox-whats-mob" href="whatsapp://send?text=Mike Salinas Dishes on Career Year in 2022, PepBoys Relationship &#038; the Mile-High Nationals https://dragillustrated.com/mike-salinas-dishes-on-career-year-in-2022-pepboys-relationship-the-mile-high-nationals/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a href="/cdn-cgi/l/email-protection#d0efa3a5b2bab5b3a4ed9db9bbb5f083b1bcb9beb1a3f094b9a3b8b5a3f0bfbef093b1a2b5b5a2f089b5b1a2f0b9bef0e2e0e2e2fcf080b5a092bfa9a3f082b5bcb1a4b9bfbea3b8b9a0f0f6f3e0e3e8ebf0a4b8b5f09db9bcb5fd98b9b7b8f09eb1a4b9bfbeb1bca3f6b1bda0eb929f9489ed99f0b6bfa5beb4f0a4b8b9a3f0b1a2a4b9b3bcb5f0b9bea4b5a2b5a3a4b9beb7f0b1beb4f0a4b8bfa5b7b8a4f0bfb6f0a3b8b1a2b9beb7f0b9a4f0a7b9a4b8f0a9bfa5fef093b8b5b3bbf0b9a4f0bfa5a4eaf0b8a4a4a0a3eaffffb4a2b1b7b9bcbca5a3a4a2b1a4b5b4feb3bfbdffbdb9bbb5fda3b1bcb9beb1a3fdb4b9a3b8b5a3fdbfbefdb3b1a2b5b5a2fda9b5b1a2fdb9befde2e0e2e2fda0b5a0b2bfa9a3fda2b5bcb1a4b9bfbea3b8b9a0fda4b8b5fdbdb9bcb5fdb8b9b7b8fdbeb1a4b9bfbeb1bca3ff">
<li class="zox-post-soc-email">
<p>Email</p>
<i class="fas fa-envelope"></i>
</li>
</a>
</ul>
</div>
</li>
</ul>
</div>
</div>
<div class="zox-post-more-wrap left zoxrel zox100">
<div class="zox-post-width">
<div class="zox-post-more left zoxrel zox100">
<div class="zox-post-main-head left zoxrel zox100">
<h4 class="zox-post-main-title">
<span class="zox-post-main-title">You May Also Like</span>
</h4>
</div>
<div class="zox-post-more-grid zox-div4 left zoxrel zox100">
<div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/pro-street-legend-tony-christian-passes/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-600x337.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-100x100.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/pro-street-legend-tony-christian-passes/" rel="bookmark">
<h2 class="zox-s-title2">Pro Street Legend Tony Christian Passes</h2>
</a>
</div>
<p class="zox-s-graph">Tony Christian, one of the pioneering drivers of the Pro Street movement, passed away Thursday, June 9. Christian was infamous for his battles with...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>June 9, 2022</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/mwdrs-mourns-loss-of-pro-mod-driver-ronnie-hobbs-at-great-bend-nationals/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-600x337.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-100x100.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/mwdrs-mourns-loss-of-pro-mod-driver-ronnie-hobbs-at-great-bend-nationals/" rel="bookmark">
<h2 class="zox-s-title2">MWDRS Mourns Loss of Pro Mod Driver Ronnie Hobbs at Great Bend Nationals</h2>
</a>
</div>
<p class="zox-s-graph">The Mid-West Drag Racing Series (MWDRS) is saddened over the passing of Pro Mod driver Ronnie Hobbs following an on-track incident during Friday night...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>June 6, 2022</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/big-money-bracket-racer-sean-serra-dies-at-27/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-600x337.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-100x100.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/big-money-bracket-racer-sean-serra-dies-at-27/" rel="bookmark">
<h2 class="zox-s-title2">Big Money Bracket Racer Sean Serra Dies at 27</h2>
</a>
</div>
<p class="zox-s-graph">Drag racer Sean Serra has passed away in a tragic car accident. He was 27 years old. Serra was involved in a single-car rollover...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/kayla-zadel/" title="Posts by Kayla Zadel" rel="author">Kayla Zadel</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>July 7, 2022</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/twbs-stevie-fast-talks-sea-towing-superchargers-and-staying-out-front-amidst-mid-season-pro-mod-rule-changes/" rel="bookmark">
<img width="556" height="337" src="https://dragillustrated.com/wp-content/uploads/2019/07/TWBS-Post-Graphic-Stevie-Jackson.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2019/07/TWBS-Post-Graphic-Stevie-Jackson.jpg 660w, https://dragillustrated.com/wp-content/uploads/2019/07/TWBS-Post-Graphic-Stevie-Jackson-400x242.jpg 400w, https://dragillustrated.com/wp-content/uploads/2019/07/TWBS-Post-Graphic-Stevie-Jackson-270x164.jpg 270w, https://dragillustrated.com/wp-content/uploads/2019/07/TWBS-Post-Graphic-Stevie-Jackson-600x364.jpg 600w, https://dragillustrated.com/wp-content/uploads/2019/07/TWBS-Post-Graphic-Stevie-Jackson-350x212.jpg 350w" sizes="(max-width: 556px) 100vw, 556px" /> <img width="100" height="61" src="https://dragillustrated.com/wp-content/uploads/2019/07/TWBS-Post-Graphic-Stevie-Jackson.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2019/07/TWBS-Post-Graphic-Stevie-Jackson.jpg 660w, https://dragillustrated.com/wp-content/uploads/2019/07/TWBS-Post-Graphic-Stevie-Jackson-400x242.jpg 400w, https://dragillustrated.com/wp-content/uploads/2019/07/TWBS-Post-Graphic-Stevie-Jackson-270x164.jpg 270w, https://dragillustrated.com/wp-content/uploads/2019/07/TWBS-Post-Graphic-Stevie-Jackson-600x364.jpg 600w, https://dragillustrated.com/wp-content/uploads/2019/07/TWBS-Post-Graphic-Stevie-Jackson-350x212.jpg 350w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">The Wes Buck Show</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/twbs-stevie-fast-talks-sea-towing-superchargers-and-staying-out-front-amidst-mid-season-pro-mod-rule-changes/" rel="bookmark">
<h2 class="zox-s-title2">TWBS: &#8220;Stevie Fast&#8221; Talks Sea Towing, Superchargers and Staying Out Front Amidst Mid-Season Pro Mod Rule Changes</h2>
</a>
</div>
<p class="zox-s-graph">&#8220;Stevie Fast&#8221; Jackson, current E3 Spark Plugs NHRA Pro Mod points leader, opens up on mid-season rule changes for supercharged and turbocharged entries and...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>July 4, 2019</span>
</div>
</div>
</div> </div>
</div> </div>
</div>
</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
	jQuery(document).ready(function($) {
  		$(".zox-soc-stat-click-51776").on("click", function(){
	  		$(".zox-more-click-51776").toggleClass("zox-soc-more-open");
  		});
	});
    </script> </article> </div>
<footer id="zox-foot-wrap" class="left zoxrel zox100">
<div class="zox-head-width">
<div class="zox-foot-grid left zoxrel zox100">
<div class="zox-foot-left-wrap">
<div class="zox-foot-logo left zox-lh0">
<a href="https://dragillustrated.com/"><img src="https://dragillustrated.com/wp-content/uploads/2022/03/DragIllustrated_flat_white-200px.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
</div>
<div class="zox-foot-left left">
<div class="zox-foot-menu">
<div class="menu-about-di-container"><ul id="menu-about-di" class="menu"><li id="menu-item-15093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15093"><a href="https://dragillustrated.com/about/">About DI</a></li>
<li id="menu-item-50895" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50895"><a href="https://www.dragillustrated.com">Newsletter</a></li>
<li id="menu-item-21282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21282"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/">Subscribe</a></li>
<li id="menu-item-50896" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50896"><a href="https://www.dragillustrated.com">Customer Service</a></li>
<li id="menu-item-50897" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50897"><a href="https://www.dragillustrated.com">Careers</a></li>
<li id="menu-item-50898" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50898"><a href="https://www.dragillustrated.com">Public Relations</a></li>
<li id="menu-item-50899" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50899"><a href="https://mediakit.dragillustrated.com/">Media Kit</a></li>
<li id="menu-item-50900" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50900"><a href="https://www.dragillustrated.com">Masthead</a></li>
</ul></div> </div>
<div class="zox-foot-copy">
<p>Since 2005, DI has informed, inspired and educated drag racers from every walk of the racing life - weekend warrior and street/strip enthusiasts to pro-level doorslammer and Top Fuel racers. From award-winning writing and photography to binge-worthy videos to electric live events, DI meets hundreds of thousands of racers where they live, creating the moments that create conversations.</p>
</div>
</div>
</div>
<div class="zox-foot-right-wrap">
<div class="zox-foot-soc right relative">
<ul class="zox-foot-soc-list left relative">
<li><a href="https://www.facebook.com/DragIllustrated" target="_blank" class="fab fa-facebook-f"></a></li>
<li><a href="https://twitter.com/DragIllustrated" target="_blank" class="fab fa-twitter"></a></li>
<li><a href="https://www.instagram.com/dragillustrated" target="_blank" class="fab fa-instagram"></a></li>
<li><a href="https://bit.ly/3y2ogFR" target="_blank" class="fab fa-youtube"></a></li>
</ul>
</div>
</div>
</div>
</div>
</footer>
</div>
</div>
</div>
</div>
<div class="zox-fly-top back-to-top">
<span class="fas fa-angle-up"></span>
</div>
</div>
<div class="zox-fly-fade zox-fly-but-click">
</div>
<div data-theiaStickySidebar-sidebarSelector='".zox-sticky-side"' data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":70,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":1004,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script> <script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
<script type="text/javascript">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</script> 
<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">

<div class="pswp__bg"></div>

<div class="pswp__scroll-wrap">

<div class="pswp__container">
<div class="pswp__item"></div>
<div class="pswp__item"></div>
<div class="pswp__item"></div>
</div>

<div class="pswp__ui pswp__ui--hidden">
<div class="pswp__top-bar">

<div class="pswp__counter"></div>
<button class="pswp__button pswp__button--close" title="Close (Esc)"></button>
<button class="pswp__button pswp__button--share" title="Share"></button>
<button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>
<button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>


<div class="pswp__preloader">
<div class="pswp__preloader__icn">
<div class="pswp__preloader__cut">
<div class="pswp__preloader__donut"></div>
</div>
</div>
</div>
</div>
<div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
<div class="pswp__share-tooltip"></div>
</div>
<button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
</button>
<button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
</button>
<div class="pswp__caption">
<div class="pswp__caption__center"></div>
</div>
</div>
</div>
</div>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/dragillustrated.com\/wp-json\/","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.6' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/ResizeSensor.js?ver=1.7.0' id='theia-sticky-sidebar/ResizeSensor.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.7.0' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.7.0' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/zoxpress-plugin//scripts/jquery.sticky-kit.min.js?ver=6.0.1' id='jquery-sticky-kit-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/zoxpress-plugin//scripts/jquery.waypoints.min.js?ver=6.0.1' id='jquery-waypoints-js'></script>
<script type='text/javascript' id='advanced-ads-responsive-js-extra'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.10.3' id='advanced-ads-responsive-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/jquery.nouislider.all.min.js?ver=3.14.2' id='reviewer-nouislider-plugin-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/photoswipe.js?ver=3.14.2' id='reviewer-photoswipe-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/jquery.knob.js?ver=3.14.2' id='reviewer-knob-plugin-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer.public.min.js?ver=3.14.2' id='reviewer-public-script-js'></script>
<script type='text/javascript' id='reviewer-reviews-boxes-script-js-extra'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerRatingObj = {"ajax_nonce":"bd6ed2b0c7","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_rating"};
var reviewerJudgeObj = {"ajax_nonce":"fafb7e28f4","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_like"};
var reviewerQueryURs = {"ajax_nonce":"90e59b4f81","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer-reviews-boxes.js?ver=3.14.2' id='reviewer-reviews-boxes-script-js'></script>
<script type='text/javascript' id='reviewer-widget-users-reviews-script-js-extra'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerQueryAllURs = {"ajax_nonce":"dac5d7f8e1","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_all_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer-widget-users-reviews.js?ver=3.14.2' id='reviewer-widget-users-reviews-script-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-pro/assets/js/advanced-ads-pro.min.js?ver=2.17.2' id='advanced-ads-pro/front-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/zoxcustom.js?ver=6.0.1' id='zox-custom-js'></script>
<script type='text/javascript' id='zox-custom-js-after'>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</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/scripts.js?ver=6.0.1' id='zox-scripts-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/retina.js?ver=6.0.1' id='zox-retina-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/jquery.infinitescroll.min.js?ver=6.0.1' id='zox-infinitescroll-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/comment-reply.min.js?ver=6.0.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/intersection-observer.js' id='zox-intersection-observer-polyfill-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/lozad.min.js' id='zox-lozad-js'></script>
<script type='text/javascript' id='zox-lozad-js-after'>

	var zoxWidgets = document.querySelectorAll("#zox-home-widget-wrap img");
	lozad(zoxWidgets, {
		rootMargin: "0px 0px",
		loaded: function (el) {
			el.classList.add("is-loaded");
		}
	}).observe();
</script>
<script type='text/javascript' id='advanced-ads-pro/cache_busting-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":"","wp_timezone_offset":"-18000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-pro/assets/js/base.min.js?ver=2.17.2' id='advanced-ads-pro/cache_busting-js'></script>
<script type='text/javascript' id='advadsTrackingScript-js-extra'>
/* <![CDATA[ */
var advadsTracking = {"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"dragi-target","blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/tracking.min.js?ver=2.3.1' id='advadsTrackingScript-js'></script>
<script>window.advads_admin_bar_items = [];</script><script>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</script><script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script src='https://stats.wp.com/e-202228.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.1.1',blog:'37035244',post:'51776',tz:'-5',srv:'dragillustrated.com'} ]);
	_stq.push([ 'clickTrackerInit', '37035244', '51776' ]);
</script>
<script id="dragi-tracking">var advads_tracking_ads = {};var advads_tracking_urls = {"1":"https:\/\/dragillustrated.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods = {"1":"frontend"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"https:\/\/dragillustrated.com\/linkout\/"};</script>
</body>
</html>