<!DOCTYPE html>
<html lang="en-US"
 xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />




<link rel="shortcut icon" href="https://dragillustrated.com/wp-content/uploads/2014/06/DI_16x16_favicon.png" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://dragillustrated.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://dragillustrated.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://dragillustrated.com/feed/atom/" />
<link rel="pingback" href="https://dragillustrated.com/xmlrpc.php" />


<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script>window._wca = window._wca || [];</script>

	<!-- This site is optimized with the Yoast SEO Premium plugin v16.0 (Yoast SEO v17.3) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Halsey, Weatherford, DeFlorian, Holdorf, Garner-Jones and Essick Close 2021 PDRA Season with World Finals Victories - Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Montserrat%3A400%7CQuicksand%3A300%2C400%7CVidaloka%7CPlayfair%20Display%3A400%2C700%2C900%7COpen%20Sans%20Condensed%3A300%2C700%7COpen%20Sans%3A400%2C800%7COswald%3A300%2C400%2C700%7CRaleway%3A200%2C300%2C400%2C500%2C600%2C700%2C800%26amp%3Bsubset%3Dlatin%2Clatin-ext&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat%3A400%7CQuicksand%3A300%2C400%7CVidaloka%7CPlayfair%20Display%3A400%2C700%2C900%7COpen%20Sans%20Condensed%3A300%2C700%7COpen%20Sans%3A400%2C800%7COswald%3A300%2C400%2C700%7CRaleway%3A200%2C300%2C400%2C500%2C600%2C700%2C800%26amp%3Bsubset%3Dlatin%2Clatin-ext&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat%3A400%7CQuicksand%3A300%2C400%7CVidaloka%7CPlayfair%20Display%3A400%2C700%2C900%7COpen%20Sans%20Condensed%3A300%2C700%7COpen%20Sans%3A400%2C800%7COswald%3A300%2C400%2C700%7CRaleway%3A200%2C300%2C400%2C500%2C600%2C700%2C800%26amp%3Bsubset%3Dlatin%2Clatin-ext&#038;display=swap" /></noscript>
	<link rel="canonical" href="https://dragillustrated.com/halsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Halsey, Weatherford, DeFlorian, Holdorf, Garner-Jones and Essick Close 2021 PDRA Season with World Finals Victories - Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
	
			<meta property="og:description" content="Newly crowned world champions Jim Halsey (Switzer Dynamics Pro Nitrous), Chris Garner-Jones (Drag 965 Pro Nitrous Motorcycle) and Tim Essick (Drag 965 Pro Street) bookended their championship seasons with victories at the Professional Drag Racers Association (PDRA) Brian Olson Memorial World Finals presented by ProCharger at Virginia Motorsports Park. Randy Weatherford (Penske/PRS Pro Boost presented [...]" />
	<meta property="og:url" content="https://dragillustrated.com/halsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories/" />
	<meta property="og:site_name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
	<meta property="article:publisher" content="https://www.facebook.com/dragillustrated" />
	<meta property="article:published_time" content="2021-10-18T06:03:09+00:00" />
	<meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2021/10/PN_Jim-Halsey-3_Tara-Bowker-photo-1-1000x667.jpg" />
	<meta property="og:image:width" content="1000" />
	<meta property="og:image:height" content="667" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@dragillustrated" />
	<meta name="twitter:site" content="@dragillustrated" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Nate Van Wagnen" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="13 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Feed" href="https://dragillustrated.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Comments Feed" href="https://dragillustrated.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; iCal Feed" href="https://dragillustrated.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Halsey, Weatherford, DeFlorian, Holdorf, Garner-Jones and Essick Close 2021 PDRA Season with World Finals Victories Comments Feed" href="https://dragillustrated.com/halsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories/feed/" />
		<!-- This site uses the Google Analytics by ExactMetrics plugin v7.1.0 - Using Analytics tracking - https://www.exactmetrics.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-21052018-1"  type="text/javascript" data-cfasync="false" async></script>
			<script type="text/javascript" data-cfasync="false">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</script>
				<!-- / Google Analytics by ExactMetrics -->
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='front-css-css'  href='https://dragillustrated.com/wp-content/plugins/facebook-comment-by-vivacity/css/fb-comments-hidewpcomments.css?ver=b6480f2684a12b5f296054be67feb451' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://dragillustrated.com/wp-includes/css/dist/block-library/style.min.css?ver=b6480f2684a12b5f296054be67feb451' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://dragillustrated.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://dragillustrated.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=b6480f2684a12b5f296054be67feb451' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css'  href='https://dragillustrated.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-vendors-style.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css'  href='https://dragillustrated.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-style.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='digg-digg-css'  href='https://dragillustrated.com/wp-content/plugins/digg-digg/css/diggdigg-style.css?ver=5.3.6' type='text/css' media='screen' />
<link rel='stylesheet' id='woocommerce-layout-css'  href='https://dragillustrated.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=5.8.0' type='text/css' media='all' />
<style id='woocommerce-layout-inline-css' type='text/css'>

	.infinite-scroll .woocommerce-pagination {
		display: none;
	}
</style>
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://dragillustrated.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=5.8.0' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='https://dragillustrated.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=5.8.0' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='mvp-style-css'  href='https://dragillustrated.com/wp-content/themes/Braxton-Child/style.css?ver=b6480f2684a12b5f296054be67feb451' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='mvp-iecss-css'  href='https://dragillustrated.com/wp-content/themes/Braxton-Child/css/iecss.css?ver=b6480f2684a12b5f296054be67feb451' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='reset-css'  href='https://dragillustrated.com/wp-content/themes/braxton/css/reset.css?ver=b6480f2684a12b5f296054be67feb451' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.css?ver=b6480f2684a12b5f296054be67feb451' type='text/css' media='all' />
<link rel='stylesheet' id='media-queries-css'  href='https://dragillustrated.com/wp-content/themes/braxton/css/media-queries.css?ver=b6480f2684a12b5f296054be67feb451' type='text/css' media='all' />

<link rel='stylesheet' id='tablepress-default-css'  href='https://dragillustrated.com/wp-content/tablepress-combined.min.css?ver=41' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://dragillustrated.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.2' type='text/css' media='all' />
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20210930' id='jetpack_related-posts-js'></script>
<script type='text/javascript' id='exactmetrics-frontend-script-js-extra'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/dragillustrated.com","hash_tracking":"false","ua":"UA-21052018-1","v4_id":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend-gtag.min.js?ver=7.1.0' id='exactmetrics-frontend-script-js'></script>
<script defer type='text/javascript' src='https://stats.wp.com/s-202142.js' id='woocommerce-analytics-js'></script>
<link rel="https://api.w.org/" href="https://dragillustrated.com/wp-json/" /><link rel="alternate" type="application/json" href="https://dragillustrated.com/wp-json/wp/v2/posts/47911" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dragillustrated.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dragillustrated.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p2voyE-csL' />
<link rel="alternate" type="application/json+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Fhalsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Fhalsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories%2F&#038;format=xml" />
<script type="text/javascript" src="https://paywall.subscriptiongenius.com/load.js"></script>

<!-- This site is using AdRotate v5.7.2 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.gformba { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.gformba img { height:auto; }
	.gformba-col { position:relative; float:left; }
	.gformba-col:first-child { margin-left: 0; }
	.gformba-col:last-child { margin-right: 0; }
	.gformba-1 {  margin: 0 auto; }
	.gformba-2 { margin:1px; 1px 1px 1px; }
	.gformba-3 { margin:1px; 1px 1px 1px; float:right; clear:right; }
	.gformba-4 { margin:1px 1px 1px 1px; }
	.gformba-5 { margin:1px 1px 1px 1px; }
	.gformba-6 { margin:1px 1px 1px 1px; }
	.gformba-7 { margin:1px; 1px 1px 1px; }
	.gformba-8 { min-width:3px; max-width:618px; }
	.bformba-8 { margin:1px 3px 1px 3px; }
	.gformba-9 { margin:1px 1px 1px 1px; }
	.gformba-10 { margin:1px 1px 1px 1px; }
	.gformba-16 { min-width:5px; max-width:150px; margin: 0 auto; }
	.bformba-16 { margin:0px 5px 0px 5px; }
	.gformba-26 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.gformba-col, .gformba-dyn, .gformba-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<meta property="fb:app_id" content="297668800418060"/>
<meta property="fb:admins" content=""/>
<meta property="og:locale" content="en_US" />
<meta property="og:locale:alternate" content="en_US" />
<style type="text/css">
			.wpsdc-drop-cap {
				float : left;				
				padding : 0.25em 0.05em 0.25em 0;				
				font-size : 5em;
				line-height : 0.4em;color : #0a0a0a;}
		</style><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://dragillustrated.com"><link rel="https://theeventscalendar.com/" href="https://dragillustrated.com/wp-json/tribe/events/v1/" /><style type='text/css'>img#wpstats{display:none}</style>
		
<style type='text/css'>

@import url(//fonts.googleapis.com/css?family=Vidaloka:100,200,300,400,500,600,700,800,900|Raleway:100,200,300,400,500,600,700,800,900|Playfair+Display:100,200,300,400,500,600,700,800,900|Oswald:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese);

#nav-wrapper,
#nav-top-wrap {
	background: #ff0000;
	}

.fly-but-wrap span {
	background: #555555;
	}

#main-nav .menu li a:hover,
#main-nav .menu li.current-menu-item a,
#search-button:hover,
.home-widget h3.widget-cat,
span.post-tags-header,
.post-tags a:hover,
.tag-cloud a:hover,
.woocommerce .widget_price_filter .ui-slider .ui-slider-range {
	background: #ff0000;
	}

.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce span.onsale,
.woocommerce #respond input#submit.alt,
.woocommerce a.button.alt,
.woocommerce button.button.alt,
.woocommerce input.button.alt,
.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt:hover {
	background-color: #ff0000;
	}

.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt:hover {
	opacity: 0.8;
	}

#main-nav .menu-item-home a:hover {
	background: #ff0000 !important;
	}

#top-story-left h3,
#top-story-right h3 {
	border-bottom: 3px solid #ff0000;
	}

a, a:visited,
ul.top-stories li:hover h2,
ul.top-stories li:hover h2,
#top-story-middle:hover h2,
#top-story-wrapper:hover #feat2-main-text h2,
#feat1-left-wrapper:hover .feat1-left-text h2,
#feat1-right-wrapper:hover .feat1-right-text h2,
ul.split-columns li:hover h2,
.home-widget ul.wide-widget li:hover h2,
.home-widget ul.home-list li:hover h2,
h3.story-cat,
h3.story-cat a,
.sidebar-widget ul.home-list li:hover h2,
.sidebar-widget ul.wide-widget li:hover h2,
.sidebar-widget ul.split-columns li:hover h2,
#footer-nav .menu li a:hover,
.footer-widget ul.home-list li:hover h2,
.footer-widget ul.wide-widget li:hover h2,
.footer-widget ul.split-columns li:hover h2,
.prev,
.next {
	color: #ff0000;
	}

#wallpaper {
	background: url() no-repeat 50% 0;
	}

.featured-text h2,
.featured-text h2 a,
.feat1-main-text h2,
.feat1-main-text h2 a {
	font-family: 'Vidaloka', serif;
	}

#main-nav .menu li a,
#main-nav .menu li:hover ul li a {
	font-family: 'Raleway', sans-serif;
	}

#top-story-left h2,
#top-story-right h2,
.feat1-left-text h2,
.feat1-right-text h2,
#feat2-main-text h2,
#middle-text h2,
ul.split-columns li h2,
.home-widget .wide-text h2,
.home-widget .home-list-content h2,
h1.story-title,
.sidebar-widget .wide-text h2,
.sidebar-widget ul.split-columns li h2,
.footer-widget .wide-text h2,
.footer-widget ul.split-columns li h2,
#post-404 h1 {
	font-family: 'Playfair Display', serif;
	}

#top-story-left h3,
#top-story-right h3,
#middle-text h3,
h1.home-widget-header,
#woo-content h1.page-title,
h3.home-widget-header,
h1.archive-header,
h3.story-cat,
h3.story-cat a,
#content-area h1,
#content-area h2,
#content-area h3,
#content-area h4,
#content-area h5,
#content-area h6,
h4.post-header,
h3.sidebar-widget-header,
h3.footer-widget-header {
	font-family: 'Oswald', sans-serif;
	}

@media screen and (max-width: 767px) and (min-width: 480px) {

	.sidebar-widget .home-list-content h2 {
		font-family: 'Playfair Display', serif;
		}

	}

#menufication-outer-wrap.menufication-transition-in #menufication-scroll-container {
	overflow-y: auto !important;
	}

</style>
	
<style type="text/css">



</style>

<style type="text/css">
#wallpaper {
	background-size: 100%;
}
.icn-t { width:100% !important; }</style>

	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e7e7e7; }
</style>
	<link rel="icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-180x180.png" />
<meta name="msapplication-TileImage" content="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-270x270.png" />

</head>

<body data-rsssl=1 class="post-template-default single single-post postid-47911 single-format-standard custom-background theme-braxton woocommerce-no-js tribe-no-js">
<div id="site">
	<div id="fly-wrap">
	<div class="fly-wrap-out">
		<div class="fly-side-wrap">
			<ul class="fly-bottom-soc left relative">
									<li class="fb-soc">
						<a href="https://www.facebook.com/DragIllustrated/" target="_blank">
						<i class="fa fa-facebook-square fa-2"></i>
						</a>
					</li>
													<li class="twit-soc">
						<a href="https://twitter.com/DragIllustrated" target="_blank">
						<i class="fa fa-twitter fa-2"></i>
						</a>
					</li>
																	<li class="inst-soc">
						<a href="https://www.instagram.com/dragillustrated/" target="_blank">
						<i class="fa fa-instagram fa-2"></i>
						</a>
					</li>
																													<li class="rss-soc">
						<a href="https://dragillustrated.com/feed/rss/" target="_blank">
						<i class="fa fa-rss fa-2"></i>
						</a>
					</li>
							</ul>
		</div><!--fly-side-wrap-->
		<div class="fly-wrap-in">
			<div id="fly-menu-wrap">
				<nav class="fly-nav-menu left relative">
					<div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-15084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15084"><a href="https://dragillustrated.com/category/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-20226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20226"><a href="https://dragillustrated.com/category/blogs/driver-blogs/">Blogs</a></li>
	<li id="menu-item-15087" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15087"><a href="https://dragillustrated.com/category/tech/">Tech</a></li>
	<li id="menu-item-15100" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15100"><a href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a></li>
</ul>
</li>
<li id="menu-item-34161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34161"><a href="https://dragillustrated.com/category/thewesbuckshow/">The Wes Buck Show</a></li>
<li id="menu-item-44403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44403"><a href="https://dragillustrated.com/category/doorslammernats/">Doorslammer Nats</a></li>
<li id="menu-item-15094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" rel="noopener" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li id="menu-item-15102" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
</ul></div>				</nav>
			</div><!--fly-menu-wrap-->
		</div><!--fly-wrap-in-->
	</div><!--fly-wrap-out-->
</div><!--fly-wrap-->	<div id="nav-top-wrap" class="left relative">
		<div id="nav-top-mid" class="relative">
			<div id="nav-top-cont" class="left relative">
																</div><!--nav-top-cont-->
		</div><!--nav-top-mid-->
	</div><!--nav-top-wrap-->
	<div id="nav-wrapper">
		<div class="nav-wrap-out">
		<div class="nav-wrap-in">
			<div id="nav-inner">
			<div class="fly-but-wrap left relative">
				<span></span>
				<span></span>
				<span></span>
				<span></span>
			</div><!--fly-but-wrap-->
							<div id="logo-small" itemscope itemtype="http://schema.org/Organization">
											<a itemprop="url" href="https://dragillustrated.com"><img itemprop="logo" src="https://dragillustrated.com/wp-content/uploads/2015/01/DI_141x54_white_shadow.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" /></a>
									</div><!--logo-small-->
						<div id="main-nav">
				<div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15084"><a href="https://dragillustrated.com/category/features/">Features</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20226"><a href="https://dragillustrated.com/category/blogs/driver-blogs/">Blogs</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15087"><a href="https://dragillustrated.com/category/tech/">Tech</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15100"><a href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34161"><a href="https://dragillustrated.com/category/thewesbuckshow/">The Wes Buck Show</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44403"><a href="https://dragillustrated.com/category/doorslammernats/">Doorslammer Nats</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" rel="noopener" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
</ul></div>			</div><!--main-nav-->
			<div id="search-button">
				<img src="https://dragillustrated.com/wp-content/themes/braxton/images/search-icon.png" />
			</div><!--search-button-->
			<div id="search-bar">
				<form method="get" id="searchform" action="https://dragillustrated.com/">
	<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>			</div><!--search-bar-->
			</div><!--nav-inner-->
		</div><!--nav-wrap-in-->
		</div><!--nav-wrap-out-->
	</div><!--nav-wrapper-->
		<div id="body-wrapper">
				<div id="main-wrapper">
										
    <div id="ad-area-wrap"><div class="ad-rotate-widget"><div class="ad-rotate-widget-widget">			<div class="textwidget"><div class="gformba gformba-7"><div class="gformba-single aformba-451"><a class="gofollow" data-track="NDUxLDcsMSwxMA==" href="http://www.worldproducts.net/" target="_blank" rel="noopener"><img src="https://dragillustrated.com/wp-content/uploads/2018/03/728x90_World_leader_03_18.jpg" /></a></div></div>
</div>
		</div></div><!-- end .ad-rotate-widget --><div class="subscribe-now"><div class="subscribe-now">			<div class="textwidget"><div align="center"><a href="https://doorslammernats.com/"><img loading="lazy" src="https://dragillustrated.com/wp-content/uploads/2021/02/WDN2021_160x90.png" alt="Drag Racing Master Mind" width="160" height="90" /></a></div>
</div>
		</div></div><!-- end .subscribe-now --></div><!-- end #ad-area-wrap -->	
	<div id="content-wrapper">
						<div id="content-main">
																										<div id="featured-image" itemscope itemtype="http://schema.org/Article">
																													<img itemprop="image" src="https://dragillustrated.com/wp-content/uploads/2021/10/PN_Jim-Halsey-3_Tara-Bowker-photo-1-660x400.jpg" />
														<span class="photo-credit">Tara Bowker photos</span>
													</div><!--featured-image-->
																					<div id="home-main">
				<div id="post-area" itemscope itemtype="http://schema.org/Article" class="post-47911 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-pdra-race-coverage category-race-coverage">
					<h3 class="story-cat">News</h3>
					<h1 class="story-title" itemprop="name">Halsey, Weatherford, DeFlorian, Holdorf, Garner-Jones and Essick Close 2021 PDRA Season with World Finals Victories</h1>
					<div id="post-info">
						By&nbsp;<span class="author" itemprop="author"><a href="https://dragillustrated.com/author/nate/" title="Posts by Nate Van Wagnen" rel="author">Nate Van Wagnen</a></span>&nbsp;|&nbsp;<time class="post-date" itemprop="datePublished" datetime="2021-10-18" pubdate>October 18, 2021</time>
					</div><!--post-info-->
											<div class="social-sharing-top">
							<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://dragillustrated.com/halsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories/&t=Halsey, Weatherford, DeFlorian, Holdorf, Garner-Jones and Essick Close 2021 PDRA Season with World Finals Victories', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"></span><p>Share</p></div></a>
							<a href="#" onclick="window.open('http://twitter.com/share?text=Halsey, Weatherford, DeFlorian, Holdorf, Garner-Jones and Essick Close 2021 PDRA Season with World Finals Victories -&url=https://dragillustrated.com/halsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"></span><p>Tweet</p></div></a>
							<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://dragillustrated.com/halsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories/&media=https://dragillustrated.com/wp-content/uploads/2021/10/PN_Jim-Halsey-3_Tara-Bowker-photo-1-660x400.jpg&description=Halsey, Weatherford, DeFlorian, Holdorf, Garner-Jones and Essick Close 2021 PDRA Season with World Finals Victories', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"></span><p>Share</p></div></a>
							<a href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https://dragillustrated.com/halsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"><div class="google-share"><span class="google-but1"></span><p>Share</p></div></a>
							<a href="https://dragillustrated.com/halsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories/#respond"><div class="social-comments"><p>0 comments</p></div></a>
						</div><!--social-sharing-top-->
										<div id="content-area">
							
		<p>Newly crowned world champions Jim Halsey (Switzer Dynamics Pro Nitrous), Chris Garner-Jones (Drag 965 Pro Nitrous Motorcycle) and Tim Essick (Drag 965 Pro Street) bookended their championship seasons with victories at the Professional Drag Racers Association (PDRA) Brian Olson Memorial World Finals presented by ProCharger at Virginia Motorsports Park.</p>
<p>Randy Weatherford (Penske/PRS Pro Boost presented by WS Construction), John DeFlorian (Liberty’s Gears Extreme Pro Stock presented by AED Competition), and Chris Holdorf ($hameless Racing Pro Outlaw 632) also won in the pro classes.</p><div class="gformba gformba-3"><div class="gformba-single aformba-288"><center><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="Mjg4LDMsMSwxMA==" href="http://www.fueltech.net/"><img src="https://dragillustrated.com/wp-content/uploads/2017/02/DI-300x300.png" /></a></center><br></div></div>
<p>The sportsman event champions were Jeremy Creasman in MagnaFuel Elite Top Sportsman presented by Tejas Borja, Kellan Farmer in Lucas Oil Elite Top Dragster, Joe Roubicek in MagnaFuel Top Sportsman 48, and David Petrofske in Lucas Oil Top Dragster 32. Michael Robbins won in Edelbrock Bracket Bash presented by COMP Cams, defeating Brianna Lukhard in the final round.</p>
<p>In the Jr. Dragster classes, Chris Suppers (Coolshirt Systems Pro Jr. Dragster) and Hunter Cunningham (Classic Graphix Top Jr. Dragster) secured the event wins. It was an all-Virginia final between Suppers and Louis Crockett, with Suppers running 7.941 to Crockett’s 7.97, both on a 7.90 dial-in. Cunningham used a starting line advantage and a 9.06 on an 8.99 dial-in to defeat 2021 world champion Rowan Parlett and his 9.068 on an 8.91 dial-in.</p>
<p>The PDRA also crowned its 2021 world champions at the World Finals. Along with Halsey, Garner-Jones, Essick, and Parlett, championships went to Kevin Rivenbark in Pro Boost, Chris Powers in Extreme Pro Stock, Wes Distefano in Pro Outlaw 632, Tim Molnar in Elite Top Sportsman, Peter Maduri in Elite Top Dragster, Nick Meloni in Top Sportsman, TG Paschal in Top Dragster, and Ethan Steding in Pro Jr. Dragster.</p>
<p>The 2021 world champions will be celebrated at the annual PDRA Awards Banquet on Friday, Dec. 10 during the Performance Racing Industry (PRI) Show weekend in Indianapolis.</p>
<h4>PRO NITROUS</h4>
<p><img loading="lazy" class="alignnone size-thumbnail wp-image-47916" src="https://dragillustrated.com/wp-content/uploads/2021/10/PN_Jim-Halsey_Tara-Bowker-photo-1-1000x667.jpg" alt="" width="1000" height="667" srcset="https://dragillustrated.com/wp-content/uploads/2021/10/PN_Jim-Halsey_Tara-Bowker-photo-1-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2021/10/PN_Jim-Halsey_Tara-Bowker-photo-1-1200x800.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2021/10/PN_Jim-Halsey_Tara-Bowker-photo-1-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2021/10/PN_Jim-Halsey_Tara-Bowker-photo-1-1536x1024.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2021/10/PN_Jim-Halsey_Tara-Bowker-photo-1-600x400.jpg 600w, https://dragillustrated.com/wp-content/uploads/2021/10/PN_Jim-Halsey_Tara-Bowker-photo-1.jpg 1800w" sizes="(max-width: 1000px) 100vw, 1000px" /></p>
<p>With four wins in the previous seven races, Jim Halsey rolled into Virginia Motorsports Park as the 2021 Pro Nitrous world champion. Halsey, tuner Brandon Switzer and crew chief Eric Davis kept pushing, though, and closed out their PDRA season with a fifth win. In the final round, Halsey in his Fulton-powered “Daddy Shark” ’68 Camaro matched his quickest pass of the day, a 3.62, to dispatch Ron Muenks and his 3.658 at 206.10.</p>
<p>“I think we had more pressure on us because we lost first round at Maple Grove and lost at GALOT in the semis,” said Halsey, now the only three-time Pro Nitrous world champion. “We just wanted to win a race. It&#8217;s been a few [events] since we did it. The consequences weren&#8217;t there to lose, but we wanted to go out on top with a win.</p>
<p>“This is like a dream come true for me,” Halsey continued. “We&#8217;ve been racing for probably close to 30 years, and to win three in a row and to run the numbers we&#8217;re running, I couldn’t be happier. My driving is pretty decent at times, not so decent at other times, but very happy. I have a great team. They&#8217;re just as happy as I am about it and they deserve way more credit than I do.”</p>
<p>Halsey qualified No. 2 – just the second time he didn’t qualify No. 1 this season – and posted a 3.63 at 208.33 over John Vergotz in the first round, then a 3.62 at 208.30 to defeat fellow Maryland native Fredy Scriba’s 3.685. His slowest pass of the day, 3.637 at 206.86, was still enough to beat two-time world champion Jason Harris and his 3.865 in the semis.</p>
<p>Driving Dave Pierce’s Reher-Morrison-powered “Purple Gorilla” ’68 Camaro, Muenks qualified No. 5 and won first round with a 3.823 over a red-lighting Rob Hunnicutt. It was all mid-3.60s from there, though, as Muenks posted a 3.665 to beat Brian Shrader and a 3.655 to win on a holeshot over No. 1 qualifier Tommy Franklin’s 3.64.</p>
<h4>PRO BOOST</h4>
<p><img loading="lazy" class="alignnone size-thumbnail wp-image-47912" src="https://dragillustrated.com/wp-content/uploads/2021/10/PB_Randy-Weatherford_Tara-Bowker-photo-1000x667.jpg" alt="" width="1000" height="667" srcset="https://dragillustrated.com/wp-content/uploads/2021/10/PB_Randy-Weatherford_Tara-Bowker-photo-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2021/10/PB_Randy-Weatherford_Tara-Bowker-photo-1200x800.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2021/10/PB_Randy-Weatherford_Tara-Bowker-photo-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2021/10/PB_Randy-Weatherford_Tara-Bowker-photo-1536x1024.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2021/10/PB_Randy-Weatherford_Tara-Bowker-photo-600x400.jpg 600w, https://dragillustrated.com/wp-content/uploads/2021/10/PB_Randy-Weatherford_Tara-Bowker-photo.jpg 1800w" sizes="(max-width: 1000px) 100vw, 1000px" /></p>
<p>On a day that saw several of the quickest runs in Pro Boost history, Randy Weatherford didn’t have the quickest car, but he stepped up when it counted. The Danville, Virginia-based driver of the ProCharger-boosted WS Construction ’17 Camaro made his quickest run of the day – a 3.606 – to defeat Daniel Pharris and his 3.607 in the final round. Pharris needed to win the race to win the championship. His teammate, Kevin Rivenbark, clinched his third Pro Boost world championship.</p>
<p>“This season was good at the beginning, we just couldn&#8217;t put one away,” said Weatherford, who appeared in two final rounds in the first three races of the season. “But we brought it home today. This year could&#8217;ve went a little better, but we ended on a good note. I can&#8217;t wait for next year because we&#8217;re going to win this championship next year. We&#8217;re going to win it, guys. We&#8217;re here to stay.”</p>
<p>Weatherford had a perfect start on race day, as he cut a .000 light and ran a 3.654 at 211.00 on a first-round single after opponent Chris Cline left before the tree activated. He needed his .005 reaction time to get the second-round win over Rivenbark, as Weatherford’s 3.658 at 208.23 won on a holeshot over Rivenbark’s 3.629. He won on a holeshot again in the semifinals, using a .002 light and a 3.641 at 209.07 to eliminate No. 1 qualifier Johnny Camp and his 3.600.</p>
<p>Pharris, who won PDRA DragWars at GALOT Motorsports Park two weeks ago, qualified No. 2 in the ProCharger-boosted GALOT Motorsports ’69 Camaro. He ran a 3.636 to beat Dean Bettenson, then a 3.61 to hold off Chuck Ulsch’s 3.662. Semifinal opponent Kurt Steding red-lit away a 3.591 at 213.00, which is quicker than the current E.T. record, allowing Pharris to move on with his 3.613.</p>
<h4>EXTREME PRO STOCK</h4>
<p><img loading="lazy" class="alignnone size-thumbnail wp-image-47917" src="https://dragillustrated.com/wp-content/uploads/2021/10/XPS_John-DeFlorian_Tara-Bowker-photo-1-1000x667.jpg" alt="" width="1000" height="667" srcset="https://dragillustrated.com/wp-content/uploads/2021/10/XPS_John-DeFlorian_Tara-Bowker-photo-1-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2021/10/XPS_John-DeFlorian_Tara-Bowker-photo-1-1200x800.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2021/10/XPS_John-DeFlorian_Tara-Bowker-photo-1-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2021/10/XPS_John-DeFlorian_Tara-Bowker-photo-1-1536x1024.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2021/10/XPS_John-DeFlorian_Tara-Bowker-photo-1-600x400.jpg 600w, https://dragillustrated.com/wp-content/uploads/2021/10/XPS_John-DeFlorian_Tara-Bowker-photo-1.jpg 1800w" sizes="(max-width: 1000px) 100vw, 1000px" /></p>
<p>John DeFlorian went into the World Finals with a checklist of three goals: qualify No. 1, win the race, and record the first 3-second pass in class history. The Jerry Haas Race Cars shop foreman accomplished the first two goals and came impossibly close to the third. He leaves Virginia with the new Extreme Pro Stock E.T. record and the event win after running a 4.015 at 178.33 in the final round to beat Chris Powers, who secured the world championship in the semifinals. Powers ran a 4.047 at 176.24 in the other lane.</p>
<p>“We had a plan in place and we just wanted to try to execute it,” said DeFlorian, who was coming off a quarter-mile win at the NHRA St. Louis race. “Thankfully, we were able to execute it all the way through. We were low [E.T.] every single session. Every run down the racetrack we were fast. We came just a thou short of the 3, but I&#8217;m really happy. That&#8217;s a new record. And it&#8217;s a hard barrier. I can&#8217;t be any happier. I can&#8217;t do this without my wife, Liann, all my guys, Jeff Graber from Graber Concrete, and [crew chief] Brian ‘Lump’ Self. Lump being here was a blessing because it makes a difference having him on the grounds.”</p>
<p>DeFlorian in his Kaase-powered Graber Concrete ’15 Camaro opened eliminations with a 4.029 at 179.54 to knock out Frank “the Flying Meatball” Gugliotta’s 4.053. He took advantage of his competition single in the second round to record a 4.000 at 179.56, the new class record. DeFlorian slowed slightly to a 4.015 at 179.52 in the semis, beating Tony Gillig’s career-best 4.06.</p>
<p>Powers entered the World Finals as the points leader in his Chuck Samuel-tuned Sonny’s Racing Engines ’14 Camaro, but he had to fend off JR Carr and defending world champion Johnny Pluchino. Powers did his part by winning first round with a 4.061 over Dave Hughes, then second round with a 4.024 over Elijah Morton. He won in the semifinals on the starting line when Pluchino went red by .009 on a 4.069 to Powers’ 4.048. With Carr taken out by Pluchino in the second round, Powers secured his first Extreme Pro Stock world championship.</p>
<h4>PRO OUTLAW 632</h4>
<p><img loading="lazy" class="alignnone size-thumbnail wp-image-47915" src="https://dragillustrated.com/wp-content/uploads/2021/10/632_Chris-Holdorf_Tara-Bowker-photo-1-1000x667.jpg" alt="" width="1000" height="667" srcset="https://dragillustrated.com/wp-content/uploads/2021/10/632_Chris-Holdorf_Tara-Bowker-photo-1-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2021/10/632_Chris-Holdorf_Tara-Bowker-photo-1-1200x800.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2021/10/632_Chris-Holdorf_Tara-Bowker-photo-1-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2021/10/632_Chris-Holdorf_Tara-Bowker-photo-1-1536x1024.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2021/10/632_Chris-Holdorf_Tara-Bowker-photo-1-600x400.jpg 600w, https://dragillustrated.com/wp-content/uploads/2021/10/632_Chris-Holdorf_Tara-Bowker-photo-1.jpg 1800w" sizes="(max-width: 1000px) 100vw, 1000px" /></p>
<p>As a consistent late-round player, Chris Holdorf has been chasing his first official Pro Outlaw 632 victory all season with five semifinal finishes. The Florida native rose to the occasion at the final race of the season, though, as he and tuner Jeff Pierce put together a string of passes in the 4.10s to get Holdorf’s first win in PDRA competition. He won on a holeshot in the final round, running a 4.171 at 170.43 in his Nelson-powered Dewitt Custom Concrete ’53 Corvette to deny Amber Franklin her first win in just her second race. Franklin posted a 4.149 at 170.54.</p>
<p>“It&#8217;s about time,” said Holdorf, who unofficially won the 2020 World Finals, as the final round was completed at a non-PDRA event. “We definitely struggled all year and had some bad luck here and there. We finally got things to go our way. We were very fortunate that we caught a break in the semifinals. That gave us a boost into the final round and gave us some of the data we needed, then we carried that through. Hat&#8217;s off to my crew, Alan Reynolds and Carl Monkhouse, and of course, Jeff Pierce, as well as Mark Micke at M&amp;M Transmission, Chris Nelson at Nelson Competition, Bob Book at BRE, and my family for giving me the chance to do this.”</p>
<p>Holdorf started the day as the No. 4 qualifier and lost traction on a first-round bye run after opponent Lexi Tanner lost oil pressure on the starting line. He bounced back with a 4.194 at 169.85 to beat Douglas Nicholl’s 4.217 in the second round. Semifinal opponent Daryl Stewart hurt his engine in the prior round, so Holdorf took another bye run – a 4.184 at 170.32 – to move on to his first final round of the season.</p>
<p>Franklin made her Pro Outlaw 632 debut two weeks ago and was on a mission to back up her runner-up finish there with a win at her home track. She qualified No. 2 in the Musi-powered “Jungle Rat” ’69 Camaro formerly campaigned by her father, Tommy Franklin, in Pro Nitrous. Franklin then locked into the low 4.10s, running a 4.143 over Sylvester Barnes Jr., a 4.132 over George Coleman, and a 4.145 to reach her second consecutive final round.</p>
<h4>PRO NITROUS MOTORCYCLE</h4>
<p><img loading="lazy" class="alignnone size-thumbnail wp-image-47913" src="https://dragillustrated.com/wp-content/uploads/2021/10/PNM_Chris-Garner-Jones_Tara-Bowker-photo-1000x667.jpg" alt="" width="1000" height="667" srcset="https://dragillustrated.com/wp-content/uploads/2021/10/PNM_Chris-Garner-Jones_Tara-Bowker-photo-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2021/10/PNM_Chris-Garner-Jones_Tara-Bowker-photo-1200x800.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2021/10/PNM_Chris-Garner-Jones_Tara-Bowker-photo-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2021/10/PNM_Chris-Garner-Jones_Tara-Bowker-photo-1536x1024.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2021/10/PNM_Chris-Garner-Jones_Tara-Bowker-photo-600x400.jpg 600w, https://dragillustrated.com/wp-content/uploads/2021/10/PNM_Chris-Garner-Jones_Tara-Bowker-photo.jpg 1800w" sizes="(max-width: 1000px) 100vw, 1000px" /></p>
<p>Second-generation Pro Nitrous Motorcycle rider Chris Garner-Jones has been a championship contender for the last few seasons, but he finally scored his first world championship in the class and backed it up with a win to make for an emotional race day. Garner-Jones dedicated the championship and the race win to his late father, T.T. Jones, who passed away last year. Garner-Jones rode his T.T. Jones Racing ’11 Hayabusa to a 3.991 at 175.52 on a bye run in the final, as Paul Gast broke after staging.</p>
<p>“I wish I could describe what this win and this championship mean,” said Garner-Jones who also won the 2021 XDA Pro Xtreme championship. “I&#8217;d probably be doing backflips and I can&#8217;t do a backflip. But it&#8217;s a big weight off my shoulders. I wanted to do it while my dad was here, but unfortunately things happen. That&#8217;s life. But this one is definitely for him. All the way. My brother [William Garner] is the best tuner in the world and I stand behind that.”</p>
<p>Garner-Jones secured the world championship in the opening round when he won with a 4.009 at 176.67 on a bye run and points leader Travis Davis lost to Gast. He was unopposed again in the semifinals when he ran a 4.108 at 144.77.</p>
<p>Gast and his Fast By Gast ’16 Hayabusa played the spoiler role, beating Davis’s 3.988 with a 3.982 and a quicker reaction time. It took a 3.937 at 179.21 – quicker than Gast’s own 3.949 class E.T. record – to defeat No. 1 qualifier Meshal Al-Saber’s 3.966 in the semis.</p>
<h4>PRO STREET</h4>
<p><img loading="lazy" class="alignnone size-thumbnail wp-image-47914" src="https://dragillustrated.com/wp-content/uploads/2021/10/PS_Tim-Essick_Tara-Bowker-photo-1000x667.jpg" alt="" width="1000" height="667" srcset="https://dragillustrated.com/wp-content/uploads/2021/10/PS_Tim-Essick_Tara-Bowker-photo-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2021/10/PS_Tim-Essick_Tara-Bowker-photo-1200x800.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2021/10/PS_Tim-Essick_Tara-Bowker-photo-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2021/10/PS_Tim-Essick_Tara-Bowker-photo-1536x1024.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2021/10/PS_Tim-Essick_Tara-Bowker-photo-600x400.jpg 600w, https://dragillustrated.com/wp-content/uploads/2021/10/PS_Tim-Essick_Tara-Bowker-photo.jpg 1800w" sizes="(max-width: 1000px) 100vw, 1000px" /></p>
<p>Tim Essick, one of the PDRA Pro Street class’s biggest proponents, closed out his season with a storybook weekend at the World Finals. He clinched the first-ever PDRA Pro Street world championship, smashed the class E.T. record, and ended race day with the event win. In the final round, Essick in his ProCharger-boosted “Brown Sugar” ’18 Mustang recorded a 3.913 at 192.14 – the exact E.T. he needed to back up his record pass in the semifinals. He was unopposed, as Ty Kasper wasn’t able to fire up for the final round.</p>
<p>“Winning the championship is the big thing,” said Essick, who thanked crew members and supporters Dan Whetstine, Timmy Savoy, Phillip Buckler, Alan, Michelle and Dawn, as well as Vince Fourcade for helping fix a rear center section issue. “It&#8217;s been a long time since I won a world championship. It means the world and I&#8217;m so happy to have a series to be able to do that in. We struggled a little bit earlier this weekend, but we made everything come together when it mattered.”</p>
<p>Essick qualified No. 2 in his ATI Racing-backed entry and started his record-setting day with a 3.918 at 191.32, which was quicker than the record by nearly half a tenth, to beat Joseph Thomas’s 4.107. He then swung for the fences with a blistering 3.875 at 192.60 in his semifinal win over Bob Ross, who ran 4.093.</p>
<p>Kasper’s turbocharged Victus Sports ’05 Mustang was the second-quickest car in the opening round with a 4.056 at 193.40 to beat Jesse Lambert’s 4.069. He took the tree and broke the staging beams to win in the semifinals when No. 1 qualifier Nick Schroeder wasn’t able to stage.</p>
<h4>TOP SPORTSMAN</h4>
<p>In the Elite Top Sportsman final round, the winner was decided on the starting line, as 2021 world champion Tim Molnar went red by .013 in his nitrous-fed ’68 Camaro. Jeremy Creasman held on in his ProCharger-boosted ’12 Camaro and recorded a 3.856 on a 3.83 dial-in to get the win.</p>
<p>California’s joe Roubicek won in Top Sportsman 48 for the second race in a row. He drove his nitrous-fed ’68 Camaro to a 4.177 on a 4.17 dial-in – with a .005 light – to win over Jeff Melnick in his ProCharged ’02 Avenger. Melnick ran a 4.178 on a 4.16 dial in the runner-up effort.</p>
<h4>TOP DRAGSTER</h4>
<p>It was a race between a past world champion and the new world champion in the Elite Top Dragster final round, where 2019 champion Kellan Farmer squared off with 2021 champion Peter Maduri. Farmer’s quicker reaction time and 3.802 on a 3.78 dial-in in his ’21 Race Tech dragster gave him the win. Maduri made it a close race with his 3.729 on a 3.72 dial-in in his K100/Dynabrade ’17 Chrome-Worx dragster.</p>
<p>David Petrofske overcame a slight starting line disadvantage in the Top Dragster 32 final round to win the race, running a 4.155 on a 4.15 dial in his ’21 Precision dragster. Virginia’s Duane Allen broke out with a 4.185 on a 4.20 dial in his ’17 American dragster to take runner-up honors.</p>
<p>The eight-race 2022 PDRA season will begin on April 7-9 at the East Coast Nationals at GALOT Motorsports Park in Benson, N.C.</p>
<div class='dd_post_share'><div class='dd_buttons'><div class='dd_button'><a name='fb_share' type='button_count' share_url='https://dragillustrated.com/halsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories/' href='http://www.facebook.com/sharer.php'></a><script src='https://static.ak.fbcdn.net/connect.php/js/FB.Share' type='text/javascript'></script></div><div class='dd_button'><a href="http://twitter.com/share" class="twitter-share-button" data-url="https://dragillustrated.com/halsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories/" data-count="horizontal" data-text="Halsey, Weatherford, DeFlorian, Holdorf, Garner-Jones and Essick Close 2021 PDRA Season with World Finals Victories" data-via="dragillustrated" ></a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script></div><div class='dd_button'><iframe src='https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fdragillustrated.com%2Fhalsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories%2F&amp;locale=en_US&amp;layout=standard&amp;action=like&amp;width=350&amp;height=24&amp;colorscheme=light' scrolling='no' frameborder='0' style='border:none; overflow:hidden; width:500px; height:24px;' allowTransparency='true'></iframe></div></div><div style='clear:both'></div></div><!-- Social Buttons Generated by Digg Digg plugin v5.3.6,
    Author : Buffer, Inc
    Website : http://bufferapp.com/diggdigg --><!-- FB Comments For Wp: http://www.vivacityinfotech.com --><h3 class='coments-title'>Comments</h3><p class='commentcount'><fb:comments-count href="https://dragillustrated.com/halsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories/"></fb:comments-count> comments</p><div class="fb-comments" data-href="https://dragillustrated.com/halsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories/" data-numposts="6" data-width="100%" data-colorscheme="light"></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-41"><a class="gofollow" data-track="NDEsMTYsMSwxMA==" href="https://www.racingconverters.com/ncrc/lockup-billet-racing-converters/?utm_source=DI&utm_medium=web&utm_campaign=banner&utm_content=300-2021-A" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2021/01/NCRC-2021-300x300-1.gif" /></a></div></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-627"><a class="gofollow" data-track="NjI3LDE2LDEsMTA=" href="http://www.callies.com/" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2020/02/300x-300-banner.jpg" /></a></div></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-685"><a class="gofollow" data-track="Njg1LDE2LDEsMTA=" href="https://www.prpracingproducts.com/product/billet-adjustable-timing-pointers/" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2021/03/PRP_BilletFuelCaps_300x300_ANIMATED_1.gif" /></a></div></div><div class="gformba gformba-16"><div class="gformba-col bformba-16 aformba-680"><a class="gofollow" data-track="NjgwLDE2LDEsMTA=" href="https://wilwood.com/racing/DragRace/Index?r=ad-dragillustrated&utm_source=dragillustrated&utm_medium=banner&utm_campaign=ad-dragillustrated" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2021/01/Wilwood-Drag-Illustrated-2021-300x300_v2-1.jpg" /></a></div></div></p>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>																		<div class="post-tags">
							<span class="post-tags-header">Related Items</span>						</div><!--post-tags-->
					</div><!--content-area-->
				</div><!--post-area-->
										<div id="author-wrapper">
						<div id="author-info">
							<img alt='' src='https://secure.gravatar.com/avatar/7ef2bd3121d8ee25ecf7cdcdd67255a1?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7ef2bd3121d8ee25ecf7cdcdd67255a1?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/>							<div id="author-text">
								<span class="author-name"><a href="https://dragillustrated.com/author/nate/" title="Posts by Nate Van Wagnen" rel="author">Nate Van Wagnen</a></span>
								<p></p>
								<ul>
																																																														</ul>
							</div><!--author-text-->
						</div><!--author-info-->
					</div><!--author-wrapper-->
													<div class="prev-next-wrapper">
					<div class="prev-post">
						&larr; Previous Story <a href="https://dragillustrated.com/s-torrence-dejoria-and-pollacheck-earn-no-1-qualifiers-at-nhra-thunder-valley-nationals/" rel="prev">S. Torrence, DeJoria and Pollacheck Earn No. 1 Qualifiers at NHRA Thunder Valley Nationals</a>					</div><!--prev-post-->
					<div class="next-post">
											</div><!--next-post-->
				</div><!--prev-next-wrapper-->
												<div id="comments">
				
	
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><h4 class="post-header"><span class="post-header">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/halsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://dragillustrated.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='47911' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	
</div><!--comments-->			</div><!--home-main-->
				</div><!--content-main-->
		<div id="sidebar-wrapper">
	<div id="text-26" class="sidebar-widget widget_text">			<div class="textwidget"><div id="adblock" align="center"><div class="gformba gformba-1"><div class="gformba-single aformba-604"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="NjA0LDEsMSwxMA==" href="https://www.holley.com/brands/holley_efi/products/fuel_systems/fuel_injection/dominator_efi/?utm_source=evforum&utm_medium=dragillustrated&utm_campaign=218011" target="_blank" rel="noopener"><img src="https://dragillustrated.com/wp-content/uploads/2021/10/218011_holleyefi_dominator_300x300.jpg" /></a></div></div></div>
</div>
		</div><div id="text-45" class="sidebar-widget widget_text">			<div class="textwidget"><div id="adblock" align="center"><div class="gformba gformba-1"><div class="gformba-single aformba-627"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="NjI3LDEsMSwxMA==" href="http://www.callies.com/" target="_blank" rel="noopener"><img src="https://dragillustrated.com/wp-content/uploads/2020/02/300x-300-banner.jpg" /></a></div></div></div>
</div>
		</div><div id="text-27" class="sidebar-widget widget_text">			<div class="textwidget"><div align="center" id="adblock"><div class="gformba gformba-2"><div class="gformba-single aformba-686"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="Njg2LDIsMSwxMA==" href="https://elitehp.com/" target="_blank" rel="noopener"><img src="https://dragillustrated.com/wp-content/uploads/2021/06/DIWeb621.jpeg" /></a></div></div></div>
</div>
		</div><div id="text-47" class="sidebar-widget widget_text">			<div class="textwidget"><div class="gformba gformba-5"><div class="gformba-single aformba-533"><H4 class="ad-header">ADVERTISEMENT</H4><a class="gofollow" data-track="NTMzLDUsMSwxMA==" href="https://maximausa.com/series-331-performance-straight-weight.html#!sq%3Dperformance%2060W" target="_blank" rel="noopener"><img src="https://dragillustrated.com/wp-content/uploads/2021/09/21-09PA_DragIllustrated__Web_300x600.jpg" /></a></div></div>
</div>
		</div> 		</div><!--sidebar-wrapper-->					</div><!--content-wrapper-->
</div><!--main-wrapper-->
		<div id="footer-wrapper">
			<div id="footer-top">
			   <div class="ad-rotate-widget-footer"><div class="ad-rotate-widget-widget">			<div class="textwidget"><div class="gformba gformba-7"><div class="gformba-single aformba-640"><a class="gofollow" data-track="NjQwLDcsMSwxMA==" href="https://www.autolite.com/products/racing-spark-plugs/hi-performance/?utm_source=dragillustrated&utm_medium=banner&utm_campaign=racing&utm_term=diy&utm_content=banner" target="_blank" rel="noopener"><img src="https://dragillustrated.com/wp-content/uploads/2021/08/21-AUTO-0752_Drag-PRI_Banners_728x90.gif" /></a></div></div>
</div>
		</div></div><!-- end .ad-rotate-widget --><div id="ad-rotate-footer-bottom"></div>				<div id="footer-nav">
					<div class="menu-about-di-container"><ul id="menu-about-di" class="menu"><li id="menu-item-21282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21282"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/">Subscribe</a></li>
<li id="menu-item-15093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15093"><a href="https://dragillustrated.com/about/">About</a></li>
<li id="menu-item-15089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15089"><a href="https://dragillustrated.com/our-team/">Our Team</a></li>
<li id="menu-item-15091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15091"><a href="https://dragillustrated.com/advertise/">Advertise</a></li>
<li id="menu-item-15090" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15090"><a href="https://dragillustrated.com/contact/">Contact</a></li>
</ul></div>				</div><!--footer-nav-->
								<div id="footer-widget-wrapper">
										<div class="footer-widget">
												<div id="logo-footer">
							<img src="https://dragillustrated.com/wp-content/uploads/2014/05/DragIllustratedMediablackRGBSMALL.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
						</div><!--logo-footer-->
												<p>Drag Illustrated is not affiliated with, nor is it bound by any sanctioning body or association. From groundbreaking stories on underground grudge and outlaw racing to in-depth interviews with world-renowned racers and exclusive event coverage, Drag Illustrated shines the spotlight on the hottest stories in drag racing. When drivers, builders, and hardcore fans want the unbiased truth, Drag Illustrated is where they turn.</p>						<div id="footer-social">
							<ul>
																<li class="fb-item">
									<a href="https://www.facebook.com/DragIllustrated/" alt="Facebook" class="fb-but2" target="_blank"></a>
								</li>
																								<li class="twitter-item">
									<a href="https://twitter.com/DragIllustrated" alt="Twitter" class="twitter-but2" target="_blank"></a>
								</li>
																																								<li class="instagram-item">
									<a href="https://www.instagram.com/dragillustrated/" alt="Instagram" class="instagram-but2" target="_blank"></a>
								</li>
																																								<li><a href="https://dragillustrated.com/feed/rss/" alt="RSS Feed" class="rss-but2"></a></li>
															</ul>
						</div><!--footer-social-->
						<div id="copyright">
							<p>Copyright © 2019 Drag Illustrated Media, LLC.</p>
						</div><!--copyright-->
					</div><!--footer-widget-->
															<div class="footer-widget">
						<h3 class="footer-widget-header">Latest News</h3>
						<ul class="home-list">
														<li>
								<a href="https://dragillustrated.com/halsey-weatherford-deflorian-holdorf-garner-jones-and-essick-close-2021-pdra-season-with-world-finals-victories/" rel="bookmark">
								<div class="home-list-content">
									<h2>Halsey, Weatherford, DeFlorian, Holdorf, Garner-Jones and Essick Close 2021 PDRA Season with World Finals Victories</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/s-torrence-dejoria-and-pollacheck-earn-no-1-qualifiers-at-nhra-thunder-valley-nationals/" rel="bookmark">
								<div class="home-list-content">
									<h2>S. Torrence, DeJoria and Pollacheck Earn No. 1 Qualifiers at NHRA Thunder Valley Nationals</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/alexis-dejoria-runs-to-first-no-1-of-2021-season/" rel="bookmark">
								<div class="home-list-content">
									<h2>Alexis DeJoria Runs to First No. 1 of 2021 Season</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/rain-washes-away-final-pro-qualifying-session-at-pdra-brian-olson-memorial-world-finals/" rel="bookmark">
								<div class="home-list-content">
									<h2>Rain Washes Away Final Pro Qualifying Session at PDRA Brian Olson Memorial World Finals</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/angie-smith-to-sit-out-rest-of-thunder-valley-nationals-after-motor-maintenance-accident/" rel="bookmark">
								<div class="home-list-content">
									<h2>Angie Smith to Sit Out Rest of Thunder Valley Nationals After Motor Maintenance Accident</h2>
								</div><!--home-list-content-->
								</a>
							</li>
														<li>
								<a href="https://dragillustrated.com/franklin-camp-deflorian-stewart-al-saber-and-schroeder-take-provisional-no-1-spots-at-pdra-world-finals/" rel="bookmark">
								<div class="home-list-content">
									<h2>Franklin, Camp, DeFlorian, Stewart, Al-Saber and Schroeder Take Provisional No. 1 Spots at PDRA World Finals</h2>
								</div><!--home-list-content-->
								</a>
							</li>
													</ul>
					</div><!--footer-widget-->
					<div class="footer-widget">
						<h3 class="footer-widget-header">Tags</h3>
						<div class="tag-cloud">
						<a href="https://dragillustrated.com/tag/drag-illustrated/" class="tag-cloud-link tag-link-377 tag-link-position-1" style="font-size: 12px;">drag illustrated</a>
<a href="https://dragillustrated.com/tag/wes-buck/" class="tag-cloud-link tag-link-1284 tag-link-position-2" style="font-size: 12px;">wes buck</a>
<a href="https://dragillustrated.com/tag/yahoo/" class="tag-cloud-link tag-link-1321 tag-link-position-3" style="font-size: 12px;">yahoo</a>
<a href="https://dragillustrated.com/tag/ian-tocher/" class="tag-cloud-link tag-link-553 tag-link-position-4" style="font-size: 12px;">ian tocher</a>
<a href="https://dragillustrated.com/tag/drag-illistrated/" class="tag-cloud-link tag-link-376 tag-link-position-5" style="font-size: 12px;">drag illistrated</a>
<a href="https://dragillustrated.com/tag/dragillistrated/" class="tag-cloud-link tag-link-382 tag-link-position-6" style="font-size: 12px;">dragillistrated</a>
<a href="https://dragillustrated.com/tag/dragillustrated/" class="tag-cloud-link tag-link-383 tag-link-position-7" style="font-size: 12px;">dragillustrated</a>
<a href="https://dragillustrated.com/tag/google/" class="tag-cloud-link tag-link-501 tag-link-position-8" style="font-size: 12px;">google</a>
<a href="https://dragillustrated.com/tag/drag-racing/" class="tag-cloud-link tag-link-378 tag-link-position-9" style="font-size: 12px;">drag racing</a>
<a href="https://dragillustrated.com/tag/bing/" class="tag-cloud-link tag-link-163 tag-link-position-10" style="font-size: 12px;">bing</a>
<a href="https://dragillustrated.com/tag/nhra/" class="tag-cloud-link tag-link-840 tag-link-position-11" style="font-size: 12px;">nhra</a>
<a href="https://dragillustrated.com/tag/nhra-photos/" class="tag-cloud-link tag-link-879 tag-link-position-12" style="font-size: 12px;">nhra photos</a>
<a href="https://dragillustrated.com/tag/pro-stock/" class="tag-cloud-link tag-link-973 tag-link-position-13" style="font-size: 12px;">pro stock</a>
<a href="https://dragillustrated.com/tag/funny-car/" class="tag-cloud-link tag-link-462 tag-link-position-14" style="font-size: 12px;">funny car</a>
<a href="https://dragillustrated.com/tag/top-fuel/" class="tag-cloud-link tag-link-1222 tag-link-position-15" style="font-size: 12px;">top fuel</a>
<a href="https://dragillustrated.com/tag/pro-mod/" class="tag-cloud-link tag-link-968 tag-link-position-16" style="font-size: 12px;">pro mod</a>
<a href="https://dragillustrated.com/tag/pro-modified/" class="tag-cloud-link tag-link-970 tag-link-position-17" style="font-size: 12px;">pro modified</a>
<a href="https://dragillustrated.com/tag/adrl/" class="tag-cloud-link tag-link-55 tag-link-position-18" style="font-size: 12px;">ADRL</a>
<a href="https://dragillustrated.com/tag/john-force/" class="tag-cloud-link tag-link-639 tag-link-position-19" style="font-size: 12px;">john force</a>
<a href="https://dragillustrated.com/tag/jeg-coughlin-jr/" class="tag-cloud-link tag-link-597 tag-link-position-20" style="font-size: 12px;">jeg coughlin jr</a>
<a href="https://dragillustrated.com/tag/courtney-force/" class="tag-cloud-link tag-link-298 tag-link-position-21" style="font-size: 12px;">courtney force</a>
<a href="https://dragillustrated.com/tag/don-schumacher/" class="tag-cloud-link tag-link-361 tag-link-position-22" style="font-size: 12px;">don schumacher</a>
<a href="https://dragillustrated.com/tag/antron-brown/" class="tag-cloud-link tag-link-107 tag-link-position-23" style="font-size: 12px;">antron brown</a>
<a href="https://dragillustrated.com/tag/jack-beckman/" class="tag-cloud-link tag-link-576 tag-link-position-24" style="font-size: 12px;">jack beckman</a>
<a href="https://dragillustrated.com/tag/tony-schumacher/" class="tag-cloud-link tag-link-1217 tag-link-position-25" style="font-size: 12px;">tony schumacher</a>
<a href="https://dragillustrated.com/tag/american-drag-racing-league/" class="tag-cloud-link tag-link-95 tag-link-position-26" style="font-size: 12px;">american drag racing league</a>
<a href="https://dragillustrated.com/tag/erica-enders/" class="tag-cloud-link tag-link-419 tag-link-position-27" style="font-size: 12px;">erica enders</a>
<a href="https://dragillustrated.com/tag/allen-johnson/" class="tag-cloud-link tag-link-88 tag-link-position-28" style="font-size: 12px;">allen johnson</a>
<a href="https://dragillustrated.com/tag/greg-anderson/" class="tag-cloud-link tag-link-505 tag-link-position-29" style="font-size: 12px;">greg anderson</a>
<a href="https://dragillustrated.com/tag/spencer-massey/" class="tag-cloud-link tag-link-1119 tag-link-position-30" style="font-size: 12px;">spencer massey</a>						</div>
					</div><!--footer-widget-->
					 									</div><!--footer-widget-wrapper-->
			</div><!--footer-top-->
		</div><!--footer-wrapper-->
	</div><!--body-wrapper-->
</div><!--site-->


<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=297668800418060&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		
<script type="text/javascript">
jQuery(document).ready(function($) {

	// Main Menu Dropdown Toggle
	$('.menu-item-has-children a').click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$('.menu-item-has-children').click(function(){
    	  $(this).addClass('toggled');
    	  if($('.menu-item-has-children').hasClass('toggled'))
    	  {
    	  $(this).children('ul').toggle();
	  $('.fly-nav-menu').getNiceScroll().resize();
	  }
	  $(this).toggleClass('tog-minus');
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});

});
</script>

<script type="text/javascript">
//<![CDATA[
jQuery(document).ready(function($) {
"use strict";
$('.infinite-content').infinitescroll({
	navSelector: ".nav-links",
	nextSelector: ".nav-links a:first",
	itemSelector: ".infinite-post",
	  loading: {
		msgText: "Loading more posts...",
		finishedMsg: "Sorry, no more posts"
	  }
});
});
//]]>
</script>

<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script>	<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
	<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/comment-reply.min.js?ver=b6480f2684a12b5f296054be67feb451' id='comment-reply-js'></script>
<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.7' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/dragillustrated.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.5.1' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.7.0-wc.5.8.0' id='jquery-blockui-js'></script>
<script type='text/javascript' id='wc-add-to-cart-js-extra'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/dragillustrated.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=5.8.0' id='wc-add-to-cart-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4-wc.5.8.0' id='js-cookie-js'></script>
<script type='text/javascript' id='woocommerce-js-extra'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=5.8.0' id='woocommerce-js'></script>
<script type='text/javascript' id='wc-cart-fragments-js-extra'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_f0c91d7f4e3f0644a3ce523654f9cc4c","fragment_name":"wc_fragments_f0c91d7f4e3f0644a3ce523654f9cc4c","request_timeout":"5000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=5.8.0' id='wc-cart-fragments-js'></script>
<script type='text/javascript' id='wc-cart-fragments-js-after'>
		jQuery( 'body' ).bind( 'wc_fragments_refreshed', function() {
			var jetpackLazyImagesLoadEvent;
			try {
				jetpackLazyImagesLoadEvent = new Event( 'jetpack-lazy-images-load', {
					bubbles: true,
					cancelable: true
				} );
			} catch ( e ) {
				jetpackLazyImagesLoadEvent = document.createEvent( 'Event' )
				jetpackLazyImagesLoadEvent.initEvent( 'jetpack-lazy-images-load', true, true );
			}
			jQuery( 'body' ).get( 0 ).dispatchEvent( jetpackLazyImagesLoadEvent );
		} );
		
</script>
<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/checkout\/|\/cart\/|\/my-account\/|\/wc-api\/v(.*)|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/dragillustrated.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/braxton/js/jquery.iosslider.js?ver=b6480f2684a12b5f296054be67feb451' id='iosslider-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/braxton/js/scripts.js?ver=b6480f2684a12b5f296054be67feb451' id='braxton-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/braxton/js/respond.min.js?ver=b6480f2684a12b5f296054be67feb451' id='respond-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/braxton/js/retina.js?ver=b6480f2684a12b5f296054be67feb451' id='retina-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/braxton/js/jquery.infinitescroll.js?ver=b6480f2684a12b5f296054be67feb451' id='infinitescroll-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/wp-embed.min.js?ver=b6480f2684a12b5f296054be67feb451' id='wp-embed-js'></script>
<script src='https://stats.wp.com/e-202142.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.2',blog:'37035244',post:'47911',tz:'-5',srv:'dragillustrated.com'} ]);
	_stq.push([ 'clickTrackerInit', '37035244', '47911' ]);
</script>

</body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1634574470 -->