<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script>window._wca = window._wca || [];</script>

<title>Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals - Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</title>
<link rel="canonical" href="https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals" />
<meta property="og:description" content="Rookie Pro Stock driver Camrie Caruso has raced her way through some of the toughest competition during the 2022 NHRA Camping World Drag Racing Series season and NHRA Countdown. The [&hellip;]" />
<meta property="og:url" content="https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/" />
<meta property="og:site_name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
<meta property="article:publisher" content="https://www.facebook.com/dragillustrated" />
<meta property="article:published_time" content="2022-10-25T22:03:02+00:00" />
<meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2.jpg" />
<meta property="og:image:width" content="1600" />
<meta property="og:image:height" content="900" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="Drag Illustrated" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@dragillustrated" />
<meta name="twitter:site" content="@dragillustrated" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Drag Illustrated" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="4 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/#article","isPartOf":{"@id":"https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/"},"author":{"name":"Drag Illustrated","@id":"https://dragillustrated.com/#/schema/person/0661ece4a1f63b36068a5b45db454932"},"headline":"Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals","datePublished":"2022-10-25T22:03:02+00:00","dateModified":"2022-10-25T22:03:02+00:00","mainEntityOfPage":{"@id":"https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/"},"wordCount":744,"publisher":{"@id":"https://dragillustrated.com/#organization"},"image":{"@id":"https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/#primaryimage"},"thumbnailUrl":"https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2.jpg","articleSection":["News"],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/","url":"https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/","name":"Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals - Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More","isPartOf":{"@id":"https://dragillustrated.com/#website"},"primaryImageOfPage":{"@id":"https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/#primaryimage"},"image":{"@id":"https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/#primaryimage"},"thumbnailUrl":"https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2.jpg","datePublished":"2022-10-25T22:03:02+00:00","dateModified":"2022-10-25T22:03:02+00:00","breadcrumb":{"@id":"https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/#primaryimage","url":"https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2.jpg","contentUrl":"https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2.jpg","width":1600,"height":900},{"@type":"BreadcrumbList","@id":"https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://dragillustrated.com/"},{"@type":"ListItem","position":2,"name":"Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals"}]},{"@type":"WebSite","@id":"https://dragillustrated.com/#website","url":"https://dragillustrated.com/","name":"Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More","description":"","publisher":{"@id":"https://dragillustrated.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://dragillustrated.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https://dragillustrated.com/#organization","name":"Drag Illustrated","url":"https://dragillustrated.com/","sameAs":["https://www.instagram.com/dragillustrated","https://www.youtube.com/channel/UCbREkYFDiSOs8JCRTsqEMeg","https://www.facebook.com/dragillustrated","https://twitter.com/dragillustrated"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://dragillustrated.com/#/schema/logo/image/","url":"https://dragillustrated.com/wp-content/uploads/2012/03/Drag_Illustrated_Logo_RED.png","contentUrl":"https://dragillustrated.com/wp-content/uploads/2012/03/Drag_Illustrated_Logo_RED.png","width":2150,"height":592,"caption":"Drag Illustrated"},"image":{"@id":"https://dragillustrated.com/#/schema/logo/image/"}},{"@type":"Person","@id":"https://dragillustrated.com/#/schema/person/0661ece4a1f63b36068a5b45db454932","name":"Drag Illustrated","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://dragillustrated.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/19114ff647afcd14a1c84568b6be9a46?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/19114ff647afcd14a1c84568b6be9a46?s=96&d=mm&r=g","caption":"Drag Illustrated"},"url":"https://dragillustrated.com/author/developer/"}]}</script>

<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Feed" href="https://dragillustrated.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Comments Feed" href="https://dragillustrated.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; iCal Feed" href="https://dragillustrated.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals Comments Feed" href="https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/feed/" />

<script src="//www.googletagmanager.com/gtag/js?id=UA-21052018-1" data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>

<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/dragillustrated.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<script id="dragi-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://dragillustrated.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.3' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://dragillustrated.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://dragillustrated.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css' href='https://dragillustrated.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-vendors-style.css?ver=8.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css' href='https://dragillustrated.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-style.css?ver=8.5.1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://dragillustrated.com/wp-includes/css/dashicons.min.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css' href='https://dragillustrated.com/wp-includes/js/thickbox/thickbox.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome_v4_shim_style-css' href='https://use.fontawesome.com/releases/v5.3.1/css/v4-shims.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://use.fontawesome.com/releases/v5.3.1/css/all.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-css' href='https://dragillustrated.com/wp-content/plugins/theia-post-slider/css/buttons-red.css?ver=1.15.1' type='text/css' media='all' />
<link rel='stylesheet' id='ql-jquery-ui-css' href='//ajax.googleapis.com/ajax/libs/jqueryui/1.12.1/themes/smoothness/jquery-ui.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-photoswipe-css' href='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/css/photoswipe.css?ver=3.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-public-css' href='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/css/reviewer-public.css?ver=3.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='zox-custom-style-css' href='https://dragillustrated.com/wp-content/themes/zoxpress/style.css?ver=6.0.3' type='text/css' media='all' />
<style id='zox-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='fontawesome-child-css' href='https://use.fontawesome.com/releases/v5.5.0/css/all.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='zox-custom-child-style-css' href='https://dragillustrated.com/wp-content/themes/zoxpress-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='zox-fonts-css' href='//fonts.googleapis.com/css?family=Heebo%3A300%2C400%2C500%2C700%2C800%2C900%7CAlegreya%3A400%2C500%2C700%2C800%2C900%7CJosefin+Sans%3A300%2C400%2C600%2C700%7CLibre+Franklin%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CFrank+Ruhl+Libre%3A300%2C400%2C500%2C700%2C900%7CNunito+Sans%3A300%2C400%2C600%2C700%2C800%2C900%7CMontserrat%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CAnton%3A400%7CNoto+Serif%3A400%2C700%7CNunito%3A300%2C400%2C600%2C700%2C800%2C900%7CRajdhani%3A300%2C400%2C500%2C600%2C700%7CTitillium+Web%3A300%2C400%2C600%2C700%2C900%7CPT+Serif%3A400%2C400i%2C700%2C700i%7CAmiri%3A400%2C400i%2C700%2C700i%7COswald%3A300%2C400%2C500%2C600%2C700%7CRoboto+Mono%3A400%2C700%7CBarlow+Semi+Condensed%3A700%2C800%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto+Condensed%3A300%2C400%2C700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7CPT+Serif%3A400%2C700%7COpen+Sans+Condensed%3A300%2C700%7COpen+Sans%3A700%7CSource+Serif+Pro%3A400%2C600%2C700%7CIM+Fell+French+Canon%3A400%2C400i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito+Sans%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' type='text/css' media='all' />
<link rel='stylesheet' id='zox-media-queries-css' href='https://dragillustrated.com/wp-content/themes/zoxpress/css/media-queries.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://dragillustrated.com/wp-content/tablepress-combined.min.css?ver=41' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css' href='https://dragillustrated.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=14.1.4' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel='stylesheet' id='jetpack_css-css' href='https://dragillustrated.com/wp-content/plugins/jetpack/css/jetpack.css?ver=11.4' type='text/css' media='all' />
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/exactmetrics-premium/assets/js/frontend-gtag.min.js?ver=7.9.1' id='exactmetrics-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='exactmetrics-frontend-script-js-extra'>/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/dragillustrated.com","hash_tracking":"false","ua":"UA-21052018-1","v4_id":""};/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='photocrati_ajax-js-extra'>
/* <![CDATA[ */
var photocrati_ajax = {"url":"https:\/\/dragillustrated.com\/index.php?photocrati_ajax=1","wp_home_url":"https:\/\/dragillustrated.com","wp_site_url":"https:\/\/dragillustrated.com","wp_root_url":"https:\/\/dragillustrated.com","wp_plugins_url":"https:\/\/dragillustrated.com\/wp-content\/plugins","wp_content_url":"https:\/\/dragillustrated.com\/wp-content","wp_includes_url":"https:\/\/dragillustrated.com\/wp-includes\/","ngg_param_slug":"nggallery"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/ajax/static/ajax.min.js?ver=3.30' id='photocrati_ajax-js'></script>
<script type='text/javascript' src='https://use.fontawesome.com/releases/v5.3.1/js/v4-shims.js?ver=5.3.1' id='fontawesome_v4_shim-js'></script>
<script type='text/javascript' defer integrity="sha384-kW+oWsYx3YpxvjtZjFXqazFpA7UP/MbiY4jvs+RWZo2+N94PFZ36T6TFkc9O3qoB" crossorigin="anonymous" data-auto-replace-svg="false" data-keep-original-source="false" data-search-pseudo-elements src='https://use.fontawesome.com/releases/v5.3.1/js/all.js?ver=5.3.1' id='fontawesome-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/balupton-history.js/jquery.history.js?ver=1.7.1' id='history.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/async.min.js?ver=14.09.2014' id='async.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/tps.js?ver=1.15.1' id='theiaPostSlider/theiaPostSlider.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/main.js?ver=1.15.1' id='theiaPostSlider/main.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/tps-transition-slide.js?ver=1.15.1' id='theiaPostSlider/transition.js-js'></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.37.0' id='advanced-ads-advanced-js-js'></script>
<script defer type='text/javascript' src='https://stats.wp.com/s-202243.js' id='woocommerce-analytics-js'></script>
<script type='text/javascript' id='__ytprefs__-js-extra'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","security":"66229354bc","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/dragillustrated.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"https:\/\/dragillustrated.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"14.1.4","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","pause_others":"","stopMobileBuffer":"1","facade_mode":"","not_live_on_channel":"","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=14.1.4' id='__ytprefs__-js'></script>
<link rel="https://api.w.org/" href="https://dragillustrated.com/wp-json/" /><link rel="alternate" type="application/json" href="https://dragillustrated.com/wp-json/wp/v2/posts/55046" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dragillustrated.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dragillustrated.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.3" />
<meta name="generator" content="WooCommerce 7.0.0" />
<link rel='shortlink' href='https://wp.me/p2voyE-ejQ' />
<link rel="alternate" type="application/json+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Fcamrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2Fcamrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals%2F&#038;format=xml" />
<script type="text/javascript" src="https://paywall.subscriptiongenius.com/load.js"></script>


<script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window, document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init', '634980329980573');fbq('track', 'PageView');</script><noscript><img height="1" width="1" style="display:none"src="https://www.facebook.com/tr?id=634980329980573&ev=PageView&noscript=1"/></noscript>


<style type="text/css">
			.wpsdc-drop-cap {
				float : left;				
				padding : 0.25em 0.05em 0.25em 0;				
				font-size : 5em;
				line-height : 0.4em;color : #0a0a0a;}
		</style> <meta name="theme-color" content="#000" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-1024x576.jpg" />
<meta name="twitter:image" content="https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-1024x576.jpg" />
<meta property="og:url" content="https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/" />
<meta property="og:title" content="Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals" />
<meta property="og:description" content="Rookie Pro Stock driver Camrie Caruso has raced her way through some of the toughest competition during the 2022 NHRA Camping World Drag Racing Series season and NHRA Countdown. The [&hellip;]" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:url" content="https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/">
<meta name="twitter:title" content="Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals">
<meta name="twitter:description" content="Rookie Pro Stock driver Camrie Caruso has raced her way through some of the toughest competition during the 2022 NHRA Camping World Drag Racing Series season and NHRA Countdown. The [&hellip;]">
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://dragillustrated.com"><link rel="alternate" href="https://dragillustrated.com/wp-json/tribe/events/v1/" /><script type="text/javascript">
		;var advadsCfpExpHours = 1;
		var advadsCfpClickLimit = 8;
		var advadsCfpBan = 1;
		var advadsCfpPath = '';
		var advadsCfpDomain = '';
		</script><script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
<style>img#wpstats{display:none}</style>
<link rel="pingback" href="https://dragillustrated.com/xmlrpc.php"> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
<link rel="icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-180x180.png" />
<meta name="msapplication-TileImage" content="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-270x270.png" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-55046 single-format-standard custom-background wp-embed-responsive theme-zoxpress theiaPostSlider_body woocommerce-no-js tribe-no-js page-template-zoxpress-child zox-sport2 zox-s6 elementor-default elementor-kit-42099 aa-prefix-dragi- aa-disabled-bots">
<div id="zox-site" class="left zoxrel ">
<div id="zox-fly-wrap">
<div id="zox-fly-menu-top" class="left relative">
<div id="zox-fly-logo" class="left relative">
<a href="https://dragillustrated.com/"><img src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
</div>
<div class="zox-fly-but-wrap zox-fly-but-menu zox-fly-but-click">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</div>
<div id="zox-fly-menu-wrap">
<nav class="zox-fly-nav-menu left relative">
<div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-49701" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49701"><a href="https://dragillustrated.com/category/news/">News</a></li>
<li id="menu-item-49702" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49702"><a href="https://dragillustrated.com/category/race-coverage/">Race Coverage</a></li>
<li id="menu-item-49703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49703"><a href="https://dragillustrated.com/category/tech/">Tech</a></li>
<li id="menu-item-52430" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52430"><a href="https://dragillustrated.com/category/thewesbuckshow/">The Wes Buck Show</a></li>
<li id="menu-item-15094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" rel="noopener" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li id="menu-item-15102" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
<li id="menu-item-52946" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52946"><a href="https://dragillustrated.com/gearwrench-giveaway/">Contests</a></li>
<li id="menu-item-53657" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-53657"><a href="https://dragillustrated.com/top-8/">Top 8</a></li>
</ul></div> </nav>
</div>
<div id="zox-fly-soc-wrap">
<span class="zox-fly-soc-head">Connect with us</span>
<ul class="zox-fly-soc-list left relative">
<li><a href="https://www.facebook.com/DragIllustrated" target="_blank" class="fab fa-facebook-f"></a></li>
<li><a href="https://twitter.com/DragIllustrated" target="_blank" class="fab fa-twitter"></a></li>
<li><a href="https://www.instagram.com/dragillustrated" target="_blank" class="fab fa-instagram"></a></li>
<li><a href="https://bit.ly/3y2ogFR" target="_blank" class="fab fa-youtube"></a></li>
</ul>
</div>
</div> <div id="zox-search-wrap">
<div class="zox-search-cont">
<p class="zox-search-p">Hi, what are you looking for?</p>
<div class="zox-search-box">
<form method="get" id="zox-search-form" action="https://dragillustrated.com/">
<input type="text" name="s" id="zox-search-input" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "Search") { this.value = ""; }' />
<input type="submit" id="zox-search-submit" value="Search" />
</form> </div>
</div>
<div class="zox-search-but-wrap zox-search-click">
<span></span>
<span></span>
</div>
</div>
<div id="zox-site-wall" class="left zoxrel">
<div id="zox-lead-top-wrap">
<div id="zox-lead-top-in">
<div id="zox-lead-top">
</div>
</div>
</div>
<div id="zox-site-main" class="left zoxrel">
<header id="zox-main-head-wrap" class="left zoxrel zox-trans-head">
<div id="zox-bot-head-wrap" class="left zoxrel">
<div class="zox-head-width">
<div id="zox-bot-head">
<div id="zox-bot-head-left">
<div class="zox-fly-but-wrap zoxrel zox-fly-but-click">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</div>
<div id="zox-bot-head-mid" class="relative">
<div class="zox-bot-head-logo">
<div class="zox-bot-head-logo-main">
<a href="https://dragillustrated.com/"><img class="zox-logo-stand" src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /><img class="zox-logo-dark" src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
</div>
<h2 class="zox-logo-title">Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</h2>
</div>
<div class="zox-bot-head-menu">
<div class="zox-nav-menu">
<div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49701 zox-mega-drop"><a href="https://dragillustrated.com/category/news/">News</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/steve-torrence-not-ready-to-concede-top-fuel-title/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/Steve-Torrence-2022-6-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/Steve-Torrence-2022-6-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/Steve-Torrence-2022-6-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/10/Steve-Torrence-2022-6-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/10/Steve-Torrence-2022-6-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/10/Steve-Torrence-2022-6-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/10/Steve-Torrence-2022-6-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/10/Steve-Torrence-2022-6.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Steve Torrence Not Ready to Concede Top Fuel Title</p></a></li><li><a href="https://dragillustrated.com/justin-ashley-riding-wave-of-momentum-onto-the-strip-at-las-vegas-motor-speedway/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/Justin-Ashley-2022-3-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/Justin-Ashley-2022-3-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/Justin-Ashley-2022-3-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/10/Justin-Ashley-2022-3-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/10/Justin-Ashley-2022-3-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/10/Justin-Ashley-2022-3-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/10/Justin-Ashley-2022-3-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/10/Justin-Ashley-2022-3.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Justin Ashley Riding Wave of Momentum onto The Strip at Las Vegas Motor Speedway</p></a></li><li><a href="https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals</p></a></li><li><a href="https://dragillustrated.com/josh-hart-ready-to-rock-as-nhra-rolls-into-las-vegas/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/josh-hart-2022-2-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/josh-hart-2022-2-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/josh-hart-2022-2-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/10/josh-hart-2022-2-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/10/josh-hart-2022-2-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/10/josh-hart-2022-2-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/10/josh-hart-2022-2-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/10/josh-hart-2022-2.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Josh Hart Ready to Rock as NHRA Rolls into Las Vegas</p></a></li><li><a href="https://dragillustrated.com/arana-racing-fields-pro-stock-motorcycle-entry-at-last-two-nhra-events-in-2022-with-support-from-gettrx/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/arana-racing-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/arana-racing-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/arana-racing-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/10/arana-racing-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/10/arana-racing-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/10/arana-racing-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/10/arana-racing-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/10/arana-racing.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Arana Racing Fields Pro Stock Motorcycle Entry at Last Two NHRA Events in 2022 with Support From GETTRX</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49702 zox-mega-drop"><a href="https://dragillustrated.com/category/race-coverage/">Race Coverage</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/first-ever-pdra-pro-boost-world-champion-todd-tutterow-wins-second-title/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/PB_Todd-Tutterow-head_Gary-Rowe-photo-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/PB_Todd-Tutterow-head_Gary-Rowe-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/PB_Todd-Tutterow-head_Gary-Rowe-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>First-Ever PDRA Pro Boost World Champion Todd Tutterow Wins Second Title</p></a></li><li><a href="https://dragillustrated.com/peeps-pennington-wins-on-final-day-of-million-dollar-drag-race/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/Peeps-Pennington-million-2022-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/Peeps-Pennington-million-2022-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/Peeps-Pennington-million-2022-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/10/Peeps-Pennington-million-2022-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/10/Peeps-Pennington-million-2022-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/10/Peeps-Pennington-million-2022-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/10/Peeps-Pennington-million-2022-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/10/Peeps-Pennington-million-2022.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Peeps Pennington Wins on Final Day of Million Dollar Drag Race</p></a></li><li><a href="https://dragillustrated.com/tony-stewart-to-make-nhra-top-alcohol-dragster-debut-at-las-vegas/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/TS-Team-Owner-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/TS-Team-Owner-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/TS-Team-Owner-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Tony Stewart to Make NHRA Top Alcohol Dragster Debut at Las Vegas</p></a></li><li><a href="https://dragillustrated.com/iowas-tucker-kanselaar-wins-27th-annual-mickey-thompson-million-dollar-drag-race/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/Tucker-Kanselaar-Million-Win-2022-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/Tucker-Kanselaar-Million-Win-2022-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/Tucker-Kanselaar-Million-Win-2022-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/10/Tucker-Kanselaar-Million-Win-2022-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/10/Tucker-Kanselaar-Million-Win-2022-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/10/Tucker-Kanselaar-Million-Win-2022-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/10/Tucker-Kanselaar-Million-Win-2022-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/10/Tucker-Kanselaar-Million-Win-2022.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Iowa&#8217;s Tucker Kanselaar Wins 27th annual Mickey Thompson Million Dollar Drag Race</p></a></li><li><a href="https://dragillustrated.com/jim-halsey-collects-unprecedented-fourth-consecutive-pdra-pro-nitrous-world-championship/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/PN_Jim-Halsey-action_Tara-Bowker-photo-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/PN_Jim-Halsey-action_Tara-Bowker-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/PN_Jim-Halsey-action_Tara-Bowker-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Jim Halsey Collects Unprecedented Fourth Consecutive PDRA Pro Nitrous World Championship</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49703 zox-mega-drop"><a href="https://dragillustrated.com/category/tech/">Tech</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/nhra-crew-chief-dave-connolly-race-promoter-jennifer-folk-purchase-competitive-suspension/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/Folk-Connolly_Competition-Suspension-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/Folk-Connolly_Competition-Suspension-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/Folk-Connolly_Competition-Suspension-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>NHRA Crew Chief Dave Connolly, Race Promoter Jennifer Folk Purchase Competitive Suspension</p></a></li><li><a href="https://dragillustrated.com/sema-garage-opens-in-detroit/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/R3__3313ed-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" /></div><p>SEMA Garage Opens in Detroit</p></a></li><li><a href="https://dragillustrated.com/stroud-safety-issues-warning-about-fake-sfi-tags/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/08/Stroud-fake-SFI-tags-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/08/Stroud-fake-SFI-tags-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/08/Stroud-fake-SFI-tags-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Stroud Safety Issues Warning About Fake SFI Tags</p></a></li><li><a href="https://dragillustrated.com/stroud-safetys-female-forward-workforce-makes-it-happen/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/Stroud-OKC-3048-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/Stroud-OKC-3048-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/Stroud-OKC-3048-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Stroud Safety&#8217;s Female-Forward Workforce Makes it Happen</p></a></li><li><a href="https://dragillustrated.com/race-winning-brands-continues-growth-into-new-markets/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/CORSA-Intake-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/CORSA-Intake-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/CORSA-Intake-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Race Winning Brands Continues Growth into New Markets</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52430 zox-mega-drop"><a href="https://dragillustrated.com/category/thewesbuckshow/">The Wes Buck Show</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/wbs-champ-talk-todd-tutterow-jamie-miller-johnny-pluchino-plus-jay-boddie-jr/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-279-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-279-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-279-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-279-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-279-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-279.jpg 1280w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>WBS: CHAMP TALK: Todd Tutterow, Jamie Miller, Johnny Pluchino, Plus: Jay Boddie Jr.</p></a></li><li><a href="https://dragillustrated.com/wbs-live-from-the-texas-motorplex-for-second-annual-stampede-of-speed/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-278-1-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-278-1-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-278-1-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-278-1-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-278-1-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-278-1.jpg 1280w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>WBS: Live From the Texas Motorplex for Second-Annual Stampede of Speed</p></a></li><li><a href="https://dragillustrated.com/wbs-drag-racings-ultimate-outlaw-scott-palmer-talks-shop-daniel-pharris-dishes-on-first-nhra-pro-mod-win/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-277-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-277-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-277-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-277-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-277-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-277.jpg 1280w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>WBS: Drag Racing&#8217;s Ultimate Outlaw Scott Palmer Talks Shop; Daniel Pharris Dishes on First NHRA Pro Mod Win</p></a></li><li><a href="https://dragillustrated.com/wbs-travis-pastrana-talks-top-fuel-experience-stevie-fast-jackson-back-in-the-winners-circle-alex-laughlin-more/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/09/WBS-EPISODE-276-2-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/09/WBS-EPISODE-276-2-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/09/WBS-EPISODE-276-2-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/09/WBS-EPISODE-276-2-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/09/WBS-EPISODE-276-2-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/09/WBS-EPISODE-276-2.jpg 1280w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>WBS: Travis Pastrana Talks Top Fuel Experience, &#8220;Stevie Fast&#8221; Jackson Back in the Winner&#8217;s Circle, Alex Laughlin &#038; More!</p></a></li><li><a href="https://dragillustrated.com/wbs-ryan-martin-opens-up-on-no-prep-kings-domination-erica-enders-talks-pro-stock-championship-chase-don-scott-on-wdra/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/09/WBS-EPISODE-275-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/09/WBS-EPISODE-275-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/09/WBS-EPISODE-275-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/09/WBS-EPISODE-275-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/09/WBS-EPISODE-275-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/09/WBS-EPISODE-275.jpg 1280w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>WBS: Ryan Martin Opens Up on No Prep Kings Domination, Erica Enders Talks Pro Stock Championship Chase, Don Scott on WDRA</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" rel="noopener" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52946"><a href="https://dragillustrated.com/gearwrench-giveaway/">Contests</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-53657"><a href="https://dragillustrated.com/top-8/">Top 8</a></li>
</ul></div> </div>
</div>
</div>
<div id="zox-bot-head-right">
<span class="zox-night zox-night-mode fas fa-moon"></span>
<span class="zox-nav-search-but fas fa-search zox-search-click"></span>
</div>
</div>
</div>
</div> </header>
<div id="zox-site-grid">
<div id="zox-site-wall-small">
<div id="zox-lead-bot">
</div>
<div id="zox-main-body-wrap" class="left relative"> <article id="post-55046" class="post-55046 post type-post status-publish format-standard has-post-thumbnail hentry category-news" itemscope itemtype="http://schema.org/NewsArticle">
<div class="zox-article-wrap zoxrel left zox100">
<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/" />
<div class="zox-post-top-wrap zoxrel left zox100">
<div class="zox-post-title-wrap zox-tit2">
<div class="zox-post-width">
<header class="zox-post-head-wrap left zoxrel zox100">
<div class="zox-post-head zoxrel">
<h3 class="zox-post-cat">
<a class="zox-post-cat-link" href="https://dragillustrated.com/category/news/"><span class="zox-post-cat">News</span></a>
</h3>
<h1 class="zox-post-title left entry-title" itemprop="headline">Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals</h1>
<div class="zox-post-info-wrap">
<div class="zox-post-byline-wrap">
<div class="zox-author-thumb">
<img alt='' src='https://secure.gravatar.com/avatar/19114ff647afcd14a1c84568b6be9a46?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/19114ff647afcd14a1c84568b6be9a46?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy' /> </div>
<div class="zox-author-info-wrap">
<div class="zox-author-name-wrap" itemprop="author" itemscope itemtype="https://schema.org/Person">
<p>By</p><span class="zox-author-name vcard fn author" itemprop="name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span>
</div>
<div class="zox-post-date-wrap">
<p>Published</p> <span class="zox-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-10-25">2 hours ago</time></span>
<meta itemprop="dateModified" content="2022-10-25" />
</div>
</div>
</div>
<div class="zox-post-soc-top-wrap">
<div class="zox-post-soc-stat">
<ul class="zox-post-soc-stat-list left zoxrel">
<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/&amp;t=Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="zox-post-soc-fb">
<i class="fab fa-facebook-f"></i>
</li>
</a>
<a href="#" onclick="window.open('https://twitter.com/share?text=Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals -&amp;url=https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="zox-post-soc-twit">
<i class="fab fa-twitter"></i>
</li>
</a>
<li class="zox-post-soc-copy">
<i class="fas fa-link"></i>
</li>
<li class="zox-post-soc-more zox-soc-stat-click-55046">
<i class="fas fa-ellipsis-h"></i>
<div class="zox-soc-more-stat zox-more-click-55046">
<ul class="zox-soc-more-list">
<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals&url=https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
<li class="zox-post-soc-flip">
<p>Flipboard</p>
<i class="fab fa-flipboard"></i>
</li>
</a>
<a href="#" onclick="window.open('https://www.reddit.com/submit?url=https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/&title=Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals', 'redditShare', 'width=626,height=436'); return false;" title="Share on Reddit">
<li class="zox-post-soc-redd">
<p>Reddit</p>
<i class="fab fa-reddit-alien"></i>
</li>
</a>
<a href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/&amp;media=https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2.jpg&amp;description=Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<li class="zox-post-soc-pin">
<p>Pinterest</p>
<i class="fab fa-pinterest-p" aria-hidden="true"></i>
</li>
</a>
<a class="zox-whats-main" href="https://web.whatsapp.com/send?text=Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a class="zox-whats-mob" href="whatsapp://send?text=Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a href="/cdn-cgi/l/email-protection#3b04484e59515e584f06785a5649525e1b785a494e48541b73544b52555c1b4f541b7854565e1b6e4b1b7a585e481b5a4f1b7573697a1b755e4d5a5f5a1b755a4f5254555a57481d5a564b0079747f6206721b5d544e555f1b4f5352481b5a494f5258575e1b52554f5e495e484f52555c1b5a555f1b4f53544e5c534f1b545d1b48535a4952555c1b524f1b4c524f531b42544e151b78535e58501b524f1b544e4f011b534f4f4b480114145f495a5c5257574e484f495a4f5e5f1558545614585a5649525e16585a494e48541653544b52555c164f54165854565e164e4b165a585e48165a4f165553495a16555e4d5a5f5a16555a4f5254555a574814">
<li class="zox-post-soc-email">
<p>Email</p>
<i class="fas fa-envelope"></i>
</li>
</a>
</ul>
</div>
</li>
</ul>
</div>
</div>
</div>
</div>
</header> </div>
</div>
</div>
<div class="zox-post-main-grid">
<div class="zox-post-width">
<div class="zox-post-main-wrap zoxrel left zox100">
<div class="zox-post-main">
<div class="zox-post-bot-wrap">
<div class="zox-post-img-wrap">
<div class="zox-post-img left zoxrel zoxlh0" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
<img width="1600" height="900" src="https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2.jpg" class="flipboard-image wp-post-image" alt="" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2.jpg 1600w, https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2-600x338.jpg 600w" sizes="(max-width: 1600px) 100vw, 1600px" /> <meta itemprop="url" content="https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2.jpg">
<meta itemprop="width" content="1600">
<meta itemprop="height" content="900">
</div>
<span class="zox-post-img-cap"></span>
 </div>
</div>
<div class="zox-post-body-wrap left zoxrel">
<div class="zox-post-body left zoxrel zox100">
<div id="tps_slideContainer_55046" class="theiaPostSlider_slides"><div class="theiaPostSlider_preloadedSlide">
<p>
<p>Rookie Pro Stock driver Camrie Caruso has raced her way through some of the toughest competition during the 2022 NHRA Camping World Drag Racing Series season and NHRA Countdown. The 24-year-old who resides in Denver, North Carolina, will bring a new look to the NHRA Nevada Nationals with the Powerbuilt Chevrolet Camaro powered by Titan Racing Engines looking to close out the season with a signature win at The Strip at Las Vegas Motor Speedway. Last season in Vegas rookie Dallas Glenn took the Pro Stock win and went on to Rookie of the Year honors. Caruso, one of two finalists for the 2022 top rookie award, would like nothing better than to duplicate Glenn’s feat this weekend.
<p>“It is great to be a finalist for Rookie of the Year and winning that award was one of my pre-season goals,” said Caruso. “We have qualified for every race and I feel like the team is getting better but this is a marathon not a sprint. The homestretch is coming up with Las Vegas and Pomona and we want to finish strong.”
<p>This will be a return engagement for Caruso at the Las Vegas track located 20 minutes from downtown. The rookie driver competed in her first NHRA Four-Wide Nationals here earlier this season. The familiarity will be a welcome element to the driver who has been competing on brand new track week in and week out throughout the season.
<p>“I love Las Vegas and I am glad we are coming back to a track like this for the Countdown,” said Caruso. “The four-wide nationals was a new experience so I am looking forward to traditional side-by-side racing this weekend. My crew chief Jim Yates has been working his tail off on our tune-up and I think we have a car that can go rounds. I have been trying to be super aggressive on the starting line. We just need a few things to go our way and we could have a long day on Sunday. This is Las Vegas so anything can happen.”
<p>Caruso has qualified for every event this season which is an impressive feat in the hyper-competitive Pro Stock category but even more impressive is the fact she and her Powerbuilt Chevrolet Camaro team have been going rounds in her rookie season. Historically, drivers and teams have significant hurdles, but Caruso and her Jim Yates tuned Chevrolet Camaro have established themselves as consistent performers grabbing a round win in just their second start and a No. 1 qualifier at the Houston SpringNationals. Caruso advanced to the final round of the Houston national event in just her fifth professional start.
<p>“We have achieved some of my goals for this season, but there are a few we are still chasing,” said Caruso. “We have all the pieces to get into the winner’s circle, we just need to put them all together on race day. The Nevada Nationals would be a great race to get our first win and then roll into the Auto Club Finals in Pomona with some momentum. I have learned a lot this season and I am excited for these last two races.”
<p>Prior to the Nevada Nationals Caruso will be joining several NHRA drivers at the Fremont Street Fan Experience on Thursday night signing free autographs from 5:30 p.m. – 6:30 p.m. and following the race she will be attending the SEMA show spending time in a number of marketing partners’ booths promoting their products and signing autographs. The Pro Stock rookie knows the off the track events can be just as impactful as win lights on Sunday.
<p>“I enjoy spending time with our marketing partners away from the track and I especially like the fan fest events,” said Caruso. “Events like those are where you can make a connection with the fans and really talk about how great NHRA is or how one of our marketing partners can benefit their business or personal life. We have a lot of great partners that have supported us this season and we are looking forward to SEMA for sure.”<div class="zox-post-ad-wrap"><span class="zox-ad-label">Advertisement. Scroll to continue reading.</span><div class="zox-post-ad"><div class="zox-post-ad-in1"><div class="zox-post-ad-in2"></div></div></div></div>
<p>Pro Stock qualifying for the NHRA Nevada Nationals will begin Friday at 12:30 p.m. and 3:15 p.m. with Saturday’s sessions running at noon and 3:30 p.m. On Sunday final eliminations will begin at 11:00 a.m. with Top Fuel, Funny Car, Pro Stock and Pro Stock Motorcycle. The race will be broadcast nationally on FS1.
<p>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>
</div></div><div class="theiaPostSlider_footer _footer"></div><div data-theiaPostSlider-sliderOptions='{&quot;slideContainer&quot;:&quot;#tps_slideContainer_55046&quot;,&quot;nav&quot;:[&quot;.theiaPostSlider_nav&quot;],&quot;navText&quot;:&quot;%{currentSlide} of %{totalSlides}&quot;,&quot;helperText&quot;:&quot;Use your \u2190 \u2192 (arrow) keys to browse&quot;,&quot;defaultSlide&quot;:0,&quot;transitionEffect&quot;:&quot;slide&quot;,&quot;transitionSpeed&quot;:400,&quot;keyboardShortcuts&quot;:true,&quot;scrollAfterRefresh&quot;:true,&quot;numberOfSlides&quot;:1,&quot;slides&quot;:[],&quot;useSlideSources&quot;:null,&quot;themeType&quot;:&quot;classic&quot;,&quot;prevText&quot;:&quot;Prev&quot;,&quot;nextText&quot;:&quot;Next&quot;,&quot;buttonWidth&quot;:0,&quot;buttonWidth_post&quot;:0,&quot;postUrl&quot;:&quot;https:\/\/dragillustrated.com\/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals\/&quot;,&quot;postId&quot;:55046,&quot;refreshAds&quot;:false,&quot;refreshAdsEveryNSlides&quot;:1,&quot;adRefreshingMechanism&quot;:&quot;javascript&quot;,&quot;ajaxUrl&quot;:&quot;https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php&quot;,&quot;loopSlides&quot;:false,&quot;scrollTopOffset&quot;:0,&quot;hideNavigationOnFirstSlide&quot;:false,&quot;isRtl&quot;:false,&quot;excludedWords&quot;:[&quot;&quot;]}' data-theiaPostSlider-onChangeSlide='&quot;&quot;'></div> </div>
<div class="zox-post-body-bot left zoxrel zox100">
<div class="zox-post-body-width">
<div class="zox-post-tags left zoxrel zox100">
<span class="zox-post-tags-header">In this article:</span><span itemprop="keywords"></span>
</div>
<div class="zox-posts-nav-link">
</div>
<div class="zox-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<div class="zox-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<img src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" />
<meta itemprop="url" content="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg">
</div>
<meta itemprop="name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More">
</div>
</div>
</div>
</div> </div>
<div class="zox-post-side-wrap zox-post-side-noalp zoxrel zox-sticky-side">
<div id="zox-side-wrap" class="zoxrel zox-divs">
<div id="zox_ad_widget-13" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
</div>
</div><div id="zox_side_trend_widget-4" class="zox-side-widget zox_side_trend_widget"><div class="zox-widget-side-head"><h4 class="zox-widget-side-title"><span class="zox-widget-side-title">Trending</span></h4></div>
<div class="zox-widget-side-trend-wrap left zoxrel zox100">
<section class="zox-art-wrap zoxrel zox-art-small">
<div class="zox-art-grid">
<a href="https://dragillustrated.com/neff-stuns-comp-eliminator-world-with-215-mph-production-gas-ford/" rel="bookmark">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/10/Neff-Ford-Dragster-3-100x100.jpg" class="lazy-load wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/Neff-Ford-Dragster-3-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/10/Neff-Ford-Dragster-3-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </div>
</a>
<div class="zox-art-text">
<h3 class="zox-s-cat"><span class="zox-s-cat">Exclusive</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/neff-stuns-comp-eliminator-world-with-215-mph-production-gas-ford/" rel="bookmark">
<h2 class="zox-s-title3">Neff Stuns Comp Eliminator World with 215 MPH Production Gas Ford</h2>
</a>
</div>
</div> </div>
</section> <section class="zox-art-wrap zoxrel zox-art-small">
<div class="zox-art-grid">
<a href="https://dragillustrated.com/wbs-champ-talk-todd-tutterow-jamie-miller-johnny-pluchino-plus-jay-boddie-jr/" rel="bookmark">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-279-100x100.jpg" class="lazy-load wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-279-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-279-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </div>
</a>
<div class="zox-art-text">
<h3 class="zox-s-cat"><span class="zox-s-cat">The Wes Buck Show</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/wbs-champ-talk-todd-tutterow-jamie-miller-johnny-pluchino-plus-jay-boddie-jr/" rel="bookmark">
<h2 class="zox-s-title3">WBS: CHAMP TALK: Todd Tutterow, Jamie Miller, Johnny Pluchino, Plus: Jay Boddie Jr.</h2>
</a>
</div>
</div> </div>
</section> <section class="zox-art-wrap zoxrel zox-art-small">
<div class="zox-art-grid">
<a href="https://dragillustrated.com/wbs-live-from-the-texas-motorplex-for-second-annual-stampede-of-speed/" rel="bookmark">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-278-1-100x100.jpg" class="lazy-load wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-278-1-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/10/WBS-EPISODE-278-1-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </div>
</a>
<div class="zox-art-text">
<h3 class="zox-s-cat"><span class="zox-s-cat">The Wes Buck Show</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/wbs-live-from-the-texas-motorplex-for-second-annual-stampede-of-speed/" rel="bookmark">
<h2 class="zox-s-title3">WBS: Live From the Texas Motorplex for Second-Annual Stampede of Speed</h2>
</a>
</div>
</div> </div>
</section> <section class="zox-art-wrap zoxrel zox-art-small">
<div class="zox-art-grid">
<a href="https://dragillustrated.com/two-nhra-camping-world-drag-racing-series-drivers-eligible-for-2022-rookie-of-the-year-award/" rel="bookmark">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/10/Nomination-Graphic-100x100.jpg" class="lazy-load wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/Nomination-Graphic-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/10/Nomination-Graphic-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </div>
</a>
<div class="zox-art-text">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/two-nhra-camping-world-drag-racing-series-drivers-eligible-for-2022-rookie-of-the-year-award/" rel="bookmark">
<h2 class="zox-s-title3">Two NHRA Camping World Drag Racing Series Drivers Eligible for 2022 Rookie of the Year Award</h2>
</a>
</div>
</div> </div>
</section> <section class="zox-art-wrap zoxrel zox-art-small">
<div class="zox-art-grid">
<a href="https://dragillustrated.com/herman-grayson-team-up-to-produce-jr-corvette-roadster/" rel="bookmark">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/10/Jr-Corvette-Roadster-100x100.jpg" class="lazy-load wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/10/Jr-Corvette-Roadster-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/10/Jr-Corvette-Roadster-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </div>
</a>
<div class="zox-art-text">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/herman-grayson-team-up-to-produce-jr-corvette-roadster/" rel="bookmark">
<h2 class="zox-s-title3">Herman, Grayson Team Up to Produce Jr. Corvette Roadster</h2>
</a>
</div>
</div> </div>
</section> </div>
</div><div id="zox_ad_widget-16" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
</div>
</div><div id="zox_ad_widget-14" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
</div>
</div><div id="zox_ad_widget-15" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
</div>
</div> </div>
</div>
</div>
</div>
</div>
<div class="zox-post-soc-scroll">
<ul class="zox-post-soc-list left zoxrel">
<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/&amp;t=Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="zox-post-soc-fb">
<i class="fab fa-facebook-f"></i>
</li>
</a>
<a href="#" onclick="window.open('https://twitter.com/share?text=Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals -&amp;url=https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="zox-post-soc-twit">
<i class="fab fa-twitter"></i>
</li>
</a>
<li class="zox-post-soc-copy">
<i class="fas fa-link"></i>
</li>
<li class="zox-post-soc-more zox-soc-scroll-click">
<i class="fas fa-ellipsis-h"></i>
<div class="zox-soc-more-scroll">
<ul class="zox-soc-more-list">
<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals&url=https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
<li class="zox-post-soc-flip">
<p>Flipboard</p>
<i class="fab fa-flipboard"></i>
</li>
</a>
<a href="#" onclick="window.open('https://www.reddit.com/submit?url=https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/&title=Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals', 'redditShare', 'width=626,height=436'); return false;" title="Share on Reddit">
<li class="zox-post-soc-redd">
<p>Reddit</p>
<i class="fab fa-reddit-alien"></i>
</li>
</a>
<a href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/&amp;media=https://dragillustrated.com/wp-content/uploads/2022/10/Camrie-Caruso-2022-2.jpg&amp;description=Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<li class="zox-post-soc-pin">
<p>Pinterest</p>
<i class="fab fa-pinterest-p" aria-hidden="true"></i>
</li>
</a>
<a class="zox-whats-main" href="https://web.whatsapp.com/send?text=Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a class="zox-whats-mob" href="whatsapp://send?text=Camrie Caruso Hoping to Come Up Aces at NHRA Nevada Nationals https://dragillustrated.com/camrie-caruso-hoping-to-come-up-aces-at-nhra-nevada-nationals/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a href="/cdn-cgi/l/email-protection#ba85c9cfd8d0dfd9ce87f9dbd7c8d3df9af9dbc8cfc9d59af2d5cad3d4dd9aced59af9d5d7df9aefca9afbd9dfc99adbce9af4f2e8fb9af4dfccdbdedb9af4dbced3d5d4dbd6c99cdbd7ca81f8f5fee387f39adcd5cfd4de9aced2d3c99adbc8ced3d9d6df9ad3d4cedfc8dfc9ced3d4dd9adbd4de9aced2d5cfddd2ce9ad5dc9ac9d2dbc8d3d4dd9ad3ce9acdd3ced29ac3d5cf949af9d2dfd9d19ad3ce9ad5cfce809ad2cececac9809595dec8dbddd3d6d6cfc9cec8dbcedfde94d9d5d795d9dbd7c8d3df97d9dbc8cfc9d597d2d5cad3d4dd97ced597d9d5d7df97cfca97dbd9dfc997dbce97d4d2c8db97d4dfccdbdedb97d4dbced3d5d4dbd6c995">
<li class="zox-post-soc-email">
<p>Email</p>
<i class="fas fa-envelope"></i>
</li>
</a>
</ul>
</div>
</li>
</ul>
</div>
</div>
<div class="zox-post-more-wrap left zoxrel zox100">
<div class="zox-post-width">
<div class="zox-post-more left zoxrel zox100">
<div class="zox-post-main-head left zoxrel zox100">
<h4 class="zox-post-main-title">
<span class="zox-post-main-title">You May Also Like</span>
</h4>
</div>
<div class="zox-post-more-grid zox-div4 left zoxrel zox100">
<div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/pro-street-legend-tony-christian-passes/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-600x337.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-100x100.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/06/Tony-Christian_crop-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/pro-street-legend-tony-christian-passes/" rel="bookmark">
<h2 class="zox-s-title2">Pro Street Legend Tony Christian Passes</h2>
</a>
</div>
<p class="zox-s-graph">Tony Christian, one of the pioneering drivers of the Pro Street movement, passed away Thursday, June 9. Christian was infamous for his battles with...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>June 9, 2022</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/mwdrs-mourns-loss-of-pro-mod-driver-ronnie-hobbs-at-great-bend-nationals/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-600x337.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-100x100.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/06/MWDRS_Ronnie-Hobbs_Van-Abernethy-photo-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/mwdrs-mourns-loss-of-pro-mod-driver-ronnie-hobbs-at-great-bend-nationals/" rel="bookmark">
<h2 class="zox-s-title2">MWDRS Mourns Loss of Pro Mod Driver Ronnie Hobbs at Great Bend Nationals</h2>
</a>
</div>
<p class="zox-s-graph">The Mid-West Drag Racing Series (MWDRS) is saddened over the passing of Pro Mod driver Ronnie Hobbs following an on-track incident during Friday night...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>June 6, 2022</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/leah-pruett-through-the-years/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-600x337.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-100x100.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/07/Leah-Pruett-Through-the-Years-5-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Exclusive</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/leah-pruett-through-the-years/" rel="bookmark">
<h2 class="zox-s-title2">Leah Pruett Through the Years</h2>
</a>
</div>
<p class="zox-s-graph">Leah Pruett scored the first NHRA Top Fuel win for her and husband Tony Stewart&#8217;s professional drag racing team this past weekend in Denver,...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>July 21, 2022</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://dragillustrated.com/big-money-bracket-racer-sean-serra-dies-at-27/" rel="bookmark">
<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-600x337.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-100x100.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-100x100.jpg 100w, https://dragillustrated.com/wp-content/uploads/2022/07/Sean-Serra-feature-image-600x600.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
<div class="zox-art-title">
<a href="https://dragillustrated.com/big-money-bracket-racer-sean-serra-dies-at-27/" rel="bookmark">
<h2 class="zox-s-title2">Big Money Bracket Racer Sean Serra Dies at 27</h2>
</a>
</div>
<p class="zox-s-graph">Drag racer Sean Serra has passed away in a tragic car accident. He was 27 years old. Serra was involved in a single-car rollover...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://dragillustrated.com/author/kayla-zadel/" title="Posts by Kayla Zadel" rel="author">Kayla Zadel</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>July 7, 2022</span>
</div>
</div>
</div> </div>
</div> </div>
</div>
</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
	jQuery(document).ready(function($) {
  		$(".zox-soc-stat-click-55046").on("click", function(){
	  		$(".zox-more-click-55046").toggleClass("zox-soc-more-open");
  		});
	});
    </script> </article> </div>
<footer id="zox-foot-wrap" class="left zoxrel zox100">
<div class="zox-head-width">
<div class="zox-foot-grid left zoxrel zox100">
<div class="zox-foot-left-wrap">
<div class="zox-foot-logo left zox-lh0">
<a href="https://dragillustrated.com/"><img src="https://dragillustrated.com/wp-content/uploads/2022/03/DragIllustrated_flat_white-200px.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
</div>
<div class="zox-foot-left left">
<div class="zox-foot-menu">
<div class="menu-about-di-container"><ul id="menu-about-di" class="menu"><li id="menu-item-52480" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52480"><a href="https://dragillustrated.com/about-di/">About DI</a></li>
<li id="menu-item-50895" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50895"><a href="https://dragillustrated.com/join-newsletter/?swcfpc=1">Newsletter</a></li>
<li id="menu-item-21282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21282"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/">Subscribe</a></li>
<li id="menu-item-50896" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50896"><a href="https://dragillustrated.com/contact-page">Customer Service</a></li>
<li id="menu-item-50897" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50897"><a href="https://dragillustrated.com/careers">Careers</a></li>
<li id="menu-item-50898" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50898"><a href="https://dragillustrated.com/press-center/">Public Relations</a></li>
<li id="menu-item-52947" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52947"><a href="https://dragillustrated.com/advertise/">Advertise</a></li>
<li id="menu-item-50899" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50899"><a href="https://mediakit.dragillustrated.com/">Media Kit</a></li>
<li id="menu-item-50900" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50900"><a href="https://dragillustrated.com/masthead">Masthead</a></li>
</ul></div> </div>
<div class="zox-foot-copy">
<p>Since 2005, DI has informed, inspired and educated drag racers from every walk of the racing life - weekend warrior and street/strip enthusiasts to pro-level doorslammer and Top Fuel racers. From award-winning writing and photography to binge-worthy videos to electric live events, DI meets hundreds of thousands of racers where they live, creating the moments that create conversations.</p>
</div>
</div>
</div>
<div class="zox-foot-right-wrap">
<div class="zox-foot-soc right relative">
<ul class="zox-foot-soc-list left relative">
<li><a href="https://www.facebook.com/DragIllustrated" target="_blank" class="fab fa-facebook-f"></a></li>
<li><a href="https://twitter.com/DragIllustrated" target="_blank" class="fab fa-twitter"></a></li>
<li><a href="https://www.instagram.com/dragillustrated" target="_blank" class="fab fa-instagram"></a></li>
<li><a href="https://bit.ly/3y2ogFR" target="_blank" class="fab fa-youtube"></a></li>
</ul>
</div>
</div>
</div>
</div>
</footer>
</div>
</div>
</div>
</div>
<div class="zox-fly-top back-to-top">
<span class="fas fa-angle-up"></span>
</div>
</div>
<div class="zox-fly-fade zox-fly-but-click">
</div>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/swv/js/index.js?ver=5.6.3' id='swv-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/dragillustrated.com\/wp-json\/","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.6.3' id='contact-form-7-js'></script>
<script type='text/javascript' id='ngg_common-js-extra'>
/* <![CDATA[ */

var nextgen_lightbox_settings = {"static_path":"https:\/\/dragillustrated.com\/wp-content\/plugins\/nextgen-gallery\/products\/photocrati_nextgen\/modules\/lightbox\/static\/{placeholder}","context":"all_images_direct"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_gallery_display/static/common.js?ver=3.30' id='ngg_common-js'></script>
<script type='text/javascript' id='ngg_lightbox_context-js-extra'>
/* <![CDATA[ */

var nextgen_thickbox_i18n = {"next":"Next &gt;","prev":"&lt; Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them."};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/lightbox_context.js?ver=3.30' id='ngg_lightbox_context-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/thickbox/nextgen_thickbox_init.js?ver=3.30' id='thickbox-0-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/thickbox/thickbox.js?ver=3.30' id='thickbox-1-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/ResizeSensor.js?ver=1.7.0' id='theia-sticky-sidebar/ResizeSensor.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.7.0' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.7.0' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/zoxpress-plugin//scripts/jquery.sticky-kit.min.js?ver=6.0.3' id='jquery-sticky-kit-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/zoxpress-plugin//scripts/jquery.waypoints.min.js?ver=6.0.3' id='jquery-waypoints-js'></script>
<script type='text/javascript' id='advanced-ads-responsive-js-extra'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.10.3' id='advanced-ads-responsive-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/jquery.nouislider.all.min.js?ver=3.14.2' id='reviewer-nouislider-plugin-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/photoswipe.js?ver=3.14.2' id='reviewer-photoswipe-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/jquery.knob.js?ver=3.14.2' id='reviewer-knob-plugin-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer.public.min.js?ver=3.14.2' id='reviewer-public-script-js'></script>
<script type='text/javascript' id='reviewer-reviews-boxes-script-js-extra'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerRatingObj = {"ajax_nonce":"ef7d4952db","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_rating"};
var reviewerJudgeObj = {"ajax_nonce":"9f19f91051","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_like"};
var reviewerQueryURs = {"ajax_nonce":"9ef63ad0ba","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer-reviews-boxes.js?ver=3.14.2' id='reviewer-reviews-boxes-script-js'></script>
<script type='text/javascript' id='reviewer-widget-users-reviews-script-js-extra'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerQueryAllURs = {"ajax_nonce":"fca0b680e4","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_all_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer-widget-users-reviews.js?ver=3.14.2' id='reviewer-widget-users-reviews-script-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-pro/assets/js/advanced-ads-pro.min.js?ver=2.18.0' id='advanced-ads-pro/front-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/zoxcustom.js?ver=6.0.3' id='zox-custom-js'></script>
<script type='text/javascript' id='zox-custom-js-after'>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</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/scripts.js?ver=6.0.3' id='zox-scripts-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/retina.js?ver=6.0.3' id='zox-retina-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/jquery.infinitescroll.min.js?ver=6.0.3' id='zox-infinitescroll-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/comment-reply.min.js?ver=6.0.3' id='comment-reply-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/intersection-observer.js' id='zox-intersection-observer-polyfill-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/lozad.min.js' id='zox-lozad-js'></script>
<script type='text/javascript' id='zox-lozad-js-after'>

	var zoxWidgets = document.querySelectorAll("#zox-home-widget-wrap img");
	lozad(zoxWidgets, {
		rootMargin: "0px 0px",
		loaded: function (el) {
			el.classList.add("is-loaded");
		}
	}).observe();
</script>
<script type='text/javascript' id='advanced-ads-pro/cache_busting-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":"","wp_timezone_offset":"-18000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-pro/assets/js/base.min.js?ver=2.18.0' id='advanced-ads-pro/cache_busting-js'></script>
<script type='text/javascript' id='advadsTrackingScript-js-extra'>
/* <![CDATA[ */
var advadsTracking = {"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"dragi-target","blogId":"1","frontendPrefix":"dragi-"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/tracking.min.js?ver=2.3.6' id='advadsTrackingScript-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=14.1.4' id='__ytprefsfitvids__-js'></script>
<div data-theiaStickySidebar-sidebarSelector='".zox-sticky-side"' data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":70,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":1004,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script> <script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
<script type="text/javascript">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</script> 
<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">

<div class="pswp__bg"></div>

<div class="pswp__scroll-wrap">

<div class="pswp__container">
<div class="pswp__item"></div>
<div class="pswp__item"></div>
<div class="pswp__item"></div>
</div>

<div class="pswp__ui pswp__ui--hidden">
<div class="pswp__top-bar">

<div class="pswp__counter"></div>
<button class="pswp__button pswp__button--close" title="Close (Esc)"></button>
<button class="pswp__button pswp__button--share" title="Share"></button>
<button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>
<button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>


<div class="pswp__preloader">
<div class="pswp__preloader__icn">
<div class="pswp__preloader__cut">
<div class="pswp__preloader__donut"></div>
</div>
</div>
</div>
</div>
<div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
<div class="pswp__share-tooltip"></div>
</div>
<button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
</button>
<button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
</button>
<div class="pswp__caption">
<div class="pswp__caption__center"></div>
</div>
</div>
</div>
</div>
<script>window.advads_admin_bar_items = [];</script><script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script src='https://stats.wp.com/e-202243.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.4',blog:'37035244',post:'55046',tz:'-5',srv:'dragillustrated.com'} ]);
	_stq.push([ 'clickTrackerInit', '37035244', '55046' ]);
</script>
<script id="dragi-tracking">var advads_tracking_ads = {};var advads_tracking_urls = {"1":"https:\/\/dragillustrated.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods = {"1":"frontend"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"https:\/\/dragillustrated.com\/linkout\/"};</script>
</body>
</html>