<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script>window._wca = window._wca || [];</script>

	<!-- This site is optimized with the Yoast SEO Premium plugin v18.4 (Yoast SEO v18.6) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>16 Hot Takes &amp; Reactions From a Massive Weekend in Drag Racing - Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Heebo%3A300%2C400%2C500%2C700%2C800%2C900%7CAlegreya%3A400%2C500%2C700%2C800%2C900%7CJosefin%20Sans%3A300%2C400%2C600%2C700%7CLibre%20Franklin%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CFrank%20Ruhl%20Libre%3A300%2C400%2C500%2C700%2C900%7CNunito%20Sans%3A300%2C400%2C600%2C700%2C800%2C900%7CMontserrat%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CAnton%3A400%7CNoto%20Serif%3A400%2C700%7CNunito%3A300%2C400%2C600%2C700%2C800%2C900%7CRajdhani%3A300%2C400%2C500%2C600%2C700%7CTitillium%20Web%3A300%2C400%2C600%2C700%2C900%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CAmiri%3A400%2C400i%2C700%2C700i%7COswald%3A300%2C400%2C500%2C600%2C700%7CRoboto%20Mono%3A400%2C700%7CBarlow%20Semi%20Condensed%3A700%2C800%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%20Condensed%3A300%2C400%2C700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7CPT%20Serif%3A400%2C700%7COpen%20Sans%20Condensed%3A300%2C700%7COpen%20Sans%3A700%7CSource%20Serif%20Pro%3A400%2C600%2C700%7CIM%20Fell%20French%20Canon%3A400%2C400i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%26amp%3Bsubset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Heebo%3A300%2C400%2C500%2C700%2C800%2C900%7CAlegreya%3A400%2C500%2C700%2C800%2C900%7CJosefin%20Sans%3A300%2C400%2C600%2C700%7CLibre%20Franklin%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CFrank%20Ruhl%20Libre%3A300%2C400%2C500%2C700%2C900%7CNunito%20Sans%3A300%2C400%2C600%2C700%2C800%2C900%7CMontserrat%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CAnton%3A400%7CNoto%20Serif%3A400%2C700%7CNunito%3A300%2C400%2C600%2C700%2C800%2C900%7CRajdhani%3A300%2C400%2C500%2C600%2C700%7CTitillium%20Web%3A300%2C400%2C600%2C700%2C900%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CAmiri%3A400%2C400i%2C700%2C700i%7COswald%3A300%2C400%2C500%2C600%2C700%7CRoboto%20Mono%3A400%2C700%7CBarlow%20Semi%20Condensed%3A700%2C800%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%20Condensed%3A300%2C400%2C700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7CPT%20Serif%3A400%2C700%7COpen%20Sans%20Condensed%3A300%2C700%7COpen%20Sans%3A700%7CSource%20Serif%20Pro%3A400%2C600%2C700%7CIM%20Fell%20French%20Canon%3A400%2C400i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%26amp%3Bsubset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Heebo%3A300%2C400%2C500%2C700%2C800%2C900%7CAlegreya%3A400%2C500%2C700%2C800%2C900%7CJosefin%20Sans%3A300%2C400%2C600%2C700%7CLibre%20Franklin%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CFrank%20Ruhl%20Libre%3A300%2C400%2C500%2C700%2C900%7CNunito%20Sans%3A300%2C400%2C600%2C700%2C800%2C900%7CMontserrat%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CAnton%3A400%7CNoto%20Serif%3A400%2C700%7CNunito%3A300%2C400%2C600%2C700%2C800%2C900%7CRajdhani%3A300%2C400%2C500%2C600%2C700%7CTitillium%20Web%3A300%2C400%2C600%2C700%2C900%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CAmiri%3A400%2C400i%2C700%2C700i%7COswald%3A300%2C400%2C500%2C600%2C700%7CRoboto%20Mono%3A400%2C700%7CBarlow%20Semi%20Condensed%3A700%2C800%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%20Condensed%3A300%2C400%2C700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7CPT%20Serif%3A400%2C700%7COpen%20Sans%20Condensed%3A300%2C700%7COpen%20Sans%3A700%7CSource%20Serif%20Pro%3A400%2C600%2C700%7CIM%20Fell%20French%20Canon%3A400%2C400i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CNunito%20Sans%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CAnton%3A100%2C100i%2C200%2C%20200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%26amp%3Bsubset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese&#038;display=swap" /></noscript>
	<link rel="canonical" href="https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="16 Hot Takes &amp; Reactions From a Massive Weekend in Drag Racing" />
	<meta property="og:description" content="It feels like they’re stacking up. It really does. Six races into the 2022 NHRA Camping World Drag Racing Series Season, at least one or two races in for our sport’s most well-known eighth-mile series and sanctions, and with a few massively successful independent doorslammer events and a new-tradition-creating drag-and-drive event already behind us, the [&hellip;]" />
	<meta property="og:url" content="https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/" />
	<meta property="og:site_name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" />
	<meta property="article:publisher" content="https://www.facebook.com/dragillustrated" />
	<meta property="article:published_time" content="2022-05-04T06:06:30+00:00" />
	<meta property="article:modified_time" content="2022-05-04T06:07:12+00:00" />
	<meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4.jpg" />
	<meta property="og:image:width" content="1600" />
	<meta property="og:image:height" content="900" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@dragillustrated" />
	<meta name="twitter:site" content="@dragillustrated" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Wes Buck" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="13 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://dragillustrated.com/#organization","name":"Drag Illustrated","url":"https://dragillustrated.com/","sameAs":["https://www.facebook.com/dragillustrated","https://www.instagram.com/dragillustrated","https://www.youtube.com/channel/UCbREkYFDiSOs8JCRTsqEMeg","https://twitter.com/dragillustrated"],"logo":{"@type":"ImageObject","@id":"https://dragillustrated.com/#logo","inLanguage":"en-US","url":"https://dragillustrated.com/wp-content/uploads/2012/03/Drag_Illustrated_Logo_RED.png","contentUrl":"https://dragillustrated.com/wp-content/uploads/2012/03/Drag_Illustrated_Logo_RED.png","width":2150,"height":592,"caption":"Drag Illustrated"},"image":{"@id":"https://dragillustrated.com/#logo"}},{"@type":"WebSite","@id":"https://dragillustrated.com/#website","url":"https://dragillustrated.com/","name":"Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More","description":"","publisher":{"@id":"https://dragillustrated.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://dragillustrated.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/#primaryimage","inLanguage":"en-US","url":"https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4.jpg","contentUrl":"https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4.jpg","width":1600,"height":900},{"@type":"WebPage","@id":"https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/#webpage","url":"https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/","name":"16 Hot Takes & Reactions From a Massive Weekend in Drag Racing - Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More","isPartOf":{"@id":"https://dragillustrated.com/#website"},"primaryImageOfPage":{"@id":"https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/#primaryimage"},"datePublished":"2022-05-04T06:06:30+00:00","dateModified":"2022-05-04T06:07:12+00:00","breadcrumb":{"@id":"https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/"]}]},{"@type":"BreadcrumbList","@id":"https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://dragillustrated.com/"},{"@type":"ListItem","position":2,"name":"16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing"}]},{"@type":"Article","@id":"https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/#article","isPartOf":{"@id":"https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/#webpage"},"author":{"@id":"https://dragillustrated.com/#/schema/person/fc0677fcfcbb530a962b0f942a8b2fc5"},"headline":"16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing","datePublished":"2022-05-04T06:06:30+00:00","dateModified":"2022-05-04T06:07:12+00:00","mainEntityOfPage":{"@id":"https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/#webpage"},"wordCount":2561,"publisher":{"@id":"https://dragillustrated.com/#organization"},"image":{"@id":"https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/#primaryimage"},"thumbnailUrl":"https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4.jpg","articleSection":["Exclusive","Features","News"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://dragillustrated.com/#/schema/person/fc0677fcfcbb530a962b0f942a8b2fc5","name":"Wes Buck","image":{"@type":"ImageObject","@id":"https://dragillustrated.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/44fd2bb838e09a0308659c9ec2be1e1d?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/44fd2bb838e09a0308659c9ec2be1e1d?s=96&d=mm&r=g","caption":"Wes Buck"},"url":"https://dragillustrated.com/author/wes-buck/"}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Feed" href="https://dragillustrated.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; Comments Feed" href="https://dragillustrated.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; iCal Feed" href="https://dragillustrated.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More &raquo; 16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing Comments Feed" href="https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/feed/" />
		<!-- This site uses the Google Analytics by ExactMetrics plugin v7.5.0 - Using Analytics tracking - https://www.exactmetrics.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-21052018-1"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by ExactMetrics -->
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://dragillustrated.com/wp-includes/css/dist/block-library/style.min.css?ver=c72bdc91451bb172c06ef34eea4930bf' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://dragillustrated.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://dragillustrated.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=c72bdc91451bb172c06ef34eea4930bf' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css'  href='https://dragillustrated.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-vendors-style.css?ver=7.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css'  href='https://dragillustrated.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-style.css?ver=7.2.2' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-css'  href='https://dragillustrated.com/wp-content/plugins/theia-post-slider/css/buttons-red.css?ver=1.15.1' type='text/css' media='all' />
<link rel='stylesheet' id='ql-jquery-ui-css'  href='//ajax.googleapis.com/ajax/libs/jqueryui/1.12.1/themes/smoothness/jquery-ui.css?ver=c72bdc91451bb172c06ef34eea4930bf' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-photoswipe-css'  href='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/css/photoswipe.css?ver=3.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://dragillustrated.com/wp-includes/css/dashicons.min.css?ver=c72bdc91451bb172c06ef34eea4930bf' type='text/css' media='all' />
<link rel='stylesheet' id='reviewer-public-css'  href='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/css/reviewer-public.css?ver=3.14.2' type='text/css' media='all' />
<link rel='stylesheet' id='zox-custom-style-css'  href='https://dragillustrated.com/wp-content/themes/zoxpress/style.css?ver=c72bdc91451bb172c06ef34eea4930bf' type='text/css' media='all' />
<style id='zox-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='fontawesome-child-css'  href='https://use.fontawesome.com/releases/v5.5.0/css/all.css?ver=c72bdc91451bb172c06ef34eea4930bf' type='text/css' media='all' />
<link rel='stylesheet' id='zox-custom-child-style-css'  href='https://dragillustrated.com/wp-content/themes/zoxpress-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://dragillustrated.com/wp-content/themes/zoxpress-child/font-awesome/css/all.css?ver=c72bdc91451bb172c06ef34eea4930bf' type='text/css' media='all' />

<link rel='stylesheet' id='zox-media-queries-css'  href='https://dragillustrated.com/wp-content/themes/zoxpress/css/media-queries.css?ver=c72bdc91451bb172c06ef34eea4930bf' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://dragillustrated.com/wp-content/tablepress-combined.min.css?ver=41' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://dragillustrated.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.9' type='text/css' media='all' />
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/exactmetrics-premium/assets/js/frontend-gtag.min.js?ver=7.5.0' id='exactmetrics-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='exactmetrics-frontend-script-js-extra'>/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/dragillustrated.com","hash_tracking":"false","ua":"UA-21052018-1","v4_id":""};/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/balupton-history.js/jquery.history.js?ver=1.7.1' id='history.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/async.min.js?ver=14.09.2014' id='async.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/tps.js?ver=1.15.1' id='theiaPostSlider/theiaPostSlider.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/main.js?ver=1.15.1' id='theiaPostSlider/main.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-post-slider/js/tps-transition-slide.js?ver=1.15.1' id='theiaPostSlider/transition.js-js'></script>
<script defer type='text/javascript' src='https://stats.wp.com/s-202218.js' id='woocommerce-analytics-js'></script>
<link rel="https://api.w.org/" href="https://dragillustrated.com/wp-json/" /><link rel="alternate" type="application/json" href="https://dragillustrated.com/wp-json/wp/v2/posts/50397" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dragillustrated.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dragillustrated.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p2voyE-d6R' />
<link rel="alternate" type="application/json+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2F16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dragillustrated.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdragillustrated.com%2F16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing%2F&#038;format=xml" />
<script type="text/javascript" src="https://paywall.subscriptiongenius.com/load.js"></script>

<!-- This site is using AdRotate v5.8.19 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.gformba { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.gformba img { height:auto; }
	.gformba-col { position:relative; float:left; }
	.gformba-col:first-child { margin-left: 0; }
	.gformba-col:last-child { margin-right: 0; }
	.gformba-1 {  margin: 0 auto; }
	.gformba-2 { margin:1px 1px 1px 1px; }
	.gformba-3 { margin:1px 1px 1px 1px; float:right; clear:right; }
	.gformba-4 { margin:1px 1px 1px 1px; }
	.gformba-5 { margin:1px 1px 1px 1px; }
	.gformba-6 { margin:1px 1px 1px 1px; }
	.gformba-7 { margin:1px 1px 1px 1px; }
	.gformba-8 { min-width:3px; max-width:618px; }
	.bformba-8 { margin:1px 3px 1px 3px; }
	.gformba-9 { margin:1px 1px 1px 1px; }
	.gformba-10 { margin:1px 1px 1px 1px; }
	.gformba-16 { min-width:5px; max-width:150px; margin: 0 auto; }
	.bformba-16 { margin:0px 5px 0px 5px; }
	@media only screen and (max-width: 480px) {
		.gformba-col, .gformba-dyn, .gformba-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<style type="text/css">
			.wpsdc-drop-cap {
				float : left;				
				padding : 0.25em 0.05em 0.25em 0;				
				font-size : 5em;
				line-height : 0.4em;color : #0a0a0a;}
		</style>	<meta name="theme-color" content="#000" />
			<meta property="og:type" content="article" />
													<meta property="og:image" content="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-1024x576.jpg" />
				<meta name="twitter:image" content="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-1024x576.jpg" />
						<meta property="og:url" content="https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/" />
			<meta property="og:title" content="16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing" />
			<meta property="og:description" content="It feels like they’re stacking up. It really does. Six races into the 2022 NHRA Camping World Drag Racing Series Season, at least one or two races in for our sport’s most well-known eighth-mile series and sanctions, and with a few massively successful independent doorslammer events and a new-tradition-creating drag-and-drive event already behind us, the [&hellip;]" />
			<meta name="twitter:card" content="summary_large_image">
			<meta name="twitter:url" content="https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">
			<meta name="twitter:title" content="16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing">
			<meta name="twitter:description" content="It feels like they’re stacking up. It really does. Six races into the 2022 NHRA Camping World Drag Racing Series Season, at least one or two races in for our sport’s most well-known eighth-mile series and sanctions, and with a few massively successful independent doorslammer events and a new-tradition-creating drag-and-drive event already behind us, the [&hellip;]">
			<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://dragillustrated.com"><link rel="alternate" href="https://dragillustrated.com/wp-json/tribe/events/v1/" /><style type='text/css'>img#wpstats{display:none}</style>
	<link rel="pingback" href="https://dragillustrated.com/xmlrpc.php">	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
	<link rel="icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-180x180.png" />
<meta name="msapplication-TileImage" content="https://dragillustrated.com/wp-content/uploads/2021/08/cropped-DI_512x512-270x270.png" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-50397 single-format-standard custom-background wp-embed-responsive theme-zoxpress theiaPostSlider_body woocommerce-no-js tribe-no-js zox-sport2 zox-s6" >
	<div id="zox-site" class="left zoxrel ">
		<div id="zox-fly-wrap">
	<div id="zox-fly-menu-top" class="left relative">
		<div id="zox-fly-logo" class="left relative">
							<a href="https://dragillustrated.com/"><img src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
					</div><!--zox-fly-logo-->
		<div class="zox-fly-but-wrap zox-fly-but-menu zox-fly-but-click">
			<span></span>
			<span></span>
			<span></span>
			<span></span>
		</div><!--zox-fly-but-wrap-->
	</div><!--zox-fly-menu-top-->
	<div id="zox-fly-menu-wrap">
		<nav class="zox-fly-nav-menu left relative">
			<div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-49701" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49701"><a href="https://dragillustrated.com/category/news/">News</a></li>
<li id="menu-item-49702" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49702"><a href="https://dragillustrated.com/category/race-coverage/">Race Coverage</a></li>
<li id="menu-item-49703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49703"><a href="https://dragillustrated.com/category/tech/">Tech</a></li>
<li id="menu-item-15094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" rel="noopener" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li id="menu-item-15102" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
</ul></div>		</nav>
	</div><!--zox-fly-menu-wrap-->
	<div id="zox-fly-soc-wrap">
		<span class="zox-fly-soc-head">Connect with us</span>
		<ul class="zox-fly-soc-list left relative">
							<li><a href="https://www.facebook.com/DragIllustrated/" target="_blank" class="fab fa-facebook-f"></a></li>
										<li><a href="https://twitter.com/DragIllustrated" target="_blank" class="fab fa-twitter"></a></li>
										<li><a href="https://www.instagram.com/dragillustrated/" target="_blank" class="fab fa-instagram"></a></li>
																				</ul>
	</div><!--zox-fly-soc-wrap-->
</div><!--zox-fly-wrap-->		<div id="zox-search-wrap">
			<div class="zox-search-cont">
				<p class="zox-search-p">Hi, what are you looking for?</p>
				<div class="zox-search-box">
					<form method="get" id="zox-search-form" action="https://dragillustrated.com/">
	<input type="text" name="s" id="zox-search-input" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "Search") { this.value = ""; }' />
	<input type="submit" id="zox-search-submit" value="Search" />
</form>				</div><!--zox-search-box-->
			</div><!--zox-serach-cont-->
			<div class="zox-search-but-wrap zox-search-click">
				<span></span>
				<span></span>
			</div><!--zox-search-but-wrap-->
		</div><!--zox-search-wrap-->
				<div id="zox-site-wall" class="left zoxrel">
			<div id="zox-lead-top-wrap">
				<div id="zox-lead-top-in">
					<div id="zox-lead-top">
											</div><!--zox-lead-top-->
				</div><!--zox-lead-top-in-->
			</div><!--zox-lead-top-wrap-->
			<div id="zox-site-main" class="left zoxrel">
				<header id="zox-main-head-wrap" class="left zoxrel zox-trans-head">
																<div id="zox-bot-head-wrap" class="left zoxrel">
	<div class="zox-head-width">
		<div id="zox-bot-head">
			<div id="zox-bot-head-left">
				<div class="zox-fly-but-wrap zoxrel zox-fly-but-click">
					<span></span>
					<span></span>
					<span></span>
					<span></span>
				</div><!--zox-fly-but-wrap-->
			</div><!--zox-bot-head-left-->
			<div id="zox-bot-head-mid" class="relative">
				<div class="zox-bot-head-logo">
					<div class="zox-bot-head-logo-main">
													<a href="https://dragillustrated.com/"><img class="zox-logo-stand" src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /><img class="zox-logo-dark" src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
											</div><!--zox-bot-head-logo-main-->
																<h2 class="zox-logo-title">Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More</h2>
									</div><!--zox-bot-head-logo-->
				<div class="zox-bot-head-menu">
					<div class="zox-nav-menu">
						<div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49701 zox-mega-drop"><a href="https://dragillustrated.com/category/news/">News</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing</p></a></li><li><a href="https://dragillustrated.com/record-numbers-big-upsets-and-more-highlight-neopma-30th-season-opener/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/05/DSC_9822-600x337.jpeg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/DSC_9822-600x337.jpeg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/DSC_9822-1024x576.jpeg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Record Numbers, Big Upsets and More Highlight NEOPMA 30th Season Opener</p></a></li><li><a href="https://dragillustrated.com/mwdrs-to-crown-two-event-winners-in-one-weekend-at-spring-throwdown-in-t-town/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/05/Memphis-73-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/Memphis-73-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/Memphis-73-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>MWDRS to Crown Two Event Winners in One Weekend at Spring Throwdown in T-Town</p></a></li><li><a href="https://dragillustrated.com/michalek-brothers-racing-edges-out-competition-for-2022-four-wide-nationals-event-win/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/05/alt-6-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/alt-6-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/alt-6-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/alt-6-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/alt-6-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/alt-6-1536x865.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/alt-6-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/alt-6.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Michalek Brothers Racing Edges Out Competition for 2022 Four-Wide Nationals Event Win</p></a></li><li><a href="https://dragillustrated.com/jay-blakes-follow-a-dream-tafc-team-kicks-off-first-race-in-nearly-three-years-with-a-win/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-14-1-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-14-1-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-14-1-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Jay Blake&#8217;s Follow-A-Dream TAFC Team Kicks Off First Race in Nearly Three Years with a Win</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49702 zox-mega-drop"><a href="https://dragillustrated.com/category/race-coverage/">Race Coverage</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/michalek-brothers-racing-edges-out-competition-for-2022-four-wide-nationals-event-win/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/05/alt-6-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/alt-6-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/alt-6-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/alt-6-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/alt-6-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/alt-6-1536x865.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/alt-6-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/alt-6.jpg 1600w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Michalek Brothers Racing Edges Out Competition for 2022 Four-Wide Nationals Event Win</p></a></li><li><a href="https://dragillustrated.com/mike-decker-jr-wins-father-son-final-round-to-start-2022-neopma-season/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/05/Decker-final_AJ-Pinder-photo-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/Decker-final_AJ-Pinder-photo-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/Decker-final_AJ-Pinder-photo-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Mike Decker Jr. Wins Father-Son Final Round to Start 2022 NEOPMA Season</p></a></li><li><a href="https://dragillustrated.com/john-force-conquers-nhra-four-wide-nationals-at-charlotte/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/05/Force_JFA-2-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/Force_JFA-2-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/Force_JFA-2-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>John Force Conquers NHRA Four-Wide Nationals at Charlotte</p></a></li><li><a href="https://dragillustrated.com/mike-salinas-scores-first-nhra-top-fuel-win-for-pep-boys-second-of-2022-season/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/05/Salinas_JFA-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/Salinas_JFA-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/Salinas_JFA-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Mike Salinas Scores First NHRA Top Fuel Win for Pep Boys, Second of 2022 Season</p></a></li><li><a href="https://dragillustrated.com/bill-skillman-claims-factory-stock-showdowns-first-four-wide-event-win-at-charlotte/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/05/2218-15196-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/2218-15196-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/2218-15196-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Bill Skillman Claims Factory Stock Showdown&#8217;s First Four-Wide Event Win at Charlotte</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49703 zox-mega-drop"><a href="https://dragillustrated.com/category/tech/">Tech</a><div class="zox-mega-dropdown"><div class="zox-head-width"><ul class="zox-mega-list"><li><a href="https://dragillustrated.com/dsr-performance-launches-1150-horsepower-pump-gas-crate-engine/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-12-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-12-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-12-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>DSR Performance Launches 1150 Horsepower Pump Gas Crate Engine</p></a></li><li><a href="https://dragillustrated.com/race-winning-brands-shifts-into-transmission-performance/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/RWB22_PR-image-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/RWB22_PR-image-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/RWB22_PR-image-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Race Winning Brands Shifts Into Transmission Performance</p></a></li><li><a href="https://dragillustrated.com/protect-your-gears-from-breaking-with-red-line-heavy-shockproof-gear-oil/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/Red-Line-Heavy-Shockproof-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/Red-Line-Heavy-Shockproof-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/Red-Line-Heavy-Shockproof-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Protect Your Gears from Breaking with Red Line Heavy Shockproof Gear Oil</p></a></li><li><a href="https://dragillustrated.com/vp-racing-fuels-launches-speed-sauce-plus-new-injection-fluid/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-2000x1125.jpg 2000w, https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-2048x1152.jpg 2048w, https://dragillustrated.com/wp-content/uploads/2022/04/unnamed-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>VP Racing Fuels Launches Speed Sauce Plus New Injection Fluid</p></a></li><li><a href="https://dragillustrated.com/manley-expands-extreme-duty-inconel-exhaust-valve-offerings/"><div class="zox-mega-img"><img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2022/04/Extreme-Inconel-Valves-600x337.jpg" class="attachment-zox-mid-thumb size-zox-mid-thumb wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/04/Extreme-Inconel-Valves-600x337.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/04/Extreme-Inconel-Valves-1024x576.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /></div><p>Manley Expands &#8216;Extreme Duty&#8217; Inconel Exhaust Valve Offerings</p></a></li></ul></div></div></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15094"><a target="_blank" rel="noopener" href="http://digital.dragillustrated.com">Latest Issue</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15102"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/994/">Subscribe</a></li>
</ul></div>					</div><!--zox-nav-menu-->
				</div><!--zox-bot-head-menu-->
			</div><!--zox-bot-head-mid-->
			<div id="zox-bot-head-right">
									<span class="zox-night zox-night-mode fas fa-moon"></span>
								<span class="zox-nav-search-but fas fa-search zox-search-click"></span>
			</div><!--zox-bot-head-right-->
		</div><!--zox-bot-head-->
	</div><!--zox-head-width-->
</div><!--zox-bot-head-wrap-->				</header><!---zox-main-header-wrap-->
				<div id="zox-site-grid">
					<div id="zox-site-wall-small">
																																								<div id="zox-main-body-wrap" class="left relative">	<div class="zox-alp-width">
	<div class="zox-auto-post-grid">
		<div class="zox-alp-side zox-sticky-side">
			<div class="zox-alp-side-in">
				<div class="alp-related-posts-wrapper">
	<div class="alp-related-posts">
				<div class="alp-related-post post-50397 current" data-id="50397" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/news/">News</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">16 Hot Takes &amp; Reactions From a Massive Weekend in Drag Racing</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&amp;t=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing &amp;url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
					<div class="alp-advert">
									<span class="zox-ad-label">Advertisement</span>
					<div class="gformba gformba-1"><div class="gformba-single aformba-510"><a class="gofollow" data-track="NTEwLDEsMSwxMA==" href="https://utm.guru/ud9P6" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2022/01/300X300-GetSome.jpg" /></a></div></div>							</div>
				<div class="alp-related-post post-50245 " data-id="50245" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/news/">News</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/15-takeaways-from-the-final-nhra-spring-nationals-in-houston/">15 Takeaways From the Final NHRA Spring Nationals in Houston</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&amp;t=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing &amp;url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-50112 " data-id="50112" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/news/">News</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/not-backing-down-the-fight-to-save-palm-beach-international-raceway/">Not Backing Down: The Fight to Save Palm Beach International Raceway</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&amp;t=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing &amp;url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-50038 " data-id="50038" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a>
													<a class="post-category" href="https://dragillustrated.com/category/race-coverage/">Race Coverage</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/melanie-and-jon-salemi-break-down-pro-boost-record-performances-at-pdra-east-coast-nationals/">Melanie and Jon Salemi Break Down Pro Boost Record Performances at PDRA East Coast Nationals</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&amp;t=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing &amp;url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-50018 " data-id="50018" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/news/">News</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/11-hot-takes-following-season-opening-pdra-east-coast-nationals/">11 Hot Takes Following Season-Opening PDRA East Coast Nationals</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&amp;t=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing &amp;url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-49974 " data-id="49974" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/news/">News</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/11-big-takeaways-from-nhra-4-wide-nationals-in-las-vegas/">11 Big Takeaways From NHRA 4-Wide Nationals in Las Vegas</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&amp;t=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing &amp;url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-49931 " data-id="49931" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/small-tire-showdown-pdra-pro-street-seeing-growth-with-super-street-on-the-way/">Small-Tire Showdown: PDRA Pro Street Seeing Growth, With Super Street on the Way</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&amp;t=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing &amp;url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-49922 " data-id="49922" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/race-coverage/pdra-race-coverage/">PDRA</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/mountain-motors-moment-pdra-extreme-pro-stock-drivers-gearing-up-for-year-of-growth/">Mountain Motor&#039;s Moment: PDRA Extreme Pro Stock Drivers Gearing Up for Year of Growth</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&amp;t=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing &amp;url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-49772 " data-id="49772" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/race-coverage/drag-radial-race-coverage/">Drag Radial</a>
													<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/2021-di-pass-of-the-year-daniel-pharris-3-49-in-radial-vs-the-world-at-sweet-16/">2021 DI Pass of the Year: Daniel Pharris’ 3.49 in Radial vs. the World at Sweet 16</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&amp;t=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing &amp;url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
				<div class="alp-related-post post-49776 " data-id="49776" data-document-title="">
		
						<div class="post-details">
				<p class="post-meta">
												<a class="post-category" href="https://dragillustrated.com/category/exclusive/">Exclusive</a>
													<a class="post-category" href="https://dragillustrated.com/category/features/">Features</a>
													<a class="post-category" href="https://dragillustrated.com/category/race-coverage/nhra-race-coverage/">NHRA</a>
										</p>
				<a class="post-title" href="https://dragillustrated.com/2021-di-drag-racing-ambassador-of-the-year-brian-lohnes/">2021 DI Drag Racing Ambassador of the Year: Brian Lohnes</a>
			</div>
												 	<div class="zox-alp-soc-wrap">
 		<ul class="zox-alp-soc-list">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&amp;t=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 				<li class="zox-alp-soc-fb"><span class="fab fa-facebook-f"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing &amp;url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 				<li class="zox-alp-soc-twit"><span class="fab fa-twitter"></span></li>
 			</a>
 			<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
 				<li class="zox-alp-soc-flip"><span class="fab fa-flipboard"></span></li>
 			</a>
 			<a href="mailto:?subject=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">
 				<li class="zox-alp-soc-com"><span class="fas fa-envelope"></span></li>
 			</a>
 		</ul>
 	</div>
 									</div>
			</div><!--alp-related-posts-->
</div><!--alp-related-posts-wrapper-->			</div><!--zox-alp-side-in-->
		</div><!--zox-alp-side-->
		<div class="zox-auto-post-main">
			<article id="post-50397" class="post-50397 post type-post status-publish format-standard has-post-thumbnail hentry category-exclusive category-features category-news" class="zox-post-wrap" itemscope itemtype="http://schema.org/NewsArticle">
														<div class="zox-article-wrap zoxrel left zox100">
						<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/"/>
													<div class="zox-post-top-wrap zoxrel left zox100">
																	<div class="zox-post-title-wrap zox-tit2">
										<div class="zox-post-width">
											<header class="zox-post-head-wrap left zoxrel zox100">
	<div class="zox-post-head zoxrel">
		<h3 class="zox-post-cat">
			<a class="zox-post-cat-link" href="https://dragillustrated.com/category/exclusive/"><span class="zox-post-cat">Exclusive</span></a>
		</h3>
		<h1 class="zox-post-title left entry-title" itemprop="headline">16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing</h1>
				<div class="zox-post-info-wrap">
							<div class="zox-post-byline-wrap">
					<div class="zox-author-thumb">
						<img alt='' src='https://secure.gravatar.com/avatar/44fd2bb838e09a0308659c9ec2be1e1d?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/44fd2bb838e09a0308659c9ec2be1e1d?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy'/>					</div><!--zox-author-thumb-->
					<div class="zox-author-info-wrap">
						<div class="zox-author-name-wrap" itemprop="author" itemscope itemtype="https://schema.org/Person">
							<p>By</p><span class="zox-author-name vcard fn author" itemprop="name"><a href="https://dragillustrated.com/author/wes-buck/" title="Posts by Wes Buck" rel="author">Wes Buck</a></span>
						</div><!--zox-author-name-wrap-->
						<div class="zox-post-date-wrap">
							<p>Published</p> <span class="zox-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-05-04">5 hours ago</time></span>
							<meta itemprop="dateModified" content="2022-05-04"/>
						</div><!--zox-post-date-wrap-->
					</div><!--zox-author-info-wrap-->
				</div><!--zox-post-byline-wrap-->
						<div class="zox-post-soc-top-wrap">
																<div class="zox-post-soc-stat">
		<ul class="zox-post-soc-stat-list left zoxrel">
 			<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&amp;t=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
 			<li class="zox-post-soc-fb">
 				<i class="fab fa-facebook-f"></i>
 			</li>
 			</a>
 			<a href="#" onclick="window.open('https://twitter.com/share?text=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing -&amp;url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
 			<li class="zox-post-soc-twit">
 				<i class="fab fa-twitter"></i>
 			</li>
 			</a>
 			<li class="zox-post-soc-copy">
			 	<i class="fas fa-link"></i>
 			</li>
 			 			<li class="zox-post-soc-more zox-soc-stat-click-50397">
				<i class="fas fa-ellipsis-h"></i>
				<div class="zox-soc-more-stat zox-more-click-50397">
					<ul class="zox-soc-more-list">
						<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&utm_medium=article-share&utm_campaign=tools&utm_source=Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
							<li class="zox-post-soc-flip">
								<p>Flipboard</p>
								<i class="fab fa-flipboard"></i>
							</li>
						</a>
						<a href="#" onclick="window.open('https://www.reddit.com/submit?url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&title=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing', 'redditShare', 'width=626,height=436'); return false;" title="Share on Reddit">
							<li class="zox-post-soc-redd">
								<p>Reddit</p>
								<i class="fab fa-reddit-alien"></i>
							</li>
						</a>
						<a href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/&amp;media=https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4.jpg&amp;description=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
							<li class="zox-post-soc-pin">
								<p>Pinterest</p>
								<i class="fab fa-pinterest-p" aria-hidden="true"></i>
							</li>
						</a>
						<a class="zox-whats-main" href="https://web.whatsapp.com/send?text=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">
							<li class="zox-post-soc-what">
								<p>Whatsapp</p>
								<i class="fab fa-whatsapp"></i>
							</li>
						</a>
						<a class="zox-whats-mob" href="whatsapp://send?text=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">
							<li class="zox-post-soc-what">
								<p>Whatsapp</p>
								<i class="fab fa-whatsapp"></i>
							</li>
						</a>
						<a href="mailto:?subject=16 Hot Takes &#038; Reactions From a Massive Weekend in Drag Racing&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://dragillustrated.com/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing/">
							<li class="zox-post-soc-email">
								<p>Email</p>
								<i class="fas fa-envelope"></i>
							</li>
 						</a>
					</ul>
				</div><!--zox-soc-more-stat-->
 			</li>
 		</ul>
	</div><!--zox-post-soc-stat-->
 												</div><!--zox-post-soc-top-wrap-->
		</div><!--zox-post-info-wrap-->
	</div><!--zox-post-head-->
</header><!--zox-post-head-wrap-->										</div><!--zox-post-width-->
									</div><!--zox-post-title-wrap-->
																																							</div><!--zox-post-top-wrap-->
												<div class="zox-post-main-grid">
							<div class="zox-post-width">
								<div class="zox-post-main-wrap zoxrel left zox100">
									<div class="zox-post-main">
																					<div class="zox-post-bot-wrap">
																																																	<div class="zox-post-img-wrap">
																				<div class="zox-post-img left zoxrel zoxlh0" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
				<img width="1600" height="900" src="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4.jpg" class="flipboard-image wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4.jpg 1600w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-600x338.jpg 600w" sizes="(max-width: 1600px) 100vw, 1600px" />								<meta itemprop="url" content="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4.jpg">
				<meta itemprop="width" content="1600">
				<meta itemprop="height" content="900">
			</div><!--zox-post-img-->
							<span class="zox-post-img-cap"></span>
																</div><!--zox-post-img-wrap-->
																																			</div><!--zox-post-bot-wrap-->
																				<div class="zox-post-body-wrap left zoxrel">
	<div class="zox-post-body left zoxrel zox100">
		<div id="tps_slideContainer_50397" class="theiaPostSlider_slides"><div class="theiaPostSlider_preloadedSlide">

<p><!-- BEGIN THEIA POST SLIDER -->
<p><span style="font-weight: 400;">It feels like they’re stacking up. It really does. Six races into the 2022 NHRA Camping World Drag Racing Series Season, at least one or two races in for our sport’s most well-known eighth-mile series and sanctions, and with a few massively successful independent doorslammer events and a new-tradition-creating drag-and-drive event already behind us, the first five months of the year in racing feel quite deserving of our “these </span><i><span style="font-weight: 400;">are</span></i><span style="font-weight: 400;"> the good ol’ days” mantra. </span>
<p><span style="font-weight: 400;">While we could certainly have a discussion revolving around the almost unbelievable number of big-time doorslammer events going on this past weekend and how it’s impacting participation at various venues, the real story is how strong the car count was at a slew of drag strips this past weekend despite all drawing from the same pool of talent and machinery. Along those same lines, I think there’s almost always room and/or reason to debate four-wide drag racing, but what a blessing are these places? The fact that the sport of drag racing even has a facility like zMax Dragway &#8211; the Bellagio of drag strips &#8211; with its towering…um…tower, four lanes of near perfect concrete, stadium-quality seating, luxurious suites and sprawling paved pits it should be a “pinch me” moment for any racer or race fan to see our sport on </span><i><span style="font-weight: 400;">that </span></i><span style="font-weight: 400;">stage. But I digress. </span>
<p><span style="font-weight: 400;">From Jim Halsey and Johnny Pluchino bouncing back from slow starts to the PDRA season at the Doorslammer Derby in Bowling Green to John Force securing his 155th win in Charlotte to the Northeast Outlaw Pro Mod Association (NEOPMA) kicking off its 30th (yes, </span><i><span style="font-weight: 400;">thirtieth</span></i><span style="font-weight: 400;">) season of continual operation and the successful completion of Peter Biondo’s beloved Spring Fling Bracket Race at Galot Motorsports Park, late April, early May was a real resume builder for all of us committed to straight-line motorsports. What’s that they say? If you can turn left (or right), you’re not driving fast enough? </span>
<p><span style="font-weight: 400;">Anyway, here’s our biggest takeaways, reactions and surprises from a wild weekend in drag racing. </span>
<h3><span style="font-weight: 400;">CAN’T STOP, WON’T STOP</span></h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50419" src="https://dragillustrated.com/wp-content/uploads/2022/05/21-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/21-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/21-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/21-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/21-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/21-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/21-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/21.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><span style="font-weight: 400;">What more can be said about John Force at this point? The greatest drag racer in the history of the known universe continued his ongoing and seemingly never-ending effort to cement his legacy this past weekend during the NHRA Four-Wide Nationals at zMax Dragway. After securing the No. 1 qualifying position and setting both ends of the track record, Force, the defending event winner, earned his 155th career victory. </span>
<p><span style="font-weight: 400;">According to a report from the team, Force is now the winningest Funny Car driver in four-wide history and is second for most overall behind Steve Torrence (6) with his three wins. This is also now the 34th season in which Force has won at least one race. For anyone attempting to make the argument that the California-born truck-driver-turned-drag-racing-legend should retire, this past weekend didn’t help. </span>
<p><span style="font-weight: 400;">“It was a great weekend for all my sponsors. It was a great weekend for my team. Finally getting a win. This gave me confidence. I think that I can race. I turn 73 this week and I’m still out here winning races,” said Force who is now fourth in points. “Things just seem to happen where you’re destined to win. It was amazing. On some days, magical things just happen. Things went right and we were able to win the race. It was like it was destiny and it was a great weekend for my team. To finally get a win this year gives me a lot of confidence.”</span>
<p><span style="font-weight: 400;">If this is how he performs when he’s perhaps questioning himself ever so slightly, we can only imagine what the rest of 2022 is going to look like now that some real championship-level belief is forming within the walls of the PEAK / BlueDEF PLATINUM pit area. </span><div class="zox-post-ad-wrap"><span class="zox-ad-label">Advertisement. Scroll to continue reading.</span><div class="zox-post-ad"><div class="zox-post-ad-in1"><div class="zox-post-ad-in2"><div class="gformba gformba-1"><div class="gformba-single aformba-659"><a class="gofollow" data-track="NjU5LDEsMSwxMA==" href="https://www.thermotec.com/product/express-sleeve-2000-degree-heat-sleeve-thermo-tec" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2020/09/300x300_2x-Express-Sleeves.jpg" /></a></div></div></div></div></div></div>
<h3><span style="font-weight: 400;">DID YOU CATCH IT? TOP FUEL IS INSANE. ALL OF IT. </span></h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50410" src="https://dragillustrated.com/wp-content/uploads/2022/05/12-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/12-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/12-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/12-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/12-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/12-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/12-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/12.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><span style="font-weight: 400;">On a multitude of levels, Top Fuel drag racing is absolutely </span><i><span style="font-weight: 400;">bananas </span></i><span style="font-weight: 400;">this year. Everyone was saying it would be before the season with all these new teams and drivers transitioning into ownership roles, crew chiefs changing camps, but it’s not all that often that things &#8211; particularly sporting events and storylines &#8211; live up to the hype. Well, this time through </span><i><span style="font-weight: 400;">they are</span></i><span style="font-weight: 400;">. </span>
<p><span style="font-weight: 400;">For instance, what in the hell are Cameron Ferre and Spencer Massey doing in the final quad at zMax? Ferre nearly won the damn race (he finished runner-up). We didn’t even know Massey was planning to race and per Facebook &#8211; former </span><i><span style="font-weight: 400;">DRAG ILLUSTRATED </span></i><span style="font-weight: 400;">cover star Cameron Ferre’s involvement was a last minute decision (clearly, a good one). </span>
<p><span style="font-weight: 400;">Seeing folks in those meaningful racing moments that </span><i><span style="font-weight: 400;">aren’t</span></i><span style="font-weight: 400;"> amongst the usual suspects is such a refreshing feeling, and has to be inspiring to up-and-comers and journeyman nitro racers around the world. We’ve seen this trend developing since the start of the season, and we’re hoping it doesn’t change anytime soon. </span>
<h3><span style="font-weight: 400;">SALINAS STANDING TALL</span></h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50347" src="https://dragillustrated.com/wp-content/uploads/2022/05/Salinas_JFA-1000x666.jpg" alt="" width="1000" height="666" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/Salinas_JFA-1000x666.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/Salinas_JFA-1201x800.jpg 1201w, https://dragillustrated.com/wp-content/uploads/2022/05/Salinas_JFA-2000x1333.jpg 2000w, https://dragillustrated.com/wp-content/uploads/2022/05/Salinas_JFA-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/Salinas_JFA-1536x1024.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/Salinas_JFA-2048x1365.jpg 2048w, https://dragillustrated.com/wp-content/uploads/2022/05/Salinas_JFA-600x400.jpg 600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><span style="font-weight: 400;">Fresh faces and underdogs surely weren’t the only storylines to emerge from Concord. </span>
<p><span style="font-weight: 400;">Mike Salinas, who had his new marketing partner Pep Boys’ CEO on hand for the weekend, knocked down his second win of the season in Charlotte and looks like a legit championship contender as we head into summer despite the departure of tuning duo of Alan Johnson and Brian Hussen. Veteran crew chief Rob Flynn took the reins in their absence and is delivering in spades for the Scrappers Racing team with help from newly appointed car chief and Scrappers “OG” Arron Cave. Salinas’ Pep Boys-backed dragster stayed locked into the bottom 3.70s and was good enough to get the job done at zMax, which seems to be the theme of four-wide: survive and advance. </span>
<h3><span style="font-weight: 400;">WAITING ON A WIN</span></h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50411" src="https://dragillustrated.com/wp-content/uploads/2022/05/13-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/13-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/13-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/13-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/13-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/13-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/13-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/13.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><span style="font-weight: 400;">Adding to the insanity was Steve Torrence again going out early. He lost in the opening stanza on Sunday, which, again, when you win as much as these cats, is, unfortunately, big news. He won this race in ‘17, ‘18, ‘19 and ‘21 (there wasn’t one in ‘20). That’s the last </span><i><span style="font-weight: 400;">four in a row</span></i><span style="font-weight: 400;">. The last thing we want to do is pile on, and we’re sure as hell not concerned, but considering the devastatingly dominant force that Torrence and his Capco Boys have been for the last several years it’s hard not to be somewhat upended at the team’s slow start to the season. That said, this particular drag racing aficionado wouldn’t be at all surprised to see him win the next six races </span><i><span style="font-weight: 400;">in a row</span></i><span style="font-weight: 400;">.</span>
<h3><span style="font-weight: 400;">NUMERO UNO</span></h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50409" src="https://dragillustrated.com/wp-content/uploads/2022/05/11-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/11-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/11-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/11-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/11-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/11-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/11-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/11.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><span style="font-weight: 400;">Considering all the success enjoyed by Justin Ashley in his relatively new Top Fuel career, the New Yorker earned his first career pole qualifying position over the weekend and provided yet another reminder that the super-team era, at least in pro-level nitro racing, is over and no longer a prerequisite for success at this level. </span>
<h3><span style="font-weight: 400;">MCATTACK MOMENT</span></h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50403" src="https://dragillustrated.com/wp-content/uploads/2022/05/5-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/5-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/5-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/5-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/5-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/5-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/5-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/5.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50406" src="https://dragillustrated.com/wp-content/uploads/2022/05/8-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/8-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/8-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/8-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/8-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/8-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/8-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/8.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><span style="font-weight: 400;">Who couldn’t be happy for Chesterland, Ohio’s Mike McIntire Jr. &#8211; especially if you saw his dad’s interview on the jumbotron after he won in the first round of Funny Car eliminations. McIntire put the family’s “McAttack” fuel flopper into the 14th spot in the field with a 4.34-second 1,000-feet lap, and made it to the third and final quad during the NHRA Four-Wide Nationals. </span>
<h3><span style="font-weight: 400;">FOUR-WIDE FIASCO</span></h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50424" src="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-5-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-5-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-5-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-5-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-5-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-5-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-5-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-5.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><span style="font-weight: 400;">How about that Pro Mod final? If the craziness of four-wide drag racing could be summed up by a singular round of racing…this would be it. Truthfully, even a couple days removed from the incident, it’s difficult to wrap my head around the calamity. FuelTech NHRA Pro Mod Drag Racing Series presented by D-Wagon enjoyed a good bit of positivity and enthusiasm in Charlotte after back-to-back title-rights and presenting sponsorship announcements circulated in the days leading up to the race. That momentum continued throughout the event after word of a “very productive” meeting between a newly-formed Pro Mod racer union of sorts and NHRA brass. A spectacular final round would certainly have been a fitting end to the weekend, but it wasn’t meant to be. Series newcomer and accomplished tractor puller Stan Shelton rolled through the beams inadvertently, backed up and made another attempt to pre-stage &#8211; likely getting mixed up on which of the blue sets of LEDs he was working with. The ensuing delay saw “Tricky” Rickie Smith leave before the Christmas Tree activated along with Shelton (kinda) while Kris Thorne and Lyle Barnett waited for the ambers to flash. It was a costly wait for Barnett (sources confirmed a fully-cooked transmission), but served as an opportunity for Thorne, who despite a .320-second reaction time scored his second-straight win in the freshly-funded series with a 5.795-second, 252.14 mph effort.</span><div class="zox-post-ad-wrap"><span class="zox-ad-label">Advertisement. Scroll to continue reading.</span><div class="zox-post-ad"><div class="zox-post-ad-in1"><div class="zox-post-ad-in2"><div class="gformba gformba-1"><div class="gformba-single aformba-721"><a class="gofollow" data-track="NzIxLDEsMSwxMA==" href="http://www.chassisengineering.com/" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2022/02/CE-300x300-1.jpg" /></a></div></div></div></div></div></div>
<h3><span style="font-weight: 400;">STIRRING THE POT</span></h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50418" src="https://dragillustrated.com/wp-content/uploads/2022/05/20-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/20-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/20-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/20-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/20-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/20-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/20-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/20.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><span style="font-weight: 400;">We’re not sure who’s next on the list for Steve Johnson to square off with in a war of words and we recognize and respect that the famously high energy rider’s outspoken nature isn’t for everyone, but it’s hard to argue that the rivalry with reigning champion Matt Smith (that he seems to have reignited after his most recent win in Houston a couple weeks ago) has more people talking about NHRA Pro Stock Motorcycle than any other in recent history. The veteran racer is saying what he thinks and, honestly, he’s been backing it up on the drag strip. He set the track record in Charlotte </span><i><span style="font-weight: 400;">and </span></i><span style="font-weight: 400;">won his second race in a row. He’s as polarizing a character as exists in the sport, but he’s smashing people right now, and we’re here for it. </span>
<h3><span style="font-weight: 400;">STRAIGHT TO THE FINALS</span></h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50422" src="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-3-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-3-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-3-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-3-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-3-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-3-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-3-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-3.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><span style="font-weight: 400;">It was </span><i><span style="font-weight: 400;">huge news</span></i><span style="font-weight: 400;"> last week that defending NHRA Funny Car world champion Ron Capps was making the move to a Toyota GR Supra and joining the brand in an official capacity. Social media melted down, fans reacted, and the newfound team-owner-and-driver delivered for the Ellipses (that’s what Toyota calls their logo/symbol. Cool, right?). </span>
<p><span style="font-weight: 400;">It was a big deal to make the move, but it was an even bigger deal to put the blue-and-yellow Supra in the money round from the jump. Capps &amp; Co. surely scored some brownie points from the TRD camp in Charlotte, and we’re hoping that pays dividends for one of our sport’s most significant ambassadors of all time. Also, if you’re paying close attention, you might appreciate knowing that our sources report the Supra body with its rear wing configuration is </span><i><span style="font-weight: 400;">significantly </span></i><span style="font-weight: 400;">faster than other bodies on the market and could see Capps posting up world record speeds in short order. </span>
<h3><span style="font-weight: 400;">TONY STEWART STEADY DOING IT BIG </span></h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50423" src="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-4-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-4-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-4-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-4-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-4-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-4-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-4-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-4.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><span style="font-weight: 400;">The newest power player in drag racing, NASCAR Hall of Famer Tony Stewart, continued to do big things in a new space, hosting 350-plus employees and family members from Stewart-Haas Racing with his drivers Matt Hagan and wife Leah Pruett. Pruett pointed to team manager Kelly Antonelli as the driving force behind the multi-day program, but also noted that it was a relatively unique experience for Stewart &#8211; especially the essentially all-access nature of the pits at a professional level drag race. </span>
<h3><span style="font-weight: 400;">HOW ABOUT AMBER FREAKING FRANKLIN?</span></h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50415" src="https://dragillustrated.com/wp-content/uploads/2022/05/17-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/17-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/17-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/17-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/17-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/17-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/17-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/17.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><span style="font-weight: 400;">Having had something of a front row seat to second-generation racer Amber Franklin’s ascension from Jr. Dragsters to Top Dragster and now Pro 632 (a low four-second doorslammer heads up eliminator), it’s hard to imagine a scenario where this young woman doesn’t have a long and meaningful career in professional drag racing &#8211; especially if you consider how quickly it’s happened. </span>
<p><span style="font-weight: 400;">The Virginia-based racer and daughter of PDRA Pro Nitrous titan Tommy Franklin, who along with his wife, Judy, owns the series, as well as Virginia Motorsports Park, made her debut in Pro 632 late in 2021 and positioned herself as a contender immediately. Just two races into the Professional Drag Racers Association season she found herself in the winner’s circle and championship contention. Incredibly, she was paired against dear friend and fellow up-and-coming female racer Lexi Tanner, adding another dimension to what has been an absolutely incredible year for women in drag racing. </span>
<h3><span style="font-weight: 400;">MORE ON TEAM TANNER</span></h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50417" src="https://dragillustrated.com/wp-content/uploads/2022/05/19-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/19-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/19-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/19-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/19-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/19-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/19-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/19.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><span style="font-weight: 400;">From what we understand, Lexi Tanner, the aforementioned other-half of the first-ever all-female PDRA Pro 632 final, had to drive back to Indianapolis (an easy three-and-a-half hours from the track) to take a final exam on Saturday morning. She ran into car troubles on the way and had to take two different Ubers to get back to the track in time for first round eliminations. The young lady literally met her car in the staging lanes and proceeded to take it to the finals. Impressive. </span>
<p><span style="font-weight: 400;">In other Tanner-related news, her older brother Preston, a </span><i><span style="font-weight: 400;">DRAG ILLUSTRATED 30 Under 30 </span></i><span style="font-weight: 400;">alum, also made it to his first pro-level final in Pro Boost competition. The brother-and-sister duo won PDRA Jr. Dragster championships together in 2015. </span>
<h3><span style="font-weight: 400;">JIMMY WINLIGHTS BACK AT IT</span></h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50414" src="https://dragillustrated.com/wp-content/uploads/2022/05/16-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/16-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/16-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/16-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/16-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/16-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/16-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/16.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><span style="font-weight: 400;">Momentarily, like…for a week or two…Jim Halsey looked human. The Maryland-based owner-operator of Cecil County Dragway started his 2022 PDRA Pro Nitrous campaign with a first-round exit at the season-opening East Coast Nationals, which was headline news &#8211; especially for a racer who closed out last season having won five of eight races. Halsey and team, including wife, Cathy, close friend and crew chief Eric Davis and nitrous super tuner Brandon Switzer, as well as his wife, Melissa, performed a complete teardown of their ‘68 Camaro and spent a couple days testing since their last outing in North Carolina and it showed. The nitrous racing legend admitted the team gained some knowledge throughout the course of the weekend that’ll show later in the season and have “Daddy Shark” back in its sweet spot. </span><div class="zox-post-ad-wrap"><span class="zox-ad-label">Advertisement. Scroll to continue reading.</span><div class="zox-post-ad"><div class="zox-post-ad-in1"><div class="zox-post-ad-in2"><div class="gformba gformba-1"><div class="gformba-single aformba-724"><a class="gofollow" data-track="NzI0LDEsMSwxMA==" href="http://coffeebyartisan.com/" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2022/02/ARTISANAD-DRAGILLUST-300x300-1.png" /></a></div></div></div></div></div></div>
<h3>JOHNNY PLUCHINO IS, TOO</h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50412" src="https://dragillustrated.com/wp-content/uploads/2022/05/14-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/14-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/14-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/14-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/14-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/14-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/14-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/14.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p>&#8220;Swaggy P&#8221; was back in the winner&#8217;s circle where he&#8217;s most comfortable again this past weekend in Bowling Green. The Extreme Pro Stock young gun already has one strap to his name and proved that he&#8217;s not going to let anyone hold onto that No. 1 decal for long.
<p>Pluchino, who qualified second amongst an increasingly strong field of XPS cars, met up with top qualifier J.R. Carr in the final. The New York-based driver left first in his trademark orange-and-black Ford Mustang (.015) and never looked back, taking the win with a 4.086-second elapsed time to best Carr&#8217;s 4.087.
<h3><span style="font-weight: 400;">PRO MOD IS STRONG. FIGHT ME. </span></h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50400" src="https://dragillustrated.com/wp-content/uploads/2022/05/2-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/2-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/2-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/2-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/2-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/2-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/2-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/2.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p><span style="font-weight: 400;">Despite a slew of crossover-capable cars being spread across three events this past weekend in North Carolina (NHRA), Kentucky (PDRA) and Maryland, the overall show of strength by the brand of racing was genuinely impressive. Sixty-three cars ranging from screw- and roots-type supercharged, twin turbocharged, nitrous oxide injected and centrifugal supercharged doorslammers numbered 15 in Charlotte, 12 and 15 in Pro Nitrous and Pro Boost and 21 for the Northeast Outlaw Pro Mod season opener at MIR. </span>
<h3>SHOUTOUT NEOPMA! THREE DECADES STRONG!</h3>
<p><img loading="lazy" class="aligncenter size-thumbnail wp-image-50421" src="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-2-1000x563.jpg" alt="" width="1000" height="563" srcset="https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-2-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-2-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-2-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-2-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-2-1024x576.jpg 1024w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-2-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2022/05/16-Hot-Takes-May-4-2.jpg 1600w" sizes="(max-width: 1000px) 100vw, 1000px" />
<p>Is it as hard for you to believe John Mazzorana&#8217;s Northeast Outlaw Pro Mod Association is celebrating its 30th season of continual operation this year? Makes a guy look at Pro Mod through even thicker rose-colored glasses than we do already, right? It also makes a guy feel <em>old.</em>
<p>Congratulations to John, his team, family, sponsors, fans and racers on what is an almost unimaginably challenging three decades of doing the Lord&#8217;s work and spreading the gospel of drag racing.
<p><!-- END THEIA POST SLIDER -->
<div class="gformba gformba-7"><div class="gformba-single aformba-690"><a class="gofollow" data-track="NjkwLDcsMSwxMA==" href="https://www.fram.com/for-the-road-ahead-landing-page/?utm_source=caranddriver&utm_medium=banner&utm_campaign=theroadahead&utm_term=diy&utm_content=animated_banner" target="_blank"><img src="https://dragillustrated.com/wp-content/uploads/2021/10/2021-0930-WEB-728x90-Fast-Furious-2-1.gif" /></a></div></div></p>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>

</div></div><div class="theiaPostSlider_footer _footer"></div><div data-theiaPostSlider-sliderOptions='{&quot;slideContainer&quot;:&quot;#tps_slideContainer_50397&quot;,&quot;nav&quot;:[&quot;.theiaPostSlider_nav&quot;],&quot;navText&quot;:&quot;%{currentSlide} of %{totalSlides}&quot;,&quot;helperText&quot;:&quot;Use your \u2190 \u2192 (arrow) keys to browse&quot;,&quot;defaultSlide&quot;:0,&quot;transitionEffect&quot;:&quot;slide&quot;,&quot;transitionSpeed&quot;:400,&quot;keyboardShortcuts&quot;:true,&quot;scrollAfterRefresh&quot;:true,&quot;numberOfSlides&quot;:1,&quot;slides&quot;:[],&quot;useSlideSources&quot;:null,&quot;themeType&quot;:&quot;classic&quot;,&quot;prevText&quot;:&quot;Prev&quot;,&quot;nextText&quot;:&quot;Next&quot;,&quot;buttonWidth&quot;:0,&quot;buttonWidth_post&quot;:0,&quot;postUrl&quot;:&quot;https:\/\/dragillustrated.com\/16-hot-takes-reactions-from-a-massive-weekend-in-drag-racing\/&quot;,&quot;postId&quot;:50397,&quot;refreshAds&quot;:false,&quot;refreshAdsEveryNSlides&quot;:1,&quot;adRefreshingMechanism&quot;:&quot;javascript&quot;,&quot;ajaxUrl&quot;:&quot;https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php&quot;,&quot;loopSlides&quot;:false,&quot;scrollTopOffset&quot;:0,&quot;hideNavigationOnFirstSlide&quot;:false,&quot;isRtl&quot;:false,&quot;excludedWords&quot;:[&quot;&quot;]}' 
					 data-theiaPostSlider-onChangeSlide='&quot;&quot;'></div>			</div><!--zox-post-body-->
	<div class="zox-post-body-bot left zoxrel zox100">
		<div class="zox-post-body-width">
			<div class="zox-post-tags left zoxrel zox100">
				<span class="zox-post-tags-header">In this article:</span><span itemprop="keywords"></span>
			</div><!--zox-post-tags-->
						<div class="zox-posts-nav-link">
							</div><!--zox-posts-nav-link-->
						<div class="zox-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
				<div class="zox-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
											<img src="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg"/>
						<meta itemprop="url" content="https://dragillustrated.com/wp-content/uploads/2022/04/Drag-Illustrated-Logo-White-BG-01.svg">
									</div><!--zox-org-logo-->
				<meta itemprop="name" content="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More">
			</div><!--zox-org-wrap-->
					</div><!--zox-post-body-width-->
	</div><!--zox-post-body-bot-->
</div><!--zox-post-body-wrap-->									</div><!--zox-post-main-->
								</div><!--zox-post-main-wrap-->
							</div><!--zox-post-width-->
						</div><!--zox-post-main-grid-->
																	</div><!--zox-article-wrap-->
						<div class="zox-post-more-wrap left zoxrel zox100">
		<div class="zox-post-width">
			<div class="zox-post-more left zoxrel zox100">
				<div class="zox-post-main-head left zoxrel zox100">
					<h4 class="zox-post-main-title">
						<span class="zox-post-main-title">You May Also Like</span>
					</h4>
				</div><!--zox-widget-main-head-->
									<div class="zox-post-more-grid zox-div4 left zoxrel zox100">
													<div class="zox-art-wrap zoxrel zox-art-mid">
			<div class="zox-art-grid">
			<div class="zox-art-img zoxrel zox100 zoxlh0">
				<a href="https://dragillustrated.com/lights-out-v-movers-shakers/" rel="bookmark">
				<img width="506" height="337" src="https://dragillustrated.com/wp-content/uploads/2014/02/DSC_1839.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2014/02/DSC_1839.jpg 600w, https://dragillustrated.com/wp-content/uploads/2014/02/DSC_1839-300x200.jpg 300w" sizes="(max-width: 506px) 100vw, 506px" />				<img width="100" height="67" src="https://dragillustrated.com/wp-content/uploads/2014/02/DSC_1839.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2014/02/DSC_1839.jpg 600w, https://dragillustrated.com/wp-content/uploads/2014/02/DSC_1839-300x200.jpg 300w" sizes="(max-width: 100px) 100vw, 100px" />				</a>
			</div><!--zox-art-img-->
			<div class="zox-art-text">
	<div class="zox-art-text-cont">
					<h3 class="zox-s-cat"><span class="zox-s-cat">Race Coverage</span></h3>
				<div class="zox-art-title">
			<a href="https://dragillustrated.com/lights-out-v-movers-shakers/" rel="bookmark">
			<h2 class="zox-s-title2">Movers &amp; Shakers: The People Who Make Lights Out</h2>
			</a>
		</div><!--zox-art-title-->
		<p class="zox-s-graph">Scotty G and Paul from Induction Solutions talk a little laughing gas in the staging lanes.</p>
		<div class="zox-byline-wrap">
			<span class="zox-byline-name"></span><span class="zox-byline-date"><i class="far fa-clock"></i>February 23, 2014</span>
		</div><!--zox-byline-wrap-->
	</div><!--zox-art-text-cont-->
</div><!--zox-art-text-->		</div><!--zox-art-grid-->
	</div><!--zox-art-wrap-->													<div class="zox-art-wrap zoxrel zox-art-mid">
			<div class="zox-art-grid">
			<div class="zox-art-img zoxrel zox100 zoxlh0">
				<a href="https://dragillustrated.com/history-making-houston-raceway-park-to-close-following-2022-nhra-national-event/" rel="bookmark">
				<img width="505" height="337" src="https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-scaled.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-scaled.jpg 2560w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-1320x880.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-2000x1334.jpg 2000w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-1536x1024.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-2048x1366.jpg 2048w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-600x400.jpg 600w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-350x233.jpg 350w" sizes="(max-width: 505px) 100vw, 505px" />				<img width="100" height="67" src="https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-scaled.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-scaled.jpg 2560w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-1320x880.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-2000x1334.jpg 2000w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-1536x1024.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-2048x1366.jpg 2048w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-600x400.jpg 600w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2021/07/TF-Leah-Pruett-burn-out-350x233.jpg 350w" sizes="(max-width: 100px) 100vw, 100px" />				</a>
			</div><!--zox-art-img-->
			<div class="zox-art-text">
	<div class="zox-art-text-cont">
					<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
				<div class="zox-art-title">
			<a href="https://dragillustrated.com/history-making-houston-raceway-park-to-close-following-2022-nhra-national-event/" rel="bookmark">
			<h2 class="zox-s-title2">History-Making Houston Raceway Park to Close Following 2022 NHRA National Event</h2>
			</a>
		</div><!--zox-art-title-->
		<p class="zox-s-graph">NHRA and Houston Raceway Park have teamed up to announce the final NHRA SpringNationals as the historic track will close following the 2022 event....</p>
		<div class="zox-byline-wrap">
			<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>July 14, 2021</span>
		</div><!--zox-byline-wrap-->
	</div><!--zox-art-text-cont-->
</div><!--zox-art-text-->		</div><!--zox-art-grid-->
	</div><!--zox-art-wrap-->													<div class="zox-art-wrap zoxrel zox-art-mid">
			<div class="zox-art-grid">
			<div class="zox-art-img zoxrel zox100 zoxlh0">
				<a href="https://dragillustrated.com/lizzy-musi-to-debut-new-69-camaro-at-street-outlaws-no-prep-kings-in-epping/" rel="bookmark">
				<img width="506" height="337" src="https://dragillustrated.com/wp-content/uploads/2021/07/80de0ec7-cacb-2dc3-040d-2ee572dd46ae.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2021/07/80de0ec7-cacb-2dc3-040d-2ee572dd46ae.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2021/07/80de0ec7-cacb-2dc3-040d-2ee572dd46ae-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2021/07/80de0ec7-cacb-2dc3-040d-2ee572dd46ae-600x400.jpg 600w, https://dragillustrated.com/wp-content/uploads/2021/07/80de0ec7-cacb-2dc3-040d-2ee572dd46ae-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2021/07/80de0ec7-cacb-2dc3-040d-2ee572dd46ae-350x233.jpg 350w" sizes="(max-width: 506px) 100vw, 506px" />				<img width="100" height="67" src="https://dragillustrated.com/wp-content/uploads/2021/07/80de0ec7-cacb-2dc3-040d-2ee572dd46ae.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2021/07/80de0ec7-cacb-2dc3-040d-2ee572dd46ae.jpg 1200w, https://dragillustrated.com/wp-content/uploads/2021/07/80de0ec7-cacb-2dc3-040d-2ee572dd46ae-768x512.jpg 768w, https://dragillustrated.com/wp-content/uploads/2021/07/80de0ec7-cacb-2dc3-040d-2ee572dd46ae-600x400.jpg 600w, https://dragillustrated.com/wp-content/uploads/2021/07/80de0ec7-cacb-2dc3-040d-2ee572dd46ae-1000x667.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2021/07/80de0ec7-cacb-2dc3-040d-2ee572dd46ae-350x233.jpg 350w" sizes="(max-width: 100px) 100vw, 100px" />				</a>
			</div><!--zox-art-img-->
			<div class="zox-art-text">
	<div class="zox-art-text-cont">
					<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
				<div class="zox-art-title">
			<a href="https://dragillustrated.com/lizzy-musi-to-debut-new-69-camaro-at-street-outlaws-no-prep-kings-in-epping/" rel="bookmark">
			<h2 class="zox-s-title2">Lizzy Musi to Debut New &#8217;69 Camaro at Street Outlaws: No Prep Kings in Epping</h2>
			</a>
		</div><!--zox-art-title-->
		<p class="zox-s-graph">A plan that started more than a year ago will come to fruition as the Musi Racing team is set to debut its new Edelbrock-equipped...</p>
		<div class="zox-byline-wrap">
			<span class="zox-byline-name"><a href="https://dragillustrated.com/author/josh/" title="Posts by Josh Hachat" rel="author">Josh Hachat</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>July 9, 2021</span>
		</div><!--zox-byline-wrap-->
	</div><!--zox-art-text-cont-->
</div><!--zox-art-text-->		</div><!--zox-art-grid-->
	</div><!--zox-art-wrap-->													<div class="zox-art-wrap zoxrel zox-art-mid">
			<div class="zox-art-grid">
			<div class="zox-art-img zoxrel zox100 zoxlh0">
				<a href="https://dragillustrated.com/world-doorslammer-nationals-pro-stock-qualifying-sheets/" rel="bookmark">
				<img width="600" height="337" src="https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18.jpg" class="zox-reg-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18.jpg 2048w, https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18-2000x1125.jpg 2000w, https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18-350x197.jpg 350w" sizes="(max-width: 600px) 100vw, 600px" />				<img width="100" height="56" src="https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18.jpg" class="zox-mob-img wp-post-image" alt="" loading="lazy" srcset="https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18.jpg 2048w, https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18-1320x743.jpg 1320w, https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18-2000x1125.jpg 2000w, https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18-768x432.jpg 768w, https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18-1536x864.jpg 1536w, https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18-600x338.jpg 600w, https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18-1000x563.jpg 1000w, https://dragillustrated.com/wp-content/uploads/2020/03/Image-from-iOS-18-350x197.jpg 350w" sizes="(max-width: 100px) 100vw, 100px" />				</a>
			</div><!--zox-art-img-->
			<div class="zox-art-text">
	<div class="zox-art-text-cont">
					<h3 class="zox-s-cat"><span class="zox-s-cat">News</span></h3>
				<div class="zox-art-title">
			<a href="https://dragillustrated.com/world-doorslammer-nationals-pro-stock-qualifying-sheets/" rel="bookmark">
			<h2 class="zox-s-title2">World Doorslammer Nationals &#8211; Pro Stock Qualifying Sheets</h2>
			</a>
		</div><!--zox-art-title-->
		<p class="zox-s-graph">Q4 Q3 Q2 Q1</p>
		<div class="zox-byline-wrap">
			<span class="zox-byline-name"><a href="https://dragillustrated.com/author/developer/" title="Posts by Drag Illustrated" rel="author">Drag Illustrated</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>March 8, 2020</span>
		</div><!--zox-byline-wrap-->
	</div><!--zox-art-text-cont-->
</div><!--zox-art-text-->		</div><!--zox-art-grid-->
	</div><!--zox-art-wrap-->											</div><!--zox-post-more-grid-->
							</div><!--zox-post-more-->
		</div><!--zox-post-width-->
	</div><!--zox-post-more-wrap-->
	<div class="zox-post-bot-ad left zoxrel zox100 zox-lh0">
		<span class="zox-ad-label">Advertisement</span>
		<div class="gformba gformba-1"><div class="gformba-single aformba-288"><a class="gofollow" data-track="Mjg4LDEsMSwxMA==" href="http://www.fueltech.net/"><img src="https://dragillustrated.com/wp-content/uploads/2022/02/DI-300x300-1.png" /></a></div></div>	</div><!--zox-post-bot-ad-->

    <script type="text/javascript">
	jQuery(document).ready(function($) {
  		$(".zox-soc-stat-click-50397").on("click", function(){
	  		$(".zox-more-click-50397").toggleClass("zox-soc-more-open");
  		});
	});
    </script>							</article><!--zox-post-wrap-->
		</div><!--zox-auto-post-main-->
			</div><!--zox-auto-post-grid-->
</div><!--zox-alp-width-->							</div><!--zox-main-body-wrap-->
							<footer id="zox-foot-wrap" class="left zoxrel zox100">
								<div class="zox-head-width">
									<div class="zox-foot-grid left zoxrel zox100">
										<div class="zox-foot-left-wrap">
											<div class="zox-foot-logo left zox-lh0">
																									<a href="https://dragillustrated.com/"><img src="https://dragillustrated.com/wp-content/uploads/2022/03/DragIllustrated_flat_white-200px.png" alt="Drag Illustrated | Drag Racing News, Opinion, Interviews, Photos, Videos and More" data-rjs="2" /></a>
																							</div><!--zox-foot-logo-->
											<div class="zox-foot-left left">
												<div class="zox-foot-menu">
													<div class="menu-about-di-container"><ul id="menu-about-di" class="menu"><li id="menu-item-21282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21282"><a href="https://checkout.subscriptiongenius.com/dragillustrated.com/">Subscribe</a></li>
<li id="menu-item-15093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15093"><a href="https://dragillustrated.com/about/">About</a></li>
<li id="menu-item-15089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15089"><a href="https://dragillustrated.com/our-team/">Our Team</a></li>
<li id="menu-item-15091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15091"><a href="https://dragillustrated.com/advertise/">Advertise</a></li>
<li id="menu-item-15090" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15090"><a href="https://dragillustrated.com/contact/">Contact</a></li>
</ul></div>												</div><!--zox-foot-menu-->
												<div class="zox-foot-copy">
													<p>Drag Illustrated is not affiliated with, nor is it bound by any sanctioning body or association.<br>
From groundbreaking stories on underground grudge and outlaw racing to in-depth interviews<br>
with world-renowned racers and exclusive event coverage, Drag Illustrated shines the spotlight<br>
on the hottest stories in drag racing.<br>
When drivers, builders, and hardcore fans want the unbiased truth, Drag Illustrated is where they turn.
<br><br>
Copyright © 2022 Drag Illustrated Media, LLC.</p>
												</div><!--zox-foot-copy-->
											</div><!--zox-foot-left-->
										</div><!--zox-foot-left-wrap-->
										<div class="zox-foot-right-wrap">
											<div class="zox-foot-soc right relative">
												<ul class="zox-foot-soc-list left relative">
																											<li><a href="https://www.facebook.com/DragIllustrated/" target="_blank" class="fab fa-facebook-f"></a></li>
																																								<li><a href="https://twitter.com/DragIllustrated" target="_blank" class="fab fa-twitter"></a></li>
																																								<li><a href="https://www.instagram.com/dragillustrated/" target="_blank" class="fab fa-instagram"></a></li>
																																																																																										</ul>
											</div><!--zox-foot-soc-->
										</div><!--zox-foot-right-wrap-->
									</div><!--zox-foot-grid-->
								</div><!--zox-head-width-->
							</footer><!--zox-foot-wrap-->
						</div><!--zox-site-wall-small-->
					</div><!--zox-site-grid-->
				</div><!--zox-site-main-->
			</div><!--zox-site-wall-->
			<div class="zox-fly-top back-to-top">
				<span class="fas fa-angle-up"></span>
			</div><!--zox-fly-top-->
		</div><!--zox-site-->
		<div class="zox-fly-fade zox-fly-but-click">
		</div><!--zox-fly-fade-->
				<div data-theiaStickySidebar-sidebarSelector='".zox-sticky-side"'
		     data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":70,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":1004,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script>	<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
	<script type="text/javascript">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</script>		<!-- Root element of PhotoSwipe. Must have class pswp. -->
		<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">

		    <!-- Background of PhotoSwipe.
		         It's a separate element as animating opacity is faster than rgba(). -->
		    <div class="pswp__bg"></div>

		    <!-- Slides wrapper with overflow:hidden. -->
		    <div class="pswp__scroll-wrap">

		        <!-- Container that holds slides.
		            PhotoSwipe keeps only 3 of them in the DOM to save memory.
		            Don't modify these 3 pswp__item elements, data is added later on. -->
		        <div class="pswp__container">
		            <div class="pswp__item"></div>
		            <div class="pswp__item"></div>
		            <div class="pswp__item"></div>
		        </div>

		        <!-- Default (PhotoSwipeUI_Default) interface on top of sliding area. Can be changed. -->
		        <div class="pswp__ui pswp__ui--hidden">

		            <div class="pswp__top-bar">

		                <!--  Controls are self-explanatory. Order can be changed. -->

		                <div class="pswp__counter"></div>

		                <button class="pswp__button pswp__button--close" title="Close (Esc)"></button>

		                <button class="pswp__button pswp__button--share" title="Share"></button>

		                <button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>

		                <button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>

		                <!-- Preloader demo http://codepen.io/dimsemenov/pen/yyBWoR -->
		                <!-- element will get class pswp__preloader-active when preloader is running -->
		                <div class="pswp__preloader">
		                    <div class="pswp__preloader__icn">
		                      <div class="pswp__preloader__cut">
		                        <div class="pswp__preloader__donut"></div>
		                      </div>
		                    </div>
		                </div>
		            </div>

		            <div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
		                <div class="pswp__share-tooltip"></div>
		            </div>

		            <button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
		            </button>

		            <button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
		            </button>

		            <div class="pswp__caption">
		                <div class="pswp__caption__center"></div>
		            </div>

		        </div>

		    </div>

		</div>
		<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/dragillustrated.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.5.6' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/ResizeSensor.js?ver=1.7.0' id='theia-sticky-sidebar/ResizeSensor.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.7.0' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.7.0' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/zoxpress-plugin//scripts/jquery.sticky-kit.min.js?ver=c72bdc91451bb172c06ef34eea4930bf' id='jquery-sticky-kit-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/zoxpress-plugin//scripts/jquery.waypoints.min.js?ver=c72bdc91451bb172c06ef34eea4930bf' id='jquery-waypoints-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/jquery.nouislider.all.min.js?ver=3.14.2' id='reviewer-nouislider-plugin-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/photoswipe.js?ver=3.14.2' id='reviewer-photoswipe-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/jquery.knob.js?ver=3.14.2' id='reviewer-knob-plugin-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer.public.min.js?ver=3.14.2' id='reviewer-public-script-js'></script>
<script type='text/javascript' id='reviewer-reviews-boxes-script-js-extra'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerRatingObj = {"ajax_nonce":"08090b5cf4","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_rating"};
var reviewerJudgeObj = {"ajax_nonce":"5207dde558","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_ajax_action_like"};
var reviewerQueryURs = {"ajax_nonce":"2a88357ff9","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer-reviews-boxes.js?ver=3.14.2' id='reviewer-reviews-boxes-script-js'></script>
<script type='text/javascript' id='reviewer-widget-users-reviews-script-js-extra'>
/* <![CDATA[ */
var rwpConstants = {"debugVue":""};
var reviewerQueryAllURs = {"ajax_nonce":"4a265129a6","ajax_url":"https:\/\/dragillustrated.com\/wp-admin\/admin-ajax.php","action":"rwp_reviews_box_query_all_users_reviews"};
/* ]]> */
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/plugins/reviewer/public/assets/js/reviewer-widget-users-reviews.js?ver=3.14.2' id='reviewer-widget-users-reviews-script-js'></script>
<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/checkout\/|\/cart\/|\/my-account\/|\/wc-api\/v(.*)|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/dragillustrated.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/zoxcustom.js?ver=c72bdc91451bb172c06ef34eea4930bf' id='zox-custom-js'></script>
<script type='text/javascript' id='zox-custom-js-after'>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</script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/scripts.js?ver=c72bdc91451bb172c06ef34eea4930bf' id='zox-scripts-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/retina.js?ver=c72bdc91451bb172c06ef34eea4930bf' id='zox-retina-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/alp.js?ver=c72bdc91451bb172c06ef34eea4930bf' id='zox-alp-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-includes/js/comment-reply.min.js?ver=c72bdc91451bb172c06ef34eea4930bf' id='comment-reply-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/intersection-observer.js' id='zox-intersection-observer-polyfill-js'></script>
<script type='text/javascript' src='https://dragillustrated.com/wp-content/themes/zoxpress/js/lozad.min.js' id='zox-lozad-js'></script>
<script type='text/javascript' id='zox-lozad-js-after'>

	var zoxWidgets = document.querySelectorAll("#zox-home-widget-wrap img");
	lozad(zoxWidgets, {
		rootMargin: "0px 0px",
		loaded: function (el) {
			el.classList.add("is-loaded");
		}
	}).observe();
</script>
<script src='https://stats.wp.com/e-202218.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9',blog:'37035244',post:'50397',tz:'-5',srv:'dragillustrated.com'} ]);
	_stq.push([ 'clickTrackerInit', '37035244', '50397' ]);
</script>
	</body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1651663505 -->